14:00:07 <nikhil> #startmeeting glance
14:00:11 <nikhil> #topic roll call
14:00:12 <openstack> Meeting started Thu Aug 25 14:00:07 2016 UTC and is due to finish in 60 minutes.  The chair is nikhil. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:16 <openstack> The meeting name has been set to 'glance'
14:00:32 <rosmaita> o/
14:00:36 <abashmak> o/
14:00:37 <raj_singh> o/
14:00:40 <dharinic> o/
14:00:41 <tsymanczyk> \o
14:00:51 <nikhil> let's get started
14:01:03 <hemanthm> o/
14:01:05 <nikhil> #topic Updates (nikhil)
14:01:20 <nikhil> #info Import Refactor updates
14:01:44 <nikhil> #link https://review.openstack.org/#/q/status:open+project:openstack/glance+branch:master+topic:import-refactor-newton
14:02:15 <nikhil> I pushed up this patch last evening
14:02:17 <nikhil> #link https://review.openstack.org/#/c/270980/
14:02:36 <nikhil> it's ready for review and based on them (whatever gaps of confusion are) I will keep updating the CM
14:02:48 <nikhil> This patch:
14:02:49 <nikhil> #link https://review.openstack.org/267209
14:02:59 <nikhil> it needs a bit of work and I've got it wip
14:03:27 <nikhil> there needs to be a bunch of code removed and headers updated according to latest amendments done
14:03:59 <nikhil> besides, I hope to push a clean set of PS for the rest of the direct streaming to "/stage"
14:04:12 <nikhil> that's that from here, I can take questions
14:05:02 <nikhil> seems like none..
14:05:12 <nikhil> moving on
14:05:14 <Jokke_> o/
14:05:24 <nikhil> #info v1 deprecation (nikhil)
14:05:32 <nikhil> #link https://review.openstack.org/#/c/328390/
14:05:38 <nikhil> I have a few comments inline
14:05:45 <nikhil> looks almost ready to go after that
14:05:50 <nikhil> let's get that sorted asap
14:05:57 <Jokke_> ++
14:06:13 <nikhil> if I don't hear from Mike in next 2-4 hours, I will clean up that patch and post a clean commit for review
14:06:38 <nikhil> #action all: please make it a priority to review v1 deprecation patch https://review.openstack.org/#/c/328390/
14:06:56 <nikhil> There's some concerns on devstack testing on which I've left a comment up
14:07:13 <nikhil> ideally we'd have a spec up for discussion, so if time permits that will be up too
14:07:47 <Jokke_> nikhil: I don't think it hurts to take that over. My comments have been unadressed for over month now
14:08:01 <Jokke_> I seriously doubt few hours will do difference
14:08:04 <nikhil> cool
14:08:32 <nikhil> Jokke_: I see, I just wanted to give a courtesy heads up from my end but I agree this one is too critical to wait
14:09:04 <nikhil> any more comments/questions?
14:09:19 <Jokke_> just give us a ping when you have the new rev up
14:09:25 <nikhil> will do
14:09:28 <nikhil> #topic Important reviews for Newton (nikhil)
14:09:33 <Jokke_> lets get that fixed and merged
14:10:05 <nikhil> I realized , now that we're pushing thing through the pipe near the release week there have been trivial changes proposed
14:10:19 <nikhil> near to release week, that's a really bad idea
14:10:34 <nikhil> it increases load on the gate and results into distraction for cores and waste of time
14:10:54 <nikhil> I have tried to clean up the gate to give cores more b/w to look into importatnt issues
14:11:06 <nikhil> especially many times when I needed second opinion
14:11:40 <nikhil> #info all: please do not encourage trivial fixes or review such at/near to release week
14:12:09 <nikhil> Also, last night I poked out a few stalling commits in the review queue
14:12:25 <nikhil> let me jot them down here and I highly encourage cores to review them
14:12:34 <nikhil> these all are release critical (Whether they make it or not)
14:12:59 <nikhil> #link https://review.openstack.org/270980
14:13:06 <nikhil> #link https://review.openstack.org/328390
14:13:11 <nikhil> #link https://review.openstack.org/272118
14:13:18 <nikhil> #link https://review.openstack.org/324012
14:13:25 <nikhil> #link https://review.openstack.org/313936
14:13:28 <Jokke_> nikhil: I can only speak on my on behalf, but feel free to highlight me on #os-glance for any urgent reviews
14:13:54 <nikhil> #link https://review.openstack.org/352391
14:14:04 <nikhil> Jokke_: sure, will do
14:14:09 <rosmaita> nikhil: me too
14:14:10 <nikhil> thanks!
14:14:31 <nikhil> (these links are also for those who read back the meeting logs, so lemme add them here too)
14:15:21 <nikhil> Also, one more important one:
14:15:30 <nikhil> this lite spec for multi locations deprecation
14:15:32 <nikhil> #link https://review.openstack.org/360220
14:16:06 <nikhil> and the review for removing downgrades:
14:16:08 <nikhil> #link https://review.openstack.org/229220
14:16:23 <nikhil> besides, we will have a few more import commits
14:16:40 <nikhil> that's all for now, if new things come up I will make sure to ping people
14:16:54 <nikhil> any comments/question?
14:17:24 <rosmaita> should we -2 trivial stuff, saying "come back in 2 weeks"?
14:17:34 <nikhil> rosmaita: totally, I just did one this morning!
14:17:36 <Jokke_> nikhil: did you verify when the stable branch will be cut ... RC-2 is due two weeks after N-3
14:17:39 <Jokke_> ?
14:17:49 <nikhil> rosmaita: example one https://review.openstack.org/360372
14:17:53 <Jokke_> RC-1 even
14:18:05 <rosmaita> nikhil: i will follow your example
14:18:10 <nikhil> Jokke_: sorry, didn't get a chance this week. lemme put an action item on me
14:18:32 <nikhil> #action nikhil: verify the date when stable/newton is supposed to be cut
14:19:05 <nikhil> rosmaita: sorry, that may not be perfect example but I will add a comment elaborating on the same
14:19:43 <nikhil> for store related changes, here's a good example :)
14:19:45 <nikhil> #link https://review.openstack.org/357827
14:19:49 <rosmaita> i meant follow in spirit, not exact syntax!
14:19:53 <rosmaita> ok
14:19:56 <nikhil> that one applied to client too
14:20:09 <nikhil> rosmaita: thanks for taking the intent!
14:21:09 <nikhil> #topic Release(s) (nikhil)
14:21:24 <nikhil> we've store and client released to final newton versions
14:21:45 <nikhil> the u-c and g-r have been updated
14:22:07 <Jokke_> and no new breakages?
14:22:10 <nikhil> #link https://review.openstack.org/359559
14:22:17 <nikhil> #link https://review.openstack.org/358263
14:22:23 <nikhil> #link https://review.openstack.org/358391
14:22:28 <nikhil> #link https://review.openstack.org/358262
14:22:38 <nikhil> I have not heard for regressions until now
14:22:59 <nikhil> #link https://review.openstack.org/359511
14:23:17 <Jokke_> goodie
14:23:19 <nikhil> If you work in any other project that uses glanceclient
14:23:37 <nikhil> and the sync to requirements hasn't happened, please point out to the release liaison
14:24:02 <nikhil> let's make sure the client is tested in gate before assuming 2.5.0 is newton version
14:24:12 <Jokke_> :)
14:24:32 <Jokke_> if the u-c is there, then it's used in gate
14:25:00 <Jokke_> regardless if it's updated to g-r or not
14:25:14 <nikhil> https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L135
14:25:23 <nikhil> https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L284
14:25:44 <nikhil> https://github.com/openstack/requirements/blob/master/global-requirements.txt#L53
14:25:55 <nikhil> https://github.com/openstack/requirements/blob/master/global-requirements.txt#L195
14:26:00 <nikhil> Please note the last link
14:26:16 <nikhil> I've set the client version to be >=2.3.0
14:26:42 <nikhil> that means currently 2.3.0 and 2.5.0 is available for packagers to use for newton
14:26:59 <nikhil> tried to find a tradeoff for packagers and latest for gate
14:27:05 <nikhil> works, so kept it that way
14:27:35 <Jokke_> why the minor got bumped if no features were introduced?
14:27:38 <nikhil> Also, for other types of priority items to review please see:
14:27:40 <nikhil> #link http://docs.openstack.org/project-team-guide/release-management.html#release-candidate-period-release-3
14:28:11 <nikhil> Jokke_: release team wants requirements sync to have minor bumps
14:29:22 <nikhil> also, our final release for a cycle needs to have minor bump so that we can keep a clean namespace for that cycle stable backports (2.5.0 for newton means 2.5.1 is next release for stable/newton etc.)
14:29:25 <Jokke_> oh, we had requirement changes there, then we should up our requirement to 2.5.0 as well because that 2.3.0 won't likely match
14:30:00 <nikhil> Jokke_:  you mean, bump the g-r to have 2.5.0?
14:30:08 <Jokke_> nikhil: stable can be cut and continued from patch release without problem ... like 2.4.7 if nothing else causes the ump
14:30:14 <Jokke_> nikhil: yes
14:31:01 <Jokke_> nikhil: so the lib requirements.txt is aligned with the release one
14:31:09 <nikhil> Jokke_: only test-requirements were updated for 2.5.0
14:31:38 <nikhil> https://review.openstack.org/#/c/357688/
14:31:43 <Jokke_> and 2.3->2.4?
14:31:46 <nikhil> Jokke_: so, I think we're okay
14:32:01 <Jokke_> 2.4.0 is the ! release iirc?
14:32:41 <nikhil> Jokke_: yeah, you're right.. my bad I missed a couple other g-r sync from 2.3->2.5
14:32:47 <nikhil> Jokke_: will propose a bump today
14:32:51 <nikhil> thanks!
14:33:01 <Jokke_> and if we bump to 2.5.0 we get rid of the !2.4.0 :)
14:33:07 <nikhil> totally
14:33:08 <Jokke_> so everyone wins ;)
14:33:39 <nikhil> Please note the release schedule:
14:33:42 <nikhil> #link https://releases.openstack.org/newton/schedule.html
14:34:05 <nikhil> Although the release date is thursdays on the release week
14:34:18 <nikhil> I'd like for us to cut either on Tuesday or Wednesday
14:34:34 <nikhil> and only if there are critical patches then wait until Thursday
14:35:16 <nikhil> #info So, let's tenatively say (again) Aug 31st is target release date for Newton Glance (EOD ET)
14:35:19 <Jokke_> So FF deadline is Monday and N-3 supposed to be tagged at Thu (latest)?
14:36:08 <nikhil> Jokke_: FF is the week of R-5
14:36:18 <Jokke_> nikhil: FF is 29th
14:36:34 <nikhil> Jokke_: FF happens when we cut n-3
14:36:52 <nikhil> "Feature freeze
14:36:53 <nikhil> The newton-3 milestone marks feature freeze for projects following the release:cycle-with-milestones model. No featureful patch should be landed after this point. Exceptions may be granted by the project PTL."
14:37:10 <Jokke_> yeah just reading that
14:37:13 <nikhil> k
14:37:16 <Jokke_> interesting
14:37:30 <Jokke_> _everyone_ is talking about 29th
14:37:45 <nikhil> So, all relevant dates for that week is Aug 31 for Glance
14:38:08 <nikhil> Jokke_: we just don't have enouge churn/#people to worry :D
14:38:20 <nikhil> I know only 2-4 people planning to push things
14:38:52 <nikhil> we are a closely nit team and I am positive that we will communicate with each other if concerns are raised
14:39:34 <nikhil> any other comments/ques?
14:40:06 <Jokke_> so that much ... I will be afternoon/evening (UTC+3) of 31st away
14:40:29 <Jokke_> and aiming for PTO from that onwards so don't expect too much last minute actions from me
14:40:38 * nikhil again puts up his release liaison hat on
14:41:23 <nikhil> Jokke_: np, thanks for confirming in advance.. I don't expect any reviews from others after Monday (mostly) there may be exceptional reviews on Tues
14:41:57 <nikhil> Jokke_: whatever gets in gets in.. it's not like we'd dozens of people developing and reviewing in glance this cycle. so all that is achieved is only a bonus!
14:42:16 <Jokke_> nikhil, tru
14:42:44 <nikhil> I want to ensure that we keep things well communicated and make a smooth transition into ocata even before the summit
14:43:03 <nikhil> if we've important reviews to do then we make sure we get them done so that we can have a successful summit
14:43:17 <nikhil> that's my aim and for that I am not putting too much pressure on the release
14:43:50 <nikhil> plus defcore is not going to be topmost priority anymore so, I worry less
14:43:54 <nikhil> even less*
14:44:12 <nikhil> moving on..
14:44:22 <nikhil> #topic Barcelona Design Summit space needs (nikhil)
14:44:38 <nikhil> So, again something we need to agree on by 31st
14:44:44 <nikhil> #link https://etherpad.openstack.org/p/ocata-glance-summit-planning
14:45:01 <nikhil> Please add your +/- 0,1,2 votes
14:46:07 <nikhil> line #13 onward
14:46:40 <nikhil> Last day to cast your vote is Monday 29th
14:47:06 <Jokke_> will likely try to think that over weekend
14:47:14 <nikhil> #info nikhil : will send the final proposal based on votes by 29th to summit planners on Tues 30th
14:47:34 <rosmaita> nikhil: cast voted by 16:00 UTC on aug 29?
14:47:38 <rosmaita> *votes
14:48:00 <nikhil> rosmaita: I will just wake up on Tuesday and send this over :)
14:48:10 <Jokke_> ++
14:48:12 <rosmaita> :)
14:48:21 <Jokke_> Monday anywhere is still in :)
14:48:21 <nikhil> official time can be 23:59 PT
14:48:37 <nikhil> yeah (let's forget hawaii for a bit)
14:49:04 <nikhil> #topic Open Discussion
14:49:49 <nikhil> rosmaita: I remember you'd the members related bug brought up to meeting a couple of times
14:50:00 <nikhil> rosmaita: sorry about not being able to follow up earlier..
14:50:06 <Jokke_> Anyone heard what's the status with Glare guys? And do we have cleanup to do regarding glare before release?
14:50:23 <nikhil> rosmaita: if that's release critical, lemme know and I will try to get it reviewed (as possible)
14:50:30 <nikhil> Jokke_: good point
14:50:59 <nikhil> I had asked mike to put his plans up on:
14:51:01 <nikhil> #link https://review.openstack.org/352564
14:51:06 <rosmaita> nikhil: i don't think it's release critical, plus i don't thnk there's code for it yet
14:51:10 <nikhil> Lemme sketch something up real quick
14:51:44 <nikhil> Jokke_: but information so far is the glare code whatever is in glance stays in for newton and the clean up is expected next cycle
14:51:55 <nikhil> (as murano is using it)
14:52:09 <Jokke_> nikhil: is there anything we need to mark deprecated to be able to do so?
14:52:27 <nikhil> also there are a bunch of glare commits in glance queue that distract me all the time, now that they have decided to move to a new project!
14:52:47 <rosmaita> Jokke_: i think since it was 'experimental' we are ok
14:52:48 <tsymanczyk> can't mark them abandoned?
14:53:16 <nikhil> #action Mike Fedosin: update glare plans in the glance documentation and state if any API needs deprecation in glance in newton
14:53:25 <nikhil> rosmaita: I am of same opinion
14:53:33 <nikhil> but good to have it on paper
14:53:36 <rosmaita> ++
14:53:37 <Jokke_> rosmaita: ok, let's do sanity check that all of it was ... I don't want us to be stuck with it over Ocata just because we forgot mark something deprecated ;)
14:53:50 <nikhil> tsymanczyk: that will be super rude so I have not done that yet
14:53:51 <rosmaita> Jokke_: i agree completely
14:54:13 <nikhil> tsymanczyk: especially as they may not have a full fledged CI testing code for glare project
14:54:27 <nikhil> Jokke_: good pointers, thanks much!
14:54:47 <tsymanczyk> didn't know the etiquette. cool.
14:54:57 <nikhil> tsymanczyk: but you do indicate the attitude everyone needs to take.. clean up things after a decision is made otherwise
14:55:12 <Jokke_> tsymanczyk: yeah ... even they decided to move into their own house, we still love them :P
14:55:46 <nikhil> tsymanczyk: my passive push for getting things cleaned up in glance is the request to add plans
14:55:46 <tsymanczyk> i didn't mean it as an offensive thing, just "hey this stuff isn't ours anymore".
14:56:00 <rosmaita> get off my lawn!
14:56:04 <nikhil> once that is up, we will know what's going in behind the scenes
14:56:21 <Jokke_> tsymanczyk: yup, and it will happen either by them or by some of us but this is bit too soon
14:56:24 <nikhil> tsymanczyk: totally.. just a quirk of openstack community that's it :)
14:57:18 <nikhil> any more comments?
14:57:34 <rosmaita> just about the v2 api bump ... i saw you put up a patch
14:57:42 <Jokke_> tsymanczyk: we're kind on the phase "Mum, I've decided to look for my own place" 2 weeks lated "Hey, your shait is outside of the door, hope you got that place already" ;)
14:57:58 <nikhil> sure
14:57:59 <tsymanczyk> :D
14:58:11 <nikhil> btw, guys this also needs a API bump:
14:58:12 <nikhil> #link https://review.openstack.org/324012
14:58:13 <rosmaita> nikhil: what's changed that requires a bump?
14:58:41 <nikhil> rosmaita: that and if import things merge (at least value discovery and headers then that)
14:58:52 <rosmaita> ok, gotcha
14:59:22 <nikhil> thanks all for joining!
14:59:27 <nikhil> have a good one all.
14:59:41 <nikhil> #endmeeting