14:01:37 <nikhil> #startmeeting glance
14:01:38 <openstack> Meeting started Thu Sep  1 14:01:37 2016 UTC and is due to finish in 60 minutes.  The chair is nikhil. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:40 <nikhil> #topic roll call
14:01:41 <hemanthm|away> o/
14:01:42 <openstack> The meeting name has been set to 'glance'
14:01:47 <liwei> o/
14:01:48 <tsymanczyk> o/
14:01:49 <abashmak> o/
14:01:51 <rosmaita> o/
14:01:56 <nikhil> let's give a couple mins
14:02:04 <croelandt> o/
14:03:07 <nikhil> #topic agenda
14:03:13 <nikhil> https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:03:42 <nikhil> Mostly setting the plans for next few weeks and discussing outstanding issues.
14:03:59 <nikhil> Also, we need to come on the same page for the release work.
14:04:15 <nikhil> #topic Release updates (nikhil)
14:04:33 <nikhil> newton-3 is today
14:05:03 <nikhil> #link https://releases.openstack.org/newton/schedule.html
14:05:25 <nikhil> I've created a link for getting the patches that are waiting to go in for newton-3
14:05:27 <nikhil> #link https://review.openstack.org/#/c/363930/
14:05:48 <nikhil> looks like there are a few still needing reviews
14:06:05 <nikhil> I will list those from my end and others are encouraged to point out here
14:06:26 <nikhil> #info *must* go in newton-3 reviews are below:
14:06:34 <nikhil> #linl https://review.openstack.org/354809
14:06:53 <nikhil> #link https://review.openstack.org/354809
14:06:57 <nikhil> #link https://review.openstack.org/#/c/229220/
14:07:09 <nikhil> Thanks to sigmavirus we've managed to merge that one
14:07:23 <sigmavirus> o/
14:07:40 <nikhil> missing release notes can come in before rc-final is out
14:08:15 <nikhil> #info nice to have reviews for n-3
14:08:20 <nikhil> #link https://review.openstack.org/324012
14:08:33 <nikhil> if that goes in, we *must* bump up the API version
14:08:39 <nikhil> #link https://review.openstack.org/350809
14:08:57 <nikhil> that's it from my side, anyone else?
14:09:32 <nikhil> I see 3-4 reviews related to config help text improvements
14:09:41 <abashmak> https://review.openstack.org/#/c/354332/
14:09:46 <nikhil> what's the status and requirement for those?
14:09:56 <abashmak> this was +2 already but needed rebase
14:10:53 <nikhil> ok then, I wil assume no others are being requested and we can ship out n-3 right after the above linked are merged.
14:11:52 <abashmak> https://review.openstack.org/#/c/363838/
14:11:54 <abashmak> needs workflow
14:12:32 <abashmak> same for: https://review.openstack.org/#/c/363870/
14:13:15 <nikhil> #info client and store stable/newton branches have been cut. Reviewers are free to merge any outstanding commits. Ocata releases don't start until R-0.
14:13:26 <nikhil> thanks abashmak , hoping that's it?
14:13:57 <nikhil> moving on
14:14:10 <nikhil> #topic Import Refactor (nikhil)
14:14:58 <nikhil> as per our discussion from after the glance's weekly meeting
14:15:01 <nikhil> #link http://eavesdrop.openstack.org/irclogs/%23openstack-glance/%23openstack-glance.2016-08-25.log.html#t2016-08-25T15:00:22
14:15:25 <nikhil> the plan is to work on a feature branch where reviewers are more comfortable to test this and move ahead fast
14:15:50 <nikhil> also this will help us avoid any red herrings from outside the project and we can resolve conflicts once everything is ready
14:15:59 <nikhil> I will get that setup later today
14:16:17 <flaper87> FWIW, I couldn't attend last weeks meeting and I'd have appreciated this to be brought up to the mailing list. I actually think a feature branch is not the right approach here as it'll mess up the priority of this work review wise
14:16:22 <nikhil> ha..
14:16:40 <nikhil> I was writing :) .. flaper87 had some concerns on this plan and I will try to resolve them
14:16:57 <flaper87> I don't think it sends the right message and I'd really appreciate more eyes on the reviews than fewer, which is what we'd get on a feature branch
14:16:59 <flaper87> nikhil: :P
14:17:22 <nikhil> flaper87: sure, so.. more explanation is required definitely on 'why' this plan
14:17:35 <nikhil> flaper87: so, the intent is to not avoid more /wider review set
14:17:38 <flaper87> Also, given the fact next cycle is going to be shorter, I think this will just add more work
14:17:52 <flaper87> nikhil: I know that's not the intent but I'm afraid that's what's going to happen :(
14:18:39 <nikhil> flaper87: unfortunately, this is the only way forward.. I tried to setup many reviews this cycle & poked people for them but haven't gotten reviews.
14:19:06 <nikhil> for example: the value discovery patch has been ready (refreshed) but no reviews
14:19:16 <flaper87> I have to disagree, really. I think a feature branch for such important work is a mistake
14:19:36 <nikhil> well, one review :)
14:19:37 <nikhil> https://review.openstack.org/#/c/270980/
14:20:00 <flaper87> I think the lack of reviews might also come from a lack of awareness on this work by other folks and definitely lack of focus (glare?)
14:20:21 <nikhil> flaper87: feature branch or not, I think the intent to just focus on 2 things before the summit
14:20:22 * flaper87 is definitely not trying to find the cause of the current state
14:20:49 <nikhil> flaper87: fwiw, the glance reviews and reviewers have dropped drastically since the split of the project
14:20:54 <rosmaita> i guess we could think of master as the import feature branch?
14:20:57 <nikhil> we can keep disagreeing :)
14:21:00 <flaper87> nikhil: yup, noticed that :(
14:21:23 <nikhil> rosmaita: yeah, I am not interested in the details really
14:21:35 <nikhil> rosmaita: I think the request for feature branch was for 2 main reasons
14:21:40 <nikhil> 1) avoid merge conflicts
14:22:04 <nikhil> 2) have a way to test the entire set of patches cleanly (without extraneous commits from master)
14:22:16 <flaper87> thing is, you'll have to deal with those merge conflicts eventually
14:22:24 <flaper87> anyway, just my $0.02
14:22:26 <nikhil> true
14:22:34 <nikhil> flaper87: so the plan fully is like this:
14:22:42 <nikhil> 1. create a feature branch
14:23:04 <nikhil> 2. set up a test bed for the entire set of patches to deterministically understand import discovery and behavior
14:23:31 <nikhil> 3. get glance's (core and other influencers') consensus
14:23:40 <nikhil> 4. push the entire set to master
14:23:56 <nikhil> 5. link, poke, push cross project teams to review the set again
14:24:17 <nikhil> There are 2 advantages to this approach (besides the disadvatages you describe):
14:24:33 <nikhil> 1) have all glancer's on the same page about the feature
14:25:05 <nikhil> 2) while discussing with wider set of interest parties, have the information and behavior well udnerstood before making further claims
14:25:34 <flaper87> That's where we seem to disagree, I don't think a feature branch will help with #1 and/or #2
14:25:56 <nikhil> Having said that, I believe in democratic decision making (hence the dissatisfaction with glare too):
14:26:13 <nikhil> so, I am okay to vote on the plan and we can etherpad this out
14:26:46 <flaper87> vote sounds good, It might not be needed if everyone agreed during the last meeting
14:26:56 <flaper87> I don't mean to act as a blocker but I definitely wanted to let it all out
14:26:57 <flaper87> :P
14:27:06 <nikhil> flaper87: well, it was just rosmaita Jokke_  and me :)
14:27:07 <flaper87> I plan to help with reviews where/when possible
14:27:21 <flaper87> Jokke_: is on PTO today
14:27:31 <flaper87> so it'd be you, rosmaita and me (and whomever wants to vote)
14:27:32 <flaper87> :D
14:27:36 <nikhil> he told us.. hence the confusion :)
14:27:44 <flaper87> gotcha
14:27:55 <flaper87> ok, if you and rosmaita still think feature branch is good
14:28:02 <rosmaita> i am on the fence
14:28:05 <flaper87> I will stand by it
14:28:13 <flaper87> rosmaita: sorry? :P
14:28:24 <rosmaita> i haven't seen this done in glance before, i don't think?
14:28:31 <nikhil> flaper87: nah, we can ask votes from croelandt , sabari , stuart and othes too (whoever thinks they will have time for reviews)
14:28:37 <flaper87> yup
14:28:40 <flaper87> let me put it this way
14:28:47 <flaper87> I'm don't think I'll code on this
14:28:50 <flaper87> I'll provide reviews
14:29:08 <flaper87> if people that are going to code on this prefer it that way, then I guess I'm ok (which doesn't mean I agree :P)
14:29:20 <nikhil> flaper87: I'm on the fence too
14:29:32 <nikhil> just wanted to point out strong opinions I heard from last sync
14:29:42 <nikhil> otherwise we will have another set of confusion!
14:29:46 <flaper87> nikhil: yeah, thanks for that btw. I appreciate the extra context
14:30:03 <nikhil> flaper87: so, I can assume you acting proxy for both Jokke_  and croelandt
14:30:23 <flaper87> Jokke_: would kill me if I do :P
14:30:40 <flaper87> nah, I just found out about the feature branch today and I didn't have a chance to talk to Jokke_
14:30:46 <flaper87> I thought croelandt was around
14:30:47 <flaper87> croelandt: YO!
14:30:51 * flaper87 shakes croelandt
14:31:09 <nikhil> gotcha
14:31:09 * flaper87 shakes France
14:31:15 <nikhil> LOL
14:31:16 <flaper87> it ain't working
14:31:37 * flaper87 is hereby entitled to speak for croelandt
14:31:39 <flaper87> :P
14:31:53 <flaper87> jokes apart, process wise I don't think it'll help
14:32:01 <flaper87> and by process I mean reviews and get it into master
14:32:20 <flaper87> Code wise, it might. fewer frequent conflicts (you have conflicts when you rebase)
14:32:36 <nikhil> okay, so looks like one -2 on the feature branch and no +2 for it :D
14:32:46 <flaper87> also, I don't want the feature branch to be an excuse for "I'll do weird random commits because meh, it's a feature branch"
14:33:07 <nikhil> flaper87: oh, totoally a possiblity
14:33:39 <croelandt> flaper87: yep
14:33:40 <nikhil> so... this work is open to coding from others but my preference is to keep the team small and connected (So sync regularly and even if there's nothing to sync just talk non-sense)
14:33:41 <croelandt> huhu
14:33:54 <croelandt> I'm a bit skeptical about the whole thing as well
14:34:17 <rosmaita> croelandt: say some more, flaper87 has volunteerd you to do lots of work on this
14:34:27 <nikhil> indeed
14:34:37 * flaper87 won't try to hide the fact he has literally volunteered croelandt
14:34:39 <flaper87> :P
14:35:31 <croelandt> rosmaita: I'm afraid we might end up with more issues than we'll solve, and more complexity in the process
14:35:31 <nikhil> rosmaita: any specific opinions you are looking for?
14:35:34 <flaper87> did we lose contact with France again?
14:35:37 <flaper87> oh, there he is
14:35:42 <croelandt> now I might not be perfectly clear on the details, but eh
14:36:16 <nikhil> okay, let's just discuss the details process later but from the opinions in today's meeting
14:36:24 <rosmaita> croelandt: you mean by having the feature branch?
14:36:34 <nikhil> #agreed import refactor work will NOT have a feature branch and work continues in master
14:36:47 <croelandt> rosmaita: I mean, it might help wit hthe conflicts, but you'll end up having to fix them anyway
14:36:53 <rosmaita> croelandt: gotcha
14:36:57 <croelandt> the whole review process is already heavy enough
14:37:03 <nikhil> heh
14:37:16 <nikhil> croelandt: that's the thought of the day!
14:37:23 <rosmaita> i am in agreement with the #agreed statement
14:37:27 <croelandt> + it will get even more complex for non-pro contributors
14:37:28 * flaper87 gets his wine
14:38:08 <nikhil> should we move on?
14:38:15 <croelandt> yep
14:38:31 <nikhil> thanks all for the valuable input!
14:38:34 <nikhil> moving on..
14:38:37 <flaper87> thanks for listening
14:38:39 <flaper87> :)
14:38:46 <nikhil> #topic Community Images (nikhil, tsymanczyk)
14:38:48 <nikhil> :)
14:39:08 <nikhil> not sure if tsymanczyk is around today..
14:39:13 <tsymanczyk> should i talk?
14:39:18 <nikhil> he is!
14:39:24 <nikhil> (I did see you hi5)
14:39:34 <nikhil> tsymanczyk: please go ahead or I'd have proxy you :)
14:40:26 * rosmaita just noticed that flaper87 has wine
14:40:40 <flaper87> rosmaita: I have a wine cellar :P
14:41:00 <nikhil> tsymanczyk: you still writing?
14:41:14 <tsymanczyk> the original patchset that swaps in a visibilty column is still full of broken tests and nightmares. locally i believe i have sqlalchemy/api.py solid. starting looking at simple.api.py and there's weirdness from the getgo i still need to identify
14:41:44 <tsymanczyk> doing this non tdd is not usual for me. the broken tests make everything hard
14:41:51 <tsymanczyk> even thoygh i broke them
14:41:56 <tsymanczyk> :)
14:42:11 <tsymanczyk> ipad typing is slow
14:43:18 <nikhil> tsymanczyk: I think we forgot to sync on the TDD aspect. that non-TDD was only to help get things ready for newton reviews. now that the plan is different, we can go back to TDD :)
14:43:22 <tsymanczyk> that's all i know. questions comments?
14:44:15 <tsymanczyk> oh and i'll becollapsing the three sets into two. there's no real calue and actually downside to seperating the latter two
14:44:41 <tsymanczyk> will be easier to comprehend and review
14:44:48 <rosmaita> tsymanczyk: only comment is thanks for continuing to work on this!
14:44:55 <nikhil> ++
14:45:24 <tsymanczyk> thank you foryour continued support and patience!
14:46:14 * nikhil was imagining rosmaita and tsymanczyk xoxo :D
14:46:36 <tsymanczyk> o_O
14:46:37 * nikhil is surpised no comments from flaper87 on the comment
14:47:05 <rosmaita> hey, we are trying to show that the glance community is a caring and supportive one!
14:47:09 * nikhil trying to reduce everyone's stress level
14:47:19 <nikhil> rosmaita: indeed a good idea
14:47:20 <rosmaita> group hug everyone!
14:47:29 <rosmaita> (is there an emoticon for that?)
14:47:33 <nikhil> :hug:
14:47:40 <tsymanczyk> {} i think
14:47:53 <nikhil> \o-O-o/
14:47:57 <rosmaita> ok, so {{{{{{{{{{{}}}}}}}}}}}
14:48:14 <nikhil> mine was more for a team celebration, less of a hug
14:48:25 <nikhil> (celebration posing for a picture)
14:48:46 <nikhil> aight looks like no more comments, moving on to the next topic
14:49:01 <nikhil> #topic Mission Statement (rosmaita)
14:49:22 <rosmaita> i put that on the agenda because earlier in the week it was just sitting there
14:49:33 <nikhil> ah
14:49:35 <rosmaita> i thought the TC was waiting for more glance folks to weigh in
14:49:57 <rosmaita> but shortly after i put it on the agenda, the roll call votes started rolling in
14:50:08 <rosmaita> so now my announcement is thtat the TC has approved the change
14:50:56 <nikhil> #info Mission statement for glance has been updated since the glare split see https://review.openstack.org/#/c/354053/
14:51:10 <rosmaita> thank you! that's what i was looking for
14:51:18 <flaper87> nikhil: lol, missed that, sorry
14:51:18 <rosmaita> have too many windows open
14:51:23 <rosmaita> that's all from me
14:51:25 <flaper87> rosmaita: ++
14:51:49 <nikhil> :)
14:52:14 <nikhil> #topic Open Discussion
14:52:25 <nikhil> #link https://bugs.launchpad.net/nova/+bug/1616539
14:52:25 <openstack> Launchpad bug 1616539 in OpenStack Compute (nova) "architecture not validated in "openstack image create"" [Undecided,In progress] - Assigned to tamil vanan (tamilhce)
14:52:46 <nikhil> who proposed that to the agenda?
14:53:06 <nikhil> though, I remember rosmaita chatting with someone regarding this bug??
14:53:07 <rosmaita> probably tamilhce
14:53:10 <rosmaita> i suggested it
14:53:22 <nikhil> ah
14:53:33 <rosmaita> so briefly here's the issue
14:53:43 <rosmaita> we have "common image properties" in glance
14:53:49 <rosmaita> that really aren't special
14:54:00 <rosmaita> they were introduced for interoperability
14:54:17 <rosmaita> so that all openstack clouds would use the same metadata key for these things
14:54:24 <rosmaita> (they are listed in the docs, by the way)
14:54:36 <rosmaita> but, it was completely voluntary for people to acutally use them
14:54:43 <nikhil> #link http://docs.openstack.org/developer/glance/common-image-properties.html
14:55:00 <rosmaita> and at the time, the PTL said that we didn't want to list values because they were likely to change too fast
14:55:12 <rosmaita> whereas people's schemas would most likely only change release-to-release
14:55:40 <rosmaita> so the problem tamil is addressing is that there's no control over what values go in there
14:56:00 <nikhil> rosmaita: but we do the schematic validation!
14:56:03 <rosmaita> and if you misspell something, and a consumer (like nova) is loooking for one of these, it will choke
14:56:11 <nikhil> ah..
14:56:13 <rosmaita> nikhil: we just make sure it's a stirn
14:56:16 <rosmaita> *string
14:56:23 <nikhil> yeah, gotcha
14:56:42 <rosmaita> now, in these modern times, we have metadefs
14:56:49 <nikhil> lol
14:57:07 <rosmaita> so glance has a catalog of metadata keys (standardized) with descriptions of what values they can have
14:57:42 * nikhil remmebers the chat on attempting to enforce them using metadefs
14:57:51 <rosmaita> my opinion is that instead of trying to change the image schema piecemeal, if we want to have value enforcement, we should do it through metadefs
14:58:13 <rosmaita> that way it will extend past just one or two "common image properties"
14:58:33 <nikhil> time check, 90 seconds
14:58:46 <rosmaita> anyway, i guess comment on tamil's patch?
14:59:12 <nikhil> rosmaita: in short, I think this needs much further discussion for we're overlapping two fundamentally different parts of glance together
14:59:12 <rosmaita> i will comment, other interested parties please follow up
14:59:23 <rosmaita> nikhil: ++
14:59:26 <rosmaita> spec for sure
14:59:31 <nikhil> rosmaita: also, Ive a concern regarding the persistence of the metadefs
15:00:02 <nikhil> for instance, could someone forget to update the .json files and override such tweaks via the api (w/o exporting)
15:00:07 <nikhil> anyway, out of time
15:00:12 <nikhil> thanks all for joining!
15:00:23 <nikhil> #endmeeting