14:00:29 <nikhil> #startmeeting glance
14:00:30 <openstack> Meeting started Thu Sep  8 14:00:29 2016 UTC and is due to finish in 60 minutes.  The chair is nikhil. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:33 <openstack> The meeting name has been set to 'glance'
14:00:35 <nikhil> #topic roll call
14:00:37 <kairat> o/
14:00:39 <liwei> o/
14:00:41 <dshakhray> o/
14:00:43 <tsymanczyk> o/
14:00:46 <kragniz> o/
14:00:48 <sigmavirus> o/
14:00:49 <abashmak> o/
14:00:51 <croelandt> o/
14:01:04 <nikhil> let's give another min
14:01:07 <mfedosin> o/
14:01:27 <rosmaita> o/
14:01:41 <dharinic> o/
14:01:56 <nikhil> cool, great turn out
14:02:02 <nikhil> thanks all for joining
14:02:08 <hemanthm> o/
14:02:09 <nikhil> let's get started
14:02:12 <sigmavirus> no, thank you for running the meeting nikhil ;)
14:02:17 <nikhil> :)
14:02:21 <nikhil> #topic agenda
14:02:23 <nikhil> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:47 <nikhil> so short meeting agenda, but I'd like to give more time to each topic
14:02:56 <nikhil> see where we're falling short and where we're doing great
14:03:20 <nikhil> #topic Newton release updates ( nikhil )
14:03:49 <nikhil> First things first..
14:03:49 <bunting> o/
14:04:01 <nikhil> we NEED reviews on the patches that are likely to make it to Newton
14:04:22 <nikhil> of them the most important ones are the security bugs if any
14:04:47 <nikhil> if you are in glance-core-sec , please try to see if there are any outstanding patches that need to be addressed
14:05:19 <nikhil> #action glance-core-sec: look into outstanding security bugs that could be fixed in newton
14:05:41 * nikhil puts on his release liaison hat
14:05:59 <nikhil> I've started narrowing down the reviews that are potentially good candidates
14:06:09 <nikhil> #link http://lists.openstack.org/pipermail/openstack-dev/2016-September/103159.html
14:06:17 <nikhil> #link https://review.openstack.org/#/q/status:open+project:openstack/glance+topic:newton-rc-potential
14:06:42 <nikhil> We need the release notes, API bump and if necessary the config reordering by next week for sure
14:07:05 <nikhil> then there's this upcoming event
14:07:07 <nikhil> #link http://lists.openstack.org/pipermail/openstack-dev/2016-September/103158.html
14:07:28 <nikhil> Hope you can participate there
14:08:04 <nikhil> dual advantage: get the bugs triaged and find potential candidates for Newton to be fixed (helps with determining the urgency for rc[2,3])
14:08:37 <nikhil> also, if you know something that should make it to newton please ping me
14:09:16 <nikhil> about store and client, there've been a few reviews that matter even for next release
14:09:49 <nikhil> so, do keep an eye out for any critical issues. I'm just making sure that we don't assume things to be done until we officially release newton.
14:10:13 <nikhil> that's it on that topic from me.
14:10:21 <nikhil> ques /comments?
14:11:10 <nikhil> ok, moving on then
14:11:28 <nikhil> #topic Import Refactor updates (nikhil)
14:11:49 <nikhil> So, as agreed in the previous meeting we are NOT going to propose a feature branch for this work
14:12:26 <nikhil> this is to be continued on master and people are encouraged to give these reviews second preference (preference after newton rc reviews)
14:12:41 <rosmaita> i've been thinking about that (feature branch) and think it's good NOT to do it
14:12:51 <croelandt> +1
14:12:56 <rosmaita> i came across this wiki page by john dickinson
14:13:10 <rosmaita> https://wiki.openstack.org/wiki/Swift/feature_branches
14:13:21 <rosmaita> looks like it's good if the feature will span cycles
14:13:27 <nikhil> #link http://eavesdrop.openstack.org/meetings/glance/2016/glance.2016-09-01-14.01.html
14:13:30 <rosmaita> which we *don't* want to do here
14:13:36 <sigmavirus> Yeah, they're useful, but this isn't so much a feature that's still under decision as it is something we've committed to
14:13:44 <rosmaita> exactly
14:13:47 <sigmavirus> I'm very happy with the decision to *not* do it
14:14:33 <nikhil> I agree with your arguments and the only reason this idea was kept floating was to respect community members request who was willing to test and review things then
14:14:35 <rosmaita> anyway, just wanted to re-register my agreement
14:14:43 <nikhil> member's*
14:15:12 <nikhil> also..thanks for sharing the link Brian
14:15:18 <nikhil> rosmaita ^
14:15:22 <rosmaita> np
14:15:27 <nikhil> ...
14:15:33 <notmyname> haooy to answer questions about feature branches if any come up
14:15:34 <nikhil> however, I think swift is a special case (for feature branches)
14:15:43 <nikhil> notmyname: hoo
14:16:12 <notmyname> nikhil: I disagree with swift being a special case (but I'm sensitive on that wording)
14:16:12 <nikhil> *I think* the hummingbird was a drastically different innovation
14:16:33 <notmyname> nikhil: hummingbird was our 4th(?) feature branch. we've been using them for years, very successfully
14:16:40 <nikhil> notmyname: sorry about the wording then.. I am trying to explain what I mean by that
14:16:50 <rosmaita> notmyname: thanks for that writeup, it was helpful
14:17:09 <nikhil> notmyname: yeah, I want to avoid that discussion here.. out of context I think
14:17:42 <nikhil> my point was that feature branches shouldn't only be considered only for such features
14:17:53 <notmyname> in our experience, feature branches have been essential for gettign big stuff done. I'm a fan, having seen the success, and I hope other projects can learn from what we've done. I hope it would work for you, but if not, that's ok too
14:17:53 <nikhil> I think short term experimentation does count it
14:18:45 * nikhil just trying to write things down so that this argument of feature branch doesn't affect decisions in the future about request for other features needing such things
14:19:24 <rosmaita> yeah, everyone should read notmyname 's wiki page about feature branches
14:19:29 <rosmaita> good advice for some situations
14:19:54 <nikhil> back to import work
14:20:05 <nikhil> let's focus on the code & reviews
14:20:21 <nikhil> We've some good first set of suggestions from abashmak
14:20:23 <nikhil> #link https://review.openstack.org/270980
14:20:38 <nikhil> I would encourage others to take a look as well so that we can start moving forward
14:21:22 <nikhil> We've stalled on this work for quite long and constrcutive reviews is something we absolutely need
14:22:08 <nikhil> initial commits will need more "concept" check
14:22:22 <nikhil> and the later ones as usual need adherence check
14:22:46 <nikhil> so,  please try to think of architecture in the first phase and review accordingly (my 2 cents)
14:23:52 <nikhil> Import work is our first preference after rc-1 until the summit
14:24:53 <nikhil> Also, I've assigned some tasks to people but I want to do a reality check in terms of who has bandwidth to write code for this and be coordinated and who wants to opt-out
14:25:26 <nikhil> in the worst case, as I've mentioned I am willing to shoulder this responsiblity (after rc-1) completely
14:26:28 <nikhil> (I am guessing no one is interested here)
14:26:49 <rosmaita> well, i think the usual suspects are interested
14:27:05 <tsymanczyk> i don't think my boss would approve my time for it
14:27:14 <nikhil> I will give some time over the next couple of days to finish an email about defcore and import refactor
14:27:23 <rosmaita> so priorities are: critical bugs until rc-1, image import after
14:27:26 <rosmaita> ?
14:27:32 <nikhil> hopefully that will give us closure on who is interested and who isn't
14:28:09 <nikhil> rosmaita: for cores it's usually, reviews then bugs (but yes, critical bugs) until rc-1 then import
14:28:17 <croelandt> nikhil: I'll probably have some time for the import refactoring
14:28:29 <croelandt> though I'd have to re-read the new spec and see what we a ctually agree on
14:28:55 <nikhil> croelandt: that's okay. would you be available for reviews until rc-1 ?
14:29:36 <nikhil> #agreed rosmaita , croelandt and nikhil to split up import refactor code after rc-1
14:30:10 <rosmaita> ++
14:30:12 <nikhil> croelandt: you are free to take your time to read up on the latest spec until then
14:30:42 <nikhil> croelandt: but please make sure you also take some time to read on the discussions on the reviews proposed for that spec and alternatives for that spec, etc.
14:30:56 <croelandt> nikhil: probably :)
14:31:02 <nikhil> there's a TON of context that one needs to be aware of to avoid re-raising concerns
14:31:10 <rosmaita> croelandt: you will need to brew some pots of extra-strong coffee
14:31:47 <rosmaita> but also, ping me or nikhil in #openstack-glance for discussion while you read
14:31:48 <nikhil> rosmaita: ++
14:31:50 <croelandt> sure
14:32:01 <sigmavirus> nikhil: count me in on image refactor too
14:32:05 * sigmavirus was distracted with something else
14:32:18 <nikhil> rosmaita: I think we'd again start our weekly sync on #openstack-glance for the import refactor
14:32:19 <rosmaita> yay!
14:32:29 <rosmaita> (that was for sigmavirus )
14:32:30 <nikhil> that's a bonus!
14:32:33 <nikhil> woohoo
14:32:37 <nikhil> #undo
14:32:38 <openstack> Removing item from minutes: <ircmeeting.items.Agreed object at 0x7f23bdf68fd0>
14:32:41 <rosmaita> but yay! also for import refactor meeting
14:32:53 <nikhil> #agreed rosmaita , croelandt, sigmavirus and nikhil to split up import refactor code after rc-1
14:34:15 <nikhil> questions, comments?
14:34:50 <nikhil> moving on..
14:35:01 <sigmavirus> :D
14:35:03 <nikhil> #topic Community Images ( tsymanczyk )
14:35:31 <tsymanczyk> so this week the 2nd api, simple, was mostly finished
14:35:56 <tsymanczyk> fiund a couple preexidting bugs along the way. filed both fixed one
14:36:56 <tsymanczyk> i dont expect the last api to take long, then circle back to do unit tests (fix) on the original ispublic to visibility column swap
14:37:07 <tsymanczyk> which i expect to be paibful
14:37:15 <tsymanczyk> that is all from me
14:37:29 <nikhil> thanks. nice update.
14:37:30 <tsymanczyk> typos are ipad typing sorry its terible
14:37:47 <nikhil> looks like we're going steady, so that's a great sign.
14:37:57 <rosmaita> "paibful" seems like so painful you need to drink pabst blue ribbon
14:38:12 <tsymanczyk> that IS paibful!
14:38:12 <nikhil> lol
14:38:34 * nikhil doesn't have any comments
14:38:46 <nikhil> any more*
14:39:35 <tsymanczyk> anyone else?
14:40:06 <nikhil> moving on then..
14:40:14 <nikhil> #topic open discussion
14:40:47 <nikhil> Just want to congratulate our friends mfedosin and kairat to have successfully setup glare project and the irc channel
14:41:05 <rosmaita> congratulations!
14:41:16 <tsymanczyk> nice!
14:41:16 <nikhil> I saw some great discussion yesterday on #openstack-glare (which is missing the channel topic fyi)
14:41:25 <mfedosin> nikhil: thanks :)
14:41:33 <mfedosin> we're preparing the final release
14:41:54 <nikhil> glad to see the community forming and the discussiona and decisions being logged on irc !!! BIG WIN :))
14:42:09 <mfedosin> we just need to approve the design of artifact types
14:42:17 <nikhil> mfedosin: I see, so we are going to have a newton rc-1 for glare ?
14:42:29 <mfedosin> btw - welcome to our irc channel #openstack-glare
14:42:48 <mfedosin> nikhil: nope, we decided not to have it for Newton
14:43:02 <nikhil> mfedosin: ok
14:43:15 <nikhil> mfedosin: a few people have asked about glare/artifacts plans in glance
14:43:27 <nikhil> mfedosin: I was hoping that we get some things documented when you've time
14:43:45 <nikhil> mfedosin: if you want we could do a hangout and then I or doc liaison could write it up for you?
14:44:05 <rosmaita> +1
14:44:11 <nikhil> just want to get these things out for the community and create some FAQs in the glance project in launchpad
14:44:14 <rosmaita> might be the quickest way to get a sense of the plans
14:44:22 <mfedosin> at first I want to remove the spec from glance-specs
14:44:24 <nikhil> nothing urgent, sometime before the summit would be ideal
14:45:07 <nikhil> rosmaita: yeah, that is there as well
14:45:21 <bunting> Just to let you guys know, its my last week before I go back to uni, so am going to be about a lot less.
14:45:23 <nikhil> as long as glance and glare cores are aware I think we'd be good
14:45:51 <rosmaita> bunting: sorry to hear that, you have made a lot of contributions to glance
14:46:03 <rosmaita> and been an active community member
14:46:17 <bunting> rosmaita: Thanks :)
14:46:23 <nikhil> bunting: oh noes, sad to hear you being here lot less but happy you get to go back to school work!
14:46:59 <nikhil> and I completely agree with rosmaita , your contributions have been /are very helpful indeed.
14:47:26 <bunting> Yeah, it was good fun. I'm glad i got to contribute
14:47:38 <bunting> If openstack keeps growing, i could come back ;)
14:48:00 <nikhil> Ox (fingers crossed)
14:49:31 <nikhil> coming back to glare, I was hoping to give back some reviews
14:49:46 <nikhil> but I prolly won't get as much time until end of september
14:50:13 <nikhil> hopefully, there's good amount available for reviews then, mfedosin
14:50:46 <nikhil> any other topics before we close?
14:51:20 <nikhil> thanks all for joining!
14:51:33 <rosmaita> bye!
14:51:39 <bunting> bye!
14:51:47 <nikhil> (election season coming up... so keep an eye out for interesting emails)
14:52:00 <nikhil> #endmeeting