14:01:15 <rosmaita> #startmeeting glance
14:01:15 <rosmaita> #topic roll call
14:01:16 <openstack> Meeting started Thu Sep 29 14:01:15 2016 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:20 <openstack> The meeting name has been set to 'glance'
14:01:25 <tsymanczyk> \o
14:01:35 <sigmavirus> o/
14:01:39 <dharinic> o/
14:01:51 <abashmak> o/
14:02:13 <kragniz> o/
14:02:20 <rosmaita> louis!
14:02:32 <rosmaita> mike!
14:02:36 <mfedosin> hey :)
14:02:48 <mfedosin> sorry, I'm late
14:03:06 <rosmaita> np, you haven't missed anything yet
14:03:19 <rosmaita> hopefully a few more people will wander in
14:03:29 <rosmaita> #topic agenda
14:03:37 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:03:39 <Jokke_> o/
14:03:56 <rosmaita> erno!
14:04:11 <tsymanczyk> maybe free donuts would attract more people
14:04:12 <rosmaita> i am setting a bad precedent by not greeting the people who were on time
14:04:22 <rosmaita> free virtual donuts!
14:04:27 <tsymanczyk> ooooo
14:04:36 <rosmaita> #topic releases
14:04:46 <rosmaita> RC2 is out (a day early!).
14:04:58 <rosmaita> Thanks to sigmavirus (Ian) and Jokke (Erno) for their work reviewing, etc.
14:05:09 <rosmaita> And thanks to hemanthm (Hemanth) for quick work on a security-related fix that got in.
14:05:10 <tsymanczyk> nice work!
14:05:20 <Jokke_> \\o \o/ o// o/7
14:05:44 <rosmaita> I've noticed a lot of TrivialFix kind of patches up, let's please wait to merge any of those until *next week*.
14:05:54 <rosmaita> Let's keep the gate unclogged as a courtesy to other teams while the rest of the RCs are being cut.
14:06:12 <rosmaita> so reviewers, feel free to -1 workflow on any of those
14:06:29 <rosmaita> The official date for the Newton release is 6 Oct (one week from today)
14:06:55 <rosmaita> the only thing left are some doc changes to deprecate v1 and indicate the v2 minor version bump
14:07:13 <rosmaita> i will be bugging people to review those patches
14:07:28 <rosmaita> would like to have the docs ready for 6 Oct
14:08:02 <rosmaita> that's all from me ... questions?
14:09:23 <Jokke_> ++
14:09:36 <rosmaita> ok, moving on, then
14:09:50 <rosmaita> #topic import refactor
14:10:06 <rosmaita> I want to get a sync started, like we've been doing for community images
14:10:18 <rosmaita> This will be a 20 minute or so weekly meeting to help build momentum
14:10:29 <rosmaita> Anyone interested, please indicate your availability:
14:10:39 <rosmaita> #link http://doodle.com/poll/xc3ip9263bq5rmbh
14:10:58 <rosmaita> The sync will be in #openstack-glance, everyone can follow along, even if you are only casually interested
14:11:58 <rosmaita> ok, timothy's turn
14:12:06 <rosmaita> #topic community images
14:12:13 <rosmaita> before he says anything though
14:12:20 <rosmaita> there are patches up, please review!
14:12:32 <rosmaita> ok, tsymanczyk , all yours
14:12:36 <tsymanczyk> indeed. two pieces of good news today.
14:12:42 <tsymanczyk> https://review.openstack.org/#/c/369110/25
14:12:47 <Jack> Hello all. first time here, wondering if we have audio in this meeting?
14:13:01 <rosmaita> Jack: nope, just typing and reading
14:13:03 <tsymanczyk> the first patchset is done as well as i can make it without feedback.
14:13:12 <Jack> Ok, thanks
14:13:15 <tsymanczyk> so please review, please be harsh. quality is all i care about
14:13:56 <tsymanczyk> and secondly : the biggest outstanding problem that there WAS is how in the heck to (as well as possible) keep v1 backwards compatible while still allowing the new functionality with v2
14:14:06 <tsymanczyk> and i think it's much much simpler than i had been worried about
14:14:31 <tsymanczyk> the reason that it seems difficult is because of a misunderstanding that "public" and "private" are the two old visibility states, and that "Shared" and "community" are the two new states
14:14:38 <tsymanczyk> BUT (and here's my theory, feedback please)
14:14:51 <tsymanczyk> in reality, is_public==true is indeed public, but is_public==false is actually shared
14:15:08 <tsymanczyk> so when we migrate old to new, we don't set everything is_public=false to private we set it to shared
14:15:11 <tsymanczyk> which retains the old behaviour
14:15:24 <tsymanczyk> shared with no members IS effectively private, and members can be added with no additional steps beyond the add
14:15:33 <rosmaita> interesting
14:15:55 <tsymanczyk> then if we continue that idea, and have v1 set visibility=shared when doing a set to is_public=false, then ... unless i'm missing something... we basically get everything we want.
14:16:19 <tsymanczyk> the really confusing thing though that i'm worried about is that people are going to ... perhaps legitimately... get spooked when they migrate to the new database and see that all their old non-public images are now SHARED
14:16:26 <rosmaita> i need to think about that some more
14:16:31 <tsymanczyk> even though that doesn't change their real-world visibility
14:16:34 <rosmaita> yes, that was my concern
14:16:35 <tsymanczyk> rosmaita : please do
14:16:49 <tsymanczyk> i've been chewing it over for about a day and every angle i've looked at makes it seem correcet
14:16:57 <tsymanczyk> but if there are problems i'd love to see them
14:17:09 <rosmaita> #action rosmaita to think about tsymanczyk 's idea and discuss at sync tomorrow
14:17:11 <tsymanczyk> right now this looks to me to be a clean way to solve it.
14:17:21 <tsymanczyk> we just need to make the documentation clear
14:17:26 <rosmaita> ++
14:17:30 <tsymanczyk> that SHARED doesn't mean ... EVERYONE CAN SEE MY STUPID BROKEN IMAGE
14:17:36 <tsymanczyk> i think i'm done
14:17:53 <tsymanczyk> would love any questions or feedback now or later on today or during tomorrows sync (9am pst)
14:18:08 <rosmaita> my mind is blown
14:18:14 <tsymanczyk> :)
14:18:38 <rosmaita> we get counterintuitive results no matter what we do, so it's really a matter of picking the one that makes the most sense
14:19:11 <rosmaita> ok
14:19:25 <rosmaita> that's the end of the "official" updates
14:19:45 <rosmaita> #topic cross-project liasons
14:20:02 <rosmaita> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
14:20:18 <rosmaita> #action everyone - look at that page and update your name appropriately before nex glance meeting on 6 Oct
14:20:35 <rosmaita> what do i mean by "update appropriately"?
14:20:40 <rosmaita> glad you asked
14:20:54 <rosmaita> here are the expectations for a cross project liason
14:21:03 <rosmaita> 1 - must attend the other project's weekly meeting
14:21:16 <rosmaita> actually, i guess that's it.  key thing is attendance
14:21:28 <rosmaita> in the past, you've had to be a core to do this, but i am going to loosen that up
14:21:53 <rosmaita> but we need to get the page updated before new people can sign up
14:22:04 <rosmaita> but if you are on there already, and want to continue, that's fine
14:22:26 <rosmaita> well, here's another thing
14:22:34 <rosmaita> 2 - must represent glance at the other team's meeting
14:22:49 <rosmaita> what i mean is, if something that could impact glance comes up, please put it in *our* agenda and report back to the team
14:23:00 <rosmaita> if the other team has a question, and you aren't sure about the answer, just tell them you will consult with the glance team and get back to them at the next meeting
14:23:16 <rosmaita> the requirement to have only cores was so that other teams would get instant answers
14:23:32 <rosmaita> but i don't see the harm in having them wait one week for a definitive answer
14:23:46 <rosmaita> it wlll allow us to have more c-p representatives
14:23:51 <rosmaita> anyway
14:24:03 <rosmaita> the action item is to look at the page, if your name is there, decide if you are willing to do (1) and (2)
14:24:11 <rosmaita> if not, please remove your name before 6 Oct
14:24:29 * abashmak is thinking about picking a project whose weekly meeting is held later than 7am MST
14:24:39 <stevelle> :D
14:24:44 <rosmaita> any criterion you like!
14:25:30 <rosmaita> being a cross-project liason is important, we need to keep informed about stuff affecting glance
14:25:35 <rosmaita> and glance affecting other projects
14:25:53 <rosmaita> the changes to image sharing are going to affect openstack client for sure
14:26:07 <rosmaita> so we need to keep other teams informed as well
14:26:44 <rosmaita> this will be a great opportunity for people who want to eventually be glance cores
14:26:55 <rosmaita> plus, virtual donuts to all!
14:27:18 <rosmaita> not sure i got the action item in
14:27:52 <rosmaita> #action all current cross-project liasons -- please decide if you want to continue and update the page
14:28:06 <rosmaita> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
14:28:21 <rosmaita> any comments, questions?
14:29:06 <rosmaita> it is awful quiet in here
14:29:09 <rosmaita> ok, moving along
14:29:25 <rosmaita> #topic Feedback for Item 4 on last week's agenda
14:29:29 <Jokke_> Also for any new folks for OpenStack wiki, feel free to ping us if you need something changed. I think the new wiki account creation is still frizen
14:29:45 <Jokke_> frozen even
14:29:46 <sigmavirus> Jokke_: correct
14:29:47 <rosmaita> Jokke_: good point
14:30:04 <rosmaita> and that's a good segue into this next topic
14:30:13 <Jokke_> I have at least account, please anyone else put your hands up as well ;)
14:30:33 <rosmaita> i have one too, though haven't used it recently
14:31:16 <rosmaita> with the wiki locked down, nikhil proposed that we include an events page in the dev docs
14:31:26 <rosmaita> #link https://review.openstack.org/#/c/366923/
14:31:39 <rosmaita> then to make an announcement, you put up a patch
14:32:02 <rosmaita> and since reviews happen so quickly, it will be faster than the wiki
14:32:09 <rosmaita> :)
14:32:24 <rosmaita> so i don't know how i feel about this idea
14:32:35 <rosmaita> anyone have feedback or alternatives?
14:33:03 <sigmavirus> rosmaita: uhm, I don't like that
14:33:10 <sigmavirus> I don't like using the wiki for it either
14:33:19 <sigmavirus> Although
14:33:25 * rosmaita is waiting for spammers to start putting up viagra patches
14:33:34 <sigmavirus> I guess we can put event info in those docs and then blast the ML with them
14:33:48 <rosmaita> yeah, i think that was the idea
14:33:51 <sigmavirus> rosmaita: couldn't we also use the openstack blog(s) for this kind of stuff?
14:33:55 <Jokke_> I think the biggest problem with that approach is that it needs maintenance and before agreeing to do something like that, I'd like to see who is gonna maintain it
14:34:12 <sigmavirus> Jokke_: we (the community) are :D
14:34:21 <Jokke_> sigmavirus: my point exactly
14:34:28 <rosmaita> sigmavirus: don' know about the openstack blog
14:34:46 <hemanthm> I think Nikhil it's more for us to keep log of what happening during those meetings
14:34:53 <hemanthm> not entirely for announcing the events
14:34:58 <rosmaita> part of nikhil's idea was to keep a record of what glance has been doing
14:35:02 <hemanthm> like keeping the etherpads from past events
14:35:08 <rosmaita> (basically what hemanthm said)
14:35:11 <sigmavirus> but less ephemeral
14:35:13 <sigmavirus> got it
14:35:18 <Jokke_> rosmaita: that's why these meetings are logged
14:35:24 <sigmavirus> I was thinking that the documentation is a bad way of announcing things
14:35:30 <rosmaita> but, pipermail is also an archive
14:35:41 <Jokke_> and our channel is logged and mailing list is archived
14:35:44 <rosmaita> for ML postings
14:35:50 <rosmaita> what Jokke_
14:35:52 <sigmavirus> rosmaita: right
14:35:56 <hemanthm> Jokke_: yes, but hard to discover
14:35:57 <rosmaita> though maybe not so easy to search
14:35:57 <Jokke_> do we really need another source of truth
14:36:12 <sigmavirus> Jokke_: we need a web of truth ;)
14:36:33 <Jokke_> sigmavirus: yeah, like internet. Everything written there is true, right!
14:37:31 <Jokke_> so perhaps we should use the #command like #info here more to document these things without needing to read hours of irc logs
14:38:15 <rosmaita> well i think the idea is:
14:38:25 <rosmaita> 1 - #info at weekly meeting
14:38:31 <rosmaita> 2 - patch
14:38:47 <sigmavirus> patch with link to eavesdrop.o.o?
14:38:47 <rosmaita> 3 - ML announce with link to (what? doc or patch)
14:38:56 <rosmaita> 4 - etherpad during the event
14:38:56 <sigmavirus> That seems like a lot of process
14:39:08 <rosmaita> yeah, and i am forgetting 5 and 6
14:39:09 <Jokke_> sigmavirus: ++
14:39:18 <sigmavirus> We're already bad at other processes that take more than 2 steps in this community
14:39:27 <sigmavirus> Why would we add another process with > 2 steps?
14:39:46 <Jokke_> unless we can automate steps 2+
14:40:04 <rosmaita> well, we *are* sort of doing this already
14:40:10 <rosmaita> without the doc patch
14:40:18 <sigmavirus> we probably could but people don't always appreciate auto-generated emails
14:40:25 <rosmaita> i mean, announce here, on ML, create etherpad
14:40:58 <Jokke_> rosmaita: and on that, normally the etherpad is already either totally ignored or forgotten after 2hrs
14:41:29 <rosmaita> ok, i am sensing opposition to this idea
14:41:35 * rosmaita is very sensitive
14:41:50 <stevelle> it's the midochlorians
14:41:57 <rosmaita> :)
14:42:12 <Jokke_> yeah I'm pretty much with sigmavirus on this ... smells like heavy process for how bad we are already with processes
14:42:26 <rosmaita> ok, no point having a vote, you can comment on the patch, so sigmavirus and Jokke_ , please do
14:42:27 <Jokke_> also I kind of dislike the noise that will bring to the reviews as well
14:42:59 <rosmaita> #action sigmavirus Jokke_ comment on https://review.openstack.org/#/c/366923/
14:43:16 <rosmaita> also, anyone who likes the idea, feel free to commnet on that patch
14:43:24 <rosmaita> we can move the discussion over there
14:43:24 <hemanthm> what's the alternative though?
14:43:34 <rosmaita> alternative is just do what we do now
14:43:51 <Jokke_> yeah irc, ml, profit
14:44:26 <hemanthm> there's gotta be a better way to keep relevant historical context
14:44:36 <hemanthm> but I don't have a solution yet :/
14:44:54 <rosmaita> hemanthm: i agree
14:45:06 <rosmaita> and i should say, thanks to nikhil for getting this discussion started
14:45:21 <rosmaita> maybe someone will be inspired to come up with a good solution
14:45:34 <rosmaita> ok moving along
14:45:49 <rosmaita> #topic Design summit planning
14:46:01 <rosmaita> The votes have been cast, so thanks to everyone who voted.
14:46:07 <rosmaita> but
14:46:19 <rosmaita> the key question right now is: only 3 people have indicated that they are attending the summit
14:46:33 <rosmaita> which will be quite cozy, but it does affect the discussion ... like for instance if no one working on rolling upgrades will be there, then maybe it is kind of pointless to have that session (even though it got the most votes)
14:46:45 <rosmaita> so
14:46:55 <rosmaita> #action everyone - indicate if you will be at the summit on the etherpad
14:47:17 <rosmaita> #link https://etherpad.openstack.org/p/ocata-glance-summit-planning
14:47:32 <rosmaita> that being said
14:47:34 <rosmaita> my informal interactions are indicating that there won't be a lot of glance people in Barcelona
14:47:45 <rosmaita> so i think we should plan to have a virtual design summit as we have done in the past
14:48:27 <rosmaita> but please let's get a likely headcount to help pick physical topics
14:48:39 <rosmaita> that didn't come out quite right, but hopefully you know what i mean
14:49:24 <hemanthm> +1 to virtual design summit
14:50:05 <rosmaita> ok, i just added a place for people interested in a virtual summit to indicate interest
14:50:08 <rosmaita> so please do
14:50:29 <tsymanczyk> the virtual summit is going to coincide with the actual-summit session i assume?
14:50:44 <rosmaita> no, it will be non-concurrent
14:51:14 <rosmaita> it has been really hard to get virtual attendance at an actual design summit session
14:51:55 <Jokke_> I'm starting to think that the virtual summit is likely more hurting us in long term than benefitting
14:51:56 <tsymanczyk> fair enough. no point in making the fallback option difficult.
14:52:09 <rosmaita> Jokke_: why is that?
14:53:38 <rosmaita> i guess i should be more clear about what i'm thinking
14:53:39 <Jokke_> rosmaita: well for example what you just said that the number of attendees are declining. Could that be because of companies thinking "We don't need to send our glance folks to summit as they can always participate to the virtual planning even anyways"
14:53:57 <Jokke_> s/even/event/
14:54:15 <rosmaita> Jokke_: very possibly, but that doesn't matter for Barcelona, travel has already been approved/denied
14:54:49 <rosmaita> but i do see your point
14:55:02 <rosmaita> gives companies an excuse not to send people
14:55:08 <sigmavirus> Jokke_: I don't think at least my employer makes decisions that way
14:55:16 <rosmaita> though, hopefully they will send more people to the PTG in february
14:55:25 <sigmavirus> summit attendance here is based on role in project & whether or not someone is speaking
14:55:41 <sigmavirus> (also whether or not they actually want to travel to the summit)
14:56:11 <rosmaita> my idea is that the virtual summit doesn't need to cover the same exact topics as the physical summit
14:56:30 <rosmaita> though maybe that is dumb
14:56:34 <rosmaita> i welcome feedback
14:57:00 <rosmaita> anyway, if there is enough interest in virtual summit, i will set up a doodle poll for format and scheduling
14:57:04 <rosmaita> probably 2 different polls
14:57:15 <rosmaita> and we will need to try out some communication options
14:57:34 <rosmaita> to pick something
14:58:47 <rosmaita> ok, please update the etherpad
14:58:54 <rosmaita> #topic general discussion
14:59:01 <rosmaita> 1 minute left
14:59:06 <abashmak> I'd like to ask people to weigh in on the Alembic Migration proposal: https://review.openstack.org/374278
14:59:10 <tsymanczyk> okayquickoneminuteforopendiscussion
14:59:15 <abashmak> ... and on our Rolling Upgrades Database strategy: https://review.openstack.org/331740
14:59:43 <rosmaita> #action everyone follow abashmak 's suggestions
14:59:51 <rosmaita> ok, 10 seconds
15:00:00 <rosmaita> #endmeeting