14:01:12 <rosmaita> #startmeeting glance
14:01:14 <openstack> Meeting started Thu Nov 17 14:01:12 2016 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:18 <openstack> The meeting name has been set to 'glance'
14:01:27 <rosmaita> #topic roll call
14:01:35 <rosmaita> hello jokke_ , alex_bash
14:01:39 <abhishek_k> \o
14:01:45 <alex_bash> morning
14:02:11 <rosmaita> let's wait another minute or so
14:02:14 <kairat> \o
14:03:28 <rosmaita> #topic updates
14:03:46 <rosmaita> first, no meeting next week (Nov 24)
14:03:54 <rosmaita> Thanksgiving holiday in USA
14:04:10 <rosmaita> will probably also be low availability of reviewers
14:04:31 <jokke_> oh it's next week
14:04:50 <rosmaita> second, Spec freeze is next week, 23:59 UTC 25 November 2016
14:05:09 <rosmaita> i'm going to devote tomorrow to reviewing all open specs
14:05:28 <rosmaita> will probably ping cores directly for key specs that need review
14:05:48 <jokke_> I'm assuming the freeze does not affet the amendments
14:05:50 <rosmaita> or, motivated persons can look themselves
14:05:55 <rosmaita> #link https://review.openstack.org/#/q/project:openstack/glance-specs+status:open
14:05:59 <rosmaita> jokke_: correct
14:06:51 <rosmaita> final update: O-1 update and roadmap changes
14:07:03 <rosmaita> #link https://etherpad.openstack.org/p/ocata-glance-prioritization-and-roadmap
14:07:13 <rosmaita> key changes
14:07:24 <rosmaita> we missed O-1 for Community Images
14:07:31 <jokke_> sorry for that :(
14:07:42 <rosmaita> but, thanks to abhishek_k and alex_bash we did get the "community" goal accomplished
14:08:01 <jokke_> big hand guys
14:08:13 <abhishek_k> thank you :
14:08:43 <alex_bash> o/
14:08:43 <rosmaita> we'll talk more about the Community Images situation in a bit
14:09:05 <rosmaita> but for now, i'd like to get it merged the week of Nov 28
14:09:34 <rosmaita> don't want to stop momentum
14:09:55 <rosmaita> ok, that's all the updates
14:10:26 <rosmaita> #topic Virtual Design Session wrapup
14:11:00 <rosmaita> alex_bash and hemanth|pto held a virtual design session to showcase their zero-downtime database update work
14:11:15 <rosmaita> for those who couldn't make it, there's a recording available
14:11:27 <rosmaita> there's a link on the session etherpad:
14:11:40 <rosmaita> #link https://etherpad.openstack.org/p/ocata-glance-zero-downtime-db-upgrade
14:12:09 <rosmaita> this is a key priority for Ocata, so i encourage everyone to take a look
14:12:39 <rosmaita> (and now, i will pause 90 sec for comments or questions)
14:14:09 <rosmaita> ok, moving on
14:14:28 <rosmaita> #topic Community Images: discuss design decision of default visibility = 'shared'
14:14:45 <rosmaita> i'll put up the links first, then some talking
14:15:15 <rosmaita> #link https://review.openstack.org/#/c/396919/ (spec update)
14:15:27 <rosmaita> #link     https://review.openstack.org/#/c/369110/ (code)
14:16:04 <rosmaita> ok, the short story is that during development, we decided that the default visibility an image should be created in should be 'shared'
14:16:16 <sigmavirus> apologies for being late
14:16:18 <rosmaita> the spec update explains why, so please take a look
14:16:25 <rosmaita> sigmavirus: np
14:16:51 <rosmaita> jokke_ had some good questions that i think have helped clarify why this is a good idea
14:17:12 <rosmaita> so at this point, i think that everyone is currently onboard with default visibility of 'shared'
14:17:15 <rosmaita> but
14:17:50 <rosmaita> there's an open question about how the migration of legacy images should work
14:18:05 <rosmaita> so that's what's holding things up ATM
14:18:18 <rosmaita> the change will affect operators, so we've decided to ask them for input
14:18:31 <jokke_> So this is one of those things which just smells bad to me ... (like the fact that currently our shared images are claimed to be visibility private) ... and my biggest fear is that this is one of those decisions we will some day curse looking back "Who ever thought this would be ok" but based on the feedback/pressure for example from Horizon and infra, we really don't have options
14:19:03 <jokke_> that is for the default
14:19:10 <rosmaita> right
14:19:39 <rosmaita> i don't disagree about the smell, but i think for backward compat we're kind of stuck
14:19:49 <rosmaita> at least the new default is a bit more honest
14:19:56 <sigmavirus> ^ ++
14:20:00 <jokke_> but specially end user perspective I'm super against transitioning all currently Private images to Shared
14:20:27 <rosmaita> understood
14:21:05 <rosmaita> i think the letter i sent to the operators list summarizes the situation fairly, both good and bad aspects of the proposal, so anyone not up to speed on the controversy, please check it out
14:21:19 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-operators/2016-November/012107.html
14:21:31 <rosmaita> (for those not subscribed to the operators' list)
14:21:56 <rosmaita> let's see what kind of feedback we get
14:22:12 <rosmaita> since no meeting next week, i'll update the ML when i've got some responses
14:22:29 <rosmaita> one more issue related to this
14:22:30 <jokke_> thank Brian
14:22:34 <rosmaita> np
14:23:18 <sigmavirus> do I understand correctly, then, that we're not goign to land this for o-1?
14:23:26 <jokke_> sigmavirus: correct
14:23:33 <rosmaita> sigmavirus: yes, aiming for week of Nov 28 now
14:23:46 <sigmavirus> so there's nothing blocking 14.0.0.0b1 then, yes?
14:23:59 <jokke_> sigmavirus: we can't land it without the db migrations, and what ever we merge on the db side we're stuck with
14:24:09 <sigmavirus> jokke_: how do you mean?
14:24:50 <jokke_> sigmavirus: the db migrations are "immutable" even between milestone releases
14:25:24 <sigmavirus> jokke_: sure, but we could add another migration atop the previous one to get to the desired end state
14:25:44 <jokke_> we should not break rolling o-1 -> o-2 -> o-3 and same time N -> O needs to look the same
14:25:45 <sigmavirus> sure that's not optimal but databases are going to migrate, might as well land something for a beta release that people can test
14:26:07 <sigmavirus> jokke_: N-> Ob1 should look the same as N->O?
14:26:13 <sigmavirus> Since when? Where is this documented?
14:26:38 <rosmaita> (we have a light agenda, so let's continue this now, it's worth figuring out)
14:26:39 <jokke_> sigmavirus: so when you do visibility = "shared" when visibility = "private" ... how do you fix that on the next migration?
14:27:15 <jokke_> sigmavirus: N -> O-[1..3] -> O should look db wise the same as N -> O
14:27:18 <rosmaita> jokke_: i think the idea is that you shouldn't run a beta in production?
14:27:22 <alex_bash> for what it's worth, if we move to Alembic migrations in Ocata, then the N->Ob1 and N->O will look different anyway
14:28:04 <jokke_> alex_bash: see above ... anything breaking that, I will happily block ;)
14:28:31 <rosmaita> it would be good to get some guidance from the release mgmt team about this to guide future development plans
14:28:43 <rosmaita> i.e., sigmavirus 's request for where this is written down
14:28:52 <rosmaita> anyone want to take that action item?
14:28:53 <jokke_> rosmaita: in theory we claim that we're on CI/CD and one could cut release almost at any point of the repos and get working cloud :P
14:29:04 <sigmavirus> Okay, so I agree that without an idea of where we'll land with private images after the migration to default to shared would be tricky to migrate back
14:29:24 <sigmavirus> jokke_: who is "we"? I've never heard glance claim that as reality but as a goal
14:29:34 <jokke_> sigmavirus: as
14:29:43 <jokke_> sigmavirus: we as OpenStack
14:29:57 <sigmavirus> jokke_: further, the migrations run to upgrade to O will be all the migrations added in O-1, O-2, and O-3
14:30:08 <jokke_> that's why we have all this gating to ensure that any patch does not break the functionality
14:30:17 <sigmavirus> So if migrating to each individual milestone and then to O final provides different results, I'd be really surprised
14:30:34 <sigmavirus> jokke_: sure, but when adding new functionality, it's highly unlikely it'll just work perfectly out of the box
14:30:45 <sigmavirus> brb
14:31:07 <jokke_> sigmavirus: Exactly ... cause they are "immutable" or "sacred" how ever you want to put that .... so we can't just go and change the migration script that landed O-1 in O-2
14:31:22 <sigmavirus> No, because they're deterministic
14:31:38 <sigmavirus> jokke_: No one in this discussion is advocating for modifying an existing migration script
14:31:51 <sigmavirus> You're tilting at windmills
14:31:56 <rosmaita> i thought the migration scripts weren't "immutable" until actual release?
14:32:32 <jokke_> sigmavirus: well that was what I said why we are not landing the community images by O-1 and you disagreed that we could change it in O-2
14:32:56 <rosmaita> at this point we're starting to go in circles
14:33:08 <sigmavirus> rosmaita: that's a good point. I don't know which is the right answer
14:33:12 <rosmaita> anyone want to take the action item to find a definitive statement about this?
14:33:26 <rosmaita> maybe an email to the release team?
14:33:36 <sigmavirus> rosmaita: as liaison, I'll start writing that right now
14:33:41 <rosmaita> sigmavirus: ty
14:34:08 <rosmaita> #action sigmavirus to contact release mgmt team about what db changes are allowable for milestone releases
14:34:18 <sigmavirus> I guess we're just not going to come to a decision for this until after our deadline for O-1 has passed
14:34:21 <rosmaita> or between milestone releases
14:34:28 <rosmaita> or whatever was discussed above
14:34:37 <rosmaita> yeah, the ship has sailed for O-1
14:34:46 <jokke_> sigmavirus: oh, we are ... I still have the -2 on the change itself
14:34:47 <rosmaita> but this is a good issue to have clarity on
14:35:00 <rosmaita> ok, back to community images ...
14:35:06 <jokke_> sigmavirus: so feel free prep O-1, the work will not be ready to merge on time
14:35:14 <rosmaita> the final point has to do with the naming of the 'shared' identified
14:35:24 <rosmaita> whether it should be 'shared' or 'shareable'
14:35:40 <rosmaita> which used to seem important, but i'm pretty much sold on 'shared' now
14:35:51 <jokke_> if we really want to make it shreable, then we need shared as well
14:36:13 <rosmaita> but, i sent a message to the i18n team asking whether either one is a big deal conceptually trnaslation wise
14:36:31 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2016-November/107437.html
14:36:38 <jokke_> 'cause neither of them is accurate on the model we are planning for them
14:36:42 <rosmaita> jokke_: i'm dead set against that
14:36:50 <rosmaita> and actually, 'shared' is accurate
14:37:00 <rosmaita> a 'shared' image is always accessible to all image members
14:37:17 <rosmaita> sometimes the member list is empty
14:37:23 <rosmaita> but the statement is still true
14:37:34 <jokke_> rosmaita: I'm against having 2 as well, I'm just saying shareable is perhaps even worse than shared
14:37:38 <rosmaita> that's why I'm +1 on 'shared'
14:37:50 <rosmaita> jokke_: ok, i'm with you on that one
14:38:23 <rosmaita> and, i've only asked for advice, we still will go with what makes sense using our best engineering knowledge in light of the available evidence
14:38:32 <jokke_> shareable is as bad opiions as our current usage of "private"
14:39:14 <rosmaita> ok, any questions
14:39:25 <rosmaita> (only waiting 20 sec this time)
14:39:27 <alex_bash> just want to bring up that hemanth|pto has another suggestion to get us out of the impasse
14:39:38 <stevelle> since the topic has been established as dead
14:39:42 <stevelle> I don't see a point to talking about it
14:40:04 <alex_bash> remove 'shared' visibility from community images change completely
14:40:36 <rosmaita> i'm pretty much 100% against that
14:40:53 <rosmaita> we'll face the same issue again for hierarchical sharing
14:41:07 <jokke_> that alex_bash is valid point if we were at the stage of fighting it in week before release deadline
14:41:27 <rosmaita> i think we're close to a realistic settlement here, so let's continue on course
14:41:47 <jokke_> now we actually have time to figure this out without rushing the work in that is the key point of the change
14:41:52 <jokke_> rosmaita: ++
14:42:13 <rosmaita> ok, moving on
14:42:25 <rosmaita> #topic     Release O-1 (14.0.0.0b1)
14:42:39 <rosmaita> ok, to answer sigmavirus 's question from earlier
14:43:11 <rosmaita> i'd like to see https://review.openstack.org/#/c/368192/ in O-1, but as the lite-spec isn't approved, i think we've missed the boat on that
14:43:31 <rosmaita> i believe O-1 has to be tagged today, in like a few hours or so?
14:43:41 <sigmavirus> yes
14:44:17 <jokke_> rosmaita: Is there anything blocking us merging those two like now and tagging after they merge?
14:44:30 <sigmavirus> jokke_: nope
14:44:45 <sigmavirus> jokke_: maybe reviews
14:44:51 <rosmaita> what sigmavirus said
14:45:00 <rosmaita> i don't want to rush stuff through
14:45:25 <rosmaita> but it would be good to get the lite-spec merged ASAP
14:45:36 <rosmaita> it has one +2 now
14:45:53 <rosmaita> and 2 +1s
14:46:35 <jokke_> I think there is logic error in that spec 'though
14:46:41 <jokke_> but I need to double check
14:46:50 <rosmaita> ok, then def don't want to rush this
14:47:08 <jokke_> IIRC our locations code replace is delete+add (like what happens in the code)
14:47:43 <jokke_> which would cause the first rule permitting the second on 'queued' state
14:48:05 <rosmaita> ok, let's discuss this on the lite-spec
14:48:18 <jokke_> sounds good, I need to double check the code as well
14:48:24 <rosmaita> image locations are bad enough without us making them worse!
14:48:32 <jokke_> ++
14:49:12 <rosmaita> so key accomplishment for O-1 (repeating for sigmavirus who wasn't here earlier) is
14:49:27 <rosmaita> "community goal" accomplished thanks to abhishek_k and alex_bash
14:49:38 <sigmavirus> heh yeah, that's for the client
14:50:01 <rosmaita> good point, so we hit a project goal, but not something in the glance code
14:50:18 <rosmaita> it's work, anyway
14:50:26 <rosmaita> ok, moving along
14:50:31 <rosmaita> #topic open discussion
14:52:32 <sigmavirus> https://review.openstack.org/397793 is our review for O-1 release
14:53:20 <jokke_> I just want to thanks rosmaita for taking the time yesterday and bending the railroad for me about what's going on around that visibility
14:53:35 <jokke_> s/thanks/thank/
14:53:47 <rosmaita> np, i think the discussion brought some clarity
14:54:08 <rosmaita> it was easier to explain the motivation/issues to operators after working all that out
14:55:03 <jokke_> "We know that we screw this up for you and we did that intentinally as we figured out a way which could have been way worse" :P
14:56:33 <jokke_> looks like we're done. Thanks all! :)
14:56:52 <rosmaita> ok, bye everyone! no meeting next week, but keep an eye on the ML
14:57:04 <rosmaita> #endmeeting