14:01:08 <rosmaita> #startmeeting glance
14:01:10 <openstack> Meeting started Thu Dec 15 14:01:08 2016 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:14 <openstack> The meeting name has been set to 'glance'
14:01:19 <sigmavirus> hey there
14:01:52 <stevelle> o/
14:01:53 <rosmaita> sigmavirus: hang on a sec
14:01:58 <rosmaita> #topic roll call
14:02:01 <rosmaita> :)
14:02:04 <dharinic> \o
14:02:09 <abhishekk> o/
14:02:18 <sigmavirus> o/
14:02:29 <stevelle> good afternoon
14:02:35 <sigmavirus> good evening, stevelle
14:02:45 <alex_bash> o/
14:03:19 <rosmaita> not a bad turnout
14:03:37 <rosmaita> ok, let's get started
14:03:47 <rosmaita> #topic updates
14:04:12 <croelandt> \o
14:04:20 <rosmaita> first update is that thanks to the efforts of sigmavirus, our "release czar", O-2 is ready
14:04:34 <rosmaita> although, i must admit that there's not much in it
14:04:44 <rosmaita> (but we'll talk about that during priorities review)
14:05:16 <rosmaita> also, i just realized that although i informed the release team that sigmavirus is our go-to person for releases, i haven't announced it on the ML
14:05:38 <rosmaita> #action rosmaita send notice about Ian being release czar to ML
14:06:06 <rosmaita> next up will be O-3, week of Jan 23
14:06:21 <rosmaita> should be a lot of stuff in it, commmunity images for example
14:06:42 <rosmaita> ok, next update
14:07:00 <rosmaita> you've probably seen the message i sent to the ML nominating stevelle for Glance core
14:07:17 <rosmaita> the response has been overwhelmingly positive (+100 from Erno!)
14:07:30 <sigmavirus> rosmaita: damnit no one's supposed to know ;)
14:07:47 <rosmaita> so I'll add him to the list after the meeting and update the ML
14:07:51 * sigmavirus 's interwebs are slow today
14:08:19 <rosmaita> sigmavirus: i need to get word of your powers out there so that you'll be accorded the respect you deserve!
14:08:29 * sigmavirus deserves no respect
14:08:52 <rosmaita> anyway, i'm sure we're all looking forward to working with stevelle, who's been doing great, detailed reviews
14:09:02 <stevelle> not me
14:09:22 <stevelle> he's always bothering me when I'm trying to work
14:09:41 <rosmaita> what's going on here? i can't say anything nice about anyone without being corrected?
14:09:44 <rosmaita> :)
14:10:03 <stevelle> just following the pattern :)
14:10:04 <dharinic> Yes, very good reviews with valuable comments and suggestions. :)
14:10:09 <stevelle> thanks for the kind words folks
14:10:33 <rosmaita> ok, next update
14:10:38 <rosmaita> i need feedback on this one
14:11:06 <rosmaita> the "holidays" are approaching, so there won't be a lot of people around the next few weeks
14:11:19 <rosmaita> so, i'm wondering what to do about the next 3 meetings
14:11:28 <rosmaita> Dec 22, Dec 29, Jan 5
14:11:38 <rosmaita> i don't want to cancel all 3
14:11:50 <rosmaita> but i don't want to waste people's time, either
14:12:19 * croelandt won't be there on the 22nd, and on the 29th either
14:12:58 * stevelle == croelandt
14:13:13 <rosmaita> ok, how does this sound
14:13:24 <rosmaita> actually, i should give people more time to respond
14:13:29 <rosmaita> since i did ask a question
14:13:34 * rosmaita sits on his hands
14:14:38 <rosmaita> ok, well, the silence is deafening
14:14:48 <croelandt> people are already on vacation.
14:15:15 <rosmaita> here's my proposal: cancel Dec 29.  I'll be here Dec 22 and Jan 5, but won't hold it against anyone if they don't show up
14:16:24 * croelandt is relieved
14:16:36 <rosmaita> next thing ... i wonder whether it would be good to have an etherpad with people's availability, to assist people seeking reviews? nothing detailed, just something like "working 1/2 time Dec 22-Dec 29" something like that
14:16:40 <rosmaita> or
14:17:02 <rosmaita> is it sufficient to tell people to put an occasional shout into #openstack-glance and see who's there?
14:17:14 <croelandt> well, I think people will /quit IRC when on vacation
14:17:28 <croelandt> basically, if you're on IRC, you're probably available
14:19:03 <rosmaita> ok, so in the email announcing meeting cancellation for Dec 29, i will remind people that reviewers may be on holiday, so things will be a bit slow, please be patient
14:19:29 <rosmaita> #action rosmaita email to ML about dec 29 meeting and reviewer availablity over holidays
14:19:45 <rosmaita> while i'm at it
14:20:06 <rosmaita> #action rosmaita email to ML about stevelle being confirmed core
14:20:30 <rosmaita> ok, that's it for updates ... i will pause 45 seconds for comments, concerns
14:21:16 <rosmaita> hearing none, let's move along
14:21:25 <rosmaita> #topic priorities review
14:21:52 <rosmaita> ok, first up is a reminder about priorities
14:22:02 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2016-December/108969.html
14:22:21 <rosmaita> just about the process, to make sure we're all on the same page
14:22:38 <rosmaita> you probably saw it already; if not, please look it over
14:22:55 <rosmaita> ok, and now the actual review ... here's the link:
14:23:09 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2016-December/108704.html
14:23:35 <rosmaita> ok, #1 - database strategy for rolling upgrades
14:23:53 <rosmaita> now has a +2 courtesy of sigmavirus ... thank you sigmavirus
14:24:13 <rosmaita> it has a +1 after some really careful reviewing from stevelle
14:24:39 <rosmaita> so, i am inclined to request that stevelle use his new powers to change that to a +2
14:24:53 <rosmaita> but, i am also open to objections that that's not quite kosher
14:25:06 <jokke_> I'll be available for the Jan 5 and maybe dec 22 but defo not 29
14:25:13 <jokke_> sorry for answering late
14:25:15 <rosmaita> jokke_: ty
14:26:17 <jokke_> so ref the priorities
14:26:18 <rosmaita> any thoughts on the above? anyone?
14:26:51 <jokke_> I think it's the move to alembic one that has -1 from me towards the rolling upgrade dependency
14:27:01 <rosmaita> correct
14:27:36 <rosmaita> the one we're talking about now has +1 from jokke_ saying he's not comfortable +2ing DB stuff
14:27:46 <rosmaita> which is quite acceptable
14:27:51 <jokke_> so I'm leaning towards +2 for that if we decide to take the route proposed towards rolling upgrades, but I'm tempted to say that we don't want to move to alembic if we do not have clear need for it
14:28:06 <jokke_> yes that was the other one
14:28:09 <rosmaita> jokke_: i respect that
14:28:33 <rosmaita> my feeling is that the database strategy proposal is sound, and we should go in that direction
14:28:44 <rosmaita> i would +2 myself except that i'm co-author :)
14:29:04 <jokke_> cool ... and if that's the case, I'm more than happy to +1 the alembic proposal as well
14:29:14 <rosmaita> but we did explore a lot of options (me and hemanth_ (who's on vacation), plus alex_bash too), and i think this is really solid
14:29:17 <jokke_> the bundle as whole sounds reasonable for me
14:29:27 <rosmaita> plus, we have the POC that alex_bash and hemanth_ put together
14:29:34 <jokke_> so people, don't be too worried about my -1 there
14:29:53 <rosmaita> cool
14:30:40 <rosmaita> my only concern with stevelle being the second +2 is that me, hemanth_ , sigmavirus , and stevelle are all rackspace
14:30:51 <rosmaita> but, other people have looked at it and left comments
14:31:01 <sigmavirus> yeah
14:31:02 <sigmavirus> I don't personally like the look of that
14:31:03 <sigmavirus> then again, our core team is so inactive at this point :/
14:31:08 <rosmaita> sigmavirus: exactly
14:31:21 <rosmaita> i was about to say, i have not had success getting other people to look
14:31:36 <jokke_> rosmaita: that's fair ... I think the big question is, do we have others than me who is not comfy to +2 db stuff and rackspacers in our active core list anymore
14:32:03 <rosmaita> my feeling is that the entire process, because the first patch is way different from the current patch, was done out in the open, with feedback from the wider openstack community
14:32:40 <rosmaita> so while i agree with sigmavirus that it looks a bit smelly, i think we are actually ok here
14:32:45 <rosmaita> (bad mixed metaphor)
14:33:03 <rosmaita> and i really want to get alex_bash and hemanth_ unblocked
14:33:08 <jokke_> so honestly I can change my +1 to +2 with a note that I trust the judgement of these guys but don't understand the technical details ... which does not look any better IMO :P
14:33:21 <rosmaita> jokke_: i agree
14:33:30 <jokke_> so we can in my point of view just move forward with that as we don't have objections there either
14:33:32 <rosmaita> i think you are well within your rights not to +2
14:33:47 <rosmaita> i mean, it's not like you didn't read & review the spec
14:33:54 <jokke_> indeed
14:33:56 <rosmaita> and you also participated in teh virtual design session
14:34:28 <rosmaita> stevelle: what do you think?
14:34:34 <rosmaita> (sorry to put you on the spot)
14:34:51 <jokke_> stevelle: you gotta earn your ranks form the first minutes :P
14:34:58 <sigmavirus> lol
14:35:24 <sigmavirus> jokke_: you are the most active non-Rackspace core I've seen lately (which is purely anecdotal data)
14:35:39 <stevelle> Unless we can identify someone who wants to put an additional review in, I can go over it again and see if I can go with the upgraded vote.
14:36:01 <jokke_> stevelle: please do so
14:36:10 <rosmaita> stevelle: that sounds good to me
14:36:42 <jokke_> not only to unblock Alex and Hemanth but I'd like to see this merging rather asap than alap :)
14:36:44 <rosmaita> there will be some movement on the core team in the next few weeks, so this kind of one-company thing shouldn't come up again
14:37:17 <rosmaita> ok, thanks for this discussion
14:37:30 <rosmaita> #action stevelle to re-review database strategy spec
14:37:57 <rosmaita> #action rosmaita to come up with plan B (which will hopefully not be necessary)
14:38:14 <rosmaita> ok, back to the priorities
14:38:42 <rosmaita> we've already talked about #2, basically if #1 is approved, #2 can follow
14:38:51 <rosmaita> moving to #3
14:39:08 <rosmaita> i am happy to report that this one happened ... the community images spec update has merged
14:39:46 <rosmaita> since timothy is out of action for a while, dharinic has volunteered to change his patch so that the migration of existing images goes according to the spec update
14:40:04 <rosmaita> (which we all hope makes operators and end users happy!)
14:40:47 * sigmavirus crosses fingers
14:40:56 <rosmaita> so, this item will move from reviewing the spec to reviewing the actual CI code (as soon as dharinic gets a new patch up)
14:41:20 <rosmaita> moving to #4
14:41:22 <dharinic> coming up. :)
14:41:33 <rosmaita> dharinic has been busy, this is hers too
14:41:41 <jokke_> I'm happy that we found common ground ... feel free to blame me if it turns out to be nightmare
14:41:45 <rosmaita> the patch to fix the regression was merged!
14:42:21 <rosmaita> jokke_: i think we did the best we could ... at the very least, that extensive discussion shows that we didnt' take the migration issue lightly!
14:43:13 <jokke_> ref regression, well done and I was happy to see tests there as well (did glance it through today even it had merged)
14:43:26 <rosmaita> the second part of #4 hasn't merged yet, i think there's a request on the patch to update the config option description text or something
14:43:42 <dharinic> Thanks jokke_
14:44:08 <rosmaita> also, i think stevelle was having second thoughts about the strategy
14:44:20 <dharinic> Yeah alex_bash suggested we do that. But I was wondering if that had to go with the same patch..
14:44:34 <rosmaita> basically, the problem is that there are two options for the swift backend ... if you enable them both, horrible stuff happens
14:44:59 <rosmaita> so, dharinic 's second patch makes glance refuse to start with a suitable log message if both options are enabled
14:45:04 <jokke_> rosmaita: but have we ever indicated by any means that we would support such?
14:45:15 <stevelle> my second thoughts were dismissed by review, and I added the comment to that effect
14:45:22 <rosmaita> cool
14:45:26 <rosmaita> i am behind the times here
14:45:39 <rosmaita> jokke_: not exactly, but the problem pops up because of devstack
14:46:09 <rosmaita> it has one of the options enabled, and then if you turn on the other one, you eventually notice that bad stuff has happened
14:47:02 <rosmaita> jokke_: so the options are there, and we've never said previously that they shouldn't be used together
14:47:15 <jokke_> ah
14:47:18 <rosmaita> plus, i believe you get into a kind of non-recoverable situation
14:47:26 <jokke_> lovely
14:47:38 <rosmaita> so it's really better to put this in code not just in docs
14:47:43 <jokke_> so yes I'd be pro not allowing them both, for now
14:48:28 <jokke_> I think there has been quite a bit of requests for the multiple active backend stores and we might need to revisit it when implementing that
14:49:18 <rosmaita> ok, i think we should discuss multiple stores support at the PTG
14:49:19 <jokke_> but on current state documenting "This is not smart and might break things horribly" is pretty good standing
14:49:25 <jokke_> ++
14:50:22 <rosmaita> ok, cool
14:51:10 <rosmaita> ok, we are running out of time ... abhishekk thanks for being patient, your request-id patch will become high priority
14:51:31 <abhishekk> no issues rosmaita
14:51:39 <rosmaita> and i don't think there was action on #6 or #7
14:51:55 <rosmaita> actually, that's false
14:51:58 <rosmaita> #7 merged
14:52:01 <rosmaita> hooray!
14:52:39 <rosmaita> ok, i'll send out a revised priority list tomorrow
14:52:54 <rosmaita> i want to wait and see what happens to the db strategy spec today
14:53:01 <bhagyashris> i am working on creating the patch for #6
14:53:06 <rosmaita> bhagyashris: ty
14:53:13 <bhagyashris> will submit it asap.
14:53:17 <stevelle> I need to look at 5 then 6. have them queued up already though
14:53:29 <rosmaita> sounds good, i will move #6 up in the list, too
14:53:45 <rosmaita> #topic next operators survey
14:54:01 <rosmaita> not much to say here, if you are interested, i have a draft up:
14:54:17 <rosmaita> #link https://etherpad.openstack.org/p/glance-swift-multitenant-usre-survey
14:54:48 <rosmaita> why don't i say i'd like to send that out early next week
14:55:11 <jokke_> rosmaita: I'd say wait for 3 more weeks
14:55:24 <jokke_> next week will disappear into the X-mas void
14:55:26 <rosmaita> jokke_: you are probably right
14:55:33 <rosmaita> ok, then there's no rush on this one
14:55:47 <rosmaita> #topic question about config regeneration
14:55:56 <rosmaita> jokke_: this is really a question for you
14:56:01 <jokke_> shoot
14:56:26 <rosmaita> this is about adding 'ploop' (i just had to say that)
14:56:31 <rosmaita> #link https://review.openstack.org/#/c/341633/
14:56:48 <rosmaita> so, the value for one of our config options changes
14:57:11 <rosmaita> well, my question is, we should probably regenerate the config files before each release
14:57:19 <rosmaita> just to be sure everything got in
14:57:35 <rosmaita> so do we need to also require regeneration with a patch like this?
14:57:38 <jokke_> yup we do need to do that as I still haven't seen the web ones being available for anything else than master
14:58:06 <jokke_> I personally thing that anything that touches the config options should trigger regen
14:58:11 <rosmaita> i see, so it's a publication thing
14:58:31 <rosmaita> ok, not much time for open discussion
14:58:35 <jokke_> but that seems to have been continuous battle between myself and some others
14:58:35 <rosmaita> #topic open discussion
14:58:53 <jokke_> Glance Tasks have horrible hardcoded dependencies
14:58:56 <rosmaita> who put up the Py3 functional test topic?
14:58:58 <jokke_> just saying
14:59:04 <croelandt> rosmaita: me!
14:59:13 <rosmaita> ok, tell us!
14:59:14 <croelandt> I'd love some review on this patch series https://review.openstack.org/#/c/392889
14:59:23 <croelandt> they are small, simple patches to enable functional tests for Py3
14:59:27 <jokke_> like seriously horrible stuff in the parsing of the tasks triggering
14:59:55 <croelandt> it's not top priority, but if you've got some free time before going on vacation... :)
15:00:03 <rosmaita> croelandt: i will put that on the priority list, i think it's worth having people look it over
15:00:09 <rosmaita> (but at the bottom!)
15:00:16 <croelandt> Py2 will be deprecated in 2020
15:00:17 <jokke_> croelandt: that sounds good, I'll try to remember to have a look into them
15:00:24 <rosmaita> ok, we are impinging on the searchlight meeting
15:00:26 <croelandt> so we might have some time to review all of these patches :)
15:00:35 <stevelle> I like having these py3 topics on the priorities list
15:00:36 <rosmaita> yes, croelandt this is a good thing to do now
15:00:38 <jokke_> thanks all! Sorry Searchlight guys!
15:00:45 <croelandt> stevelle: <3
15:00:47 <rosmaita> thanks for taking it on
15:00:50 <TravT> no worries
15:00:56 <croelandt> been doing that for ~2years
15:01:02 <rosmaita> ok, bye everyone!
15:01:03 <croelandt> shall we wrap it up?
15:01:06 <croelandt> Bye!
15:01:09 <rosmaita> #endmeeting