14:00:07 <rosmaita> #startmeeting glance
14:00:10 <sigmavirus> o/
14:00:13 <openstack> Meeting started Thu Dec 22 14:00:07 2016 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:17 <openstack> The meeting name has been set to 'glance'
14:00:27 <rosmaita> #topic roll call
14:00:38 <rosmaita> ok, now everyone can say hi
14:00:39 <sigmavirus> o/
14:00:40 <abhishek_k> once again o/
14:00:45 <dharinic> \o
14:00:46 <alex_bash> o/
14:00:53 <jokke_> o/
14:01:22 <stevelle> o/
14:01:42 <rosmaita> i see our light meeting has been given some content by stevelle and dharinic
14:02:00 <rosmaita> just a reminder of where the agenda is:
14:02:08 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:21 <rosmaita> #topic updates
14:02:34 <rosmaita> don't forget no meeting next week
14:02:50 <sigmavirus> s/don't forget/remember/
14:03:18 <rosmaita> remember not to forget
14:03:50 <rosmaita> i've been away and haven't looked through all of the priorities, but i did see some action on some of the patches
14:04:02 <rosmaita> i'll send out a new list later today
14:04:21 <rosmaita> ok, might as well move onto the big issue of the day
14:04:41 <rosmaita> #topic Community Images feature is blocked by Tempest tests
14:04:54 <rosmaita> so, i cleared this with operators and the api wg
14:05:03 <rosmaita> didn't realize tempest was the guardian of truth
14:05:11 <rosmaita> anyway, stevelle, you have the floor
14:05:57 <stevelle> right, so we are hard blocked on community images work
14:06:01 <jokke_> they should not be ... so IMO if they are not willing to a) fix their tests, b) revert it we have option c) to drop it from the glance tests
14:06:33 <rosmaita> i am on board with jokke_ , but stevelle seems a bit more sympathetic
14:06:47 <rosmaita> stevelle: should we take 5 min to read what you put on the agenda?
14:06:55 <rosmaita> or would you rather talk us through it?
14:07:08 * jokke_ just had read through it from the agenda
14:07:10 <stevelle> it would be best to read through what I put in the agenda, but I can quickly summarize
14:07:53 <stevelle> a recently-added tempest test, prevent's timothy's patch set from passing the gate clean
14:07:56 <jokke_> IMO this is pretty clear ... it should not be tempest's call and if they think it is, we just drop tempest off from glance CI
14:08:24 <stevelle> wow, typing badly today :)
14:09:17 <stevelle> I presented 3 options to proceed
14:09:49 <stevelle> 1) we argue with tempest cores, and assemble the evidence to support it
14:09:53 <sigmavirus> jokke_: I disagree, but that's a separate topic
14:10:30 <dharinic> tiny clarification. Actually, Timothys PS passed the gate clean. After we added the migration part, the tempests failed cos the new tempest tests were added at a later time (just before migration with visibility was added to CI)
14:10:38 <stevelle> 2) we actually start to implement microversion support (api-wg flavor, which is the nova flavor) for this change
14:11:23 <stevelle> 3) we back up and modify the spec and impl again to do something which I seem to recall jokke_ suggested several weeks ago
14:11:26 <rosmaita> i dont' think we want to do option 2 this late in the cycle
14:11:30 <alex_bash> -1 on 2)
14:12:06 <jokke_> 2) is not an option to unblock this work
14:12:48 <sigmavirus> jokke_: actually it is, because if we actually implemented microversions correctly (allowing users to request old behaviour based on the version) then this wouldn't be an issue
14:12:50 <sigmavirus> But we don't
14:13:03 <sigmavirus> We have "microversions" in that we bump the version of the API when we change things and users be damned
14:13:12 <rosmaita> we have milliversions
14:13:15 <sigmavirus> (I've been saying this for a while now)
14:13:16 <jokke_> sigmavirus: as we do not do microversions ;)
14:13:42 <jokke_> we just have minor version number in our API version to indicate that something has changed
14:13:42 <rosmaita> stevelle: quick question
14:14:03 <rosmaita> if the migration put all images into 'shared', the tempest tests would pass?
14:14:15 <rosmaita> not all, but you know what i mean
14:14:16 <jokke_> there has been no agreement nor even discussions of moving Glance to microversions and I'd be not fond of having that discussion now either
14:14:18 <sigmavirus> jokke_: but when a user sees the listing of versions, v2.{N-1} is listed as supported, which is a lie
14:14:36 <rosmaita> sigmavirus: it's supported, just not enthusiastically
14:14:36 <stevelle> rosmaita: no, the test is not a migration test. it is a new-images thing
14:15:02 <rosmaita> ok, got it
14:15:17 <rosmaita> so the problem is that they are creating an image with --visibility private
14:15:21 <rosmaita> and then trying to share it
14:15:34 <rosmaita> so you said, they shoudl just create a "default" image
14:15:41 <stevelle> yes
14:15:45 <rosmaita> and they said,
14:15:53 <rosmaita> well, i won't give an interpretation
14:15:59 <rosmaita> ok
14:16:13 <stevelle> they said we're breaking the api
14:16:34 <dharinic> and making it backward incompatible
14:16:35 <stevelle> and tempest is stopping us from doing that.
14:16:40 <rosmaita> we're fixing a bug in the implementation
14:17:40 <jokke_> well we have known all the time that we are breaking the API and that was agreed acceptable with multiple stakeholders
14:18:09 <sigmavirus> jokke_: right, tempest didn't have that information
14:18:24 <stevelle> if we have ample supporting evidence to point to, gmann grudgingly acknowledged that they would look at that and reconsider a solution that was more focused than what I submitted
14:18:36 <rosmaita> well, it looks like we try option 1, then
14:18:48 <jokke_> sigmavirus: judging the timeline they made these new tests, I'm pretty sure they did and they just didn't bother to participate to the conversation
14:19:23 <sigmavirus> jokke_: so you think tempest did this ... to hamper our development efforts? That's rather pessimistic, even for you
14:19:32 <rosmaita> let's try option 1 first, and then we can try jokke_ 's "nuclear option"
14:19:34 <sigmavirus> tempest is a large part of the interoperability team's efforts
14:19:57 <rosmaita> i thought that was refstack, but we are getting off topic here
14:19:57 <jokke_> sigmavirus: what you just said ^^
14:19:59 <sigmavirus> This is documenting, for lack of a better term, our current API behaviour for interoperability in a way that interop can use
14:20:13 <stevelle> having spent hours looking at this, I don't believe it is fair to suggest this test landing was anything more than a coincidence
14:20:21 <jokke_> Would not be first time these guys are jumping on something we try to do and not listening reasoning ;)
14:20:45 <rosmaita> ok, let's break this up into work items
14:20:48 <sigmavirus> jokke_: yeah, I thoroughly disagree and I think you're being entirely inappropriate in your characterizations of those team members
14:20:57 <rosmaita> i can draft a message to tempest team
14:21:08 <rosmaita> with refs to all the ML, patch, API-WG meeting discussions
14:21:22 <rosmaita> i will need stevelle and dharinic to review
14:21:32 <rosmaita> plus anyone else who's interested
14:21:41 <jokke_> sigmavirus: Other option is that they are doing new tests without having a single word with the team affected nor looking into the specs on flight and I doubt the guys are that naive/stupid, so I rather believe it was intentional ;)
14:21:43 <rosmaita> so i guess i will draft on an etherpad?
14:22:11 <alex_bash> rosmaita: yes, I'm interested
14:22:18 <rosmaita> ok, good
14:22:26 <dharinic> sure rosmaita.
14:22:27 <rosmaita> what is people's availability today?
14:22:43 <dharinic> I am available
14:23:26 <rosmaita> #action rosmaita draft message to tempest team
14:23:28 <stevelle> I expect to be around, but have some errands to run
14:23:32 <alex_bash> I'm technically on vacation, but will be popping in
14:23:34 <rosmaita> #link https://etherpad.openstack.org/p/glance-ocata-community-images-tempest-imbroglio
14:24:03 <jokke_> rosmaita: I was hoping to ~ start my X-mas holidays (have few things I will try to work through tonight/tomorrow around the import workflow) after I get the hour long meeting wrapped I have after this
14:24:05 <rosmaita> sigmavirus: i guess we direct the result to the dev list with [glance][tempest] in the submect line
14:24:07 <sigmavirus> jokke_: maybe they didn't look at specs because they'd never expect a project like Glance to break the API behaviour in the same major version?
14:24:14 <sigmavirus> rosmaita: yes, I'd agree with that
14:24:41 <rosmaita> sigmavirus: if they didn't expect weird stuff from glance ... then they can't have been around openstack very long
14:25:29 <rosmaita> jokke_: ok, that's fine, i think we have enough people
14:26:07 <sigmavirus> rosmaita: to be fair, Glance attracts very little cross-project attention
14:26:20 <rosmaita> writing stuff always takes me longer than i expect, so i will aim to have this done by 15:30utc
14:26:23 <sigmavirus> People leave us alone until we do weird shit and then we work with them to fix it and then they disappear
14:26:44 <rosmaita> i will put a note at the top of the etherpad indicating if i'm still writing and it's not ready yet
14:27:00 <jokke_> sigmavirus: I just find it quite incredible that it would be coincidence of ignorance and chance that they happen to implment these tests just after we have had huge discussion over multiple mailing lists and over that spec and got finally to the point that we have to do minor breakage to make sure that the future usability is reasonable ... and they write the exactly on the way that it will br
14:27:06 <jokke_> eak, not like it would have been convenient to write the test
14:27:42 <rosmaita> #action stevelle dharinic alex_bash to look at etherpad around 16:00 utc
14:28:01 <rosmaita> (and anyone else, of course, but those are the committed parties)
14:28:11 <rosmaita> sigmavirus: if you have time, definitely could use your input
14:28:55 <rosmaita> i will probably have to write 2 versions, the second one with all the bad language removed
14:28:59 <rosmaita> but i digress
14:29:08 <rosmaita> stevelle: thanks for your work on this
14:29:11 <stevelle> with the time gap before next meeting, do we have a limit on the time we want to take for option 1?
14:29:39 <rosmaita> stevelle: excellent question
14:29:48 <rosmaita> problem is, they will be on vacation too
14:31:00 <rosmaita> if option 1 fails, we will go for option 3, i guess?
14:31:17 <sigmavirus> rosmaita: absolutely
14:31:29 <rosmaita> any idea how much time those code changes will absorb?
14:31:44 <sigmavirus> I think if we remove tempest from our gate, we'll really invoke the ire of the community
14:32:25 <rosmaita> well, i'm not opposed to doing it short-term as a kind of statement ... but only if they are completely unreasonable in rejection option 1
14:32:26 <stevelle> option 3 was, to reiterate, migrate images from private to shared when a member is added
14:33:10 <rosmaita> yes, it would basically allow member operations on a 'private' image, and change the visibility to shared at the same time
14:33:12 <stevelle> option 2 was to do that on the base v2 api with microversions and retain our agreed on behavior forward
14:33:36 <sigmavirus> rosmaita: I don't think they will reject option 1 or be unreasonable
14:33:57 <sigmavirus> If they do object to that, though, then having a temporary version of option 3 is a good idea
14:34:16 <alex_bash> tempirary?
14:34:19 <sigmavirus> If not only from the tempest perspective but also from user experience for transitioning to a version of Glance's API they didn't get to pick
14:34:23 <stevelle> dharinic: do you have any feel for the time the code changes would take?
14:34:43 <sigmavirus> alex_bash: as in have behaviour that does the auto-transition that is temporary and document that it is transitional behaviour that disappears in queens
14:34:57 <dharinic> Not too sure stevelle. But since I will be available through this year, i can work on it at a decent pace
14:35:02 <sigmavirus> 2 is not reasonable for the timelines in Ocata
14:35:55 <stevelle> I'm in agreement on option 2 being problematic for process, but if we were looking at the beginning of a 6 month cycle I would feel differently
14:36:06 <rosmaita> stevelle: me too
14:36:10 * alex_bash really hopes option 1 works
14:36:17 <rosmaita> sigmavirus: i dont' like the idea of the "transitional" behavior
14:36:22 <jokke_> alex_bash: ++
14:36:35 <jokke_> rosmaita: sigmavirus: me neither
14:36:45 <sigmavirus> stevelle: right, I think option 2 should be a thing for Pike in general
14:36:59 <jokke_> I think doing stuff like that is worse than honestly breaking something for good reason
14:37:05 <rosmaita> sigmavirus: take an action item to present a session at the design summit?
14:37:07 <sigmavirus> jokke_: I think we all agree option 3 is bad from a Community Images perspective
14:37:12 <sigmavirus> rosmaita: won't make it
14:37:19 <rosmaita> arrrrrrrrgh
14:37:32 <sigmavirus> would probably have to pay my own way or find a new employer that would send me
14:37:34 * sigmavirus shrugs
14:37:49 <rosmaita> #action someone start thinking about putting together a PTG session on microversioning glance
14:39:18 <rosmaita> ok, anything else on this topic?
14:39:48 <jokke_> rosmaita: please keep us up to date on mailing list
14:39:56 <stevelle> as for community images...
14:40:02 * jokke_ will keep eye for that over the holidays
14:40:05 <rosmaita> jokke_: will do
14:40:17 <jokke_> or who ever is on this meanwhile
14:40:29 * jokke_ is expecting rosmaita having some time off as well
14:40:30 <stevelle> the only thing that the current patch set fails, with respect to our current spec, is this added tempest test.
14:40:41 <dharinic> yes.
14:40:51 <dharinic> 1 tempest test.
14:40:53 <stevelle> if folks want to review it tentatively, that would be helpful
14:41:04 <stevelle> dharinic has fixed the migrations
14:41:16 <jokke_> stevelle: thanks, I'll see if I have energy to read it through at some point
14:41:26 <jokke_> thanks dharinic !
14:41:30 <sigmavirus> I'll look at it today before I leave I hope
14:41:40 <rosmaita> me three
14:41:42 <sigmavirus> I'm off Friday through Jan 2. And will be sans computer
14:41:49 <sigmavirus> (Tomorrow Friday)
14:41:54 <dharinic> was altering between 2 different migrations models and the latest PS has the better efficient one i guess
14:42:10 * sigmavirus will be watching the mailing list thoug
14:42:22 <dharinic> awesome
14:42:24 <rosmaita> how is this for the subject line to watch:
14:42:27 <rosmaita> [glance][tempest] community images, tempest tests, and API stability
14:42:31 <dharinic> Thanks stevelle and jokke_
14:43:16 <jokke_> rosmaita: sounds good
14:43:24 <dharinic> tempest test* probably?
14:43:24 <alex_bash> when reviewing CI patch, might be prudent to diff with set 53
14:44:03 <alex_bash> that was Timothy's last PS which was nearly +A'd
14:44:21 <sigmavirus> alex_bash: or diff against master if one hasn't looked at it at all
14:44:26 <rosmaita> alex_bash: thanks, good suggestion
14:44:31 <sigmavirus> because reviewing the whole patch rather than minor modifications is also valuable
14:44:48 <jokke_> ++
14:45:01 <stevelle> we should probably throw together an alternate review for tempest since we want to try that again?
14:45:04 <jokke_> we have 16min left ... should we move forwards?
14:45:10 <sigmavirus> jokke_: let's
14:45:23 <rosmaita> ok, next topic is open discussion
14:45:31 <rosmaita> #topic open discussion
14:45:57 <rosmaita> so, let's set some tentative times for this tempest situation
14:46:11 <rosmaita> i will aim to have draft ready at 16:00 utc today
14:46:26 <rosmaita> will everyone have time then to look & comment?
14:46:41 <rosmaita> would be good to have a comment deadline
14:47:00 <sigmavirus> that's 1 hour from now, yes?
14:47:06 <sigmavirus> I'll definitely have time to review it
14:47:06 <rosmaita> right
14:47:11 <rosmaita> cool
14:47:17 <rosmaita> stevelle: alex_bash: ?
14:47:23 <stevelle> ok
14:47:33 <alex_bash> +1
14:47:42 <rosmaita> so, say review & comment before 18:00 utc?
14:48:25 <dharinic> cool
14:48:44 <alex_bash> sounds good
14:49:12 <stevelle> yes
14:49:23 <rosmaita> ok, great, thanks
14:49:44 <jokke_> sorry I dropped
14:50:03 <rosmaita> jokke_: np
14:50:06 <jokke_> and sorry I didn't realize that this was literally only topic we had in our list even I read through it ;)
14:50:21 <rosmaita> :)
14:50:32 <rosmaita> any other discussion?
14:50:40 <dharinic> One question
14:50:43 <rosmaita> sure
14:50:46 <dharinic> Not related to CI
14:51:03 <dharinic> I had put up a patch https://review.openstack.org/#/c/401391/
14:51:11 <stevelle> oh yeah, rosmaita you should pick some new review priority items
14:51:21 <stevelle> and update the #openstack-glance topic with them
14:52:00 <jokke_> I was hoping I had the import pathes up before this meeting ... well I didn't so I'm working on it
14:52:03 <dharinic> that allows replacing of specific list entries on "locations" and "tags" for images. kairat pointed out that we need api-wg recommendation
14:52:21 <rosmaita> i don't think so
14:52:24 <jokke_> still trying to have X-Mas preset for the folks and getting the WIPs to gerrit before weekend
14:52:36 <dharinic> the bug for which that patch was put up is : https://bugs.launchpad.net/glance/+bug/1521607
14:52:38 <openstack> Launchpad bug 1521607 in Glance "v2 - replacing array elements with PATCH results in 400 error" [Medium,In progress] - Assigned to Dharini Chandrasekar (dharini-chandrasekar)
14:52:40 <dharinic> needed some inputs
14:52:49 <rosmaita> we already have the tags operations
14:52:50 <rosmaita> http://developer.openstack.org/api-ref/image/v2/index.html#image-tags
14:53:10 <rosmaita> so i see this change as orthogonal to kairat's issue
14:53:26 <rosmaita> we have 2 ways to handle tags
14:53:41 <rosmaita> the resource-in-the-url way, and PATCH
14:53:53 <dharinic> This was to replace individual tag elements in a list using PATCH rather than giving the whole list
14:54:05 <dharinic> I was working on the PATCH
14:54:31 <stevelle> numeric 0-based index is the rfc6902 way? I need to review that one I guess
14:54:42 <dharinic> sigmavirus and rosmaita: you guys had commented on the bug report
14:54:54 <rosmaita> dharinic: i can't remember that far back
14:55:22 <dharinic> that glance does not support rfc 6902 entirely
14:55:52 <sigmavirus> dharinic: right, because someone thought it was a good idea for us to implement it ourselves rather than use a library that's already in g-r
14:55:54 <dharinic> comments 7 and 8
14:56:11 <sigmavirus> I'm still in favor of properly fixing this bug
14:56:15 <sigmavirus> And the related bugs
14:57:06 <rosmaita> so this brings up the question of changing libraries
14:57:12 <dharinic> cool. Would like some reviews on this at all of your convenience.
14:58:06 <rosmaita> my feeling is that we shouldn't fix this piecemeal
14:58:24 <dharinic> I totally think we should support PATCH according to rfc6902 in its entirity.
14:58:45 <rosmaita> the problem was that glance went to PATCH early, before the standard was finalized
14:58:48 <jokke_> so how big of a can of worms we will open if we claim to do so?
14:59:11 <jokke_> and how many things will break trying to achieve that?
14:59:24 <rosmaita> dharinic: can you investigate full json-patch support and report back to us?
14:59:24 <sigmavirus> jokke_: well what we implemented was a strict subset
14:59:31 <sigmavirus> We advertise support for JSON Patch but don't have it
14:59:31 <dharinic> sure
14:59:40 <sigmavirus> If we add full support for it, we're expanding our API, not contracting it
14:59:44 <sigmavirus> (In theory)
14:59:50 <dharinic> yes. agree with sigmavirus
14:59:55 <dharinic> sure rosmaita
15:00:00 <jokke_> rosmaita: on the other hand, being early adobter is not an excuse to not follow the standard once it's established
15:00:13 <dharinic> meanwhile, if you guys are free, please review and let me know.
15:00:28 <jokke_> ok, we're out of time
15:00:32 <dharinic> again agree with jokke_
15:00:32 <rosmaita> jokke_: that was historical background, not justification!
15:00:56 <rosmaita> well, we are indeed out of time ... see y'all in openstack-glance
15:01:00 <jokke_> rosmaita: I know ;)
15:01:05 <rosmaita> and to those going on holiday, happy holidays!
15:01:13 <rosmaita> #endmeeting