14:00:15 <rosmaita> #startmeeting glance
14:00:16 <openstack> Meeting started Thu Jan 12 14:00:15 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:19 <openstack> The meeting name has been set to 'glance'
14:00:26 <rosmaita> #topic roll call
14:00:40 <hemanthm> o/
14:00:57 <abhishekk> o/
14:01:03 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:01:15 <jokke_> o/
14:01:18 <mfedosin> o/
14:01:38 <dharinic> \o
14:02:16 <rosmaita> sigmavirus should be around too, just saw that he sent something to the ML a few minutes ago
14:02:23 <sigmavirus> Hey all, I am
14:02:28 <sigmavirus> Was filing bugs against bandit
14:02:34 <sigmavirus> Sorry for being late :)
14:02:44 <rosmaita> well, you are usually early!
14:02:52 <rosmaita> ok, let's get started
14:03:00 <rosmaita> #topic updates
14:03:14 <rosmaita> Reminder: gerrit downtime today 20:00-20:30 utc
14:03:33 <rosmaita> i don't know how to do sub-topice
14:03:36 <rosmaita> *topics
14:03:39 <sigmavirus> (There is no way)
14:03:44 <sigmavirus> (There is only zuul)
14:03:45 <rosmaita> anyway, #2: New experimental grenade gate job
14:03:58 <rosmaita> just want you to be aware it exists
14:04:01 <sigmavirus> I guess you could do #info but *shrug*
14:04:10 <rosmaita> #link https://review.openstack.org/#/c/414326/
14:04:32 <rosmaita> only impact could be slower overall gate
14:04:58 <rosmaita> which could be a problem, so just a heads-up for awareness
14:05:10 <rosmaita> #info item 3 - community images
14:05:26 <rosmaita> here's the latest installment in the saga:
14:05:30 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-January/110018.html
14:05:56 <rosmaita> i missed the QA meeting due to a time confusion
14:06:03 <sigmavirus> =(
14:06:18 <rosmaita> there seems to be a slight misunderstanding about what we are asking for
14:06:28 <rosmaita> so i tried to address that explicitly in the above email
14:06:56 <rosmaita> but the issue seems to be coming down to: who decides what is an acceptable API change?
14:07:12 <rosmaita> cdent has put us on the agenda for today's API-WG meeting
14:07:15 <sigmavirus> Yay. That discussion again
14:07:21 <sigmavirus> /sarcasm
14:07:46 <rosmaita> yeah, looks like that might be what it's coming down to
14:07:57 <rosmaita> anyway, api-wg meeting is at 16:00 utc today
14:08:04 <rosmaita> (that time i'm sure about!)
14:08:19 <rosmaita> i'll be there, anyone else who's interested please attend
14:09:21 <rosmaita> that's all i've got to say about this ATM
14:09:29 <rosmaita> ok, moving on
14:09:40 <rosmaita> #info Review of progress on priority items from last week
14:09:50 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-January/109772.html
14:10:18 <rosmaita> priority 1 was the request-id stuff; abhishekk has a new patch up addressing issues; please review
14:10:30 <rosmaita> maybe we can get that knocked out today and drop it from the priority list
14:10:40 <abhishekk> yes, thank you
14:11:45 <rosmaita> priority 2: alembic stuff
14:12:04 <rosmaita> https://review.openstack.org/#/c/392993/ has a -1 from dolph
14:12:06 <hemanthm> rosmaita: this needs to be included too https://review.openstack.org/#/c/397409/
14:12:16 <hemanthm> rosmaita: I'll look into that
14:12:21 <rosmaita> hemanthm: ty
14:12:59 <rosmaita> not sure everyone knows, alex_bash is on paternity leave for the next 2 weeks or so, so he'll only be around sporadically
14:13:47 <sigmavirus> rosmaita: unacceptable
14:13:51 <sigmavirus> he shouldn't be around *at all*
14:13:53 <rosmaita> :)
14:14:38 <rosmaita> ok, the alembic stuff remains a priority ... that means core reviewers need to look at it before doing other stuff this week (unless you are working on a security bug)
14:15:03 <rosmaita> so mark down these reviews:
14:15:10 <sigmavirus> Yeah, if you're a core working with the VMT, that takes priority
14:15:27 <rosmaita> #link https://review.openstack.org/#/c/392993/ (after hemanthm updates)
14:15:58 <rosmaita> #link https://review.openstack.org/#/c/397409/
14:16:12 <rosmaita> #link https://review.openstack.org/#/c/382958/
14:16:33 <rosmaita> #info priority 3: community images
14:16:51 <rosmaita> i will have to update over the ML
14:17:15 <rosmaita> i am confusing myself with the #topic and #info
14:17:30 <sigmavirus> lol
14:17:53 <rosmaita> dharinic had a request for some stuff to be put on the priority list for this coming week
14:18:19 <dharinic> Yeah. I was hoping we can add Buffered Reader to our priority
14:18:33 <rosmaita> hearing no objections, consider it added
14:18:38 <dharinic> Here is the link to the patch under review: https://review.openstack.org/#/c/120866/
14:18:53 <dharinic> Awesome, Thanks.
14:18:58 <rosmaita> i'm not inclined to add new stuff because we have an upcoming glance_store release
14:19:02 <rosmaita> (more on that later)
14:19:15 <rosmaita> so there will probably be soem glance_store related stuff that we'll need to address
14:19:30 <rosmaita> ok, last update item
14:19:40 <rosmaita> #info PTL self-nominations opens soon (week of Jan 23)
14:20:00 <rosmaita> if you're thinking of running for PTL, keep the deadline in mind
14:20:24 <rosmaita> also, you can talk to me or flavio about what it's like to be ptl to gather data
14:20:45 <rosmaita> also, i think mfedosin and flwang have some experience in that regard
14:20:59 <rosmaita> i am planning to run again, but don't let that stop you
14:21:43 <rosmaita> that's all for updates
14:21:56 <rosmaita> #topic PTG planning
14:22:14 <rosmaita> #link https://etherpad.openstack.org/p/glance-pike-ptg-planning
14:22:45 <rosmaita> oh yeah, when i said above that i was planning to run, i meant "run for glance ptl", not "run away"
14:22:58 <rosmaita> ok, we need to start thinking about The Future
14:23:09 <rosmaita> some general info is on the etherpad linked above
14:23:37 <rosmaita> if you have some ideas of where glance needs to go in Pike and Queens, please propose sessions
14:23:47 <rosmaita> we will have all day wed, thurs, and friday morning
14:24:05 <rosmaita> won't be distractions like at previous summits, so we should be able to get a lot done
14:24:49 <rosmaita> i know stevelle and jokke are interested in multiple backend support
14:25:10 <rosmaita> anyway, if you have ideas, please add them to the etherpad
14:25:28 <rosmaita> # topic upcoming glance_store release
14:25:38 <rosmaita> sigmavirus: that's you, i believe
14:25:45 <sigmavirus> Sorry got side tracked
14:25:55 <sigmavirus> #topic upcoming glance_store release
14:25:59 <sigmavirus> dang doesn't update it
14:26:01 <sigmavirus> anyway
14:26:10 <sigmavirus> The non-client library release freeze is coming up next week
14:26:25 <rosmaita> #topic upcoming glance_store release
14:26:29 <sigmavirus> As such, I'd like us to find the *top* priority (non-bug fix) reviews for the glance-store and prioritize their reviews
14:26:50 <sigmavirus> Anything that's a bug fix I would like to prioritize for *after* the release because we can work on backporting those to stable/ocata and creating a release
14:27:17 <sigmavirus> This is especially important if there are any reviews that are supporting the existing priorities (request-id, etc.)
14:27:43 <sigmavirus> If we don't have any feature related work, I'm going to submit the release request sooner rather than later to get it off my plate
14:27:51 <rosmaita> off the top of my head, we had a multi-tenant swift support fix that i believe has been merged
14:27:52 <sigmavirus> </end-release-cpl-transmission>
14:28:09 <rosmaita> we have a security bug that needs to get in
14:28:21 <rosmaita> but that's all i'm aware of right now
14:28:23 <rosmaita> anyone else?
14:29:23 <rosmaita> sigmavirus: you said Jan 18 for the release?
14:29:30 <dharinic> and possibly try getting Buffered Reader in?
14:29:45 <rosmaita> dharinic: you are correct
14:30:55 <sigmavirus> rosmaita: the dates are in the agenda
14:30:56 <rosmaita> jan 18 is before our next meeting, so if anyone thinks of something, please communicate to the ML
14:31:10 <rosmaita> sigmavirus: ty, i knew i saw them somewhere
14:31:17 <sigmavirus> :)
14:31:27 <rosmaita> #action sigmavirus to propose glance_store release on 18 Jan 2017
14:31:49 <rosmaita> ok, so right now, we have still open for glance_store:
14:32:00 <rosmaita> - buffered reader for swift
14:32:18 <rosmaita> - security bug that i can't give details on
14:32:30 <rosmaita> ok, moving along
14:32:55 <rosmaita> #topic glance_store and glance coresec
14:33:12 <rosmaita> as you may have noticed, there's a security bug open related to glance_store
14:33:28 <rosmaita> i've got some concerns about the proposed fix
14:33:45 <rosmaita> need coresec people to look at the bug and weigh in
14:34:01 <rosmaita> we absolutely need to get this fixed before jan 18
14:34:15 <rosmaita> if you are on coresec and don't know what i am talking about, please pm me
14:34:56 <rosmaita> #topic glance_store patch needs thought about testing
14:35:16 <rosmaita> #link https://review.openstack.org/#/c/378460/
14:35:48 <rosmaita> this is a follow-up patch for a ceph driver bug
14:36:02 <rosmaita> the bug had to do with how the size of an image was being determined
14:36:30 <rosmaita> it was fixed in one place earlier
14:36:48 <rosmaita> but this patch fixes it in the get_size() function
14:37:06 <rosmaita> which was a pretty bad place to miss it
14:37:37 <rosmaita> sigmavirus had put a note on an earlier patch that it would be good to have a test
14:38:10 <rosmaita> and since one of the instances of using a problematic ceph call was missed, i have to agree
14:38:23 <rosmaita> but, it's not entirely clear how this could be tested
14:38:53 <rosmaita> so my request is for people to take a look and see if you can suggest something
14:39:29 <rosmaita> i think the fix is ok, but with no tests, it's hard to avoid a regression
14:39:33 <sigmavirus> ^
14:39:35 <sigmavirus> ++
14:40:06 <rosmaita> ok, that's all for our regularly scheduled program
14:40:11 <rosmaita> #topic open discussion
14:40:22 <hemanthm> maybe stubout the method in question and barf if it is invoked?
14:41:29 <sigmavirus> hemanthm: barf is such a ... sticky word
14:41:33 <sigmavirus> ;P
14:42:09 <hemanthm> :P
14:42:11 <rosmaita> hemanthm: i think you may have hit on the solution there
14:43:37 <rosmaita> i've received some feedback that i haven't allowed for sufficient open discussion at meetings
14:43:51 <hemanthm> rosmaita: I haven't looked at the patch yet, will take a look at it today
14:43:52 <rosmaita> so, just want to point out that we have 16+ min
14:44:18 <rosmaita> so ... please discuss!
14:44:27 <hemanthm> ok ... what's happening with our logo?
14:44:47 <rosmaita> hemanthm: good question, i never heard back about the redesign
14:45:01 <rosmaita> #action rosmaita follow up about the glance logo situation
14:45:42 <rosmaita> i haven't heard about any fabulous swag that's supposed to be available at the PTG, either
14:46:01 <hemanthm> I was so hoping for chipmunk shirts
14:46:19 <rosmaita> hemanthm: you may very well get one, but it may look like a squirrel!
14:46:26 <hemanthm> haha
14:48:25 <sigmavirus> rosmaita: send swag
14:48:31 <jokke_> :)
14:48:34 * sigmavirus has a darth of OS swag
14:48:51 <rosmaita> sigmavirus: if anyone needs OS swag, it's you
14:49:09 <rosmaita> anyone have any interesting new year's resolutions?
14:49:32 <sigmavirus> Be a better release CPL
14:50:04 <dharinic> Be better at everything.
14:50:12 <dharinic> question: Is every session at the PTG like a presentation that one person presents/talks about? Or is it more like a team discussion and brainstorming?
14:50:26 <rosmaita> dharinic: sort of a combination
14:50:29 <hemanthm> Be better at writing email filters :/
14:50:30 <rosmaita> not a presentation, really
14:50:44 <rosmaita> more that someone leads the discussion in a productive manner
14:50:59 <rosmaita> so as the discussion leader, you set the stage
14:51:09 <dharinic> Cool. Thanks rosmaita
14:51:14 <rosmaita> and then most of the session is discussion and brainstorming
14:51:29 <rosmaita> np, good question
14:51:47 <dharinic> whats the approx count of ppl who will be attending it?
14:51:53 <hemanthm> dharinic: it may involve boo-ing the speaker too :P
14:51:57 <rosmaita> another good question
14:52:07 <dharinic> Will keep that in mind hemanthm :P
14:52:11 <rosmaita> let's take a quick poll of who expects to attend the PTG
14:52:23 <rosmaita> i will attend
14:52:28 <hemanthm> o/
14:52:29 <dharinic> I will too
14:52:29 <abhishekk> o/
14:52:43 <jokke_> o/
14:52:52 <rosmaita> mfedosin: will you be able to attend?
14:52:53 <jokke_> I'm all booked
14:52:55 <dharinic> alex_bash too
14:53:14 <jokke_> I'll be there from Sun evening to Sat
14:53:47 <rosmaita> i haven't set travel plans yet, but will be similar, but maybe leave friday afternoon
14:54:10 <rosmaita> so ... finally, hemanthm and jokke_ will get to meet!
14:54:20 <hemanthm> yay
14:55:31 <mfedosin> rosmaita: unfortunately no
14:55:38 <rosmaita> mfedosin: bummer
14:55:44 <mfedosin> I know
14:56:19 <mfedosin> but if its possible to organize it online I'll be happy to join
14:56:30 <rosmaita> mfedosin: i was just going to say that
14:56:46 <jokke_> :)
14:56:51 <rosmaita> #action rosmaita find out what online arrangements will be available at PTG
14:57:28 <mfedosin> if you have a laptop with webcam we may organize skype call
14:57:29 <rosmaita> i'll try to find out right away, and hten maybe you could organize a glance_store session
14:58:00 <mfedosin> great!
14:58:05 <rosmaita> mfedosin: could you put an item on next week's agenda to give us a glare update?
14:58:32 <mfedosin> sure! will be done
14:58:36 <rosmaita> excellent
14:58:47 <mfedosin> btw, sorry for offtopic, but I prepared several demos for glare
14:59:52 <rosmaita> i'm mainly interested in glance/glare areas of cooperation that we should be thinking about/aware of
15:00:00 <rosmaita> ok, we're out of time
15:00:04 <rosmaita> #endmeeting