13:58:07 <sigmavirus> #startmeeting glance
13:58:08 <openstack> Meeting started Thu Jan 19 13:58:07 2017 UTC and is due to finish in 60 minutes.  The chair is sigmavirus. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:58:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:58:11 <openstack> The meeting name has been set to 'glance'
13:58:12 <sigmavirus> #chair rosmaita
13:58:13 <openstack> Current chairs: rosmaita sigmavirus
13:58:44 <sigmavirus> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
13:58:54 <abhishek_k> o/
13:59:00 <sigmavirus> Courtesy reminder ativelkov, cpallares, flaper87, flwang1, hemanthm, jokke_, kragniz, lakshmiS, mclaren, mfedosin, nikhil_k, Nikolay_St, Olena, pennerc, rosmaita, sigmavirus24, sabari, TravT, ajayaa, GB21, bpoulos, harshs, abhishek, bunting, dshakhray, wxy, dhellmann, kairat, aavraham, alex_bash
13:59:06 <sigmavirus> #topic Roll Call
13:59:09 <sigmavirus> Hey abhishek_k :)
13:59:22 <rosmaita> sigmavirus: your clock is a bit early
13:59:32 <sigmavirus> My clock says it's 8:01:45
13:59:43 <rosmaita> mine says 13:59:41
13:59:54 <sigmavirus> One of us has clock drift (or both) =P
13:59:54 <abhishek_k> hey sigmavirus :), mine too
14:00:10 <mfedosin> o/
14:00:17 <rosmaita> ok, def 14:00 now
14:00:20 <rosmaita> o/
14:00:22 <dharinic> \o
14:00:33 <hemanthm> o/
14:00:50 <stevelle> o/
14:00:54 <rosmaita> sigmavirus: anyway, thanks for noticing and getting the meeting started
14:01:09 <rosmaita> looks like a decent turnout
14:01:46 <rosmaita> ok, so i was going to say i want to keep things short today because i'm not feeling well, but something happened at 13:17utc today to make me feel much better
14:01:52 <rosmaita> #topic updates
14:01:54 <sigmavirus> rosmaita: looks like my other laptop is two minutes in the past
14:01:55 <nikhil> o/
14:02:12 <rosmaita> #info community images status
14:02:34 <rosmaita> ok, at 13:17utc stevelle 's tempest patch was approved
14:02:47 <nikhil> \o/
14:02:57 <rosmaita> that clears the way for us to merge community images as soon as stevelle 's patch is merged
14:03:24 <rosmaita> the test change will, i think, make all other glance changes fail until CI is merged
14:03:41 <stevelle> it shoudn't
14:03:50 <rosmaita> even better!
14:04:02 <rosmaita> even so, we want to get CI merged today
14:04:11 <rosmaita> (or at least I do, and hence, all of you do, too!)
14:04:16 <jokke_> o/
14:04:37 <sigmavirus> rosmaita: this is good news =)
14:04:39 <rosmaita> hemanthm had put a +2 with some minor corrections, so he's checking CI over again
14:04:45 <rosmaita> i have already +2'd it
14:04:50 <rosmaita> sigmavirus: indeed!
14:05:06 <rosmaita> so we should be ready to go, let's hope the gate cooperates
14:05:10 <jokke_> \\o \o/ o// o/7
14:06:05 <rosmaita> next steps are i will put up a patch for the CI release notes and promote it on the operators list
14:06:21 <rosmaita> i want to make sure everyone is clear about the changes
14:06:37 <rosmaita> and, i'll put up a patch to update the api-ref
14:06:53 <dharinic> After almost a month when all the issue starterd, CI is going to merge :)
14:07:04 <rosmaita> that's all about CI for the moment ... any questions, comments?
14:07:11 <nikhil> If they are not they will have to be at some point of time (aware)
14:07:45 <nikhil> aware==clear
14:07:48 <rosmaita> nikhil: we have communicated about the change to the ops list, even took a survey
14:08:06 <rosmaita> i'd like to get some actual operators reviewing the release notes patch, though
14:08:14 <nikhil> Cool
14:08:15 <rosmaita> since they are the intended audience
14:08:17 <rosmaita> yeah
14:08:33 <stevelle> I expect we will hear from surprised operators ~1y from now
14:08:40 <stevelle> no matter what we do
14:08:58 <rosmaita> yes, when they upgrade from kilo :)
14:09:06 <rosmaita> ok, moving along
14:09:15 <rosmaita> #info acceptable API changes discussion
14:09:39 <rosmaita> so CI wasn't the only issue we've had to discuss with the QA team recently
14:09:50 <rosmaita> #link https://review.openstack.org/#/c/420038/
14:10:05 <rosmaita> that's a sigmavirus patch that has caused some controversy
14:10:24 <rosmaita> and has resulted in ken (the qa ptl) proposing a patch to the api-wg guidelines
14:10:35 <rosmaita> #link https://review.openstack.org/#/c/422264/
14:11:05 <rosmaita> just for awareness, if you are interested in that kind of thing
14:11:09 <nikhil> Okay..
14:11:22 <sigmavirus> Yeah, since you brought that up
14:11:27 <nikhil> I was gonna suggest we do it but he has done it already
14:11:28 <rosmaita> also, cdent put up something on the ML, a proposal for an "api compatability" tag
14:11:30 <sigmavirus> I'm just going to change our API Ref docs
14:11:47 <rosmaita> sigmavirus: just hold off for now
14:12:00 <nikhil> API compatibility tag may mean a lot of things
14:12:14 <rosmaita> i don't have a link to the ML discussion ATM
14:12:24 <rosmaita> nikhil: yes indeed, it's intentionally vague at this point
14:12:30 <nikhil> :)
14:12:34 <rosmaita> but, it will be refined
14:13:05 <rosmaita> and we will have to live with the result ... so, again, just a point of information if you are interested in that kind of thing
14:13:13 <rosmaita> #info priorities
14:13:40 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-January/110141.html
14:13:51 <jokke_> sigmavirus: IMO your patch is accurate. We are correcting a bug in our response that has been documented correctly. That is outright bug and should not need discussion
14:14:09 <rosmaita> jokke_: i agree
14:14:27 <rosmaita> since you brought it up, there is an issue here about what counts as the "API contract"
14:14:42 <rosmaita> that's why i think it's important that this be addressed directly by the api-wg
14:14:58 <rosmaita> so, sigmavirus, i respectfully ask that you not cave on this yet
14:15:06 <jokke_> as much as I'm against changing the api once it's published, but in this case the documentation points to the correct behaviour and any testing done toward that response should have flagged that the response code is wrong
14:16:03 <rosmaita> jokke_: be sure to join the discussion on the patches (links above)
14:16:31 <stevelle> fwiw I have a vote, but no harm if that change doesn't go the way I voted. it's clear this is a bug and test coverage was missed on it so I understand that reasoning.
14:16:55 <hemanthm> I haven't made up my mind yet on this, so maybe I'm just playing devil's advocate here. But, once an API is published, there isn't a more explicit contract than that.
14:16:55 <rosmaita> ok, glance coresec: i will update you-know-what today, the proposed patches will not work, i will outline how i think this issue needs to be handled
14:17:15 <rosmaita> that was priority 0, it will carry over
14:17:41 <rosmaita> priority 1 was glance_store release, ian will discuss a bit later
14:17:50 <jokke_> rosmaita: will do
14:18:25 <rosmaita> priority 2 was port glance migrations to alembic, which is part of the rolling upgrades effort
14:19:00 <rosmaita> as soon as CI is merged, the database work for rolling upgrades can get moving faster
14:19:26 <rosmaita> and since that's an ocata priority, they'll move up in the list for the coming week
14:20:11 <rosmaita> priority 3 was abhishek_k 's request-id patch for glanceclient
14:20:30 <rosmaita> and, no movement on that, still needs reviews
14:20:44 <abhishek_k> yes, new patch is up for review, waiting :)
14:20:52 <rosmaita> hopefully with the CI stuff out of the way, there will be some more bandwidth
14:21:02 <rosmaita> abhishek_k: i will commit to review it tomorrow
14:21:13 <abhishek_k> no issues, thank you
14:21:23 <rosmaita> glance cores: need a volunteer to review https://review.openstack.org/#/c/352892/
14:21:33 <rosmaita> i mean, someone to volunteer right now
14:21:52 <rosmaita> it's kind of embarrassing that this has been on the list so long
14:21:53 <sigmavirus> Can we volunteer another core? =P
14:21:59 <sigmavirus> I lost track of it.
14:22:06 <sigmavirus> #action sigmavirus to review https://review.openstack.org/#/c/352892/
14:22:15 <sigmavirus> ^Volunteered rosmaita
14:22:15 <rosmaita> sigmavirus: i salute you!
14:22:26 <sigmavirus> Am I about to rock?
14:22:42 <rosmaita> #action rosmaita review https://review.openstack.org/#/c/352892/
14:22:53 <rosmaita> do people still listen to ac/dc?
14:23:07 <abhishek_k> thank you rosmaita, sigmavirus
14:23:07 <sigmavirus> Only the best people still listen to them
14:23:12 <rosmaita> touche!
14:23:14 <mfedosin> only their old things
14:23:15 <stevelle> rosmaita: in nursing homes yes
14:23:27 <sigmavirus> stevelle: I've still got a hip!
14:23:30 <sigmavirus> I mean, I'm still hip
14:23:38 <rosmaita> stevelle: iron prostate!
14:23:51 <stevelle> :)
14:24:06 <rosmaita> (that was actually a band in the 90s, i have a vinyl LP to prove it)
14:24:13 <rosmaita> "rock 'n' roll nursing home"
14:24:19 <rosmaita> ok, i am wandering
14:24:31 <sigmavirus> Yeah. Back on topic rosmaita
14:24:50 <rosmaita> anyone have any new priorities for the week that we should consider?
14:25:23 <rosmaita> actually, i need to:
14:25:34 <rosmaita> #action rosmaita comminity images release notes patch
14:25:45 <rosmaita> #action rosmaita api-ref CI update patch
14:26:00 <sigmavirus> rosmaita: from a release schedule perspective, we need to focus on glanceclient priority reviews and then on glance O-3 deadliens
14:26:21 <rosmaita> sigmavirus: i salute you again
14:26:58 <stevelle> and then strings / docs ?
14:27:07 <rosmaita> the weekly priority list, by the way, has a link in the "topic" in teh openstack-glance channel
14:27:39 <sigmavirus> Just so everyone's aware
14:27:41 <rosmaita> soft string freese is next week
14:27:55 <nikhil> #action nikhil to review https://review.openstack.org/#/c/352892/
14:27:57 <rosmaita> hard string freeze is week of jan 30
14:28:04 <sigmavirus> #info next week is O-3 milestone; feature freeze; final release for client libraries; requirements freeze
14:28:07 <sigmavirus> #link https://releases.openstack.org/ocata/schedule.html
14:28:28 <rosmaita> the end is fast approaching
14:28:28 <sigmavirus> So please let's gather our priorities for glanceclient and feature priorities for glance
14:28:34 <sigmavirus> After O-3 we can focus on bugs
14:28:44 <nikhil> any client and store releases pending for ocata?
14:28:47 <sigmavirus> All Ocata bug priorities should be decided at next week's meeting
14:28:56 <sigmavirus> nikhil: client's final release freeze is next week
14:29:03 <sigmavirus> nikhil: glance store was tagged adn bagged yesterday
14:29:14 <nikhil> ++
14:29:24 <nikhil> I'm wondering if we should freeze on client asap too?
14:29:32 <sigmavirus> nikhil: I think we have a bit of time
14:29:45 <nikhil> as soon as this is done 352892 ?
14:29:45 <rosmaita> nikhil: we need to get CI changes into client, i think
14:29:46 <sigmavirus> I would say our feature freeze should be 4 or 5 days from now
14:29:56 <nikhil> gotcha
14:29:58 <sigmavirus> rosmaita: has anyone actually started that?
14:29:59 <rosmaita> there is a patch up for CI in glanceclient
14:30:06 <rosmaita> alex_bash
14:30:17 <sigmavirus> rosmaita: Alex's not in here
14:30:18 <nikhil> client has tendency to break the world
14:30:30 <sigmavirus> rosmaita: also not in #openstack-glance
14:30:39 <nikhil> given it's used by million other projects, better safe than sorry
14:30:39 <sigmavirus> rosmaita: someone else should be prepared to take that over
14:30:39 <rosmaita> sigmavirus: he's on paternity leave
14:30:47 <stevelle> so CI changes and the request-id changes expected for client. any others known?
14:30:49 <nikhil> only reason for me being a pain to freeze soon
14:30:58 <sigmavirus> nikhil: yep
14:30:58 <rosmaita> i'll put it on the priority list so that it can be reviewed
14:31:14 <nikhil> ++ rosmaita
14:31:19 <rosmaita> stevelle: there are some patches related to 'ploop' support
14:31:31 <stevelle> ok, lets get those on the list too
14:31:37 <nikhil> I can focus on CI and req id
14:31:48 <sigmavirus> rosmaita: those are lowish priority imo
14:31:48 <rosmaita> #action rosmaita make list of glanceclient patches for priority list
14:31:54 <nikhil> but I will be away tomorrow and monday travelling
14:32:15 <sigmavirus> nikhil: Thanks for that head's up :)
14:32:20 <sigmavirus> Safe travels
14:32:25 <nikhil> thank you :)
14:32:39 <rosmaita> sigmavirus: you are right, they only affect "offline" ploop support
14:32:52 <sigmavirus> and help strings
14:32:54 <rosmaita> otherwise, 'ploop' is already in the images schema
14:32:58 <sigmavirus> so they're good to get in for the soft string freeze
14:32:58 <sigmavirus> but
14:33:13 <sigmavirus> that's not as high prio to me as CI and Req ID
14:33:47 <rosmaita> agreed, plus my comments on those reviews are not helping, they will make the patches more complicated
14:33:52 <sigmavirus> rosmaita: yeah
14:34:33 <rosmaita> #action rosmaita make clear the priority ordering of glanceclient patches
14:34:44 <rosmaita> ok, next topic
14:34:53 <rosmaita> #topic reminder about disallowed minor code changes
14:35:12 <rosmaita> i saw a bunch of patches earlier this week for minor changes
14:35:19 <rosmaita> -2'd them all
14:35:30 <sigmavirus> rosmaita++
14:36:08 <rosmaita> so if you see such, feel free to minus wiht the strongest integer you have, and refer the patch author to:
14:36:27 <rosmaita> #link http://docs.openstack.org/developer/glance/contributing/minor-code-changes.html
14:36:38 <rosmaita> that's all about that
14:37:20 <rosmaita> except to say, it would be a good idea to look over the minor code changes doc to remind yourself what's in it
14:37:31 <rosmaita> #topic Glare
14:37:32 <jokke_> ++
14:37:37 <rosmaita> mfedosin: you have the floor
14:37:49 <mfedosin> hey! nice to meet all of you
14:38:03 <mfedosin> so, I think you saw my message in ml
14:38:13 <mfedosin> that is it :)
14:38:43 <mfedosin> rosmaita asked me to prepare small document about next plans for Glare
14:38:57 <mfedosin> https://etherpad.openstack.org/p/glare-plans
14:39:18 <mfedosin> I separate all tasks in 3 groups:
14:39:34 <mfedosin> 1. What Nokia (my current employer) is required
14:39:52 <mfedosin> 2. Other cool and important things
14:40:11 <mfedosin> 3. Small tasks and improvements
14:40:37 <mfedosin> So, what Nokia's required and I'll do first
14:41:08 <mfedosin> they need an artifact type for their package
14:41:19 <rosmaita> for Nokia-#4, are you talking about blobs in the DB?
14:41:44 <mfedosin> nope, it's like it's done in Glance
14:41:56 <mfedosin> add-location
14:41:57 <rosmaita> ok, so blobs in the backend
14:42:29 <mfedosin> in Glare there are external locations and internal (from upload)
14:42:49 <rosmaita> looking at your list quickly, that seems to be the place where glare/glance would interesct in Pike, namely, in the glance_store
14:42:55 <mfedosin> sometimes it's useful to upload some file to store directly and set this location to blob
14:43:40 <rosmaita> otherwise, it looks mostly like Glare work ATM
14:44:08 <mfedosin> yeah, glance_store
14:44:33 <mfedosin> I want to fix a lot of things there, but I'm not sure that you allow me :)
14:44:46 <rosmaita> well, that's why we're having this discussion!
14:45:24 <mfedosin> afair kairat wanted to join this initiative as well
14:45:27 <rosmaita> i did send something to the ML asking about the quality of the internet connections at the PTG, but have not got a clear answer yet
14:45:42 <rosmaita> my point being, we need to discuss glance_store at the PTG
14:46:16 <rosmaita> and get some specificity about what we can do in Pike
14:46:17 <nikhil> someone can use their 4G hotspot
14:46:18 <nikhil> lol
14:46:27 <mfedosin> okay, I'll prepare a doc that my wishlist
14:46:39 <rosmaita> mfedosin: that would be helpful
14:46:40 <mfedosin> i.e. what exactly we want to improve in glance_store
14:47:02 <mfedosin> and next week we'll be able to discuss it more detailed
14:47:12 <rosmaita> #action mfedosin prepare doc with glare glance_store wishlist
14:47:22 <rosmaita> ok, great
14:47:26 <sigmavirus> mfedosin: will Nokia bribe contributors with phones perhaps?
14:47:37 <sigmavirus> I could use a new one =P
14:47:59 <mfedosin> I'll ask them
14:48:22 <jokke_> sigmavirus: they haven't done phones for years :P
14:48:22 <mfedosin> I'll have 1/1 with my manager right after this meeting :)
14:48:32 <rosmaita> ok, we'll hold any questions for next week, and move on to open discussion
14:48:36 <rosmaita> #topic open discussion
14:48:40 <mfedosin> they'll be back soon
14:48:40 <sigmavirus> jokke_: the old ones could survive a nuclear detonation so, I'm cool with that
14:48:57 <rosmaita> sigmavirus: they may have to, after this week
14:49:22 <sigmavirus> /cue ominous music
14:49:23 <mfedosin> btw, have you seen my demos?
14:49:33 <sigmavirus> mfedosin: demolitions?
14:49:43 <stevelle> I like turtles
14:49:54 <nikhil> turtles all the way 'down'
14:49:54 <rosmaita> interruption: stevelle 's tempest patch merged 3 min ago
14:50:27 <mfedosin> like this https://asciinema.org/a/97986
14:50:40 <rosmaita> #action hemanthm complete his CI review as soon as possible
14:50:42 <mfedosin> if you want you may call it demolition
14:51:46 * sigmavirus throws a party for stevelle
14:51:51 <mfedosin> all 4 demos are here https://asciinema.org/a/97985 https://asciinema.org/a/97986 https://asciinema.org/a/97987 https://asciinema.org/a/99771
14:52:22 <stevelle> it feels a little anticlimactic tbh. that isn't CI merging yet
14:52:41 <rosmaita> stevelle: tell hemanthm to review faster!
14:53:02 * hemanthm feels the pressure
14:53:06 <stevelle> I would but I don't want to distract him
14:55:14 <rosmaita> it's gone pretty quiet in here ... any final comments?
14:55:30 <stevelle> I like turtles still
14:55:36 <sigmavirus> I prefer crickets
14:55:40 <nikhil> we can close 5 mins short and make  it a glance style short meeting :)
14:55:45 <sigmavirus> nikhil: true
14:55:51 <sigmavirus> make everyone spend that time reviewing CI
14:56:00 <rosmaita> by the way, i did ask on the ML about the glance logo
14:56:13 <jokke_> saw that, no response sofar
14:56:17 <rosmaita> reply was that a new one is almost ready for us to evaluate
14:56:24 <jokke_> I'm good calling early
14:56:53 <rosmaita> anyway, i will notify the ML if the new logo comes in before the next meeting
14:57:01 <rosmaita> ok, let's end early
14:57:23 <rosmaita> sigmavirus: want to do the honors? by your clock, we are at ending time anyway!
14:58:38 * nikhil runs ahead of speed of light to catch up with the clock
14:59:02 <rosmaita> #endmeeting