14:00:03 <rosmaita> #startmeeting glance
14:00:04 <openstack> Meeting started Thu Jan 26 14:00:03 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:07 <openstack> The meeting name has been set to 'glance'
14:00:11 <rosmaita> #topic roll call
14:00:37 <sigmavirus> o/
14:00:52 <dharinic> \o
14:00:53 <stevelle> o/
14:00:55 <nikhil> o/
14:01:00 <sigmavirus> rosmaita: we should trim that list
14:01:14 <rosmaita> which list is that?
14:01:23 <sigmavirus> courtesy meeting reminder
14:01:29 <nikhil> or ask people to voluntarily remove themselves?
14:01:37 <stevelle> should totally remove sigmavirus24
14:01:43 <nikhil> lol
14:01:45 <sigmavirus> stevelle++
14:01:46 <rosmaita> i guess i am being overly optimistic about who might show up
14:01:59 <stevelle> esp since that nick doesn't match
14:02:00 <nikhil> (doesn't hurt to have superset)
14:02:01 <sigmavirus> I'm just looking at how many of those nicks aren't here or in #openstack-glance
14:02:20 * sigmavirus shrugs
14:02:25 <rosmaita> we don't have removal criteria
14:02:47 <sigmavirus> anyway
14:02:49 <nikhil> it has always been voluntary removal
14:02:51 <rosmaita> you could put something like, nicks are removed after 6 months of no activity, or something like that
14:02:55 <sigmavirus> moving along so we don't spend too much time
14:03:06 <rosmaita> we can bring this back up in open discussion
14:03:10 <nikhil> (because it is for those who want to be notified)
14:03:10 <sigmavirus> (we can discuss removal on ML)
14:03:17 <rosmaita> ok, kind of a light agenda today
14:03:24 <rosmaita> #topic updates
14:03:25 <nikhil> link?
14:03:45 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:04:02 <nikhil> thanks (I'm on a new system)
14:04:20 <rosmaita> np, i should add that to the canned stuff we have at the top of the etherpad
14:04:25 * nikhil likes to click than type in etherpad links
14:04:34 <rosmaita> #info glanceclient
14:04:41 <jokke__> o/
14:04:54 <rosmaita> thanks to the good graces of sigmavirus, we have an ocata release of glanceclient
14:05:11 <sigmavirus> o_O
14:05:22 * nikhil claps
14:05:33 <rosmaita> i guess we need to see if there are any bugs that have backport potential?
14:05:46 <rosmaita> (sorry, didn't mean to step on the applause there)
14:05:50 <sigmavirus> rosmaita: I'd wait for O-3 to be tagged to start looking at client backport potential bugs
14:06:03 <rosmaita> sigmavirus: good point, so let's move on
14:06:18 <sigmavirus> I need to clean up our series targets in launchpad anyway
14:06:21 <sigmavirus> Give me an action for that =P
14:06:37 <rosmaita> #action sigmavirus clean up series targets in launchpad
14:06:44 <sigmavirus> (so that folks can nominate bugs for ackport)
14:06:59 <rosmaita> #info glance O-3 release today begins the Feature Freeze
14:07:01 <sigmavirus> also an action to follow up with tonyb about liberty branch
14:07:16 <rosmaita> #action sigmavirus follow up with tonyb about the liberty branch
14:07:28 <rosmaita> this meeting practically runs itself!
14:07:32 <sigmavirus> =P
14:07:38 <sigmavirus> I haven't proposed O-3 tag yet
14:07:47 <rosmaita> #info glance O-3 release today begins the Feature Freeze
14:07:49 <sigmavirus> Does anyone have anything in the gate queue for O-3?
14:07:57 <rosmaita> i think you were planning to do it today, though?
14:08:06 <sigmavirus> I would rather today than tomorrow
14:08:31 <sigmavirus> If we have stuff in the queue that needs shepherding we have the ability to wait until tomorrow
14:08:31 <rosmaita> btw, the various freezes and stuff are defined here, along wiht the timeline:
14:08:36 <rosmaita> #link https://releases.openstack.org/ocata/schedule.html
14:08:41 <sigmavirus> But if it's stuff that doesn't even have a +2 I'd rather not hold us up
14:09:06 <rosmaita> hemanthm: stevelle: what's the status of the alembic stuff?
14:09:32 <stevelle> sqlparse was merged, need an update to the alembic review
14:09:55 <rosmaita> sigmavirus: what time today are you thinking of proposing O-3 ?
14:10:19 <sigmavirus> rosmaita: so iirc those reviews don't have a +2 (as of right now0
14:10:28 <sigmavirus> So I'd rather not wait for those to be have to contend for gate availability
14:10:35 <sigmavirus> You can FFE them if hemanthm or stevelle requests it
14:10:44 <rosmaita> ok, sounds good
14:10:58 <sigmavirus> I'm more concerned about things currently in the gate queue getting merged and cutting a release after those which are identified are completely merged
14:11:09 <rosmaita> ok, the release of O-3 marks the start of the Feature Freeze
14:11:09 <sigmavirus> I'm not aware of glance things in the gate
14:11:15 <sigmavirus> Correct
14:11:23 <rosmaita> nothing featureful can be landed unless it specifically has an FFE
14:11:29 <rosmaita> (feature freeze exception)
14:11:43 <rosmaita> and there's one proposal, we will discuss it later in the meeting
14:12:01 <stevelle> is the string freeze directly linked to o-3?
14:12:09 <stevelle> or just matching schedule
14:12:11 <sigmavirus> stevelle: that's a soft string freeze, and yes
14:12:22 <sigmavirus> I think it's a soft freeze
14:12:26 <rosmaita> ok, good point, that wasn't obvious to me
14:12:33 <nikhil> I'd be worried to propose big stuff after O-3 (but open to debate)
14:12:37 <sigmavirus> Hard Freeze is next week
14:12:57 <stevelle> ok, just thinking about my replication change
14:12:59 <sigmavirus> nikhil: I think stevelle is worried about his current patch to change some controversial/insensitive language in glance
14:13:03 <sigmavirus> Yeah, that
14:13:21 <rosmaita> so hard string is when RC-1 is released
14:13:27 <rosmaita> *hard string freeze
14:14:00 <nikhil> which changes need strings manipulations ?
14:14:01 <sigmavirus> yes
14:14:06 <nikhil> (targeted for O)
14:14:13 <sigmavirus> nikhil: the string freeze is for strings being translated
14:14:14 <rosmaita> so if stevelle 's replication change can happen before RC-1, they can get in
14:14:21 <sigmavirus> So anything using i18n needs to be frozen at that point
14:14:32 <sigmavirus> Release notes are now included in that FWIW
14:14:40 <sigmavirus> (Release notes are now being translated)
14:14:52 <nikhil> I am curious if there are any features (is what I meant to ask)
14:15:23 <sigmavirus> #info when RC-1 is tagged, stable/ocata will be created. At that point Zanata translations will be imported. Stable-maint cores should feel comfortable approving those without a second +2
14:15:26 <stevelle> I need to look through again carefully but most of the rolling upgrades stuff is pretty low-impact to strings
14:15:33 <nikhil> ok, I can take that action item to verify if release notes are complete (sanity check by another person if that's req)
14:15:48 <hemanthm> there could be some error messages
14:15:57 <rosmaita> #action nikhil review release notes
14:16:01 <sigmavirus> nikhil: so, what stevelle said + rosmaita's in review patch to update for CI
14:16:16 <rosmaita> the visibility release notes need more review
14:16:38 <stevelle> and now does release notes work for FFE work?
14:16:52 <sigmavirus> stevelle: how so?
14:17:01 <rosmaita> yeah, i wasn't aware of a freeze for release notes
14:17:05 <sigmavirus> that question made little sense to me?
14:17:12 <nikhil> just with the patch should be fine stevelle
14:17:21 <sigmavirus> release notes are part of the Hard String Freeze only because they're translated now
14:17:34 <sigmavirus> nikhil: correct. I thought all changes were supposed to include the relnote anyway
14:17:36 <stevelle> I guess I'm thikning about the hard string freeze locking the release notes up
14:17:55 <sigmavirus> stevelle: they will
14:18:00 <sigmavirus> *be locked up
14:18:14 <stevelle> so FFE really just gives 1 more week, but no real news there
14:18:40 <stevelle> all good
14:18:41 <nikhil> sigmavirus: I think 'most' rather than 'all'. sometimes features are introduced by series of patches and could have outer deps. in which case we do allow independent rel note patch (like the CI case for Ocata)
14:19:09 <rosmaita> yeah, let's deal with that if it happens
14:19:14 * sigmavirus nods
14:19:28 <rosmaita> i think it's better to have accurate release notes that aren't translated than inaccurate notes in many languages
14:19:38 <nikhil> ++
14:20:00 <sigmavirus> rosmaita: we can double check that ours are being translated, but I think all of them are
14:20:11 <sigmavirus> and I'm not going to be the person to annoy our i18n team
14:20:15 <jcook> o/
14:20:24 <nikhil> rosmaita: I will go over them today and tomorrow and bug people if something shows up
14:20:25 <sigmavirus> They do fantastic work, I see no reason to move goal posts on them
14:20:27 <rosmaita> #action rosmaita annoy i18n team with question about release notes
14:20:55 <rosmaita> +1 to i18n team doing fantastic work
14:21:08 <rosmaita> ok, one more update
14:21:21 * nikhil would ack but doesn't know any currently translated language :P
14:21:21 <rosmaita> #info PTL self-nomination period closes 29 Jan at 23:45 UTC
14:22:07 <nikhil> who is running this time?
14:22:10 <rosmaita> i am standing for election again, but don't want to discourage anyone else
14:22:13 <nikhil> s/is/are/
14:22:33 <nikhil> s/discourage/encourage/ :P
14:23:07 <nikhil> (jk)
14:23:09 <rosmaita> ok, that's all for updates
14:23:22 <rosmaita> #topic FFE requests for Ocata
14:23:42 <rosmaita> i think there's only one request, but i will check my email in a minute
14:23:53 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-January/111030.html
14:24:56 <rosmaita> ok, don't see anything else on the ML
14:25:00 <nikhil> how much RA do we expect to land in O?
14:25:24 <rosmaita> RA==?
14:25:52 <sigmavirus> Refactoring Antics?
14:25:52 <jokke__> rosmaita: yeah, I think we need to just accept that IIR went to Pike .. I hopefully still have the changes up latest tomorrow
14:25:54 <nikhil> sorry, distracted typo. meant RU = rolling upgrades
14:26:11 <rosmaita> jokke__: np, i discuss that in my candidacy statement, btw
14:26:26 <sigmavirus> jokke__++
14:26:30 <jokke__> I rather see it landing Early Pike than very last minute
14:26:37 <rosmaita> nikhil: ok, thanks ... i have not had coffee yet and am kind of slow
14:26:43 <sigmavirus> If we can get RU into Ocata, that allows us to focus on IIR early in PIke
14:26:50 <rosmaita> jokke__: ++ i am with you on that 100%
14:26:50 <sigmavirus> Or 90% of RU
14:27:02 <nikhil> wow
14:27:20 <sigmavirus> nikhil: I think RU is really close to being ready for O
14:27:24 <jcook> what is IIR image import?
14:27:25 * nikhil plans to catch up on ru
14:27:26 <sigmavirus> It just needs touch-ups
14:27:32 <sigmavirus> jcook: yes, IIR is Image Import Refactor
14:27:40 <jcook> right on, thanks
14:27:51 <rosmaita> my feeling is that RU is close enough that we should keep working on it
14:27:57 <jokke__> _but_ that said, I'd really like to see it land early pike and not keeping rebasing it until end of P-2 or something ;)
14:28:03 <rosmaita> definitely want the alembic migration changes in
14:28:22 <rosmaita> and as much other stuff as we can safely merge
14:29:07 <rosmaita> i think the plan is carefully thought out and a lot of the work is done
14:29:10 <sigmavirus> jokke__: that assumes another OpenSTack team doesn't step in and block us again
14:29:11 <sigmavirus> ;)
14:29:19 <rosmaita> no api changes on this one
14:29:26 <stevelle> we have to assume they will :P
14:29:42 <sigmavirus> stevelle: always the cynic... just like me =P
14:29:44 <rosmaita> why is everyone so glass-half-empty this morning?
14:29:52 <sigmavirus> rosmaita: because my coffee mug is empty
14:30:03 <rosmaita> anyway, we are keeping people distracted with sigmavirus 's 204 patch
14:30:13 <rosmaita> :)
14:30:13 * sigmavirus creates smokescreen
14:30:22 <stevelle> you saw there was a tempest test for that added?
14:30:32 <stevelle> smokescreen engaged
14:30:34 <rosmaita> ken'ichi put up a rival patch to change the api-ref
14:30:49 <nikhil> who is primary POC for RU?
14:30:54 <rosmaita> i am going to ask him to add unit tests to prevent a regression
14:30:56 <jokke__> sigmavirus: I'd say we don't care about them at this point anymore ... they had 2 years to chip in :)
14:30:56 <rosmaita> nikhil: hemanthm
14:31:00 <nikhil> cool
14:31:03 <dharinic> The tempest PTL changed the status code in the doc for us, putting up a patch
14:31:17 <rosmaita> dharinic: yes, that's the one i meant
14:31:30 <dharinic> rival patch :D
14:31:31 <rosmaita> i am going to require a unit test to make sure that call returns 200 instead of 204
14:31:46 <rosmaita> because it's the kind of thing someone might fix inadvertently
14:31:59 <jokke__> I'm still in Favor of sigmavirus's patch as that's the correcting one
14:32:00 <rosmaita> plus, i'm still not convinced it the correct thing to do in this case
14:32:19 <nikhil> (is this all part of the FFE?)
14:32:25 * nikhil bit confused
14:32:28 <rosmaita> yeah, i left some more comments on sigmavirus 's patch
14:32:31 <rosmaita> nikhil: bugfix
14:32:43 <rosmaita> sorry, we got distracted, we can discuss this in open discussion
14:32:51 <nikhil> gotcha
14:32:56 <rosmaita> ok, so i am inclined to grant FFE for rolling upgrades
14:33:10 <rosmaita> that seems to be the general trend of this discussion, too
14:33:20 <rosmaita> do we want to take a vote? or just go for it?
14:33:48 <rosmaita> (i got some feedback that i need to be more assertive, so i am asserting let's go for it)
14:34:06 <nikhil> I'd like to learn a bit about it
14:34:13 <rosmaita> nikhil: you can read the specs
14:34:13 <nikhil> especially since IBM is interested
14:34:20 <nikhil> yup
14:34:23 <rosmaita> lots of good info in there
14:34:40 <nikhil> read and follow up is the Action item for me
14:34:40 <rosmaita> Ok, hearing no objections, i declare:
14:34:51 <rosmaita> #info FFE granted for rolling upgrades work
14:35:01 <rosmaita> ok, next topic
14:35:06 <sigmavirus> I object to the fact that no one has objected. Glance is behaving too efficiently!
14:35:10 <rosmaita> #topic Pike PTG planning
14:35:23 <rosmaita> nothing to say other than to remind you about the etherpad
14:35:38 <rosmaita> we'll pay more attention after RC-1
14:35:44 <nikhil> :)
14:36:32 <rosmaita> couldn't find the link, here it is:
14:36:36 <rosmaita> #link https://etherpad.openstack.org/p/glance-pike-ptg-planning
14:37:05 <rosmaita> ok, one non-agenda item
14:37:10 <nikhil> #link https://wiki.openstack.org/wiki/PTG/Pike/Etherpads
14:37:22 <rosmaita> #topic priorities
14:37:34 <rosmaita> ok, so priorities will be the FFE work, obviously
14:37:55 <rosmaita> and proposing backport-potential glanceclient bugs
14:38:19 <rosmaita> there's an outstanding metadefs patch that i need to follow up on
14:38:53 <rosmaita> #link https://review.openstack.org/#/c/367161/
14:40:04 <rosmaita> and coresec team, there is still The Bug outstanding
14:40:20 <rosmaita> ok, that's all for our regularly scheduled show
14:40:25 <rosmaita> #topic open discussion
14:40:46 <nikhil> I don't get the change description , quite sparsely written (367161)
14:41:13 <nikhil> rosmaita: a couple questions regarding priorities
14:41:18 <nikhil> 1. release notes?
14:41:23 <rosmaita> yes, and i am not clear on the horizon implications
14:42:03 <nikhil> that change needs a lot more work at least in terms of communicating the intent
14:42:11 <rosmaita> yes, we should add release notes since it looks like they need to be done early
14:42:35 <rosmaita> (as a priority, i mean)
14:42:42 <nikhil> commit description, lite-spec and much more explicit rel notes with upgrade impact
14:42:54 <nikhil> s/with/in
14:43:05 <nikhil> rosmaita: yep, thank
14:43:07 <nikhil> you
14:43:23 <nikhil> rosmaita: (on priority item) 2. deprecation path (and removals)
14:43:55 <rosmaita> yes, there are some config options slated for deprecation that i am concerned about
14:43:59 <nikhil> I saw sigmavirus has a -2 on one of the review  so thought we all can discuss the same
14:44:41 <nikhil> we have a the asset tag for deprecation path and in the past we've been relaxed about removals
14:44:55 <nikhil> some of the deprecated stuff in glance doesn't even mention the cycle name
14:45:07 <rosmaita> well, the tag says we remove nothing before it's time
14:45:16 <rosmaita> doesn't guarantee that we'll actually remove it
14:45:17 <sigmavirus> nikhil: I suspect we don't because we were not using debtcollector/deprecation cycle features
14:45:18 <rosmaita> :)
14:45:18 <nikhil> so, what do we want to do? indicate on or after Ocata (if it suggests Ocata)?
14:45:44 <sigmavirus> nikhil: if it suggests on or after Ocata, let's remove all those deprecated items for Pike-1
14:45:51 <rosmaita> i think we should always write these in "on or after" mode
14:45:52 <sigmavirus> I -2'd a bunch of stuff to help cores focus on our actual priorities
14:46:02 <robcresswell> I saw "horizon" and got pinged, so I'm here if I can offer any advice from the Horizon side :)
14:46:07 <nikhil> yeah
14:46:16 <nikhil> sigmavirus: thanks for bringing that up
14:46:24 <nikhil> we are having a good discussion :)
14:46:30 <nikhil> (that == -2)
14:46:33 <rosmaita> i'm worried about the show_multiple_locations removal, that may actuall need a lite spec
14:46:51 <rosmaita> robcresswell: thanks , let me get you a link to look at
14:46:53 <nikhil> the config option you mean?
14:47:00 <rosmaita> https://review.openstack.org/#/c/367161/
14:47:03 <rosmaita> robcresswell: ^^
14:47:21 <robcresswell> Ah, yes
14:47:25 <rosmaita> yes, the option, not the feature
14:47:30 <nikhil> sure (on a lite spec)
14:47:34 <rosmaita> the feature is quite popular, it turns out
14:47:38 <nikhil> indeed
14:47:46 <nikhil> it's gunna get even more
14:48:24 <nikhil> alright then, I will keep the removal stuff aside and focus on rel notes
14:48:28 <rosmaita> we need to get some security people to look at specs before we add anything to the locations stuff
14:48:30 <robcresswell> We already have the depends-on. The change itself seems pretty inoffensive, though that patch will need a release note
14:48:34 <robcresswell> in case plugins are using it
14:48:34 <nikhil> we can target them for Pike-1 as a priority then
14:50:06 <rosmaita> i just realized i have been linking to the wrong review
14:50:10 <rosmaita> here's the one on the glance side:
14:50:17 <rosmaita> https://review.openstack.org/#/c/359742/
14:51:34 <nikhil> this line in particular needs elaboration:-
14:51:36 <nikhil> "but does not align with Heat or Searchlight. It should be noted that Heat added the resource type after Glance had metadefs."
14:52:11 <nikhil> and needs to have technical ramifications before and after in the release notes
14:52:45 <rosmaita> so i guess my question to robcresswell is how bad is it for horizon if this glance change doesn't go into ocata?
14:53:08 <nikhil> (good question)
14:53:24 <rosmaita> i'm pretty sure operators can make the change themselves
14:53:32 <rosmaita> i mean if they want it now
14:53:41 <rosmaita> though, that wouldn't help horizon, nevermind
14:53:51 <robcresswell> I'm just catching up on the bug report
14:54:00 <rosmaita> robcresswell: sorry, don't mean to rush you
14:54:20 <robcresswell> Honestly, from what I can tell, it doesn't really seem to impact us either way
14:54:33 <robcresswell> It seems more of a consistency improvement than an actual requirement for us
14:54:41 <rosmaita> ok, great
14:55:05 * robcresswell may regret those words when everything is on fire next week
14:55:05 <DineshB_> Hi all, I would like to thank all for merging request_id patch on behalf of abhishekk as he is on vacation
14:55:20 <nikhil> rosmaita: LOL
14:55:24 <nikhil> robcresswell: ^
14:55:49 <rosmaita> DineshB_: thanks, and we all hope abhishekk is having a good vacation
14:56:11 <DineshB_> rosmaita: yes
14:56:18 <rosmaita> i do have one more news item, dharinic was nominated for glance core
14:56:42 <rosmaita> there have only been affirmative responses, so she'll be added to the glance core team right after this meeting
14:56:52 <rosmaita> so, congratulations to dharinic
14:56:57 <dharinic> Thank you to all the cores. :)
14:56:57 * nikhil claps
14:57:13 <DineshB_> congrats to dharinic
14:57:26 <stevelle> well done dharinic
14:57:34 <jokke__> GZ dharinic well deserved
14:57:43 <dharinic> Specially hemanthm, my OSIC mentor :)
14:57:55 <dharinic> Thanks all.
14:58:04 <sigmavirus> dharinic: the cores didn't do anything. you did =)
14:58:14 <rosmaita> well, we did recognize her excellence
14:58:20 * sigmavirus hits rosmaita
14:58:23 <rosmaita> :)
14:58:39 <dharinic> sigmavirus: The cores inspired, motivated and recognized.
14:58:52 <dharinic> haha
14:59:08 <rosmaita> well, that ends our meeting on a high note
14:59:18 <rosmaita> i will close before sigmavirus says anything else
14:59:20 <rosmaita> :)
14:59:25 <rosmaita> #endmeeting