14:00:09 <rosmaita> #startmeeting glance
14:00:10 <openstack> Meeting started Thu Feb  9 14:00:09 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:13 <openstack> The meeting name has been set to 'glance'
14:00:17 <rosmaita> #topic roll call
14:00:49 <sigmavirus> o/
14:01:12 <dharinic> \o
14:02:12 <rosmaita> let's wait another minute before sigmavirus gives his update
14:02:32 <sigmavirus> heh
14:02:40 <sigmavirus> I'll update all two of you ;)
14:02:52 <sigmavirus> Let's wait until 5 after
14:03:12 <rosmaita> 5 after works for me
14:05:10 <rosmaita> still just us
14:05:13 <hemanthm> o/
14:05:17 <sigmavirus> Anyone else here for the meeting?
14:05:23 <sigmavirus> jokke_: ?
14:05:47 <sigmavirus> okay then
14:05:49 <rosmaita> he's been late the past few weeks, i think he has a meeting right before this one
14:05:58 * sigmavirus shakes fist at that other meeting
14:06:03 <aavraham> I o
14:06:08 <rosmaita> hang on a sec sigmavirus
14:06:12 <aavraham> I'm Here
14:06:13 * sigmavirus holds on
14:06:17 <sigmavirus> hi aavraham
14:06:19 <rosmaita> #chair sigmavirus rosmaita
14:06:20 <openstack> Current chairs: rosmaita sigmavirus
14:06:32 * sigmavirus hides
14:06:34 <rosmaita> that way you can add action items
14:06:39 <abhishekk> o/
14:06:40 <aavraham> sigmavirus: Hi
14:06:41 <sigmavirus> I think anyone can add #actions
14:06:42 <rosmaita> or items or topics or whatever
14:06:46 <sigmavirus> fair
14:06:50 <sigmavirus> Should we proceed?
14:06:57 <rosmaita> maybe 2 more min
14:07:00 <sigmavirus> sure
14:07:02 <rosmaita> we have some people rolling int
14:07:04 <rosmaita> *in
14:07:07 <hemanthm> Is there a set quorum for the meetings usually?
14:07:13 <sigmavirus> hemanthm: nope
14:07:17 <dharinic> Winter mornings..
14:07:22 <sigmavirus> That'd only be a problem if we ever #vote'd on stuff
14:07:23 <sigmavirus> =P
14:07:29 <hemanthm> :)
14:07:37 <sigmavirus> We never vote because we are one hive mind controlled by the inimitable rosmaita
14:07:38 <rosmaita> we can vote on whether we need to have more votes
14:07:46 * nikhil sneaks in
14:08:11 <sigmavirus> A former PTL, current PTL, and release CPL walking into a meeting channel ...
14:08:14 <jokke_> o/
14:08:19 <rosmaita> erno!
14:08:25 <rosmaita> ok, now we can start
14:08:40 <sigmavirus> #topic Release Updates
14:08:48 <sigmavirus> We successfully released Ocata RC1 with Experimental Rolling Upgrades and CI work! (Good job alex_bash, dharinic, hemanthm, nikhil, rosmaita, et. all)
14:08:50 <jokke_> sorry ... connectivity issues getting to my irc node
14:09:04 <sigmavirus> Please tag all glance bugs with "ocata-rc-potential" on LaunchPad and ping sigmavirus or rosmaita in IRC about them
14:09:13 <sigmavirus> If no bugs are found in RC-1, 14.0.0 will be released as the same version as RC-1.
14:09:17 <sigmavirus> If we have bugs to fix, then we'll need to create further Release Candidate releases (RC-2, RC-3, etc.) until we reach the deadline or agree that an RC is stable enough for the 14.0.0 tag
14:09:27 <sigmavirus> The next bit is important:
14:09:28 <sigmavirus> NOTE: Just because a bug affects Ocata RC1 does not immediately imply it has RC potential
14:09:43 <sigmavirus> In other words, there are few bugs that some of you are actively working on
14:09:57 <sigmavirus> They may be valid backports to Ocata, but that doesnt' mean they're RC-potential
14:10:15 <sigmavirus> Ideally RC-potential bugs are bugs that were introduced just this cycle just before RC-1 was tagged
14:10:18 <sigmavirus> OR
14:10:25 <sigmavirus> They're bugs that are hugely impactful to Glance and its users
14:10:31 <rosmaita> for rc-potential we're looking for a showstopper or what sigmavirus just said
14:10:45 <sigmavirus> Thanks for using clearer words, rosmaita :)
14:10:56 <nikhil> (release critical)
14:11:19 <sigmavirus> Finally, We're also still waiting for openstack/requirements to create their stable/ocata branch. The release team ran into problems yesterday/last night with grenade, devstack, and the requirements repos but that should be done now and they should be branching today
14:11:32 <sigmavirus> ^ nikhil that's especially for you and me since we seem to be doing the bulk of stable reviews lately
14:11:47 <nikhil> Ack
14:12:15 <sigmavirus> And yes, "RC-potential bugs" means "Release Candidate bugs that are Release Critical"
14:12:22 <sigmavirus> RC bugs are only RC bugs if they're RC ;)
14:12:56 <sigmavirus> Any questions?
14:13:15 <jokke_> yes
14:13:25 <jokke_> anything critical on the pipe right now?
14:13:34 <sigmavirus> not that I've seen
14:13:43 <sigmavirus> might have missed something though
14:14:15 <hemanthm> We are treating this as RC? https://bugs.launchpad.net/glance/+bug/1516706
14:14:15 <openstack> Launchpad bug 1516706 in Glance "Glance v1 API makes requests to the v2 registry " [Medium,In progress] - Assigned to Dharini Chandrasekar (dharini-chandrasekar)
14:14:37 <nikhil> meh
14:14:38 <rosmaita> i think stevelle was arguing that it's pretty impactful
14:14:48 <nikhil> It's a medium level bug
14:14:55 <nikhil> Oh
14:15:01 <sigmavirus> Where is steve?
14:15:05 <sigmavirus> Oh right, he's west coast
14:15:05 <hemanthm> Yeah, the default config is broken
14:15:08 <rosmaita> west coast time
14:15:09 <sigmavirus> It's still 6:15AM there
14:15:47 <jokke_> I don't see how over year old bug is suddenly release critical
14:15:51 <rosmaita> let's take an action item for some of us to meet in #openstack-glance later today to talk this one over
14:15:56 <sigmavirus> jokke_: I agree
14:15:57 <rosmaita> jokke_: people are suddenly noticing
14:16:06 <nikhil> I don't think it warrants a RC
14:16:25 <sigmavirus> Right
14:16:29 <jokke_> rosmaita: good for them. We can the backport the fix to stable branches if it one day lands
14:16:53 <rosmaita> what's the advantage of not including it in the RC?
14:16:53 <sigmavirus> jokke_: Right. I think we can focus on fixing master, then prepare the fix for stable/ocata immediately after 14.0.0 is released
14:16:58 <sigmavirus> As well as stable/newton
14:17:04 <jokke_> ++
14:17:57 <sigmavirus> rosmaita: so I think the benefits/advantages are slim either way
14:18:13 <sigmavirus> That said, further RCs are usually scrutinized closely by the Release Team
14:18:21 <sigmavirus> (As well as the Stable Branch team)
14:18:35 <rosmaita> well, plus we've all been testing RC-1
14:18:36 <nikhil> The bug doesn't seem to have a fixed direction/resolution yet. I wouldn't recommend rushing into things
14:18:41 <sigmavirus> And so including a bug that has affected glance for this long in RC-2 might not be the best thing
14:18:43 <rosmaita> don't want to destabilize it
14:19:03 <hemanthm> nikhil: dharinic and I working on it. Expect a patch today
14:19:18 <sigmavirus> rosmaita: ostensibly a bug fix with sufficient testing wouldn't destabilize RC-1 but yes, having several RCs create the perception that the previous RC was not stable or suitable
14:19:31 <sigmavirus> *Technically* that's true because this bug causes problems
14:19:47 <sigmavirus> But that's also true of current stable releases and thus this isn't that high of a release priority for Ocata
14:20:07 <nikhil> sigmavirus: well...
14:20:23 <nikhil> It affects v1 more/significantly
14:20:43 <nikhil> So I'm not so sure about its level of importance
14:20:52 <sigmavirus> nikhil: that's also true
14:21:04 <sigmavirus> There are several factors here
14:21:05 <rosmaita> nikhil: which way are you thinking? more or less important?
14:21:19 <dharinic> cos it is v1. :D
14:21:23 <nikhil> :)
14:21:29 <nikhil> Less
14:21:46 * nikhil nods at dharinic
14:21:55 <sigmavirus> We're horrible parents for not caring for our v1 child ;)
14:22:09 <nikhil> Lol
14:22:09 <dharinic> I was not born when v1 was born :P
14:22:13 <hemanthm> We don't know for sure if everyone moved from V1.
14:22:22 <sigmavirus> dharinic: how young of a python prodigy are you? =P
14:22:26 <rosmaita> actually, we know for sure that everyone has NOT
14:22:34 <jokke_> I'm actually not convinced that bug is critical enough to fix at all :)
14:22:35 <nikhil> Feels as if sigmavirus has a clone child
14:22:38 <sigmavirus> hemanthm: right, but we have had it as deprecated for oer one cycle
14:22:41 <dharinic> you shall see sigmavirus ;)
14:22:51 <sigmavirus> dharinic: I'm not going to the PTG, so maybe not =P
14:23:01 <hemanthm> sigmavirus: sure, that means nothing if it still has a ton of users
14:23:06 <jokke_> The API it's affecting is deprecated and I fail to see how that bug is so critical that we need to fix it ;)
14:23:26 <rosmaita> well, that's why i'd like to discuss with stevelle
14:23:33 <dharinic> stevelle was mentioning yesterday that heat and other projects still use v1
14:23:39 <rosmaita> he had me convinced yesterday that it was key to fix
14:23:48 <sigmavirus> So
14:23:49 <hemanthm> apparently cinder uses v1 too?
14:23:49 <rosmaita> but now his arguments escape me
14:24:10 <sigmavirus> I'll say this much: I'm in favor of fixing it. I'm even in favor of backporting the fixes. I'm not in favor of fixing it for an RC-2
14:24:26 <rosmaita> jokke_: what is the rest of your day like? do you have 10 min later today, say in 3 hours or so?
14:24:50 <jokke_> rosmaita: the sooner the better, but today is looking pretty good
14:24:52 <sigmavirus> My reason for bringing up V1 status is that it does affect the priority of this wok
14:24:54 <sigmavirus> *work
14:24:56 <dharinic> cool. I will put up a patch. We can appropriately merge it whenever it is cool then. :)
14:25:02 <hemanthm> sigmavirus: fair enough, I can see that argument. steve was mentioning yday that it was breaking OSA
14:25:13 <nikhil> == sigmavirus
14:25:13 <hemanthm> If it's breaking OSA, i'd be a bit more worried
14:25:27 <sigmavirus> hemanthm: so this is the first I've heard that it's breaking OSA
14:25:32 <sigmavirus> And OSA is but one deployment project
14:25:48 <sigmavirus> So I'd be extra concerned if this was affecting *all* the deployment projects
14:26:08 <sigmavirus> If kolla, chef-openstack, and triple-o are all having the same problems that'd definitely bump the prio for me
14:26:36 <sigmavirus> Maybe andymccr can explain how severely this is affecting OSA?
14:26:46 <hemanthm> anything building glance out of the default config should fail (and have quotas configured)
14:26:47 <jokke_> well tripleO moved to v2
14:27:52 <sigmavirus> I thought OSA had moved to v2 too but I guess not
14:28:05 <sigmavirus> I guess they only follow upstream when convenient?
14:28:12 <sigmavirus> Anyway, we have other topics on the agenda
14:28:19 <sigmavirus> We've spent almost 10 min on this
14:28:28 <rosmaita> well, light agenda today
14:28:38 <sigmavirus> True, but we have other things that might generate more discussion
14:28:41 <rosmaita> let's meet in openstack-glance at 17:30
14:28:49 <rosmaita> utc
14:28:51 * sigmavirus loaded the agenda purposefully
14:28:57 <andymccr> hey sorry just catching up on the above - im not too sure how breaking the change is - we do use v2 api (and v1) i believe the issue relates to other projects only integrating with v1. i could be wrong.
14:29:13 <rosmaita> andymccr: ty
14:29:28 <andymccr> as far as im aware its not breaking our integrated builds - but i do remember stevelle mentioning some things so unfortunately he would be the best person to talk to.
14:29:38 <sigmavirus> Thanks andymccr
14:30:00 <andymccr> i'll try follow up with him, and between us we'll get back to you
14:30:01 <rosmaita> ok, does 17:30 work for jokke_ sigmavirus nikhil dharinic hemanthm ?
14:30:09 <sigmavirus> WFM
14:30:10 <hemanthm> rosmaita: yes
14:30:15 <dharinic> yes rosmaita
14:30:17 <nikhil> Sure
14:30:40 <rosmaita> jokke_: too late for you?
14:30:48 <jokke_> I'll make it work
14:31:00 <sigmavirus> jokke_: makes everything work :)
14:31:01 <rosmaita> i appreciate that, we'll keep it short
14:31:23 <jokke_> sigmavirus: just matter of taking bigger hammer ;)
14:31:59 <rosmaita> #action rosmaita hemanthm jokke_ dharinic nikhil sigmavirus stevelle to meet in #openstack-glance at 17:30 UTC today to discuss whether bug is RC candidate or should hold off for backport to stable branch
14:32:08 <sigmavirus> heh
14:32:11 <sigmavirus> Move on then?
14:32:20 <rosmaita> dharinic: do you have a link to the bug handy?
14:32:33 <dharinic> https://bugs.launchpad.net/glance/+bug/1516706
14:32:33 <openstack> Launchpad bug 1516706 in Glance "Glance v1 API makes requests to the v2 registry " [Medium,In progress] - Assigned to Dharini Chandrasekar (dharini-chandrasekar)
14:32:35 <rosmaita> ty
14:32:44 <rosmaita> #link https://bugs.launchpad.net/glance/+bug/1516706
14:32:50 <sigmavirus> #topic Bugs, Reviews, and Other Things of Note
14:32:58 <rosmaita> #action rosmaita shoot stevelle an email about meeting
14:33:05 <sigmavirus> #link https://bugs.launchpad.net/glance-store/+bug/1297451
14:33:05 <openstack> Launchpad bug 1297451 in glance_store "Image uploads to the filesystem driver are not fully atomic" [Wishlist,In progress] - Assigned to Srinivas Sakhamuri (srinivas-sakhamuri)
14:33:52 <sigmavirus> So that bug has a fix but needs to be fixed up and re-reviewed it seems
14:33:53 <sigmavirus> #link https://review.openstack.org/#/c/242084/
14:34:19 <sigmavirus> This is a feature, that would likely be really great to have for Pike
14:34:39 <sigmavirus> (And Pike development should open up at some point today)
14:35:53 <sigmavirus> Any cores want to commit to getting that through?
14:36:10 <dharinic> I can review.
14:36:12 <sigmavirus> (Believe it or not, people do use the filesystem store in production)
14:36:29 <nikhil> And with NFS!!!
14:36:38 <sigmavirus> #action dharinic to review and help work on https://review.openstack.org/#/c/242084/
14:36:40 <sigmavirus> nikhil: I know
14:37:05 <hemanthm> Do we need a lite-spec for that?
14:37:19 <sigmavirus> I wasn't sure about that honestly
14:37:25 <sigmavirus> rosmaita: thoughts?
14:37:30 <jokke_> that actually makes quite a bit of sense
14:37:40 <jokke_> I mean using that combo
14:38:04 <jokke_> not sure about the lite spec tbh, this is only back end related change, right?
14:38:21 <sigmavirus> jokke_: Yeah, for features we've been doing lite specs semi-formally
14:38:43 <rosmaita> well, my thought is that it would be nice to get this fixed eventually
14:38:54 <jokke_> so before looking into the change, how intrusive it is?
14:39:33 <nikhil> It's pretty important
14:40:00 <sigmavirus> it adds a new config option
14:40:15 <sigmavirus> And it dramatically changes how things are saved
14:40:15 <hemanthm> jokke_: from what I read, looks like it doesn't impact glance as such
14:40:21 <sigmavirus> FIrst to a temp location then to the permanent
14:40:28 <sigmavirus> It may impact operators though
14:40:46 <sigmavirus> in other words, they'll have to consider how they configure glance to store things when using the filesystem store
14:41:29 <jokke_> yeah just looking it
14:41:53 <jokke_> and honestly I really don't like the idea of that new config option. Like seriously?
14:42:08 <hemanthm> sigmavirus: I'm wondering is it perhaps a one operator change?
14:42:21 <sigmavirus> hemanthm: how do you mean?
14:42:59 <hemanthm> From the bug description, it looks like the reason for that change is some off-the-band stuff not working well with current setup
14:43:19 <rosmaita> yeah, looks like dark data left in filesystem store
14:44:11 <rosmaita> so is the question whether this needs a lite-spec?
14:44:34 <hemanthm> whatever that off-the-band stuff is, does it warrant a change in glance ?
14:45:20 <jokke_> and how about identifying those corner cases and fixing them rather than introducing yet another place where it might leave hanging
14:45:33 <hemanthm> jokke_: +1
14:45:38 <nikhil> In case config being essential
14:45:41 <rosmaita> yeah, i'm with erno, this seems to be incomplete
14:45:50 <sigmavirus> Awesome
14:45:56 <sigmavirus> #action jokke_ to help dharinic flesh this out better
14:46:11 <sigmavirus> (rosmaita made me a chair, so I'm using my chair to voluntell people ;))
14:46:13 <jokke_> also last activity on that bug was as well over a year old and original author abandoned it two years ago. Is that still even valid issue for anyone?
14:46:32 <sigmavirus> jokke_: must be if someone has bothered fixing it and keeping the patch rebased
14:46:51 <rosmaita> rebased on feb 3 by original author
14:47:08 <jokke_> good point
14:47:10 <sigmavirus> right, people don't do that just to get a contribution. They do that if it is affecting them and they don't know how to lobby us
14:47:26 <sigmavirus> I found this going through the glance-store's open bugs and cleaning them up
14:47:29 <dharinic> actually, there is another patch thats not even abandoned. https://review.openstack.org/#/c/82899/5
14:47:36 <sigmavirus> Seemed important enough to not wantonly close
14:47:45 <rosmaita> dharinic: jokke_ : reach out to srinivas and see if he'll put up a lite spec with you
14:47:48 <dharinic> same changes.
14:47:49 <sigmavirus> dharinic: that is abandoned :)
14:48:00 <sigmavirus> Also metacloud no longer exists =/
14:48:04 <dharinic> oops.
14:48:08 <sigmavirus> OpenStack's history is littered with failed startups
14:49:02 <rosmaita> ok on that note let's move to the next topic
14:49:10 <rosmaita> #topic PTG planning
14:49:11 <sigmavirus> wait
14:49:13 <sigmavirus> aw
14:49:14 <rosmaita> oops
14:49:17 <sigmavirus> #undo
14:49:18 <openstack> Removing item from minutes: #topic PTG planning
14:49:27 <sigmavirus> #link https://review.openstack.org/#/c/217282/
14:49:39 <sigmavirus> That also seemed semi-valuable/important
14:49:45 <sigmavirus> We can move on though
14:49:48 <sigmavirus> We only have 10 min left
14:49:51 <sigmavirus> #topic PTG Planning
14:50:37 <rosmaita> #link https://etherpad.openstack.org/p/glance-pike-ptg-planning
14:50:45 <rosmaita> I will be adding a lot of stuff this weekend, but there's a list of topics at the bottom of the etherpad to give you an idea
14:50:52 <rosmaita> we'll discuss image import on all 3 days
14:51:02 <jokke_> yeiii!
14:51:02 <rosmaita> interspersed with other topics, of course
14:51:09 <rosmaita> but it touches almost all aspects of glance
14:51:16 <rosmaita> i should be clear about what we are discussing, though
14:51:22 <rosmaita> the spec has been approved, it's been through review by the interop group, api-wg, us (of course), infra, etc
14:51:30 <rosmaita> so we aren't going to argue about what the calls should look like or what the acceptable workflow is ... that's been settled.  What i'll be asking is for you to exercise your creativity within the bounds of what we've already agreed
14:51:40 <rosmaita> and here's what we've agreed: http://specs.openstack.org/openstack/glance-specs/specs/mitaka/approved/image-import/image-import-refactor.html
14:51:46 <rosmaita> you notice 'mitaka' in the URL there ... you can see we're a little late delivering this
14:51:49 <jokke_> and written ;)
14:52:02 <rosmaita> i discuss that and how i want to handle getting this done in Pike in my election statement, which i imagine no one read, so in the spirit of DRY, here's a link:
14:52:10 <rosmaita> https://git.openstack.org/cgit/openstack/election/plain/candidates/pike/Glance/rosmaita.txt
14:52:20 <rosmaita> also, image import is a blocker for us to finally decommission v1
14:52:31 <rosmaita> ok, back to the PTG ... this will be different from a "normal" design summit because we have 2.5 full days to do glance stuff (unlike previous design summits, where we had 5 40min sessions to discuss/agree on things)
14:52:43 <rosmaita> so we'll really be able to get a lot done on Wednesday through Friday
14:52:55 <rosmaita> but for now, let's talk logistics
14:52:55 <jokke_> this is more like rescheduled mid-cycle
14:52:57 <nikhil> (lol, but I read it)
14:53:13 <rosmaita> for instance, who is going and what days will you be in atlanta? please put your info at the top of the PTG etherpad
14:53:32 <rosmaita> also, what times do we want to work?
14:53:39 * jokke_ will be there Sun-Sat
14:54:08 <rosmaita> 9:30am-12:30, lunch, pick back up at 2, go 2-6:00pm ?
14:54:39 <jokke_> sounds like horribly long lunch
14:54:41 <nikhil> Works for me
14:54:50 <rosmaita> anyway, if you have strong preferences, let me know, otherwise i will just make stuff up
14:55:13 <rosmaita> jokke_: my experience with lunch is that it takes about 20min to get people out of the session
14:55:22 <nikhil> Well...
14:55:24 <rosmaita> i think we have to leave for lunch, nothing is provided
14:55:34 <nikhil> And there are lunch meetings
14:55:45 <jokke_> rosmaita: I'd prefer 0900-1200; 1300-1700 ;)
14:56:11 <nikhil> I may need at least 2 hours for lunch
14:56:33 <rosmaita> i'll ask around what hte other teams are doing for lunch
14:56:44 <nikhil> Especially now that my primary responsibilities are more than glance
14:57:00 <rosmaita> also, we should have dinner as a team ... unfortunately, we will have to pay ourselves, no sponsors for dinner
14:57:30 <jokke_> Liquid lunch and dinner :D
14:57:42 <jokke_> every day
14:57:43 <nikhil> Or I may skip a afternoon
14:57:44 <sigmavirus> heh
14:57:52 <rosmaita> you can use one of those camelpaks and you won't have to leave the room
14:58:04 <hemanthm> haha
14:58:27 <rosmaita> ok, i'll get a preliminary schedule up this weekend and send to the ML when it's there
14:58:38 <rosmaita> people can comment, suggest adjustments
14:58:41 * jokke_ spent just weekend in Fosdem where the beer was available from breakfast and it was super good :D
14:58:42 <rosmaita> we can be flexible
14:59:17 <nikhil> 1 min left
14:59:22 <sigmavirus> yep
14:59:24 <rosmaita> #topic open discussion
14:59:28 <sigmavirus> heh
14:59:31 <dharinic> Wanted to bring this up.. Can I please have some reviews on https://review.openstack.org/#/c/120866/
14:59:32 <sigmavirus> QUICK 30s left
14:59:42 <rosmaita> dharinic: noted
14:59:45 <dharinic> Buffered reader.
14:59:48 <dharinic> Thanks. :)
14:59:49 <sigmavirus> #link https://review.openstack.org/#/c/120866/
14:59:56 <nikhil> ta-tah
15:00:01 <rosmaita> #endmeeting