14:00:01 <rosmaita> #startmeeting glance
14:00:02 <openstack> Meeting started Thu Feb 16 14:00:01 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:06 <openstack> The meeting name has been set to 'glance'
14:00:10 <rosmaita> #topic roll call
14:00:13 <sigmavirus> o/
14:00:19 <nikhil> O/
14:00:20 * sigmavirus was waiting for the topic to change =P
14:00:31 * rosmaita appreciates it
14:01:06 <dharinic> \o
14:01:11 <rosmaita> i'm just going to wait a minute, the updates I have aren't earth-shaking
14:01:26 <rosmaita> so it won't matter if people wander into the meeting in progress
14:01:51 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:02 <mfedosin> o/
14:02:16 <rosmaita> hi mike, saw you updating the agenda
14:02:22 <mfedosin> yep
14:02:30 <rosmaita> #topic updates
14:02:39 <rosmaita> #info mascat available
14:02:54 <sigmavirus> rosmaita: mascot or muscrat?
14:02:55 <rosmaita> #link https://www.dropbox.com/sh/xct2hsah2h8l6yi/AAATDIfxQHXfgPqop1cOSYdsa?dl=0
14:03:17 <rosmaita> yeah, it's actually a chipmunk, not a "mascat"
14:03:33 <rosmaita> so our mascot/logo is available for you to use
14:03:47 <rosmaita> licensing is CC-BY-ND , you can look it up
14:03:52 <rosmaita> we're supposed to get some guidance
14:04:00 <stevelle> o/ late
14:04:05 <rosmaita> but basically, you can't slap your company logo onto it
14:04:27 <rosmaita> but, i'm not a lawyer, so i don't know how close your logo can be before it's a violation
14:04:48 <rosmaita> anyway, use the mascot files in good health
14:05:28 <rosmaita> it's definitely better than the box-with-a-CD-ROM logo we've had forever
14:05:32 <mfedosin> why one its cheek is bigger than the other?
14:05:47 <rosmaita> that's indicating that it's got nuts in its mouth
14:05:50 <rosmaita> but it's not full yet
14:05:51 <sigmavirus> mfedosin: it's got all the blobs in taht cheek
14:06:26 <rosmaita> ok, moving on
14:06:46 <rosmaita> #info metadefs-delete-tags ... tc accepted ian's patch as the way to go
14:06:57 <rosmaita> #link https://review.openstack.org/#/c/420038/
14:07:02 <rosmaita> (that's ian's patch)
14:07:17 <rosmaita> see item #5: http://eavesdrop.openstack.org/meetings/tc/2017/tc.2017-02-14-20.01.html
14:07:31 <rosmaita> i've got a tempest patch up for review
14:07:43 <rosmaita> #link https://review.openstack.org/#/c/432611/
14:08:09 <rosmaita> two reviewers requested a change, i left a note about why maybe it's OK as is
14:08:34 <rosmaita> would appreciate it if someone (maybe sigmavirus and stevelle ) would look and see what you think
14:08:58 <sigmavirus> #action look over tempest patch
14:09:05 * sigmavirus is taking that as an action for himself
14:09:05 <rosmaita> good idea
14:09:13 <rosmaita> #action sigmavirus look over tempest patch
14:09:41 <nikhil> #action sigmavirus look at the tempest patch for tags deletion on metadefs
14:09:50 <nikhil> #undo
14:10:17 <rosmaita> what came out of the TC meeting was that bringing this to the TC was the correct course of action
14:10:18 <sigmavirus> lol
14:10:25 <sigmavirus> EVERYONE ASSIGN ME THE SAME ACTION AT THE SAME TIME ;)
14:10:33 <rosmaita> that's what they want to have happen in the future with similar changes
14:10:39 <rosmaita> (we don't want you to forget!)
14:11:04 <rosmaita> anyone else have an action for sigmavirus ?
14:11:27 <nikhil> (rock n roll)
14:11:39 <rosmaita> #info no Glance weekly meeting on Feb 23 due to PTG
14:11:50 <rosmaita> and, that's all the updates
14:12:10 <rosmaita> #topic release news
14:12:14 <rosmaita> sigmavirus: that's you
14:12:34 <sigmavirus> #link https://releases.openstack.org/ocata/schedule.html
14:12:40 <sigmavirus> So we're on the week labeled R-1
14:13:05 <sigmavirus> That means this is the time for any Final Release Candidates. We've had 0 release-critical bugs for our Ocata Release Candidate (RC-1)
14:13:14 <sigmavirus> That means there are no final release candidates for Glance to create
14:13:19 <sigmavirus> (That's *good* news)
14:13:24 <rosmaita> (i hope so!)
14:13:42 <sigmavirus> That also means that next week I'll be submitting a review to make 14.0.0.0rc1 become 14.0.0!
14:13:52 <sigmavirus> Congratulations everyone on a great cycle!
14:14:04 <nikhil> Why next week?
14:14:18 <sigmavirus> nikhil: Next week is release week :)
14:14:21 <nikhil> (instead today)
14:14:22 <sigmavirus> (See R+0)
14:14:26 <rosmaita> we don't want to make everyone else look bad
14:14:36 <nikhil> Ahk.. formalities
14:14:38 <sigmavirus> I can submit it today, doubt they'll merge it
14:14:43 * sigmavirus shrugs
14:14:43 <stevelle> more time for release critical bugs :)
14:14:49 <rosmaita> yes, just in case
14:14:50 <sigmavirus> stevelle: not really
14:15:00 <nikhil> I think we will look good
14:15:13 <stevelle> no, but joke
14:15:17 <nikhil> You can submit it whenever and they will pick up when they decide to
14:15:18 <sigmavirus> But if there's something highly critical, then yes we could in theory merge it, backport it, and make an RC
14:15:22 <sigmavirus> Yep
14:15:31 <sigmavirus> Another item
14:15:31 <rosmaita> i do have 2 release related patches that need to merge before RC-0
14:15:41 <rosmaita> for docs
14:15:50 <rosmaita> #link https://review.openstack.org/#/c/426605/
14:16:00 <rosmaita> #link https://review.openstack.org/#/c/429341/
14:16:00 <sigmavirus> rosmaita: this is news to me =)
14:16:12 <sigmavirus> oh
14:16:15 <rosmaita> they need to merge to master
14:16:22 <nikhil> rosmaita: but those will be in pike based on the Sha for O release
14:16:35 <rosmaita> i don't think anyone cares
14:16:43 <nikhil> Kk
14:16:55 <sigmavirus> Docs are published from master typically anyway as I understand it (could be wrong)
14:16:56 <rosmaita> the docs are OK for Ocata, but this enhances them a bit
14:17:07 <rosmaita> no, docs always published from master
14:17:11 <sigmavirus> One other thing I want to mention, is that it's probably best for someone to step up to become the next Release CPL
14:17:32 <rosmaita> sigmavirus: has done a great job at this
14:17:43 <sigmavirus> I'm working on docs, but I'd also like to collaborate with the next person to help them learn what's required of them
14:17:46 <sigmavirus> I'm not disappearing
14:17:47 <rosmaita> i mean, "sigmavirus has done a great job at this"
14:17:49 * hemanthm applauds sigmavirus for tackling all things release in Ocata.
14:18:08 <sigmavirus> But it's always best to have a back-up CPL who understands their responsibilities
14:18:15 <rosmaita> yeah, we need to get this knowldege spread around the team
14:18:25 <sigmavirus> And besides, I'll probably stick to our stable branches at this point (worrying about releasing them, etc.)
14:18:35 <sigmavirus> The new person would handle Pike
14:18:44 <rosmaita> i encourage anyone interested to chat with sigmavirus to see what's involved
14:18:59 <sigmavirus> So if you're interested, feel free to reach out to me. My contact details are fairly public :)
14:19:02 <sigmavirus> </fin>
14:19:08 <rosmaita> key thing is you need to tell the PTL that some stuff just cannot get into a release given time, etc
14:19:14 <nikhil> Also a good opportunity to be part of glance core
14:19:45 <rosmaita> yes, it's a serious responsibility and an important role in openstack
14:20:05 <rosmaita> ok, thanks for the update sigmavirus
14:20:14 <rosmaita> #topic PTG
14:20:22 <sigmavirus> nikhil: Release CPL != core
14:20:25 <sigmavirus> (imo)
14:20:34 <nikhil> Sure
14:20:40 <sigmavirus> Also, taking on the position of Release CPL should not provide you with core reviewer status
14:20:43 <sigmavirus> but that's a side topic
14:21:05 <rosmaita> well, worth saying something
14:21:16 <rosmaita> 1 you don't have to be core to be release CPL
14:21:32 <rosmaita> 2 being release CPL can help you on the way to core
14:21:34 <nikhil> But anyone willing to take that responsibilities will get fast track opportunity to become one by the roles very nature
14:21:58 <sigmavirus> nikhil: if they perform quality reviews
14:22:19 <rosmaita> 3 in practice, you need to be a core or someone "almost" core because you have to stand up to the PTL and possibly other cores
14:22:22 <nikhil> If they don't I don't think anyone would encourage CPL
14:22:22 <sigmavirus> It's a role that would necessitate that and that's why it would provide you with a "fast track"
14:22:52 <sigmavirus> Anyway, we're supposed to be discussing the PTG
14:22:55 <nikhil> sigmavirus: yep, that's it
14:22:57 <sigmavirus> Let's talk about this out of meeting
14:22:58 <rosmaita> oh yeah
14:23:11 <rosmaita> #link https://etherpad.openstack.org/p/glance-pike-ptg-planning
14:23:28 <rosmaita> that's the planning etherpad, i moved some stuff around, most of the info is there
14:23:41 <rosmaita> #link https://etherpad.openstack.org/p/glance-pike-ptg-schedule
14:23:52 <rosmaita> ^^ is the schedule of events
14:24:20 <rosmaita> some general comments
14:24:40 <rosmaita> monday and tuesday, you are on your own to explore the "horizontal" team meetings
14:24:46 <rosmaita> go to whatever makes sense
14:25:06 <rosmaita> also, there are some "Breakout" meetings on the planning etherpad
14:25:19 <rosmaita> just some things i noticed mentioned on the ML
14:25:44 <rosmaita> please post anything you're aware of that may impact glance
14:26:10 <rosmaita> i am mentioning the horizontal meetings because the first glance meeting is Wednesday at 9am
14:26:19 <rosmaita> most of us have not met face-to-face
14:26:30 <rosmaita> or at least, not everyone has met everyone else face-to-face
14:26:47 <sigmavirus> some of us have met virtually face to face
14:26:51 <sigmavirus> if our computer screens count as faces
14:26:58 <dharinic> :D
14:27:14 <rosmaita> so for the first session, i want us to have a bit of time to introduce ourselves, and then we'll have a roundtable discussion of what you learned on monday and tuesday
14:27:38 <rosmaita> the people who arrive tuesday night will have to ask questions or make stuff up
14:27:54 <hemanthm> or hide under the table
14:28:27 <rosmaita> we may meet under the tables so that there is no place to hide
14:28:30 <rosmaita> :)
14:28:33 <sigmavirus> or, listen and ask questions
14:28:34 <sigmavirus> =P
14:28:55 <rosmaita> anyway, please look over the schedule
14:29:12 <nikhil> rosmaita: didn't get the part where you say people arriving Tuesday night will....
14:29:16 <stevelle> just want to note for PTG that those around on Mon/Tues may want to read this etherpad to cover the community priorities discussions https://etherpad.openstack.org/p/ptg-pike-wsgi
14:29:38 <rosmaita> #link https://etherpad.openstack.org/p/ptg-pike-wsgi
14:29:42 <rosmaita> thanks stevelle
14:29:42 <sigmavirus> rosmaita: beat me to it =P
14:29:50 <sigmavirus> (Note, anyone can #link a thing)
14:29:58 <sigmavirus> (Please use #link so it shows up in the meeting minutes)
14:30:05 <rosmaita> the community priorities are ... priorities
14:30:25 <rosmaita> and they are python 3.5 support and running-glance-in-a-wsgi-container
14:30:30 <nikhil> Will just ask offline
14:30:33 <rosmaita> meaning a container the deployer chooses
14:31:02 <stevelle> for devstack, apache w/ mod_wsgi is available
14:31:53 <stevelle> that cross-project topic should be a good primer and a chance to make contacts with other folks working on this in other parts of openstack
14:32:48 <rosmaita> my impression is that we'll have a bit of work on this
14:32:57 <sigmavirus> also doc work on it
14:33:12 <sigmavirus> because it's supposedly plausible to already run glance with modwsgi under apache but no one knows how
14:33:12 <sigmavirus> =P
14:33:30 <rosmaita> yes, theoretically it can be done
14:33:46 <rosmaita> but i suspect that the container boundary may have been crossed a bit in practice
14:33:58 <rosmaita> anyway, it should be interesting
14:34:14 <rosmaita> and since it's a community goal, it is also a glance goal
14:34:20 <sigmavirus> exactly
14:34:28 <rosmaita> but it will also be helpful to glance moving forward to get this sorted out
14:34:55 <rosmaita> one comment about the schedule
14:35:11 <rosmaita> we can be flexible about most of the sessions
14:35:34 <rosmaita> except for the docs one at 11am on Wednesday (though i haven't confirmed that time, so it could change)
14:35:46 <rosmaita> and the Glare discussion at 9:30am on Thursday
14:35:59 <mfedosin> not 10:30?
14:36:20 <rosmaita> i think it's 9:30 to 10:30
14:37:03 <rosmaita> yes, just verified, 9:30-10:30
14:37:15 <rosmaita> i can't change that one, i had to book one of the "fishbowl" rooms
14:37:17 <mfedosin> yes, I'll update my calendar then
14:37:20 <rosmaita> ty
14:38:00 <rosmaita> stevelle: dharinic: nikhil: please look at the schedule, you are leading some sessions
14:38:23 <rosmaita> let me know this afternoon if there are problems, you want to change your mind, etc
14:38:24 <dharinic> Thanks rosmaita
14:38:30 <nikhil> rosmaita: is there slot available for some open discussion?
14:38:36 <rosmaita> nope
14:38:47 <rosmaita> i figured that's what lunch and dinner are for
14:38:53 <nikhil> So all slots full?
14:39:02 <rosmaita> pretty much
14:39:09 <rosmaita> but, i was going to say
14:39:23 <rosmaita> if there's a topic that's missing that should be discussed, let me know this afternoon
14:39:30 <nikhil> Ack
14:39:31 <dharinic> rosmaita: Most of my topics are light. So feel free to reschedule if required.
14:39:39 <rosmaita> dharinic: ty
14:40:04 <rosmaita> we can be a bit flexible because for most of the 2.5 days, it's "just us"
14:40:10 <nikhil> Glance is a pretty busy community
14:40:38 <rosmaita> ok, that's it ... any other questions?
14:40:47 <nikhil> rosmaita: thanks, I think I may need a 20 min slot in the middle
14:41:18 <rosmaita> that should be possible, we can talk in #openstack-glance later
14:41:25 <nikhil> Thank you
14:41:43 <rosmaita> #topic glare-ectomy (of v0.1)
14:41:53 <mfedosin> I'm happy that it's finally happening :)
14:42:12 <rosmaita> so, what this is is the removal of the code in the glance repo that was copied over to glare repo in Newton
14:42:20 <rosmaita> we need to get rid of the duplication
14:42:31 <mfedosin> If all the tests pass, then I'm happy to put my +2(A)
14:42:39 <rosmaita> i believe this is a non-impacting change
14:42:42 <mfedosin> but the code isn't copied :)
14:42:52 <rosmaita> well, ok
14:43:03 <rosmaita> how about ... the code is no longer necessary
14:43:13 <mfedosin> absolutely correct
14:43:16 <nikhil> I'm happy to +2A as well
14:43:44 <mfedosin> It will force Murano to use v1
14:44:04 <rosmaita> well, that's good ... is there any reason not to merge this right away? for example, should i send someting to the ML first saying it's about to happen?
14:44:29 <hemanthm> rosmaita: +1, I think it's better to send a FYI note to ML
14:44:38 <rosmaita> ok, that makes sense
14:44:46 <mfedosin> no hurry at all
14:44:48 <nikhil> If you're sending
14:44:59 <nikhil> Might as well cross post with ops
14:45:01 <rosmaita> my request is: everyone who knows anything about glare, please look at the releasenote ot my patch
14:45:07 <rosmaita> s/ot/on/
14:45:17 <rosmaita> https://review.openstack.org/#/c/427535/
14:45:31 <mfedosin> deal
14:45:36 <rosmaita> because, basically, that's what i'll put in the email to the ML and ops lists
14:45:54 <sigmavirus> Sounds good rosmaita
14:45:55 <rosmaita> i just want to make sure it's correct about the impact
14:45:59 <rosmaita> ok, cool
14:46:20 <rosmaita> #topic bringing glare repo under the glance tent
14:46:22 <mfedosin> the impact is Murano won't work...
14:46:35 <rosmaita> that's kind of a bad impact
14:46:36 <mfedosin> but who cares about Murano nowadays?
14:46:45 <rosmaita> why is it that murano won't work, though?
14:47:04 <mfedosin> because they use Glare
14:47:31 <rosmaita> but v0.1 was on its own endpoint
14:47:40 <rosmaita> not the glance endpoint
14:47:45 <sigmavirus> correct
14:48:00 <sigmavirus> Also, seriously, Who does care about Murano these days? Is it even maintained?
14:48:02 <rosmaita> so they could just not update their glare nodes
14:48:09 <sigmavirus> They seem to have missed a lot of release deadlines this cycle
14:48:20 <sigmavirus> (And not released deliverables)
14:48:36 <hemanthm> Also, that's the risk of using anything marked EXPERIMENTAL I guess
14:48:40 <mfedosin> I mean they use standalone v0.1 service now and they must use v1 asap
14:48:52 <rosmaita> despite all that, i want to understand why removing glare from glance would break murano
14:49:01 <rosmaita> (because it could affect other users, too)
14:49:31 <nikhil> rosmaita: it's just that people use glance
14:49:40 <nikhil> Not glare yet
14:49:48 <mfedosin> because Murano uses Glare v0.1 service - which is the part of Glance repo now
14:50:17 <mfedosin> anyway, let's go back to our topic :)
14:50:27 <rosmaita> ok, we can sort this out on the ML, i guess
14:50:28 <mfedosin> Okay, I know as we all tired of this question.
14:50:29 <nikhil> We have the naming conventions confused in our heads
14:50:30 <sigmavirus> Ah, Murano is exploiting the fact that Glance is in most clouds so they can just surreptitiously start glare for the user
14:50:33 <hemanthm> If it's a serious concern, we should hear something on the ML as a response to Brian's note
14:50:38 <stevelle> more importantly, Glare v0.1 isn't in the glare repo?
14:50:53 <mfedosin> no, glare v0.1 not in Glare repo
14:50:57 <stevelle> welp
14:51:09 <sigmavirus> sucks to have relied on an experimental API
14:51:12 <sigmavirus> *shrug*
14:51:17 <rosmaita> yeah
14:51:23 <sigmavirus> so let's let mfedosin continue with his pitch :)
14:51:25 <mfedosin> But let us decide what to do with Glare next.
14:51:25 <stevelle> at least there is a full pike cycle to remedy
14:51:28 <rosmaita> ok, now i understand
14:51:36 <rosmaita> stevelle: ++
14:51:38 <sigmavirus> mfedosin: live and let live
14:51:41 <mfedosin> As you may know Glare is pretty stable and Nokia decided to use it in their product (CloudBand) for storing vnf and ns packages.
14:51:41 <nikhil> I think we should just call all that is in glance to be artifacts and not glare
14:52:04 <mfedosin> Currently I'm integrating all the stuff with their system.
14:52:15 <mfedosin> Ansible workbook and rpm spec is done, artifact type for them is almost done as well.
14:52:28 <mfedosin> Yesterday I updated all docstrings (as much as I could) and started imlementing the sharing of artifacts.
14:52:43 <mfedosin> So currently we have almost complete feature parity.
14:52:51 <mfedosin> And there is a question - why can't we develop Glare as a natural evolution of Glance under Glance tent as one community?
14:53:10 <mfedosin> For the smoothest transition ever I can prepare Image v2 API for Glare.
14:53:18 <mfedosin> As well as db migration script.
14:53:28 <mfedosin> So what objections (except religious) do you have?
14:53:38 <sigmavirus> mfedosin: my objections are not religious
14:53:40 <rosmaita> well, my key objection is:
14:53:46 <rosmaita> it's been tried before and failed
14:53:51 <nikhil> == sigmavirus
14:53:54 <rosmaita> from lack of glance and community support
14:54:07 <sigmavirus> My objections are purely practical. Only one employer in the entirety of Glance actually wants artifacts in Glance
14:54:08 <rosmaita> so, that's why i scheduled the meeting at the ptg
14:54:24 <mfedosin> Anyway we have to admit that many projects need this binary repository and they will be sad without it.
14:54:31 <sigmavirus> Unless there are drastically more resources provided for the work, no one on this team has the available bandwidth to make Glance becoem Glare
14:54:39 <rosmaita> we need to figure out what makes sense for the overall openstack ecosystem, as well as for openstack users
14:54:40 <nikhil> I like the idea and feel it should never have been cut out of Glance, but that's done and we should live with it now
14:54:42 <mfedosin> Also it's a good chance for Glance community to get at least one full-time developer from Nokia.
14:54:46 <sigmavirus> mfedosin: Good news! Glare exists and can be deployed today!
14:55:38 <sigmavirus> mfedosin: also, forgive my skepticism, but the last time Glance was promised developers from the sole employer interested in artifacts, it didn't actually help Glance, it only helped Glare
14:55:52 <rosmaita> well, let's see how the discussion goes at the PTG
14:56:00 <sigmavirus> And the developers were constantly shuffled around producing instability, confusion, and strife
14:56:02 <rosmaita> thanks for giving us a preview, mfedosin
14:56:12 <mfedosin> emm... kairat was a good developer :)
14:56:29 <mfedosin> and he helped Glance a lot
14:56:47 <mfedosin> yeah, let's discuss it personally in Atlanta
14:56:53 <mfedosin> but I got your point
14:56:54 <sigmavirus> mfedosin: you, Alex, Kairat are all *excellent* developers. That's not my objection
14:57:20 <rosmaita> ok, 2 minutes for
14:57:25 <rosmaita> #topic open discussion
14:57:49 <rosmaita> #action everyone read the glare-ectomy release note, i want to send to the ML asap
14:57:53 <sigmavirus> Just a head's up, I plan to respond to the following bug with Won't Fix but I need someone with more context to help explain why
14:57:55 <sigmavirus> #link https://bugs.launchpad.net/python-glanceclient/+bug/1665208
14:57:56 <openstack> Launchpad bug 1665208 in Glance Client "glance client needs to support multiple backends" [Undecided,New]
14:58:14 <sigmavirus> (The title is a bad one)
14:58:34 <hemanthm> rosmaita: and everyone read image import spec for PTG discussion?
14:58:46 <nikhil> Wow
14:58:48 <rosmaita> hemanthm: thank you, good reminder
14:58:51 <nikhil> Nasty bug
14:59:05 <nikhil> People are still stuck in that world
14:59:12 <rosmaita> i didn't realise there was a --store option
14:59:28 <nikhil> sigmavirus: let's create a FAQ out of that question
14:59:39 <rosmaita> ok,everyone, image import is really important becuase it will allow us to finally kill off v1
14:59:46 <rosmaita> (if you need some motivation)
14:59:52 <sigmavirus> nikhil: I've never done that before. Feel free to do so :)
15:00:00 <nikhil> Ack
15:00:14 <rosmaita> ok, out of time, see you next week everyone! and see you in irc the week after for everyone else
15:00:19 <sigmavirus> Later!
15:00:19 <stevelle> just to be clear, the operators are supposed to send the file to the storage system out of band, and add the location directly, considering RBAC, right?
15:00:40 <sigmavirus> stevelle: locations are the devil, so no
15:00:45 <rosmaita> #endmeeting