14:00:21 <rosmaita> #startmeeting glance
14:00:23 <openstack> Meeting started Thu Mar  2 14:00:21 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:26 <openstack> The meeting name has been set to 'glance'
14:00:27 <dharinic> \o
14:00:33 <rosmaita> #topic roll call
14:00:44 <sigmavirus> o/
14:00:45 <rosmaita> hello jokke_ , dharinic : you are too quick!
14:00:55 <alex_bash> \o
14:01:41 <rosmaita> sigmavirus: what was that command we were using for sub-topics? we haven't met for a week and i completely forgot
14:02:06 <sigmavirus> There is no command for subtopics =)
14:02:14 <sigmavirus> I just tend to do #topic Top-Level :: Sub-Level
14:02:15 <asettle> o/
14:02:23 <rosmaita> sigmavirus: we were using something to fake it, i thought
14:02:26 <sigmavirus> Kind of like C++ because who doesn't like C++?
14:02:27 <sigmavirus> =P
14:02:35 <sigmavirus> rosmaita: honestly, I've forgotten =/
14:02:36 <rosmaita> c++ ftw
14:02:44 <rosmaita> ok
14:02:47 <asettle> RST! \o/ :p
14:02:58 <rosmaita> asettle: thanks for attending!
14:03:01 <sigmavirus> asettle: ACK
14:03:04 <asettle> I'm just such an attender
14:03:17 <rosmaita> #topic updates
14:03:34 <rosmaita> #topic updates :: new spotlight links
14:03:41 <sigmavirus> asettle: YOU COULD HAVE BEEN A CONTENDER!
14:03:56 <rosmaita> ok, just want to point out the updated links on the etherpad
14:04:06 <rosmaita> got the openstack pike release schedule
14:04:17 <rosmaita> and the preliminary glance pike priorities and milestones:
14:04:25 <hemanthm> o/
14:04:26 <rosmaita> #link https://etherpad.openstack.org/p/glance-pike-ptg-roadmap-prelim
14:04:54 <rosmaita> also, the PTG glance schedule etherpad has links to all the etherpads we used at the PTG
14:05:28 <rosmaita> #link https://etherpad.openstack.org/p/glance-pike-ptg-schedule
14:05:51 <rosmaita> please check out the proposed dates and provide any comments, etc.
14:06:12 <rosmaita> key thing are the spec proposal freeze and spec freeze for pike
14:06:41 <rosmaita> #link https://review.openstack.org/#/c/440561/
14:06:58 <nikhil> o/
14:07:03 <rosmaita> that patch also has the proposed weeks for the virtual midcycle and operators midcycle
14:07:23 <rosmaita> nikhil has volunteered to organized the operators virtual midcycle for glance
14:07:26 <rosmaita> :)
14:07:34 <asettle> Lucky nikhil
14:07:55 <rosmaita> #topic updates :: ocata postmortem
14:08:14 <nikhil> Lol
14:08:15 <stevelle> its dead, jim
14:08:16 <rosmaita> we took a few minutes at the PTG to do a quick postmortem of the ocata cycle
14:08:33 <jroll> stevelle: don't drag me into this :D
14:08:34 <rosmaita> i'd like to open it up to people who couldn't attend
14:08:57 <rosmaita> jroll: i never think of you as "jim", just as "jroll"
14:09:00 <jcook> :D
14:09:09 <rosmaita> #link https://etherpad.openstack.org/p/glance-pike-ptg-ocata-postmortem
14:09:10 <jroll> :P
14:09:25 <rosmaita> anyway, there's the link ... please add any comments suggestions etc you may have
14:09:28 <asettle> rosmaita: that's because his name isn't 'jim' obvs. It's jroll on the birth certificate
14:09:33 <asettle> Just the same way sigmavirus is *not* Ian
14:09:55 <jcook> would have like to have gotten further on Rolling Upgrades, but I'm glad we landed what we did
14:10:19 <rosmaita> jcook: good point, please add to etherpad
14:10:38 <sigmavirus> asettle: who's this "Ian"?
14:11:08 <rosmaita> Dury?
14:11:22 <rosmaita> but we digress
14:11:52 <rosmaita> anyway, your feedback is welcome, particularly if you have suggestions that would make pike smoother
14:12:14 <rosmaita> i think stevelle already suggested "don't make any backward incompatible api changes"
14:12:47 <rosmaita> #topic updates :: image import virtual meetup
14:13:12 <rosmaita> i'll send out a doodle poll later today to get a time, but I'm thinking of wednesday
14:13:38 <rosmaita> point of the meetup is to go over the spec update which i will hopefully have posted on monday
14:13:41 <stevelle> :D
14:13:51 <rosmaita> and to parcel out work items and discuss open questions
14:14:26 <rosmaita> as far as communication medium ... jokke_ you still have bluejeans access?
14:14:31 <nikhil> Doodle please
14:14:33 <jokke_> yup
14:15:06 <rosmaita> bluejeans seems to have worked out the best, any objections (in the form of a suggestion of something better)?
14:15:55 <stevelle> no idea, never used it
14:16:15 <stevelle> cant be worse than carrier pigeon
14:16:23 <rosmaita> well, it
14:16:28 <rosmaita> s better than webex
14:16:34 <sigmavirus> lol
14:16:43 <sigmavirus> bluejeans does work well but we need someone like jokke_ or flaper87 to host it
14:16:48 <sigmavirus> (typically flaper87 has hosted it)
14:17:00 <rosmaita> jokke_ handled it last time, i think
14:17:44 <rosmaita> ok, sounds like bluejeans or carrier pigeon
14:18:18 <rosmaita> jokke_: i'll send a doodle poll about time to the ML, can you set up bluejeans access once we have a datetime?
14:18:56 <sigmavirus> +1 to carrier pigeon
14:19:08 * jcook uses bluejeans for grad school office hours and it works well.
14:19:17 <jokke_> rosmaita: sure
14:19:26 <rosmaita> ok, thanks
14:19:43 <sigmavirus> http://conferencecall.biz/ might work too
14:19:49 <rosmaita> people who prefer carrier pigeon have to fed ex their pigeons to blacksburg, virginia, before wednesday
14:20:09 <sigmavirus> asettle: might prefer we communicate via owls
14:20:22 <jcook> from what I can tell bluejeans is a lot like hangouts and you really just need a link
14:20:25 <asettle> I'm more of a pigeon lady, myself
14:20:29 <asettle> Owls seems nice
14:20:35 * asettle comes in with the important comments
14:20:45 <jcook> lol
14:20:55 <sigmavirus> asettle: what house are you in?
14:20:56 <rosmaita> i think some owls at least will attack pigeons
14:21:05 <rosmaita> so we can't mix communication media here
14:21:09 <jcook> inb4 ravenclaw
14:21:10 <rosmaita> or there will be bad results
14:21:13 <asettle> sigmavirus: you're clearly referring to HP and it is very obvious that I am a Hufflepuff.
14:21:25 <sigmavirus> =D
14:21:29 <jcook> :D
14:21:57 <asettle> So, perhaps we communicate using Badger?
14:22:00 * asettle is a thinker
14:22:01 <rosmaita> #action everyone look for doodle poll in the ML today and respond quickly
14:22:15 <rosmaita> #topic looking for owners
14:22:19 * sigmavirus would propose that everyone learn their house today and include it in the doodle
14:22:22 <asettle> Wow that's a vague topic.
14:22:40 <sigmavirus> rosmaita: I think asettle just owned you
14:22:41 <rosmaita> we've got some pike items that need people to shepherd them
14:22:48 <rosmaita> or whatever you do with pigeons
14:22:55 * rosmaita is ignoring the peanut gallery
14:23:01 <asettle> rosmaita: probably smart :P
14:23:04 <stevelle> I own a hungry cat
14:23:33 <rosmaita> #topic owner needed :: remove 'show_multiple_locations'
14:23:41 <rosmaita> this one is going to require a spec
14:23:58 * nikhil feels like watching the Tarzan movie now
14:24:19 <rosmaita> removal will be slightly complicated, and there will be argument over the proper default value for the policies
14:24:34 <rosmaita> (I favor "!", others favor "role:admin")
14:24:56 <rosmaita> to get an idea of what's up, here are some things to look at:
14:24:58 <sigmavirus> rosmaita: if I could just rm show_multiple_locations I would
14:25:10 <rosmaita> #link http://git.openstack.org/cgit/openstack/glance/tree/releasenotes/notes/deprecate-show-multiple-location-9890a1e961def2f6.yaml
14:25:12 <nikhil> I will take that item
14:25:20 <rosmaita> #link http://git.openstack.org/cgit/openstack/glance/tree/releasenotes/notes/update-show_multiple_locations-helptext-7fa692642b6b6d52.yaml
14:25:24 <rosmaita> sold!
14:25:40 <rosmaita> that was easy
14:25:46 <rosmaita> ok, next item
14:26:01 <rosmaita> #topic owner needed :: removing deprecated options
14:26:22 <rosmaita> there are several deprecated options who've passed their "remove by" date
14:26:39 <rosmaita> it would be nice if someone could gather them on an etherpad
14:26:52 <alex_bash> these topics are sweet music to my ears
14:26:53 <nikhil> And I've wip review that someone can pick up if they want
14:27:09 <rosmaita> i think most of them are simpler than the show_mult_locations and can be handled by bugs
14:27:34 <rosmaita> but it would be good to see what they all are first so we can check them off
14:27:43 <hemanthm> I can help
14:27:52 <rosmaita> sold!
14:28:00 <rosmaita> i forgot to "action" nikhil
14:28:11 <nikhil> It's fine
14:28:21 <rosmaita> #action nikhil to handle show_multiple_locations option removal
14:28:24 <hemanthm> no one can action nikhil
14:28:33 <nikhil> It is to important for me to forget
14:28:38 <nikhil> Lol
14:28:44 <rosmaita> #action hemanthm to put together list of deprecated options for removal
14:28:50 <rosmaita> ok, next one
14:28:59 <alex_bash> Chuck Norris could action nikhil
14:29:14 <rosmaita> #topic owner needed :: remove usage of deprecated options
14:29:17 <hemanthm> so, rosmaita is Chunk Norris
14:29:29 <nikhil> :P
14:29:36 * asettle comes back to the convo
14:29:40 <asettle> Well that escalated quickly
14:29:40 <rosmaita> in the macho sense, yes; in the political sense, no
14:29:49 <stevelle> but is Chuck Norris deprecated?
14:29:55 <rosmaita> should be
14:30:00 <jokke_> stevelle: you can try :P
14:30:00 <stevelle> +1
14:30:11 <asettle> sigmavirus or stevelle plz print plaque for next summit that says " rosmaita is chuck norris in the macho sense, not hte political sense"
14:30:38 <rosmaita> i think i need to run this meeting more like chuck norris
14:30:40 <sigmavirus> asettle: as if You Know Who would send me to the summit
14:30:52 <asettle> sigmavirus: *gasp* Voldy is back working for Backspace?
14:31:06 <asettle> I could sense it.
14:31:07 <sigmavirus> =D
14:31:12 <sigmavirus> asettle: did your forehead tingle?
14:31:26 <asettle> sigmavirus: it was actually my upper arm, I have that different from HP
14:31:38 <stevelle> was there more work to pass out?
14:31:38 <sigmavirus> oh totes
14:31:48 <asettle> stevelle: yes, plaque plz
14:32:07 <rosmaita> so we need a new defense against the dark arts instructor
14:32:19 <asettle> *raises hand*
14:32:20 <asettle> Oh oh oh oh oh
14:32:21 <sigmavirus> lmao
14:32:22 <stevelle> last one was eaten by a grue
14:32:22 <rosmaita> to take on the task of seeing what stuff we're consuming the deprecated options of
14:32:25 <asettle> I vote nikhil
14:32:28 <rosmaita> and stop consuming them
14:33:02 * rosmaita pauses to wait for volunteers
14:33:13 <sigmavirus> I think asettle voluntold nikhil, didn't she?
14:33:16 <asettle> Sure did.
14:33:30 <nikhil> I vote Mike
14:33:40 <asettle> Ohhhh I see what you did there nikhil
14:33:43 <stevelle> sorry thought that cleaning up was same task as collecting the things to clean up
14:33:59 <hemanthm> stevelle ++
14:34:23 <hemanthm> so, I'll do it as a part of my previous todo
14:34:38 <nikhil> Well you just need to go visit different projects using them
14:34:47 <nikhil> For cleanup I mean
14:34:50 <asettle> hemanthm is the new Defense Against the Dark Arts teacher! \o/
14:35:06 <rosmaita> let's hope he lasts longer than the last one
14:35:20 * hemanthm should know better
14:35:26 <rosmaita> ok, that's all i got
14:35:41 <rosmaita> #topic Automating the current release name in glance code for making maitenance a long term viable reality
14:35:49 <rosmaita> this is nikhil
14:35:49 * hemanthm hides
14:36:07 <nikhil> Well pretty much what the review says
14:36:27 <nikhil> I just need ideas to see how we can do such things
14:37:21 * nikhil waits for ideas
14:37:26 <rosmaita> one suggestion is a checklist of stuff that must be done when a stable branch is cut
14:37:30 <rosmaita> which reminds me
14:37:39 <stevelle> I feel like having it in setup.cfg would be good enough
14:37:55 <hemanthm> +1
14:38:02 <rosmaita> i think sigmavirus was working on a release checklist or something like that
14:38:08 <sigmavirus> IsI am
14:38:12 <nikhil> I was thinking of the same thing stevelle
14:38:13 <sigmavirus> *I am
14:38:57 <hemanthm> either way, we'd still have to maintain it manually
14:38:57 <nikhil> stevelle: but you probably know better if that confuses downstream
14:39:25 <rosmaita> hemanthm is correct, i think
14:39:38 <rosmaita> but i guess the advantage is that it's in a more obvious place?
14:39:41 <nikhil> hemanthm: I think we can request it part of release automation
14:40:05 <hemanthm> nikhil: yeah, kinda where I was headed as well
14:40:39 <nikhil> Typically when release is cut we get that flag and set it
14:41:08 <nikhil> But today only signs are in git commit messages
14:42:23 <rosmaita> so the problem i see is that master doesn't get a name until a stable branch has been cut
14:42:32 <rosmaita> and master is where we need the correct name
14:42:43 <nikhil> Yup
14:43:52 <hemanthm> I don't know enough about release automation, are there any post-release automation that is done currently?
14:43:58 <dharinic> neutron maintains a release checklisr for few things that needs to be done manually when a stable branch is to be cut.
14:44:26 <rosmaita> dharinic: ++ , i think we need that even independently of how we fix this
14:45:01 <rosmaita> sigmavirus: do you have any ideas?
14:45:23 <nikhil> Well I think that is opposite of where we want to go
14:45:29 <rosmaita> we could always mention dhellmann and see what happens
14:45:38 <sigmavirus> hemanthm: nikhil so there is automation around updating upper-constraints, .gitreview, and a few other things
14:45:51 <sigmavirus> rosmaita: ttx is the release PTL now :)
14:46:06 <sigmavirus> I think having extra steps that we carry out manually works well too
14:46:06 <rosmaita> but those are into the stable branch
14:46:14 <nikhil> We were trying to get rid of configs in tree so that release is not blocked on such manual updates
14:46:16 <rosmaita> we need this to happen in master
14:46:40 <sigmavirus> ah I see
14:46:44 <alex_bash> maybe we can add a gate job for this
14:46:47 <nikhil> It would be a horrendous experience for waiting on a zillion patches to cut release
14:47:05 <sigmavirus> nikhil: currently we don't wait on those patches
14:47:12 <sigmavirus> I'm not sure what you're expecting to be the problem
14:47:31 <sigmavirus> alex_bash: the gate job would run every time we merge to a branch. How would that help?
14:47:45 <alex_bash> first patch to merge to master on new release will have to manually update it
14:47:46 <nikhil> sigmavirus: we need to refresh configs in tree before cutting a branch
14:47:46 <sigmavirus> So what is the core of the problem? Our config files have the wrong name?
14:48:01 <alex_bash> all subsequent patches would pass
14:48:10 <hemanthm> https://github.com/openstack/glance/blob/master/glance/db/migration.py#L50
14:48:13 <hemanthm> sigmavirus: ^
14:48:17 <sigmavirus> nikhil: so that's 1 patch to wait on before creating a release?
14:48:20 <rosmaita> i dont't think any file currently has the name we need
14:48:46 <nikhil> sigmavirus: ha, I don't think so
14:48:50 <sigmavirus> so what hemanthm linked can be pulled out of a setup.cfg if we watned it to be
14:49:12 <hemanthm> yeah and I don't know why cutting a branch should get delayed
14:49:34 <sigmavirus> hemanthm: right, we'd update setup.cfg after a branch has been released
14:49:36 <nikhil> it should not be
14:49:38 <nikhil> but it can be
14:49:39 <sigmavirus> current_release would be set at the start of the cycle and then we'd be done until the next
14:49:39 <rosmaita> yeah, the new stable branch will already have the corect name
14:49:39 <hemanthm> when cutting the branch that label should have already been updated
14:49:59 <sigmavirus> I think we're conflating a lot of things
14:50:09 <rosmaita> sigmavirus: ++
14:50:11 <hemanthm> +1
14:50:16 <nikhil> I am quite clear on the problem
14:50:18 <sigmavirus> I think what you're saying is that you want to have automation that hooks into the release automation when we create a release
14:50:28 <sigmavirus> That's the basis of everything, yes?
14:50:38 <nikhil> for this issue, may be that's the answer
14:50:40 <sigmavirus> Kind of like we have tools/test-setup.sh that will run for our gate jobs
14:51:05 <sigmavirus> nikhil: if you're clear on the issue, I'm not getting a cohesive picture of it from everyoen else
14:51:25 <nikhil> sigmavirus: alright, let me be explicit
14:52:00 <nikhil> this is the review :-
14:52:04 <nikhil> #link https://review.openstack.org/#/c/438736/
14:52:30 <stevelle> I think automating something that happens 2x per year is a digression derailing the meeting at this point
14:52:32 <nikhil> it has the var CURRENT_RELEASE hardcoded to the current release name
14:52:48 <rosmaita> stevelle: good point
14:52:55 <rosmaita> let's go with the checklist approach for now
14:53:00 <nikhil> so you are saying we are not discussing important stuff
14:53:14 <rosmaita> we're saying that we're not having open discussion
14:53:18 * nikhil leaves the meeting
14:53:30 <rosmaita> #topic open discussion
14:54:11 <rosmaita> (i got feedback that i should make sure we have open discussion time at each meeting)
14:54:27 <rosmaita> (and whenever i do ... there's usually no discussion)
14:55:24 <jokke_> :)
14:55:24 <jcook> hi
14:55:28 <jcook> :)
14:55:46 <sigmavirus> ^5 for everyone
14:55:47 <rosmaita> we need to get the previous topic settled before August 7
14:56:04 <jcook> I have a question
14:56:32 <jcook> Does anyone know of a deployment that builds thousands of concurrent VMs off an uncached image?
14:56:47 <jcook> besides Rackspace Public Cloud users?
14:57:23 <jcook> I'm assuming cern might if not cached on hypervisor or precached in glance, but I hear they are tiny.
14:57:58 <rosmaita> yes, they tend to be something like 256MB
14:58:17 <jcook> I think you could have stampeding heard with that size
14:58:21 <jcook> herd*
14:58:24 <jokke_> and answer to your question, no I would not know anyone else
14:58:35 <jcook> but maybe not with their scale, or they cache, or cache completes quickly enough
14:58:51 <rosmaita> jcook: well, cern uses lots of clouds that aren't theirs
14:59:00 <jcook> ah
14:59:01 <rosmaita> they get time donated by various clouds
14:59:21 <rosmaita> so it could be a general problem, give all the clouds they use
14:59:26 <jcook> I wonder if they fail a lot of builds and jsut retry or no
14:59:30 <rosmaita> but i haven't heard anyone mention it as a problem
14:59:34 <jcook> k
15:00:11 <rosmaita> ok, we're about out of time ... look for a doodle poll about image import mtg next week
15:00:17 <rosmaita> #endmeeting