14:00:02 <rosmaita> #startmeeting glance
14:00:02 <openstack> Meeting started Thu Mar  9 14:00:02 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:05 <openstack> The meeting name has been set to 'glance'
14:00:07 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:17 <rosmaita> (that's the agenda)
14:00:23 <rosmaita> #topic roll call
14:00:51 <dharinic> \o
14:01:42 <rosmaita> light turnout, i know jokke_ is around somewhere, though
14:01:55 <rosmaita> sigmavirus has a conflict this morning
14:02:46 <hemanthm> o/
14:02:55 <rosmaita> i decided to take some advice from stevelle and timebox the agenda more clearly
14:02:58 <alex_bash> o/
14:03:10 <rosmaita> i think we've got 35 min of stuff if i don't talk too much
14:03:19 <rosmaita> so i'll wait 2 more min to see who else arrives
14:03:40 <stevelle> so if things run over, we should have time
14:03:45 <stevelle> and know how much
14:05:00 <rosmaita> ok, let's get started ... agenda link for anyone who missed it earlier: https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:05:18 <rosmaita> #topic updates - dates to keep in mind
14:05:27 <jokke_> o/
14:05:28 <rosmaita> #link https://etherpad.openstack.org/p/glance-pike-ptg-roadmap-prelim
14:05:41 <rosmaita> you can look at the dates there, i wont' paste here
14:05:51 <rosmaita> key things are spec proposal freeze in 2 weeks
14:05:57 <rosmaita> spec freeze 2 weeks later
14:06:12 <rosmaita> virtual midcycle - no exact date yet, just a week
14:06:27 <rosmaita> virtual operators' midcycle - no exact date yet, just a week
14:06:46 <rosmaita> #topic updates - docs
14:07:09 <rosmaita> asettle , the docs PTL is working with us to reorganize the glance docs
14:07:20 * asettle enters with a dramatic flourish
14:07:21 <asettle> You rang?
14:07:24 <rosmaita> #link https://etherpad.openstack.org/p/glance-pike-ptg-docs
14:07:32 <jokke_> \\o \o/ o// o/7
14:07:35 <asettle> hey!
14:07:41 <asettle> So, as per my email last week - we need to split up the work
14:07:58 <asettle> Each that volunteered - me, jokke_ alex_bash stevelle and rosmaita - we should split up the lifting
14:08:10 <asettle> Someone take admin, dev ref, etc etc
14:08:12 <jokke_> Noo, there's that much of it? :o
14:08:15 <asettle> Who can volunteer for what?
14:08:23 <asettle> jokke_: it's just to split it up and make it go a bit faster :)
14:09:03 <rosmaita> before we do that, i have some questions about the admin guide, operations guide, etc
14:09:12 <asettle> Shoot :)
14:09:24 <rosmaita> my key question is who maintains those, and where they exist?
14:09:32 <asettle> ... oh
14:09:43 <asettle> https://github.com/openstack/openstack-manuals/tree/master/doc
14:09:44 <asettle> We do :)
14:09:47 <rosmaita> and where are they published to, he said ungrammatically
14:09:53 <asettle> https://docs.openstack.org/
14:09:54 <asettle> Here :)
14:10:07 <asettle> End User Guide - user guide, ADministration Guide (admin guide) Operations Guide (ops guide)
14:10:15 <asettle> The docs team looks after this page and everything attached to it
14:10:33 <rosmaita> ok, that's good
14:10:35 <asettle> I apologise, when I was referencing all this content in our session I thought we were on the same page
14:10:39 <asettle> Now, with that
14:10:59 <asettle> I don't want a 'dump and run' on behalf of the glance team. The CPL ( alex_bash ) will be in charge of ensuring this content is maintained.
14:11:04 <jokke_> asettle: I think rosmaita was just asleep ... we discussed that there ;)
14:11:27 <rosmaita> yes, but i want it written down
14:11:31 <asettle> Keep in mind though, I think you should keep content related to the ADministration Guide in-tree. As you may or may not know, we'll be doing a project-specific admin guide soon
14:11:44 <stevelle> What is the essential difference between Admin / Ops guides? That drives decisions of what goes where.
14:11:47 <asettle> rosmaita: the openstack-manuals project has always been around, I'm not too sure what you're asking me to write down?
14:12:14 <rosmaita> asettle: i am a very simple person, i need the info i outlined on the etherpad
14:12:19 <asettle> stevelle: yes, so that's an excellent question and one we're trying to address. At the moment, the admin guide is about the 'operational tasks' whereas the operations guide details 'designing and creating' your cloud
14:12:28 <rosmaita> where the stuff is stored, where it's published, what the audience is
14:12:42 <rosmaita> we don't see the stuff that's not in our repo
14:12:52 <rosmaita> so it's not obvious where there is overlap
14:12:57 <rosmaita> which is what we would like to eliminate
14:13:01 <asettle> No problem :)
14:13:08 <asettle> I'll have it all detailed when I get a spare mo
14:13:23 <rosmaita> thanks, not trying to rush you
14:13:36 <asettle> No not at all :) we're just a bit all hands on deck with some nova stuff today (ughhhh)
14:13:39 <stevelle> rosmaita: we need to fix our dashboard. I made a query to find glance related docs changes we can work into our dash btw
14:13:55 <stevelle> we can follow that item up later
14:14:00 <rosmaita> great
14:14:31 <rosmaita> ok, so action items are:
14:14:50 <rosmaita> #action asettle will update etherpad with some descriptive info about what the docs team maintains
14:15:05 <asettle> *nods* got it :)
14:15:20 <rosmaita> #everyone look at the etherpad to see how our docs are being reorganized (or proposed to be re-orged)
14:15:30 <rosmaita> ok, one more docs topic
14:15:33 <rosmaita> the man pages
14:15:45 <rosmaita> some distros (ubuntu) package them
14:15:53 <rosmaita> but they have tended to languish
14:16:00 <asettle> Which is interesting
14:16:15 <rosmaita> key problem is that the --help from the tools (like glance-manage) and hte man pages aren't quite in sync
14:16:41 <jokke_> do we have bug opened for that?
14:16:41 <rosmaita> also, updating for general stuff like what release is out of date too
14:16:59 <rosmaita> no bug open yet
14:17:10 <rosmaita> there's a patch to update the man pages
14:17:15 <alex_bash> there would have to be many bugs
14:17:31 <rosmaita> i am thinking maybe a spec-lite to propose a longer term solution?
14:17:41 <asettle> Question - maybe a silly question - why do the distros use your man pages to package? It doesn't appear that way in other projects.
14:17:57 <rosmaita> well, nova has man pages
14:18:04 <rosmaita> so there
14:18:05 <jokke_> asettle: because we and they are special :D
14:18:15 <rosmaita> but seriously, if we don't provide them, who will?
14:18:19 <asettle> hahahha did you just 'so there' me rosmaita ?!
14:18:25 <rosmaita> :)
14:18:34 <asettle> THat doesn't explain anything! It's a genuine question. I don't know why they do that tbh
14:18:46 <rosmaita> we can ask the packagers
14:18:52 <rosmaita> i actually emailed some people
14:18:56 <asettle> If it comes along the way, that'd be rad to know tbh
14:19:21 <rosmaita> the RDO group says that they hate the man pages, were not sorry that you deleted them
14:19:27 <rosmaita> they prefer the --help text
14:19:39 <asettle> Well, that's what I would have thought
14:19:43 <rosmaita> but, looking at the man pages, they do contain some contextual info that's missing from--help
14:19:45 <asettle> (using the help text, that is)
14:19:49 <asettle> WHy is it mising?
14:19:53 <asettle> missing* SHould you not be adding it in?
14:19:59 <asettle> (If htat's a thing)
14:20:01 <rosmaita> well, that's an interesting question
14:20:21 <rosmaita> it is not a simple thing to do given the way the tools are configured ATM
14:20:22 * stevelle whispers "one source of truth"
14:20:24 <asettle> I mean, if the issue is that the man pages contain information that the help text doesn't, isn't htat a gap you should fix rather than providing two sets of help information?
14:20:30 * asettle is on board with stevelle rn
14:20:58 <asettle> rosmaita: should that not be a greater long term bug/fix rather than trying to find another way around it?
14:20:59 <stevelle> I like that answer but hold the opinion lightly right now
14:21:07 <jokke_> asettle: so before everything turned to wannabe Windows PowerShell the documentation and specially the manpages were used to document the behavior of the software and delivered with the software itself so it was available for those who were operating systems without access to online docs and search engines. I guess we're just old-fashioned
14:21:18 <asettle> Ahhhh!
14:21:22 <asettle> ^^ that's what i Was looking for :)
14:21:36 <asettle> It's interesting, no criticisms, promise. Just interested as to why things are they way they are
14:21:53 <rosmaita> so here's what i'm wondering
14:22:11 <rosmaita> man pages can give you some context about why you would use a tool and maybe some stuff to be aware of
14:22:21 <rosmaita> like the implications of using db purge
14:22:29 <rosmaita> whereas, --help maybe not
14:22:55 * jokke_ also absolutely hates those 7 screen long --help outputs
14:22:55 <rosmaita> what i'd like to see is to somehow fill in the man pages with --help text
14:23:05 <rosmaita> i agree, too much --help sucks
14:23:11 <asettle> ^^ that I could agree with too
14:23:16 <rosmaita> but we do want the single source of truth
14:23:48 <stevelle> how about a man page that contains a url? (devils' advocate)
14:23:49 <rosmaita> ok, we will return to this later when i ask if anyone wants to investigate this for a decent solution
14:24:05 <rosmaita> url to ... ?
14:24:16 <stevelle> html docs that contain more context
14:24:21 <jokke_> stevelle: sure as long as that uri is file://<path-to-local-docs> :P
14:24:36 <rosmaita> ok, we'll talk more about this later
14:24:41 <jokke_> ;)
14:24:45 <rosmaita> #topic march operators' survey
14:25:08 <rosmaita> i've got 2 surveys set up, need feedback on the questions and advice on whihc one to do in march, whihc in april
14:25:17 <rosmaita> #link https://etherpad.openstack.org/p/glance-cache-operator-survey
14:25:33 <rosmaita> i re-used the etherpad, it actually contains 2 surveys
14:26:04 <rosmaita> the topics are owner_is_tenant=False, who does it, and glance-cache, who uses it
14:26:15 <stevelle> what's the deadline for the march survey?
14:26:26 <rosmaita> i'd like to send the survey out next week, so please look them over
14:26:42 <rosmaita> probably one week after i announce it on the operators' list
14:27:02 <rosmaita> this is our glance-specific surevey, so we cna do whatever we want
14:27:18 <rosmaita> i am interested in owner_is_tenant ATM, but that's just me
14:27:34 <rosmaita> so
14:27:49 <rosmaita> #action everyone feedback on https://etherpad.openstack.org/p/glance-cache-operator-survey
14:28:18 <rosmaita> any questions? (i boxed this for 5 min figuring the previous topic might run over)
14:28:52 <rosmaita> ok, moving along
14:29:02 <rosmaita> #topic "owned" topics reports
14:29:23 <rosmaita> last week i asked for volunteers to take on specific tasks to make sure they don't fall through the cracks
14:29:56 <rosmaita> i'd like to check in, see what people have been up to, and who may need to get some help/someone else to pick up the topic
14:30:14 <rosmaita> first up is sigmavirus who is not here
14:30:34 <rosmaita> he's got a draft of his release czar process and advice that i've seen
14:30:48 <rosmaita> i guess he'll be putting it up as a patch soon, to live somewhere in the dev docs
14:31:12 <rosmaita> #topic owned - show_multiple_locations
14:31:32 <rosmaita> nikhil was going to work on a spec for this, didn't see him around this morning, though
14:31:55 <rosmaita> spec proposal deadline is 2 weeks away, so i'm not worried yet
14:32:12 <rosmaita> #topic owned - dev docs for E-M-C db migrations
14:32:21 <rosmaita> hemanthm is working on this one
14:32:27 <hemanthm> should have a patch up in a bit
14:32:32 <rosmaita> excellent
14:32:34 <jokke_> gr8
14:32:57 <rosmaita> #topic owned - list of glance deprecated options
14:33:10 <rosmaita> hemanthm was working on this, but i think someone else should take it
14:33:46 <dharinic> I can help hemanthm.
14:33:54 <rosmaita> sold!
14:34:16 <hemanthm> thanks dharinic
14:34:20 <rosmaita> question: the next topic was the deprecated options glance is consuming
14:34:37 <rosmaita> i guess we decided to combine the two lists?
14:34:45 <hemanthm> yes
14:34:51 <rosmaita> ok
14:35:17 <rosmaita> #topic owned - image import backend
14:35:31 <rosmaita> this one is jokke_ , who just put up a bunch of patches before the meeting
14:36:01 <rosmaita> jokke_: any requests, other than that people look over the patches ?
14:36:22 <jokke_> would be great to get some comments as well
14:36:39 <rosmaita> sorry, i meant "look over" in the sense of "review"!
14:36:59 <rosmaita> #everyone review jokke's image import patches
14:37:05 <rosmaita> i'll put a list in the weekly emial
14:37:07 <rosmaita> *email
14:37:16 <jokke_> any ideas how to improve those, but lets keep in mind this is really the MVP ... lets get those merged as soon as they "work" and we have common agreement that the approach is by the spec
14:37:27 <jokke_> and iterate from that
14:37:43 <rosmaita> sounds good
14:37:43 <jokke_> otherwise the patches will just keep existing in my local
14:37:57 <rosmaita> and nobody wants that!
14:38:04 <jokke_> indeed
14:38:17 <jokke_> also that dependency chain is nightmare to maintain and rebase
14:38:55 <stevelle> they always are
14:39:13 <rosmaita> ok, next topic
14:39:20 <rosmaita> #topic Boston "Forum" planning
14:39:38 <rosmaita> i know we just finished the PTG, but it's Boston summit planning time
14:39:51 <stevelle> foundation missed an opportunity by not having this premier in Rome
14:39:53 <rosmaita> actually, we devs will be at the "Forum"
14:40:01 <rosmaita> stevelle: ++
14:40:23 * jokke_ has no idea yet if I will be there or not
14:40:31 <stevelle> the deadline is already passed for talk submittions
14:40:33 <rosmaita> anyway, the info about the forum, what it is, and what facilities are available is here:
14:40:44 <rosmaita> #link https://etherpad.openstack.org/p/BOS-Glance-brainstorming
14:41:00 <rosmaita> so, what's weird, is that while the summit talk submissions has closed
14:41:04 <rosmaita> the forum has not
14:41:20 <rosmaita> and the TC is asking the community to propose stuff from which they will select
14:41:29 <rosmaita> with the proposals being on etherpad, i think
14:41:41 <rosmaita> you can read the details, i put links on the etherpad linked above
14:42:28 <rosmaita> anyway, i don't know if i've got travel support to go yet either
14:42:46 <rosmaita> but, don't let not going interfere with proposing some exciting topics!
14:43:20 <rosmaita> ok, that's all i had there
14:43:41 <rosmaita> i should take a quick poll, though ... how many people here understand what the "Forum" is?
14:43:53 <jokke_> _o_
14:44:12 <stevelle> I think I do, but probably not the sanctioned answer
14:44:31 <rosmaita> yeah, not sure what i meant to ask there
14:44:31 * hemanthm raises hand half-way
14:44:39 <rosmaita> i guess my question is:
14:44:58 <rosmaita> if you had travel support, would you attend the Boston Forum?
14:45:07 * rosmaita not sure
14:45:32 <rosmaita> (though i guess i'm supposed to, to gather all the feedback from operators and users)
14:45:33 <jokke_> What is Boston Forum
14:45:36 * stevelle leaning no
14:45:58 <alex_bash> forum != summit?
14:45:59 <jokke_> s/Forum/Forum?/
14:46:04 <rosmaita> jokke_: this explains it a bit: http://lists.openstack.org/pipermail/openstack-dev/2017-March/113115.html
14:46:06 <stevelle> https://www.openstack.org/summit/boston-2017/ over May 8-11, 2017 btw
14:46:10 <rosmaita> it's a part of the summit
14:46:11 <hemanthm> alex_bash: that's the new name after PTG split
14:46:29 <rosmaita> supposed to be non-marketing, allow for feedback to dev teams from ops and users
14:46:40 <dharinic> So Forum is more like a dev meeting thing?
14:46:58 <rosmaita> like the ptg but with more listening and less design planning
14:47:04 <rosmaita> (i think)
14:47:06 <hemanthm> dev-dev is PTG
14:47:09 <dharinic> ahh, cool.
14:47:13 <hemanthm> dev-ops/users is Forum
14:47:36 <rosmaita> hemanthm: that's a good one-line description
14:47:42 <stevelle> forum is one of the tracks at summit
14:47:50 <jokke_> yes, I'd likely be there if I get travels arranged
14:47:54 <stevelle> the way I understand it at least
14:48:10 <hemanthm> stevelle: yeah, possibly. I could be wrong
14:48:22 <rosmaita> stevelle: my impression was that it's a special thing, not a track
14:48:25 <rosmaita> but i could be wrong, too
14:48:35 <stevelle> https://www.openstack.org/summit/boston-2017/summit-categories/ there we go
14:48:40 <stevelle> it's listed on there
14:49:40 <rosmaita> yep, looks like you're right
14:49:46 <hemanthm> alex_bash: forget what I said earlier :)
14:50:22 <rosmaita> hemanthm: i think you're right, it's a summit track for dev-ops/users
14:50:33 <stevelle> part of the summit is probably most accurate, track can mean something else
14:50:36 <dharinic> there is a category for developers seperately too.
14:50:47 <rosmaita> just that being held concurrently with everything else ... who knows how it will work?
14:50:49 <stevelle> those are cloud consumers in this case dharinic
14:50:53 <dharinic> oops thats for cloud apps
14:51:00 <rosmaita> anyway, back on topic ...
14:51:18 <rosmaita> please add stuff to the etherpad so that we've got something to propose
14:51:35 <rosmaita> #link https://etherpad.openstack.org/p/BOS-Glance-brainstorming
14:51:47 <rosmaita> and it looks like if have mis-esstimated time
14:52:02 <rosmaita> i wlll postpone looking for new owners to next week
14:52:08 <rosmaita> #topic open discussion
14:52:23 <rosmaita> stevelle: had a suggestion about dashboards?
14:53:11 <stevelle> the glance dashboard should probably include a slice of openstack-manuals related to glance
14:53:54 <stevelle> I cooked up a query for it last friday I think, I can dig that back out but I would like to see the dashboard folks use updated to include awareness of docs
14:54:51 <stevelle> any thoughts?
14:54:55 <rosmaita> stevelle: you mean this dashboard: http://gerrit-dash-creator.readthedocs.io/en/latest/dashboards/dashboard_glance.html
14:55:18 <stevelle> rosmaita: pretty sure that's the one, yes
14:55:35 <jokke_> wasn't that Flavio's gift for us?
14:55:55 <rosmaita> yes, and i for one have been un-good about using it
14:56:09 <stevelle> it's the second link in my browser toolbar
14:56:25 <stevelle> do folks have custom ones?
14:57:12 <rosmaita> (while we're looking, could someone please take care of https://review.openstack.org/#/c/420038/ ?)
14:57:56 <alex_bash> where do these come from: https://review.openstack.org/#/admin/projects/openstack/glance,dashboards ?
14:58:02 <rosmaita> my thought is that i agree with stevelle that it would be good to get the docs we are supposed to keep an eye on into this dashboard
14:58:37 <rosmaita> alex_bash: i don't know
14:59:08 <hemanthm> +1
14:59:20 <rosmaita> ok, we are almost out of time ... the ocata postmortem had a split result on whether the priorities emails are worth doing, i will break the tie and continue them
14:59:30 <rosmaita> 30 sec ...
14:59:56 <rosmaita> ok, thanks everyone!
15:00:01 <rosmaita> #endmeeting