14:00:29 <rosmaita> #startmeeting glance
14:00:30 <openstack> Meeting started Thu Mar 16 14:00:29 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:33 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:34 <openstack> The meeting name has been set to 'glance'
14:00:36 <sigmavirus> o/
14:00:42 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:43 <rosmaita> #topic roll call
14:00:47 <rosmaita> sigmavirus: :)
14:00:53 <dharinic> \o
14:01:12 <sigmavirus> rosmaita: that's roosevirus to you =P
14:01:12 <abhishekk> o/
14:01:27 <rosmaita> bully!
14:01:32 <sigmavirus> am not!
14:01:49 <jokke_> o/
14:01:53 <stevelle> o/
14:02:20 <rosmaita> ok, decent turnout, let's get started
14:02:23 <aavraham> o/
14:02:42 <rosmaita> i realized that putting the agenda link before the roll call was dumb, so here it is again:
14:02:50 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:03:05 <rosmaita> pretty light agenda
14:03:35 <rosmaita> i caught some kind of nasty bug over the weekend and have been about 75% this week
14:03:49 <rosmaita> #topic Updates
14:04:00 <rosmaita> #topic update - docs:install-guide-verified tag
14:04:10 * asettle comes in wiggling eyebrows
14:04:15 <asettle> Well hello
14:04:16 <asettle> nice topic
14:04:26 <rosmaita> very dramatic entrance
14:04:32 <asettle> You know me, I like to make noise
14:04:38 <rosmaita> asettle has proposed a new tag for projects
14:04:43 <rosmaita> here's the basic info:
14:05:03 <rosmaita> #link https://review.openstack.org/445536
14:05:18 <rosmaita> (i am having big copy-paste probs from the etherpad this morning)
14:05:33 <rosmaita> anyway, i'll follow up on that
14:05:51 <rosmaita> #action rosmaita review install guide tag spec
14:05:55 <stevelle> nice
14:06:01 <asettle> Thanks rosmaita :) I want it to be helpful, not a hinderance. So, please provide honest opinions etc
14:06:05 <asettle> I'm sure you'll undersatnd the point I'm getting at
14:06:08 <asettle> At least, I hope so
14:06:11 <asettle> If not, I have a problem :p
14:06:13 <rosmaita> me too :)
14:06:23 <stevelle> will read
14:06:35 <rosmaita> just keeping everyone in the loop since it fits in with our ongoing docs reorg effort this cycle
14:06:50 <rosmaita> any questions since we have asettle here?
14:07:01 <asettle> Sure does :)
14:07:50 <jokke_> is it done yet? :P
14:07:51 <rosmaita> alex_bash: read back through the meeting log later, some stuff that impacts you as docs liason occurred
14:07:56 <asettle> lawl jokke_ :P
14:08:03 <alex_bash> just joined
14:08:17 <asettle> We saw :p
14:08:42 <sigmavirus> alex_bash: that's likely why rosmaita tagged you in that comment =)
14:09:06 <rosmaita> it's pretty early where alex_bash is, so i imagine the coffee has not kicked in yet
14:09:20 <rosmaita> ok, asettle, thanks for joining
14:09:25 <rosmaita> moving along
14:09:33 <asettle> No worries :)
14:09:42 <rosmaita> #topic QA wants to drop testing v1
14:10:04 <rosmaita> i haven't completely digested this one yet, but it may be impacting us already
14:10:16 <rosmaita> here's the start of the thread:
14:10:34 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-March/113664.html
14:10:44 <sigmavirus> means defcore can't use that in future defcore specifications right?
14:10:50 <sigmavirus> If so, BULLY for it
14:10:58 <rosmaita> go roosevirus
14:11:14 <jokke_> so I would love to do that
14:11:20 <jokke_> but I don't think we can
14:11:24 <rosmaita> exactly
14:11:37 <sigmavirus> jokke_: don't ruin my unpresidented dreams ;)
14:11:43 <rosmaita> i replied this morning that we're in a weird situation with v1
14:12:07 <rosmaita> it's deprecated but not feature-paritable (or whatever the correct term is)
14:12:10 <jokke_> We still have agreement that the API is supported and if we kill the tests we can as well just remove the code as it's per default broken at that point
14:12:31 <rosmaita> well, i think they would like us to take over the test ourselves if we really want them
14:12:31 <sigmavirus> jokke_: we could just not merge things that affect v1
14:12:43 <jokke_> sigmavirus: oh we don't
14:12:48 <sigmavirus> you say that
14:12:51 <sigmavirus> =P
14:12:58 <jokke_> it still doesn't mean that the bitrot wouldn't happen
14:13:15 <rosmaita> well, plus there are changes not to v1 API that can affect it
14:13:23 <jokke_> rosmaita: indeed
14:13:44 <rosmaita> anyway, i'd of course like the qa team to hold onto this stuff for a while longer
14:14:11 <rosmaita> but abhishekk noticed some python-glanceclient failures this morning
14:14:17 <rosmaita> not sure what's happening there
14:14:25 <rosmaita> but our glanceclient tests can't find the v1 api
14:14:37 <rosmaita> #link http://logs.openstack.org/18/445318/1/check/gate-glanceclient-dsvm-functional-ubuntu-xenial/5e48dbe/console.html
14:14:42 <rosmaita> dang
14:14:45 <jokke_> rosmaita: so tl;dr was that just tempest they wanna drop or do they want to make statement that we do not gate deprecated features anymore?
14:15:02 <rosmaita> #link http://logs.openstack.org/18/445318/1/check/gate-glanceclient-dsvm-functional-ubuntu-xenial/5e48dbe/console.html
14:15:17 <sigmavirus> rosmaita: abhishekk isn't that because devstack stopped deploying v1 by default?
14:15:18 <rosmaita> jokke_: it wasn't completely clear to me
14:15:35 <rosmaita> sigmavirus: bet you're right
14:15:39 <rosmaita> of course
14:15:44 <jokke_> cause if it's just tempest that is QA maintained, I'm fine with it
14:15:52 <stevelle> looked like a discussion still abt what to do with it
14:16:01 <rosmaita> stevelle: yes
14:16:07 <rosmaita> jokke_: what stevelle said
14:16:10 <jokke_> but we need to keep our unit/functional/integration tests still going
14:17:01 <rosmaita> the discussion seemed to be, once a DEPRECATED notice goes out, the clock starts ticking, and they want to remove tests on the 3rd cycle
14:17:15 <rosmaita> which isn't quite the way i understood how deprecation works
14:17:23 <abhishekk> sigmavirus: i think you are right
14:18:19 <rosmaita> abhishekk: sigmavirus: where's the right place to correct this? i think we modify the tempest test setup to turn on the v1 api?
14:18:28 <rosmaita> for python-glanceclient, i mean
14:19:13 <jokke_> rosmaita: I think it needs to be in devstack, but I'm not sure
14:19:17 <abhishekk> rosmaita: not sure at this point
14:19:27 <sigmavirus> jokke_: shouldn't need to be
14:19:37 <sigmavirus> might be something in the devstack dos
14:19:38 <sigmavirus> *docs
14:19:41 <stevelle> pretty sure we can turn it back on in that gate, without setting it default on in devstack but not sure how
14:19:45 <sigmavirus> I suspect this is something glance needs to do
14:19:57 * sigmavirus isn't familiar with devstack though
14:19:57 <rosmaita> i think we can change the particular test
14:20:00 <jokke_> yeah, I can't remember where it actually comes from
14:20:23 <rosmaita> there's like a setup preliminary thing that affects the devstack that gets built
14:20:26 <rosmaita> (i believe)
14:20:48 <rosmaita> ok, anyone interested in helping out the glanceclient test probs, meet in openstack-glance after this meeting
14:20:58 <rosmaita> back to the QA discussion
14:21:22 <rosmaita> i'll try to convince QA to keep the tests
14:21:38 <rosmaita> otherwise, i think we will have to take them over, which i really don't want to do ATM
14:21:45 <rosmaita> as we have other stuff on our plates
14:21:52 <nikhil> There's a ini set flag on devstack to enable_v1=true
14:23:27 <rosmaita> nikhil: i think we'd set that in the tempest test, as part of the setup?
14:23:46 <rosmaita> to close out the QA discussion, here's what I responded:
14:23:53 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-March/114141.html
14:24:20 <rosmaita> like i said earlier, this bug i caught has me at about 75% of mental capacity
14:24:30 <rosmaita> so, the argument may not be very convincing
14:24:50 <rosmaita> and, my track record on convincing arguments to QA is pretty bad, even when i am 100%
14:25:07 <rosmaita> so please read & respond if appropriate
14:25:18 <rosmaita> cinder is ok with their v1 being removed
14:25:26 <rosmaita> but they are in a different situation, i think
14:25:45 <rosmaita> any questions/comments?
14:25:58 <nikhil> It's the setup of devstack used for the job to run the tempest tests
14:26:05 <rosmaita> (or is everyone off looking at devstack?)
14:27:04 <rosmaita> is the gate job setup in the infra repo?
14:27:17 <nikhil> One of the infra repo
14:27:29 <rosmaita> https://github.com/openstack-infra/devstack-gate
14:27:33 <rosmaita> maybe?
14:27:44 <nikhil> Yeah
14:28:04 <nikhil> That will enable it for all openstack who run glance tests
14:28:11 <rosmaita> ok, we can look into that after the meeting
14:28:16 <rosmaita> not too much left
14:28:24 <stevelle> good info there. didn't know abt that
14:29:01 <rosmaita> I think i am going to skip the "looking for owners"
14:29:10 <rosmaita> #topic "owned" topic reports
14:29:26 <rosmaita> i just want to check in on whether people are making progress/need help
14:29:34 <nikhil> Mine will be out later today
14:29:52 <rosmaita> nikhil: you mean the show_multiple_locations removal spec?
14:30:00 <nikhil> Y
14:30:12 <rosmaita> great, i think dharinic has some ideas about that also
14:30:27 <dharinic> yeah, i started working on the code https://review.openstack.org/#/c/444540/
14:30:38 <rosmaita> dharinic and hemanthm put together an etherpad of the deprecated options
14:30:48 <dharinic> will continue working once the spec is ready, agreed upon
14:30:54 <rosmaita> i'll create a few bugs from that
14:31:15 <rosmaita> sigmavirus: how is the "so you want to be a release czar" doc coming?
14:31:58 <sigmavirus> rosmaita: slowly, I think mostly it just needs some updates
14:32:15 <sigmavirus> hemanthm: asked me to include automation tooling, but there really is none left for a czar to use
14:32:16 <jokke_> sigmavirus: let me know if you need help with thta
14:32:25 <rosmaita> ok, good
14:32:29 <sigmavirus> jokke_: well I can't serve as czar this cycle
14:32:37 <sigmavirus> which was the reason to doc it up
14:32:42 <jokke_> ohh
14:33:07 <jokke_> well I can take it back ... should have easier cycle than what the previous was
14:33:10 <sigmavirus> it's actually increasingly likely that I'll be resigning from all of the openstack projects I'm involved with
14:33:14 <sigmavirus> jokke_: yeah
14:33:21 <rosmaita> well, that is bad news
14:33:24 <sigmavirus> it's just a matter of saying no to people is what I tried to convey
14:33:28 <jokke_> sigmavirus: oh :(
14:33:30 <dharinic> :(
14:33:41 <sigmavirus> c'est la vie
14:33:51 <sigmavirus> this has all happened before and it will all happen again. so say we all =P
14:34:20 <rosmaita> sigmavirus: do you have a patch for your doc yet?
14:34:33 <jokke_> sigmavirus: yeah ... got the flashback already
14:34:36 <sigmavirus> no, was going to make the remainder of edits to it and submit it at the same time
14:34:46 <rosmaita> ok, sounds good
14:35:02 <sigmavirus> rosmaita: was wondering, does that make sense in glance's doc/source tree or ?
14:35:16 <rosmaita> yes, part of the contributors guide for now
14:35:22 <sigmavirus> sgtm
14:35:26 <rosmaita> ty
14:35:42 <sigmavirus> happy to hel
14:35:43 <sigmavirus> *help
14:36:05 <rosmaita> hemanthm has a patch up for the E-M-C migrations
14:36:12 <rosmaita> how to do them, i mean
14:36:51 <rosmaita> jokke_: anything you want to say about your import patches?
14:37:01 <stevelle> #link https://review.openstack.org/#/c/443741/
14:37:12 <jokke_> trying to figure out why the check blows up there
14:37:55 <jokke_> the config and the taskflow IIRC passes currently so would be nice to get feedback and if none merge those to start with
14:38:42 <rosmaita> ok, thanks
14:39:02 <jokke_> #link https://review.openstack.org/#/c/391442/
14:39:17 <jokke_> #link https://review.openstack.org/#/c/391441/
14:40:08 <rosmaita> ok, let's move to open discussion, i see dims put an item on the agenda
14:40:25 <rosmaita> #topic open discussion
14:40:28 <dims> :) thanks rosmaita
14:40:36 <rosmaita> #topic open discussion - unblock eventlet
14:40:43 <rosmaita> actually, we've been looking at this
14:40:55 <rosmaita> #link https://review.openstack.org/#/c/419074/
14:41:05 <rosmaita> i think hemanthm stevelle and dharinic
14:41:40 <dharinic> yeah, we had been going back and forth on it. stevelle
14:41:43 <stevelle> yes, hemanthm brought the topic up in #eventlet but we have seen no reply yet
14:42:13 <stevelle> then the oslo.il8n release broke our gate, so we had to triage and deal with that
14:42:28 <rosmaita> can someone give dims a quick update on what the problem is?
14:42:30 <stevelle> the broken gate turned out to be a badly written glance test
14:42:32 <dims> stevelle : that's what i was going to ask if we need to find someone who knows eventlet
14:42:58 <rosmaita> yes, i saw the patch that fixed the gate, thank you stevelle hemanthm and dharinic
14:43:00 <jokke_> I thought we had someone who knew it pretty well :D
14:43:01 <stevelle> dims: I would love to find someone who knows eventlet, specifically who knows the long history of why we monkey_patch it
14:43:17 <jokke_> or then not :(
14:43:51 <dims> stevelle : one person who comes to mind is haypo (victor stinner)
14:45:14 <stevelle> thanks dims, which projects has he been active in?
14:45:55 <abhishekk> IMO trove
14:46:48 <rosmaita> #action hemanthm follow up with haypo (victor stinner) in #openstack-trove
14:46:50 <dims> stevelle : he has helped in a lot of projects including oslo stuff, python3 porting etc. i haven't seen him active here recently, so we may have to ask someone at red hat to ping him for us
14:47:05 <stevelle> ok, I don't see him in the trove channel right now but I'll follow up
14:47:08 <rosmaita> jokke_: ^^
14:47:38 <jokke_> yp, I'll see if I can help there as well
14:47:51 <rosmaita> ty
14:47:59 <dims> thanks jokke_ stevelle rosmaita
14:48:10 <stevelle> my hope is we have agreement on a fix this week (not much time left), even if it sets us back on py35
14:48:28 <stevelle> but eventlet has given us problems in py35
14:49:01 <rosmaita> #action stevelle, hemanthm, jokke_ to contact victor stinner (haypo) for eventlet moneky-patching knowledge
14:49:17 <rosmaita> ok, anything else for open discussion?
14:49:32 <rosmaita> #topic open discussion
14:50:06 <jokke_> Just wanted to ask if anyone has any questions around the IIR work?
14:50:59 <stevelle> what happened to my week that I haven't gotten time to spend on the iir work yet, jokke_?
14:51:13 <jokke_> haha
14:51:28 <rosmaita> yeah, i have the same question
14:51:32 <jokke_> stevelle: you wasted it on something useless and less important ... shame on you :P
14:51:59 <stevelle> I will punish my liver this weekend, and do better next week
14:52:14 <rosmaita> ok, sounds like priority list will be pretty much like the last one
14:52:16 <jokke_> stevelle: sounds like a brilliant plan
14:52:29 <rosmaita> top priority is getting the eventlet thing unblocked
14:52:46 <jokke_> stevelle: I'll do the same if I'm still stuck with those tests tomorrow
14:52:52 <rosmaita> next is glanceclient gate, which hopefully we will fix in the next half hour
14:53:04 <rosmaita> rest are:
14:53:10 <rosmaita> review erno's patches
14:53:19 <rosmaita> review hemanthm's E-M-C doc
14:53:28 <rosmaita> anything else?
14:53:38 <stevelle> isn't there another requirements blocker?
14:53:50 <stevelle> or did we resolve that (no coffee yet today)
14:54:02 <rosmaita> not sure, checking
14:54:05 <alex_bash> webob
14:54:13 <rosmaita> oh, right
14:54:29 <dharinic> https://review.openstack.org/#/c/423366/
14:55:25 <rosmaita> sigmavirus: did hemanthm talk to you about him taking that patch over?
14:56:07 <nikhil> https://review.openstack.org/#q,I4de03e2a1ca493cd49a474a67cbbdec24d61b98f,n,z
14:56:18 <rosmaita> got some comments early today from a webob person on that patch
14:57:02 <rosmaita> "that patch" == https://review.openstack.org/#/c/423366/
14:57:48 <stevelle> 2 min left
14:57:53 <rosmaita> anyway, that is a priority also to get requirements un-blocked
14:58:05 <stevelle> but we need to make progress on that
14:58:24 <sigmavirus> rosmaita: no, but that's fine
14:58:34 * sigmavirus olds no grudges
14:58:35 <rosmaita> sigmavirus: unless you have time?
14:58:41 <sigmavirus> I don't
14:58:50 <rosmaita> ok, i'll ask hemanthm to continue
14:58:52 <dharinic> i think we are in  a better state at it than the event let monkey-patch issue. So i feel it can done and merged soon
14:59:14 <rosmaita> yeah, it looks like a useful suggestion from the webob person
14:59:25 <rosmaita> ok, just about out of time ...
14:59:44 <rosmaita> anyone interested in getting glanceclient gate unblocked, please convene in #openstack-glance now
14:59:53 <rosmaita> #endmeeting