14:00:04 <rosmaita> #startmeeting glance
14:00:04 <openstack> Meeting started Thu Mar 23 14:00:04 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:08 <openstack> The meeting name has been set to 'glance'
14:00:15 <rosmaita> #topic roll call
14:00:41 <rosmaita> kind of quiet in here this morning
14:00:57 <rosmaita> hello dharinic
14:01:10 <dharinic> Good Morning rosmaita
14:01:19 <alex_bash> o/
14:01:35 <rosmaita> hi alex
14:01:56 <stevelle> o/
14:02:08 <jokke__> o/
14:03:18 <rosmaita> ok, guess we can get started
14:03:56 <rosmaita> i'm starting with general openstack updates anyway
14:04:02 <rosmaita> #topic updates
14:04:21 <rosmaita> #topic update - R release naming
14:04:35 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-March/114436.html
14:04:44 <rosmaita> that email give you the info about the rules
14:05:17 <rosmaita> so if you'd like to be immortalized, you can suggest an R name and maybe make the cut for the big vote
14:05:40 <rosmaita> that's all about that
14:05:52 <rosmaita> #topic update - quotas action
14:06:11 <rosmaita> this is for awareness of what's happening right now
14:06:25 <rosmaita> sean dague has proposed a "unified limits" conceptual spec
14:06:38 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-March/114230.html
14:06:42 <rosmaita> that email gives some info
14:06:46 <rosmaita> key things are:
14:06:56 <rosmaita> aiming for 2-week comment cycle so that it will be clear whether this can happen in Pike or not
14:07:06 <rosmaita> and, comments close 30 March
14:07:16 <rosmaita> here's the actual spec link
14:07:20 <rosmaita> #link https://review.openstack.org/#/c/440815/
14:07:42 <rosmaita> i think nikhil is the glancer most interested in this, but i don't seem him around atm
14:08:23 <rosmaita> anyway, the quotas work will eventually impact glance, so take a look at the spec if you want to provide input on the ground floor
14:08:36 <rosmaita> #topic update - log messages
14:08:53 <rosmaita> in case you haven't followed the discussion on the ML, log messages are no longer translated
14:09:14 <rosmaita> there's a patch up to remove the _L* from glance code:
14:09:23 <rosmaita> #link https://review.openstack.org/447970
14:09:38 <jokke__> so I have to admit, I haven't followed ... is this permanent?
14:09:52 <rosmaita> the rationale for removal is that most people google log messages to figure out what they mean
14:10:01 <jokke__> as those translation rules seems to change every second cycle
14:10:07 <rosmaita> so keeping them all in english means less fragmentation and better results
14:10:12 <rosmaita> jokke__: good point
14:10:20 <rosmaita> i believe this is meant to be permanent
14:10:34 <alex_bash> I also thought the discussion was still ongoing
14:10:40 <rosmaita> but i was wondering whether it would be better to make the _L* no-ops instead of removing
14:11:00 <rosmaita> but it would make the coder harder to read
14:11:06 <jokke__> yeah, that has been discussed a lot exactly for that reason and the rationale has always been that the localization people have been super agains that specially around the more dominant languages
14:11:08 <rosmaita> though, no harder than it is presently
14:11:31 <rosmaita> alex_bash: i thought it had concluded, but maybe not
14:11:48 <alex_bash> rosmaita: you mean redefine them ourselves or within i18n?
14:12:00 <jokke__> lets hold off with that patch, please ... I have a look on that discussion and probe for more info if needed
14:12:05 <rosmaita> there are refs to the ML in the commit message of that patch
14:12:12 <jokke__> cheers
14:12:13 <rosmaita> ok, that's a good idea
14:12:31 <rosmaita> #action rosmaita determine actual status of i18n for log messages
14:12:39 <stevelle> I endorse this action
14:12:51 <rosmaita> i'll put a note on the patch to that effect
14:13:07 <stevelle> translating logs was always flawed for this reason but let's be sure
14:13:07 <rosmaita> alex_bash: i was thinking within glance for the _L* no-ops
14:13:23 <rosmaita> i must admit
14:13:35 <rosmaita> my reading of the discussion was that it was trending to non-translation
14:13:46 <rosmaita> and then i saw the patch and figured it was a done deal
14:13:52 <rosmaita> but that was an inference, not a fact
14:13:55 <rosmaita> so i will check
14:14:03 <rosmaita> and report back next week
14:14:48 <rosmaita> ok, jokke__ , make sure you are seated comfortably before the next one
14:14:58 <rosmaita> #update - microversioning in glance
14:15:05 <rosmaita> oops
14:15:18 <rosmaita> #topic update - microversioning in glance
14:15:29 <rosmaita> i need to write some macros or something
14:15:30 <jokke__> oh this is quick topic ;)
14:15:41 <jokke__> -2 ... neext
14:15:43 <rosmaita> draft API compatibility/stability "guidelines" (actually requirements for asserting the proposed 'assert:supports-api-compatibility' tag
14:15:59 <rosmaita> #link https://review.openstack.org/#/c/421846/
14:16:15 <rosmaita> changes will require version changes, and the only acceptable versioning scheme satisfying the guidelines is microversions
14:16:28 <rosmaita> so, without microversions
14:16:33 <rosmaita> we either don't make changes
14:16:38 <rosmaita> or don't assert the tag
14:16:42 <stevelle> so I really love what Graham has been saying on that guideline
14:17:05 <rosmaita> stevelle: tell us more, i haven't looked in about a week
14:17:07 <stevelle> I want glance to work toward the tag by simply not changing the API
14:17:23 <stevelle> Graham is suggesting the alternative to microversions is "stop changing stuff"
14:17:37 <stevelle> when an API goes into Supported, no changes as all
14:17:48 <jokke__> rosmaita: so easy, we don't assert the tag
14:17:52 <jokke__> ;)
14:18:07 <stevelle> when it's time to change that resource, you make a new version and he is trying to carve space for experimental apis
14:18:09 <hemanthm> I haven't read that stuff yet, but what's a "change" here?
14:18:28 <stevelle> hemanthm: anything that can be seen is a change
14:18:28 <mugsie> stevelle: well, not quite - but we shouild get api's right before saying users can rely on them
14:18:44 <rosmaita> change to url, change to resource representation, change to response codes, etc
14:18:49 <rosmaita> basically, anything
14:18:59 <rosmaita> that you can see through the api
14:19:00 <hemanthm> a bug fix too?
14:19:07 <rosmaita> yep
14:19:09 <jokke__> mugsie: o/ ... totally agree on that one ;)
14:19:17 <rosmaita> only serious security ones will be allowed
14:19:35 <rosmaita> so basically, all our ocata changes are impossible under the guideline
14:19:37 <stevelle> I agree mugsie, which is why I'm enthusiastic about that line of discussion on the guideline
14:19:43 <jokke__> yeah, I'm just happy not asserting that tag
14:19:51 <jokke__> for now
14:19:57 <mugsie> yeah - I hope people come on board to back me up  :)
14:19:58 <jokke__> lets say next 6 or 7 cycles
14:20:04 <mugsie> comments welcome
14:20:25 <stevelle> my hope is that Glance can bundle intended API changes for 2y at a time and just increment major versions
14:20:44 <rosmaita> i had a bunch of early comments, but have really nothing more to say
14:21:22 <rosmaita> just want this to be a point of information for everyone to cogitate upon
14:21:37 <rosmaita> and as mugsie points out, leave comments if you have an opinion
14:22:03 <rosmaita> any other comments about that?
14:22:29 <hemanthm> I do but I don't want to derail the meeting :)
14:22:43 <stevelle> maybe we can discuss in #openstack-glance after this
14:22:45 <rosmaita> ok, hold 'em for open discussion
14:22:52 <rosmaita> or what stevelle said
14:22:57 <rosmaita> ok, moving along, last update
14:23:09 <rosmaita> #topic update - farewell to Ian
14:23:23 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-March/114462.html
14:23:23 <jcook> =(
14:23:25 <hemanthm> -2
14:23:35 <rosmaita> sigmavirus is moving on
14:23:39 <dharinic> :(
14:23:49 <rosmaita> yes, i am bummed, too
14:23:53 * stevelle is now an abandoned change set
14:24:28 <sigmavirus> =/
14:24:50 <sigmavirus> I'm not thrilled either, but c'est la vie
14:25:11 <hemanthm> All the very best to you!
14:25:16 <rosmaita> sigmavirus: thank you for all your service to glance, you will be missed a lot!
14:25:22 <dharinic> Glance was so much fun and lively with sigmavirus/roosevirus around.
14:25:28 <stevelle> fair speed and don't take any wooden nickels, sigmavirus
14:26:04 <rosmaita> and as ttx pointed out, openstack expects to expand to encompass the entire universe of software, so we should meet again
14:26:18 <dharinic> Thank you for all the motivation sigmavirus. All the best. :)
14:26:21 <jokke__> sigmavirus: I was afraid this will come
14:26:22 <sigmavirus> rosmaita++
14:26:37 <rosmaita> but, the sad departure of sigmavirus does leave us with some holes to fill
14:26:48 <rosmaita> #topic volunteers and responsibilities
14:26:54 <sigmavirus> y'all better step up... or else... my Rooseghost will haunt y'all
14:27:01 * stevelle hides
14:27:03 <rosmaita> #link https://etherpad.openstack.org/p/glance-pike-volunteers
14:27:06 <jokke__> sigmavirus: Thanks a million and keep in touch! If we ever land to same area, lets get drunk as ducks. ;)
14:27:29 <rosmaita> i didn't realize ducks were big drinkers
14:27:34 <hemanthm> me neither
14:27:46 <jokke__> rosmaita: they are not, thus they get very drunk ;)
14:27:47 * hemanthm was about to google drunk ducks
14:27:59 <rosmaita> jokke__: thanks, that explains it
14:28:08 <rosmaita> ok, please open that etherpad
14:28:26 <rosmaita> i've asked hemanthm to become release czar
14:28:43 <rosmaita> ian's departure also leaves an opening on glance coresec
14:28:53 <rosmaita> for which i propose stevelle
14:29:21 <rosmaita> i have a question about stable branch liason
14:29:48 <rosmaita> which i think jokke__ is answering "live" on the etherpad
14:30:04 <rosmaita> ok, great
14:30:27 <rosmaita> i like having different ptl - release czar - and stable branch people
14:30:43 <rosmaita> i think it keeps a healthy balance of opinions on impacting issues
14:30:45 <rosmaita> ok, cool
14:31:04 <rosmaita> alex_bash is doing documentation
14:31:20 * jokke__ is still also part of the glance release team, and happy to keep it so and help out
14:31:25 <rosmaita> asettle has enhanced the expections of the docs liason, so he'll be busy
14:31:38 <jokke__> I've been following the OS release side pretty closely anyways
14:32:06 <rosmaita> jokke__: great, you will provide some continuity
14:32:35 <rosmaita> key unfilled slots are: infra, which i am filling in for now, but i'm open to let someone else take over
14:33:05 <rosmaita> key thing about infra CPL is that the infra team wants a +1 from infra CPL before they approve changes
14:33:13 <rosmaita> so that slot *must* be filled
14:33:20 <rosmaita> but i'll do it for now
14:33:30 <jokke__> for that, I'm not willing to step in :P
14:33:33 <rosmaita> i was thinking of volunteering dharinic for oslo CPL
14:33:45 <jokke__> Voluntold :)
14:33:48 <rosmaita> since she has some commits into oslo
14:33:50 <dharinic> I would love that. :)
14:34:09 <rosmaita> dharinic: that's great if you are serious, i don't want to make you do it
14:34:27 <hemanthm> rosmaita: you already did :)
14:34:35 <rosmaita> well, i meant it to be a hint
14:34:43 <rosmaita> i used the wrong font, i guess
14:34:54 <dharinic> I was serious.
14:34:55 <rosmaita> it all looks alike in irc!
14:35:07 <rosmaita> dharinic: great, happy to have you do that
14:35:14 <dharinic> I have contributed to oslo and would love to do this.
14:35:27 <dharinic> Thanks for volunteering me rosmaita
14:35:28 <rosmaita> everyone: please review the expectations on https://wiki.openstack.org/wiki/CrossProjectLiaisons
14:35:33 <rosmaita> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
14:35:58 <rosmaita> OK, a key unfilled CPL is QA
14:36:14 <rosmaita> but we can look for someone later on that
14:37:00 <jokke__> hehe
14:37:15 <rosmaita> my thought is that once everyone is confirmed, i will move this etherpad into the priorities for pike page in teh specs repo, which i'll put up after the spec freeze
14:37:28 <rosmaita> which reminds me, the spec proposal freeze is soon
14:37:33 <jokke__> that will be fun position to take on ... it's shame sigmavirus is leaving ... would love to have his character dealing with them ;)
14:37:41 <rosmaita> :)
14:38:13 <hemanthm> jokke__: I think you're a good character fit too :P
14:38:24 <rosmaita> #info spec proposal freeze - patch with spec must be up before 13:59 UTC on Thursday 30 March 2017
14:38:39 <rosmaita> ok, moving on
14:38:44 <jokke__> hemanthm: _if_ I would understand anything about testing :P
14:38:55 <rosmaita> #topic "owned" topics reports
14:39:12 <rosmaita> ok, dharinic has been active on removing deprecated options
14:39:22 <rosmaita> hemanthm has a patch up for E-m-C docs
14:39:24 <dharinic> here is my update
14:39:26 <dharinic> The important opt: “show_multiple_locations”. 
We would be removing it in favor of RBAC (Role Based Access Control) from policy.json.  nikhil, rosmaita and I had some discussions on few combinations for the property rules and nikhil will be putting up a spec for it.
14:39:35 <dharinic> I have a patch up with code changes for one such combination for review and opinions (https://review.openstack.org/#/c/444540/)
14:39:59 <rosmaita> thank you
14:40:06 <dharinic> Another set of opts was the swift store auth opts like “swift_store_auth_address”, “swift_store_user” etc. There were to be removed in favor of reading related information from the swift store config file. This requires considerable code change with respect to swift store in multi-tenant mode (we are currently not allowing a swift conf file to be given if multi-tenant mode is on). I am working on this and will
14:40:40 <jokke__> dharinic: just a reminder ... do we have the policy options in place for the multiple locations yet?
14:40:41 <dharinic> I assume we do not need a spec/lite-spec for this ^
14:40:59 <rosmaita> nikhil said he'd have a patch up soon for the removal spec, not sure if it's there yet, though i did see an early draft on an etherpad
14:41:04 <dharinic> jokke__: Currently they are open.
14:41:08 <rosmaita> dharinic: for the swift-opts, you mean?
14:41:21 <rosmaita> jokke__: yes, we have policies, but the default is ""
14:41:31 <dharinic> rosmaita: yeah, i meant spec/lite-sepc fopr swift auth opts.
14:41:37 <rosmaita> it's a problem, as you'll see from nikhil 's spec
14:41:47 <dharinic> for the show_multiple_locations, nikhil will be putting up a patch soon
14:41:58 <rosmaita> dharinic: were they the ones i said do release notes first?
14:42:07 <rosmaita> (i am not fully caffeinated this morning)
14:42:10 <jokke__> ok ... so we need to document the change well in release notes and make sure we do not open that up by anyone upgrading
14:42:24 <rosmaita> jokke__: exactly!
14:42:32 <dharinic> yes rosmaita. I have the release note: https://review.openstack.org/#/c/448316/
14:42:38 <rosmaita> dharinic: ty
14:42:54 <rosmaita> so, instead of a lite spec, i asked dharinic to put up the release note
14:43:09 <rosmaita> we can review it to see what hte impact looks like
14:43:24 <rosmaita> hopefully, won;t need a spec, but i haven't looked yet
14:43:38 <rosmaita> #action everyone review https://review.openstack.org/#/c/448316/
14:43:43 <dharinic> please feel free to help me edit the release note for the swift store auth opts. Wordings are not great.. Want to make sure things are conveyed correctly.
14:43:44 <rosmaita> #link https://review.openstack.org/#/c/448316/
14:43:55 <rosmaita> ok, thanks
14:44:03 <rosmaita> jokke__: i owe you reviews on your patches
14:44:22 <rosmaita> i intend to go offline and do nothing but that this afternoon
14:44:32 <rosmaita> go to get you unblocked
14:44:32 <dharinic> And the last opt which i also started work on: https://review.openstack.org/#/c/447172/
14:44:54 <rosmaita> ok, thanks to all the "owners" for keeping things moving!
14:45:06 <jokke__> rosmaita: cheers ... there is some gate failures still down in that chain I haven't been able to figure out ... any help would be great
14:45:09 <rosmaita> next topic is a fun one, show and tell
14:45:22 <rosmaita> #topic     docs update -- discuss for 5 minutes and then we will vote
14:45:37 <rosmaita> Shinya Kawabata has a POC patch up for improving one of our docs pages, which right now is really hard to read because of the way the options and there descriptions are all jammed in together
14:45:51 <rosmaita> he put together a POC giving us 2 options
14:46:05 <rosmaita> so please opent the next link in your browser:
14:46:16 <rosmaita> #link http://docs-draft.openstack.org/80/423880/6/check/gate-glance-docs-ubuntu-xenial/628a2af//doc/build/html/configuring.html
14:46:31 <rosmaita> options: headings ("Configuring multiple swift accounts/stores") vs. definition list ("Configuring the RBD storage backend")
14:46:33 <stevelle> and this patch is a rework before the lift and shift of this section to the proper place in openstack-manuals, right?
14:46:43 <rosmaita> correct
14:46:54 <rosmaita> this is a readability issue on this page
14:47:08 <rosmaita> so, if you open that page
14:47:17 <hemanthm> I like the latter
14:47:21 <rosmaita> look at the OTC in the left bar
14:47:28 <rosmaita> i mean the TOC
14:47:32 <stevelle> that readability issue will be fixed by `git rm` :)
14:48:01 <rosmaita> not a choice atm, though
14:48:24 <alex_bash> +1 #2
14:48:33 <rosmaita> ok, so the problem is that the options have bullets and it's hard to see what description goes with what option
14:48:49 <rosmaita> so the http://docs-draft.openstack.org/80/423880/6/check/gate-glance-docs-ubuntu-xenial/628a2af//doc/build/html/configuring.html#configuring-multiple-swift-accounts-stores
14:48:58 <rosmaita> makes each option a heading
14:49:05 <rosmaita> pro: it also shows up in the TOC
14:49:20 <rosmaita> con: it's going to fill up the TOC when all these are headings
14:49:26 <stevelle> I prefer the "multiple swift " formatting but I would love to see the option titles bolded or bumped in size one step
14:49:27 <rosmaita> but, it does make stuff easy to find
14:49:51 <jokke__> rosmaita: please no :(
14:50:02 <rosmaita> ok, other option is like the RBD
14:50:07 <rosmaita> a simple definition list
14:50:10 <jokke__> that toc becomes totally unusable if we make every option being heading and crapping it out
14:50:15 <rosmaita> http://docs-draft.openstack.org/80/423880/6/check/gate-glance-docs-ubuntu-xenial/628a2af//doc/build/html/configuring.html#configuring-the-rbd-storage-backend
14:50:22 <rosmaita> jokke__: that's my worry too
14:50:28 <stevelle> there should be a way to limit the depth of the toc
14:50:31 <hemanthm> Yes, TOC won't be TOC any more with all the noise
14:50:48 <rosmaita> stevelle: there is, we can keep stuff out of the toc
14:51:01 <stevelle> if we can exclude those headings from toc that makes that formatting work
14:51:10 <rosmaita> don't have control over the size without hacking the styles, though
14:51:13 <jokke__> it's already long as it is and if you're looking just for specific option and it's documentation you can always use search on that page
14:51:36 <rosmaita> everyone ready to vote?
14:51:43 <hemanthm> aye
14:51:46 <stevelle> its the HRs that help for me, we could add HRs without the use of headings too
14:52:03 <jokke__> stevelle: ++
14:52:11 <rosmaita> hmmm ... i tend to not like HRs
14:52:20 <rosmaita> i prefer the indentation like the RBD stuff
14:52:33 <rosmaita> anyway, that's why we can vote and just go with the majority
14:52:54 <jokke__> rosmaita: that is more pythonic tbh
14:53:04 <rosmaita> believe it or not this is my first vote, so let
14:53:09 <rosmaita> 's see what happens
14:53:20 <jokke__> but the question is which one is more convenient for the non-developer reader
14:53:37 <stevelle> so many questions, jokke__
14:53:47 <rosmaita> #startvote (how to markup the config page) ? headings, definition-list
14:53:48 <openstack> Begin voting on: (how to markup the config page) ? Valid vote options are headings, definition-list.
14:53:50 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:53:59 <jokke__> stevelle: information is key to right decisions
14:53:59 <rosmaita> #vote definition-list
14:54:11 <hemanthm> #vote definition-list
14:54:15 <jokke__> #vote definition-list
14:54:42 <dharinic> <dl>
14:54:47 <stevelle> #vote definition-list
14:54:59 <dharinic> #vote definition-list
14:55:07 * stevelle is swayed
14:55:18 <rosmaita> anyone else?
14:55:30 <hemanthm> alex_bash: mentioned #2 earlier
14:55:42 <rosmaita> alex_bash: ??
14:55:58 <alex_bash> option 2 has already carried, my vote is meaningless
14:56:01 <alex_bash> I demand a recount
14:56:09 <rosmaita> no vote is meaningless!
14:56:14 <rosmaita> some just have less meaning than others
14:56:18 <alex_bash> so that I can vote first
14:56:21 <jokke__> alex_bash: get your disagreement recorded if you have one so you can bitch about the "wrong" decision later ;)
14:56:26 <stevelle> alex_bash: you're just reading the exit polls
14:56:33 <alex_bash> #vote definition-list
14:56:36 <rosmaita> ok
14:56:40 <rosmaita> #endvote
14:56:41 <openstack> Voted on "(how to markup the config page) ?" Results are
14:56:42 <openstack> definition-list (6): jokke__, dharinic, stevelle, alex_bash, hemanthm, rosmaita
14:56:59 <rosmaita> and it appears to be stuck
14:57:12 <rosmaita> anyway, it's a landslide for definition-list
14:57:17 <rosmaita> ok, next topic
14:57:27 <jokke__> be quick ... we have 3 left
14:57:34 <jokke__> 3 min I mean
14:57:36 <rosmaita> #topic technical debt - time bomb
14:57:45 <rosmaita> #link https://review.openstack.org/#/c/419074/
14:57:51 <rosmaita> we merged that last week, and
14:58:03 <rosmaita> tick, tick, boom: https://review.openstack.org/#/c/448653/
14:58:14 <rosmaita> just a point of awareness
14:58:26 <rosmaita> #topic - looking for owners
14:58:39 <rosmaita> i'm going to solicit for these on the ML
14:58:51 <rosmaita> both require some expertise we don't currently have, anyway
14:59:01 <rosmaita> #topic open discussion
14:59:08 <rosmaita> 50 seconds!
14:59:16 <alex_bash> shameless own patch plug: https://review.openstack.org/#/c/436257/ & https://review.openstack.org/#/c/436258/ were +A, but had to rebase because of the time bomb
14:59:30 <alex_bash> so close
14:59:33 <stevelle> more talk of api stability and other topics in glance channel
14:59:48 <jokke__> Thanks everyone!
15:00:01 <rosmaita> thanks!
15:00:04 <rosmaita> #endmeeting