14:00:13 <rosmaita> #startmeeting glance
14:00:16 <openstack> Meeting started Thu Mar 30 14:00:13 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:20 <openstack> The meeting name has been set to 'glance'
14:00:24 <stevelle> o/
14:00:29 <dharinic> \o
14:00:46 <hemanthm> o/
14:00:47 <rosmaita> guess i don't need to actually #topic roll call
14:01:29 <rosmaita> ok, hello everyone
14:01:38 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:01:45 <rosmaita> light agenda today
14:01:57 <rosmaita> my plan is to get through the first few items fairly quickly
14:02:15 <rosmaita> and spend the remainder (except for open discussion) talking about image import
14:02:45 <rosmaita> #topic updates - spec proposal freeze
14:02:56 <rosmaita> the glance spec proposal freeze for pike is now in effect
14:03:20 <rosmaita> #topic updates - openstack mission statement revision
14:03:33 <rosmaita> #link  https://review.openstack.org/447031
14:03:53 <rosmaita> just in case you haven't seen the notice on the ML, there's a revision proposed to the openstack mission statement
14:03:59 <rosmaita> to make it more "app-aware"
14:04:20 <rosmaita> so, if you have strong feelings about this kind of thing, please take a look at that patch and comment
14:04:41 <rosmaita> and that's all the updates
14:05:02 <rosmaita> #topic specs review strategy
14:05:22 <rosmaita> ok, the spec proposal deadline is passed, now we have to review and give feedback
14:05:42 <rosmaita> what i'd like to do is to get each core to adopt at least one spec
14:05:49 <jokke_> -2 eevrything :D
14:05:54 <rosmaita> but let's move this discussion to the spec list
14:06:06 <rosmaita> #link https://etherpad.openstack.org/p/glance-pike-specs-review
14:06:21 <hemanthm> jokke_ and his -2 happiness :)
14:06:27 <rosmaita> but seriously, we should -2 anything that doesn't look reasonable
14:06:49 <rosmaita> ok, so please open your browser to the etherpad link i posted above
14:07:10 <jokke_> hemanthm: I just try to promote more relaxed attitude towards -2 ... cure by exposure :)
14:07:33 <rosmaita> these were all the open patches at the deadline
14:08:02 <rosmaita> as i say in the comment about the first one, that's sort of a meta-spec -- it's a change to the template
14:08:43 <rosmaita> we can argume more about the template change later, but for now, use it to guide thinking about those specs that may require database changes
14:09:45 <rosmaita> ok
14:10:13 <rosmaita> i volunteered dharini and stevelle to review 451560
14:10:20 <stevelle> np
14:10:35 <rosmaita> it's a small change, and a code patch is up already
14:10:50 <dharinic> Thanks rosmaita
14:10:53 <rosmaita> it's a full spec instead of lite-spec because it has possible api impact
14:11:06 <rosmaita> i should stress *minimal* impact
14:11:11 <rosmaita> minimal and legitimate
14:11:14 <rosmaita> but i digress
14:11:41 <rosmaita> 450621 is about how to deal with removing a deprecated option
14:11:53 <rosmaita> there are some weird interactions with the policy layer
14:12:09 <rosmaita> but once we get the behavior sorted out, it shouldn't be bad code-wise
14:12:22 <rosmaita> and dharinic already has a code patch up for some of it
14:12:40 <rosmaita> 206120 has been around for a long time
14:12:54 <rosmaita> sort of a glance all-star list of past cores have reviewed it
14:13:29 <rosmaita> priority-wise, i'm not so sure about it
14:13:40 <jokke_> does not mean that you need to agree with them 'though ;)
14:13:57 <stevelle> I disagree, jokke_ ! :)
14:14:18 <rosmaita> well, i mentioned it primarily for anyone who wanted to take a stroll down memory lane
14:14:44 <jokke_> :)
14:14:57 <rosmaita> i guess i should mention what the expectations are here
14:15:15 <rosmaita> i'd like particular cores to be assigned to each spec
14:15:20 <rosmaita> to give early feedback
14:15:37 <dharinic> Good idea rosmaita
14:15:39 <rosmaita> then it's up to the proposer to be prompt in making revisions
14:16:02 <rosmaita> but there's no pressure that these things *must* be approved
14:16:21 <rosmaita> we just want early feedback so revisions can happen before the spec freeze
14:16:34 <rosmaita> ok, moving on
14:16:58 <rosmaita> 442863 is awaiting response, so that one's ok for now
14:17:09 <rosmaita> 448680 is unreviewed
14:17:22 <rosmaita> it's a small change though, and one operators need
14:17:36 <rosmaita> but, it impacts the API
14:17:47 <rosmaita> and there's an opportunity for some bikeshedding
14:18:08 <rosmaita> key thing is we need something to supplement the current 'checksum' in glance
14:18:17 <rosmaita> something cryptographically secure
14:18:41 <rosmaita> jesse's proposal is to use a "multihash", a self-identifying hash
14:18:57 <rosmaita> that way, you're not stuck with a particular algorithm forever
14:19:09 <rosmaita> but some details need to be worked out
14:19:33 <rosmaita> ok the rest are all lite specs
14:19:41 <rosmaita> need some volunteers ...
14:20:00 <rosmaita> key thing is quick feedback about whether a spec-lite is enough
14:20:12 <jokke_> I do think that the current hash security issue is critical enough for us to _need_ to figure out fix for it
14:20:19 <stevelle> i figure i am on enough of them already
14:20:24 <jokke_> even if we end up breaking the API again ;)
14:20:47 <rosmaita> i think we are ok
14:20:59 <rosmaita> i think we have a non-breaking way to do that
14:21:32 <rosmaita> ok, i just volunteered to look at the lite specs
14:21:46 <hemanthm> I'll look at them too
14:21:53 <rosmaita> any non-cores, by the way, should look at specs, too
14:21:57 <stevelle> 444530 is one jokke_ should look at since it was largely his idea
14:22:07 <stevelle> in terms of the expected solution
14:22:16 <rosmaita> i don't mean to imply that only cores should review
14:22:25 <rosmaita> i just want to make sure there's at least one core taking a look
14:22:47 <rosmaita> so non-cores who want to become more involved, please review! your quality comments will be noticed
14:23:14 <jokke_> stevelle: k
14:23:32 <rosmaita> ok, last thing
14:24:05 <rosmaita> at the bottom there are some proposed specs that I -1'd back in ocata, with no response
14:24:18 <rosmaita> I may just abandon them
14:24:22 <rosmaita> with a nice note
14:24:38 <rosmaita> i do want us to think about 373896, though
14:24:53 <rosmaita> we still don't have a plan for what to do about OSSN-0075
14:24:55 <jokke_> 373896 is something we need to discuss carefully, perhaps take it up in the Forum
14:25:17 <jokke_> :)
14:25:17 <rosmaita> good point about the forum
14:25:54 <rosmaita> #action propose something around OSSN-0075 for the forum or incorporate it into a current proposal
14:26:17 <rosmaita> ok, thanks everyone ... early feedback is important, spec freeze is in 2 weeks
14:26:27 <rosmaita> which brings us to the next item
14:26:39 <rosmaita> #topic releaze czar report
14:26:53 <hemanthm> I'll keep this quick
14:27:04 <hemanthm> I'll be taking over the realse CPL duties from sigmavirus, who has done an amazing job for us last cycle.
14:27:12 <hemanthm> To ensure we release Glance on time, we must stick to our priorities and respect community milestones.
14:27:15 <hemanthm> To do the necessary for each milestone, in consultation with the PTL, I'll set a deadline.
14:27:24 <hemanthm> And, there will be close to no exceptions to sneak something in too close to/after the deadline. (blame sigmavirus, he started playing tough and I have no option but to follow :P )
14:27:28 <hemanthm> I'll be using the following etherpad to track our milestones and priorities
14:27:31 <hemanthm> https://etherpad.openstack.org/p/glance-pike-ptg-roadmap-prelim
14:27:55 <hemanthm> rosmaita already talked about spec proposal freeze and spec freeze
14:28:05 <hemanthm> Then, we have Pike-1 coming up soon in R-20, Apr 10 - Apr 14.
14:28:05 <hemanthm> Anything that is intended for Pike-1 must be merged no later than Thursday next week, that is April 6th.
14:28:08 <hemanthm> I understand that rosmaita wants to merge partial image download stuff. He may talk more about that later.
14:28:58 <hemanthm> done
14:29:07 <rosmaita> hemanthm: thank you
14:29:21 <rosmaita> #topic would like to get into P-1
14:29:36 <rosmaita> dharinic has been working on some partial download stuff
14:29:46 <rosmaita> the 3 patches are noted on the agenda
14:30:03 <rosmaita> they are mostly ready, but will be a review priority this week
14:30:12 <rosmaita> the other priority is, of course, image import
14:30:41 <rosmaita> and on that note ...
14:30:47 <rosmaita> #topic image import refactor
14:30:58 <rosmaita> jokke_ has had some patches up
14:31:16 <rosmaita> for the backend "stage"
14:31:50 <rosmaita> jokke_ has some technical issues he wants to discuss
14:31:57 <rosmaita> but first, i do want to say
14:32:22 <rosmaita> we need to keep in mind that the image import refactor has been bikeshedded extensively
14:32:43 <rosmaita> at this point, we are stuck with the basic design
14:32:50 <rosmaita> so please keep that in mind
14:33:06 <rosmaita> also, while we don't want to merge bad code
14:33:32 <rosmaita> we should have a "patch later" policy on the non-essential stuff (e.g., exact wording of help text)
14:33:57 <rosmaita> that's it from me
14:34:01 <jokke_> dharinic: thanks for pointing out that state error in the workflow ... apart from that I've tried to figure out why the gate does not like the config option checks. Any insight for that would be great. Do we overwrite the config object in tests and I need to add it up there or do I have some (re)basing issue lingering there (the staging endpoint is just pep8 issue)
14:35:10 <rosmaita> anyone have any ideas ^^
14:36:30 <hemanthm> I didn't look at the import patches yet, will comment if I know anything
14:36:56 <jokke_> thnx hemanthm
14:37:16 <dharinic> You are welcome jokke_.
14:37:24 <rosmaita> hemanthm: maybe you can just look specifically at that config option check
14:37:34 <hemanthm> sure, will do
14:37:40 <rosmaita> i think you and dharinic are the most experienced with the config stuff
14:37:56 <jokke_> so this is the one in the chain https://review.openstack.org/#/c/443632/3 where the errors starts
14:38:26 <jokke_> http://logs.openstack.org/32/443632/4/check/gate-glance-python35/9f6f124/console.html#_2017-03-10_12_51_30_241611
14:38:43 <rosmaita> we've got time, let's all look now
14:41:18 <dharinic> I think we need it here paste_deploy_opts
14:41:25 <dharinic> oops. https://github.com/openstack/glance/blob/master/glance/opts.py
14:42:05 <dharinic> actually not. Apologies.
14:42:23 <dharinic> jokke_ added the opts under an existing group.
14:42:59 <jokke_> yes that option should be in the DEFAULT
14:43:48 <jokke_> so I really think that patch is either not basing correctly or we overwrite the conf object (not the input to config parser) somewhere ... 'cause it should pick up the default even not specified
14:45:25 <stevelle> we don't need to import it, like show_multiple_locations do we?
14:47:20 <jokke_> it should come with the import from glance.common.config
14:47:32 <jokke_> but that said, I'm not convinced anymore
14:47:49 <hemanthm> jokke_: what patch does that depend on?
14:48:14 <jokke_> hemanthm: the workflow patch that depends on the config patch
14:48:30 <dharinic> the config patch: https://review.openstack.org/#/c/391441/4
14:48:59 <dharinic> workflow patch: https://review.openstack.org/#/c/391442/
14:49:00 <hemanthm> so, I don't see that in my git log when I download that patch
14:49:01 <stevelle> depends on sha bb0acf1278b3e9cfe9ff4b0eba094a73f4534512 // WIP:Add api_image_import flow 42/391442/4
14:49:19 <stevelle> rather, child of
14:49:56 <hemanthm> I mean, I don't see the patch that's adding the config opt in the git log. So, maybe the dependency chain is messed up?
14:50:01 <hemanthm> or is it just me?
14:50:07 <jokke_> hemanthm: and that why I'm not convinced that it's based correctly in gerrit ... I tried to rebase it but the output was the same
14:50:35 <jokke_> and I'm not sure how it should work when you pull it down from gerrit
14:50:45 <jokke_> that's why I'm crying for help ;)
14:50:53 <jokke_> as I don't know anymore
14:51:07 <hemanthm> it should pull down all commits it depends on
14:51:29 <hemanthm> here's what I see.
14:51:29 <hemanthm> http://paste.openstack.org/show/604865/
14:51:34 <jokke_> ok ... so the dependency chain is definitely messed up in gerrit then
14:51:41 <dharinic> I would manually try adding dependency branch wise.
14:52:25 <stevelle> it looks right to me, this change is grandchild of the one that introduces config
14:52:58 <stevelle> hemanthm: https://review.openstack.org/gitweb?p=openstack/glance.git;a=log;h=9b2deb9a13f3a74cb694d7ad55eaeac57d393b94
14:53:03 <hemanthm> stevelle: do you see all ancestors when you pull that change down?
14:55:38 <stevelle> hemanthm: yes, when I use checkout
14:55:52 <stevelle> git fetch https://git.openstack.org/openstack/glance refs/changes/32/443632/3 && git checkout FETCH_HEAD
14:56:22 <dharinic> I do not the see the ancestors when i download that patch
14:56:26 <hemanthm> ok, so just downloading the review won't pull dependencies?
14:56:50 <stevelle> you say downloading the review, that's ambiguous to me :)
14:56:54 <dharinic> Whereas actually with just a git review -d, ideally we should be able to see it
14:56:57 <hemanthm> git review -d
14:57:06 <hemanthm> yeah, that's what I'd expect
14:57:16 <rosmaita> me too
14:57:47 <hemanthm> I did see the dependencies when I was working rolling upgrades chain
14:57:50 <dharinic> I can say that with confidence cos just yesterday i created a manual branch wise dependency and downloading (git review -d) the child, pulls the parent and appears on the git log
14:58:01 <rosmaita> ok, let's continue in openstack-glance, it would be great if we could get jokke_ unstuck
14:58:05 <stevelle> I never use review -d, just out of habit
14:58:12 <rosmaita> #topic open discussion
14:58:20 <rosmaita> anyone got anything?
14:58:24 <jokke_> stevelle: yeah
14:58:28 <jokke_> -st
14:58:40 <hemanthm> rosmaita: o/
14:58:41 <jokke_> I'll be in Boston ... anyone else got confirmed yet?
14:58:44 <nikhil> will try to provide feedback on the doc for release stuff later today
14:58:58 <stevelle> thanks
14:59:01 <hemanthm> I was thinking about organizing an on-boarding event every two weeks or so
14:59:02 <blancos> Just a question about Glance v1 deprecation plans: Is that something that's going to be removed during Pike?
14:59:22 <jokke_> blancos: no
14:59:27 <rosmaita> blancos: no, but it hasn't been announced yet
14:59:40 <blancos> jokke_ rosmaita Okay, thank you
14:59:40 <jokke_> just realistically not possible
15:00:02 <rosmaita> ok, got to stop
15:00:06 <rosmaita> #endmeeting