14:00:01 <rosmaita> #startmeeting glance
14:00:01 <rosmaita> #topic roll call
14:00:02 <openstack> Meeting started Thu Apr 27 14:00:01 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:05 <openstack> The meeting name has been set to 'glance'
14:00:13 <rosmaita> o/
14:00:31 <jokke_> o/
14:00:58 <rosmaita> hi erno
14:01:14 <rosmaita> let's wait two more minutes
14:02:03 <jokke_> yeah
14:04:12 <rosmaita> ok, i guess we can get started
14:04:36 <rosmaita> topic #updates - agenda archive
14:04:46 <rosmaita> oops
14:04:53 <rosmaita> #topic updates - agenda archive
14:05:05 <jokke_> I guess we might be quick today
14:05:11 <rosmaita> yeah
14:05:25 <rosmaita> ok, i moved each year of agenda onto its own etherpad
14:05:44 <rosmaita> the were like 50K lines in the current etherpad, made it slow to load
14:05:44 <slaweq_> hello
14:05:52 <rosmaita> slaweq_: welcome
14:06:02 <rosmaita> #topic updates - new operator survey
14:06:13 <jokke_> aha! ... good call ... I'm not even sure how worthy it was to save ;)
14:06:21 <rosmaita> we have a new survey going to get info about glance cache usage
14:06:32 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-operators/2017-April/013236.html
14:06:57 <rosmaita> that's what i sent to the ops list, if any of you also operate a cloud, feel free to take the survey
14:07:04 <rosmaita> (link is in that email)
14:07:06 <nikhil> .\
14:07:13 <rosmaita> hi nikhil
14:07:28 <jokke_> any responses so far?
14:07:48 <rosmaita> haven't looked, been kind of distracted lately :)
14:08:32 <rosmaita> 7 responses!
14:09:14 <jokke_> \\o \o/ o// o/7
14:09:16 <rosmaita> i'll send a reminder out on monday, i think the survey closes on Thursday
14:09:22 <jokke_> sounds good
14:09:30 <rosmaita> that's a good response, i think our best so far has been 9
14:09:56 <rosmaita> #topic updates - wsgi goal
14:09:59 <nikhil> Maybe the word "all" helped
14:10:06 <rosmaita> :)
14:10:30 <rosmaita> ok, at the midcycle we said that the wsgi goal would ahve to slip
14:10:44 <rosmaita> but in the meantime, mtreinish has volunteered to take it on!
14:10:51 <rosmaita> so it may happen after all
14:11:03 <rosmaita> he's got 2 patches up
14:11:09 <jokke_> yeah, I haven't even looked why the gate fails on it 'though
14:11:22 <rosmaita> me neither
14:11:56 <rosmaita> anywya, just wanted to publicly say thanks to matt and cue us to keep an eye on his patches
14:12:12 <rosmaita> not sure if the gate prob is related to the next topic
14:12:28 <rosmaita> but before i move on, anyone else have an update to share?
14:12:37 <jokke_> quick one
14:12:53 <rosmaita> the floor is yours
14:13:06 <jokke_> the glance_store backport before EOLing does not look good
14:13:27 <jokke_> the change does not even pass Ocata gate due some cinder errors
14:13:38 <rosmaita> arrrrrgh
14:13:43 <jokke_> so I haven't been able to W+ it in to newton
14:14:08 <rosmaita> will tony kill us if we ask to wait to eol until after the summit?
14:14:41 <jokke_> I don't know and I'm not sure if it is really worth of it
14:15:21 <jokke_> as I haven't had opportunity to chase it either
14:16:15 <rosmaita> ok, i'll take a look after this meeting ends early, it seems like bad bug, but i need to look at teh bug again
14:16:34 <jokke_> yeah, lets sync up after and see what we do about it
14:16:40 <rosmaita> ok cool
14:16:44 <rosmaita> moving on
14:16:50 <rosmaita> #topic breaking change to deal with
14:17:01 <rosmaita> olso.config 4.0.0 released on Monday
14:17:16 <rosmaita> #link http://lists.openstack.org/pipermail/release-announce/2017-April/001370.html
14:17:37 <rosmaita> impact on us is that it's going to break a location_strategy test
14:17:50 <rosmaita> gcb submitted a patch
14:17:53 <rosmaita> #link https://review.openstack.org/#/c/457050/
14:18:14 <rosmaita> but, it fixes it by removing the test
14:18:34 <rosmaita> the problem is, we're using the 'choices' feature of oslo.config to make sure that an operator doesn't misspell the location_strategy they want to configure.  We also have code that checks for the presence of the configured location_strategy module.  That code is tested by overriding the oslo.cofig 'choices' (using an option that's basically been removed in 4.0.0) so that the configured value is the name of a non-existent strategy.  So we nee
14:18:43 <jokke_> I'd say we rather block the version
14:19:04 <jokke_> aha
14:19:15 <jokke_> so it's just breaking the test, not the actual code
14:19:22 <rosmaita> exactly
14:19:56 <rosmaita> yeah, in that series of patches there were 2 ways to fix
14:20:09 <jokke_> I still don't like remiving the test as solution. But otoh do we have anyone interested/able/willing to fix it?
14:20:14 <rosmaita> first one (i -1'd) was to remove 'choices' from the config
14:20:21 <rosmaita> current one is to remove the test
14:20:40 <jokke_> and does the test actually make sense?
14:20:52 <rosmaita> both good questions
14:21:03 <jokke_> we have quite a few tests lingering around that does not
14:21:20 <jokke_> I'll have a look if I have any input on that
14:21:21 <rosmaita> well, it's possible that someone could remove the module
14:21:27 <mtreinish> jokke_: sry to backtrack it's failing because of grenade on the sql image cache driver
14:21:27 <rosmaita> but, not likely
14:21:43 <rosmaita> mtreinish: oh, that's why you have that 2nd patch
14:21:58 <mtreinish> I used an external lock to synchronize between multiple worker processes (which uwsgi or apache) because they were racing on the db init
14:22:13 <mtreinish> but it added a mandatory config option for the lock path
14:22:14 <jokke_> mtreinish: ok, thanks! And thanks for stepping up and helping with that community goal.
14:22:18 <rosmaita> mtreinish: by the way, thanks for pitching in on this!
14:22:38 <mtreinish> sure, np
14:23:55 <mtreinish> the devstack patch: https://review.openstack.org/#/c/459451/ is more interesting
14:24:14 <mtreinish> it's stuck right now on image uploads because the wsgi protocol doesn't support chunked transfer encoding
14:24:21 <mtreinish> I need to figure out a workaround for that
14:24:54 <rosmaita> so you know, we ran up against that recently
14:25:11 <rosmaita> it was something dharinic was working on
14:25:49 <rosmaita> but i don't remember the patch, will have to look
14:26:16 <rosmaita> #action rosmaita - find wsgi chunked transfer encoding workaround
14:26:42 <rosmaita> #action rosmaita jokke_ - discuss glance_store EOL situation after meeting
14:26:45 <mtreinish> rosmaita: ok cool, thanks.
14:28:01 <rosmaita> ok, back to the location_strategy test
14:28:21 <rosmaita> i think it was really there for if/when we allowd operator configurable location_strategies
14:28:28 <rosmaita> i mean, custom strategies
14:28:36 <rosmaita> which so far we have not really supported
14:28:51 <rosmaita> so ATM, it's not really an essential test
14:29:27 <rosmaita> because if an operator removes parts of glance, they should expect stuff not to work right
14:29:46 <rosmaita> so i'm kind of inclined to accept gcb's current patch
14:29:52 <rosmaita> any thoughts?
14:32:53 <jokke_> might be
14:33:03 <jokke_> I have a look on that patch and comment on it
14:33:29 <rosmaita> ok, thanks, i will add a comment with what i said above
14:33:34 <rosmaita> and we can think about it
14:34:03 <rosmaita> mtreinish: take a look at this: https://review.openstack.org/#/c/423366/10/glance/common/wsgi.py
14:34:50 <mtreinish> rosmaita: ah ok, thanks.
14:35:03 <rosmaita> workaround for webob 1.7 not supporting chunked transfer encoding
14:36:41 <mtreinish> rosmaita: the issue here is that the request is being responded to outside of glance by uwsgi/apache and it never even makes it to glance code
14:39:04 <jokke_> I have a feeling that this was the blocker last time as well when we tried to get glance-api working as wsgi plugin
14:40:57 <rosmaita> yuck
14:41:31 <rosmaita> jokke_: i thihk you are correct
14:41:51 <rosmaita> i remember there was "one little thing" that was a blocker
14:42:02 <rosmaita> and i think this is it
14:42:21 <rosmaita> i guess no one else in openstack has this problem?
14:42:32 <rosmaita> trying to think of what other data apis there are
14:42:52 <mtreinish> I imagine swift will have similar problem
14:43:13 <mtreinish> and there is a note in the keystone apache docs about not using mod_wsgi if you use chunked requests
14:43:25 <mtreinish> but the keystone docs say mod_proxy-uwsgi works
14:43:33 <mtreinish> so I feel like I'm missing something
14:43:35 <jokke_> hmm-m
14:43:48 <mtreinish> in my patch
14:44:41 <mtreinish> uwsgi says it should work too: http://uwsgi-docs.readthedocs.io/en/latest/Chunked.html
14:44:47 <mtreinish> so I'm probably configuring something wrong
14:46:39 <jokke_> ok, sorry but did we have something else still in agenda? We're running short in time. If not I'm happy to continue this discussion or if there is lets move this to #openstack-glance after the meeting
14:47:20 <rosmaita> that's all ... we have 3 issues to discuss:
14:47:28 <rosmaita> 1  eol glance_store mitaka
14:47:40 <rosmaita> 2  gcb's patch
14:47:49 <rosmaita> 3  mtreinish 's wsgi situation
14:49:15 <jokke_> cool
14:50:51 <rosmaita> ok, in reverse order, i don't have anything useful to say about 3 ATM
14:51:48 <rosmaita> anyone else about #3?
14:52:08 <jokke_> not at the moment, I'm not that familiar with wsgi mods
14:52:22 <rosmaita> ok, sorry mtreinish
14:52:27 <jokke_> I just remember some people banging their heads against the wall with this before
14:52:50 <mtreinish> no worries, I'll figure something out eventually :)
14:53:12 <rosmaita> for #2, i am going to +2 the patch with my reasons as given above, and jokke_ and nikhil you can decide what you think
14:54:35 <rosmaita> as far as #1 goes, let's adjourn this meeting early and discuss it in #openstack-glance
14:54:51 <rosmaita> that way we won't get interrupted by having to end the meeting on time
14:55:07 <jokke_> ++
14:55:08 <rosmaita> but first i should ask:
14:55:13 <rosmaita> #topic open discussion
14:55:25 <rosmaita> anyone got anything?
14:55:41 <jokke_> just want to flag that the IIR patches are still in review Q
14:55:52 <jokke_> And we're closing Pike-2
14:56:00 * rosmaita hangs his head in shame
14:56:34 <rosmaita> which isn't very helpful
14:57:01 <rosmaita> i'm anticipating a bit of a disruption, i have to turn in all my equipment tomorrow
14:57:08 <rosmaita> but will try to look over the weekend
14:57:18 <rosmaita> ok, let's re-convene in #openstack-glance
14:57:22 <rosmaita> thanks everyone
14:57:24 <rosmaita> #endmeeting