14:00:41 <rosmaita> #startmeeting glance
14:00:43 <openstack> Meeting started Thu May 18 14:00:41 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:48 <openstack> The meeting name has been set to 'glance'
14:00:53 <rosmaita> #topic roll call
14:01:14 <rosmaita> hi kairat!
14:01:14 <kairat> o/
14:01:19 <rosmaita> glad to see you back
14:01:20 <abhishekk> o/
14:01:20 <jokke_> o/
14:01:26 <mfedosin> o/
14:01:28 <kairat> hello!
14:01:28 <jokke_> kairat! \o
14:01:43 <jokke_> kairat: how are you doing? Hope you're recovering well
14:02:12 <kairat> jokke_, good i can't use my left arm
14:02:29 <rosmaita> sorry to hear that
14:02:42 <abhishekk> kairat: take care
14:02:43 <rosmaita> but definitely glad to see you back online
14:02:48 <rosmaita> you had us worried!
14:02:49 <kairat> but it seems it need more time to recover
14:03:14 <kairat> thanks guys!
14:03:51 <rosmaita> good turnout today, but very light agenda
14:03:55 <jokke_> kairat: those things might get years ... as long as there is change happening, the hope is not lost
14:03:56 <rosmaita> we can have lots of open discussion!
14:04:05 <jokke_> \o/
14:04:23 <rosmaita> make up for all the meetings with 30sec open discussion
14:04:27 <rosmaita> ok, here we go
14:04:41 <rosmaita> #topic updates - post-summit report
14:04:56 <rosmaita> the summit was last week
14:05:11 <rosmaita> this was the first time with no design sessions
14:05:26 <rosmaita> supposed to focus on users (operators and end-users) and get feedback
14:05:35 <rosmaita> the glance sessions were pretty well attended
14:05:39 <rosmaita> we had:
14:06:20 <rosmaita> 1 - glance onboarding - there were maybe 15 people plus some current glance contributors
14:06:36 <rosmaita> hopefully we will get some contributors out of that
14:06:57 <rosmaita> be on the lookout for requests for help troubleshooting stuff in #openstack-glance
14:07:23 <rosmaita> 2 - glance update - maybe 30 people or so?
14:07:35 <jokke_> ish yeah
14:07:37 <rosmaita> people seem pretty happy with glance, believe it or not
14:08:05 <rosmaita> i'll digress for a minute about something that came up, becasue my memory is a bit hazy
14:08:25 <rosmaita> it had to do with fixing one of the OSSNs, the one where you can't purge the database
14:08:32 <jokke_> well I can fill in two things
14:08:43 <rosmaita> ok
14:09:30 <jokke_> setting image ID was pointed out to be critical at least by one operator so we should not break it (While Monty didn't even know about until recently and wasn't using it in his workflows)
14:09:53 <rosmaita> yeah, that came up at the "how do you use glance?" session
14:10:06 <jokke_> oh it was there, sorry
14:10:30 <rosmaita> we have a proposal to keep all the 'public' viz images in images table, not delete those during a purge
14:10:30 * jokke_ tries to think what might have been on the update then
14:10:52 <rosmaita> one operator pointed out that they have way more public images than private images
14:11:04 <jokke_> oh yeah and that was not liked by someone who is rolling insane amounts of public images in their cloud
14:11:08 <rosmaita> so it loooks like that won't solve the problem for that guy
14:11:45 <rosmaita> but i couldn't remember what he thought we should do ... was it put a policy on the specify-a-uuid-on-image-create ?
14:12:15 <jokke_> yeah he was pro on killing the uuid setting for the images
14:12:42 <rosmaita> so i think if we introduce the policy, and default it to '', that should be ok
14:12:55 <rosmaita> would be backward compatible, and allow operators to adjust for local usage
14:13:12 <rosmaita> on the other hand, it would be good to have a real solution to this problem
14:13:22 <jokke_> I'd prefer the later
14:13:27 <rosmaita> kairat: mfedosin: do you know any heavy-duty database people?
14:13:38 <rosmaita> this can't be only our problem (though maybe it is)
14:13:55 <rosmaita> we just want to block uuid re-use
14:14:02 <rosmaita> (except maybe by the admin)
14:15:21 <rosmaita> because we'll have to save the uuids of any image that was ever public, not just images that were public at the time of deletion
14:15:29 <kairat> rosmaita, nobody in mind, sorry
14:15:36 <rosmaita> kairat: thanks
14:15:57 <rosmaita> i'll put out an email to the dev list asking for help, then
14:16:15 <rosmaita> #action rosmaita - email dev list about blocking uuid reuse
14:16:18 <mfedosin> kairat: +1
14:16:46 <rosmaita> ok, back to the update
14:17:16 <rosmaita> 3 - "how do you use glance?" - pretty well attended, nikhil posted a tweet with a video clip of the "packed room"
14:17:23 <rosmaita> (actually about 1/2 full)
14:17:37 <rosmaita> but some lively discussion
14:17:46 <rosmaita> partly around uuid reuse, as jokke said earlier
14:18:03 <rosmaita> it's a functionality that is used and there will be great sadness if we remove it
14:18:12 <rosmaita> but also around "image lifecycle management"
14:18:24 <rosmaita> which no one agreed on exactly what it meant, but everyone wants it
14:18:33 <jokke_> Another thing that came up was that people are still waiting for the IIR work *wink**wink*
14:18:59 <rosmaita> oh, yeah ... that is quite true, they are counting on us getting that done
14:20:15 <rosmaita> so some operators there agreed to get together to propose a user story to the PWG (my preference) or to start a glance spec (which would be OK, but i think it would be better to know what's wanted before we start designing it)
14:20:26 <rosmaita> we'll see what happens
14:20:31 <jokke_> ++
14:20:48 <rosmaita> fei long and i have a patch at the pwg that's about 2 years old, didn't get a lot of love
14:21:15 <jokke_> main painpoint for them seems to be that they would like to retire images so that new instances couldn't be spawned easily from them but stuff like migrations would still work
14:21:33 <rosmaita> but that's about it for updates -- jokke_ or abhishekk or anyone else who was there, any other points?
14:22:41 <abhishekk> rosmaita: you have covered almost all points
14:22:57 <rosmaita> ok cool, i'll move on
14:23:08 <rosmaita> #topic updates - personnel situation
14:23:19 <rosmaita> i am happy to see kairat and mfedosin here today!
14:23:42 <rosmaita> don't know if you know about the OSIC intel/rackspace project closing
14:24:02 <rosmaita> has left several cores and the PTL jobless, or without openstack jobs
14:24:04 <mfedosin> yes, I'm aware about it
14:24:34 <mfedosin> rosmaita: what about you?
14:24:41 <rosmaita> still looking
14:25:14 <rosmaita> want an openstack job that will let me work upstream without relocating, and that has not been easy to find
14:25:24 <rosmaita> particularly for glance
14:25:48 <rosmaita> people seem to think it's working fine (except for image import, they want that), so not much commitment to working on it
14:26:23 <rosmaita> so i'm looking at other stuff too ... jokke_ has agreed to become emergency PTL if necessary
14:26:37 <rosmaita> and the TC is aware of the situation
14:27:12 <rosmaita> but anyway, my point in bringing this up is that there are openings on the glance core list for people who want to contribute for Pike
14:27:16 <rosmaita> :)
14:27:55 <rosmaita> don't know what everyone's situation is with respect to having time on upstream glance work, though
14:28:25 <mfedosin> it's tempting
14:28:27 <mfedosin> :)
14:28:39 <rosmaita> so on that happy note, let's talk about image import
14:28:47 <rosmaita> #topic image import update
14:29:20 <rosmaita> jokke_ pulled me into an alley in boston and kept me there until i reviewed his patches
14:29:37 <rosmaita> not sure what happened after that
14:29:38 <jokke_> ;)
14:29:41 <rosmaita> jokke_: update?
14:31:06 <jokke_> one of them is still failing tests
14:31:29 <jokke_> https://review.openstack.org/#/c/443636/
14:32:12 <jokke_> the config change you merged and I need to get Flavio having look at that taskflow patch specially so that I haven't missed anything there
14:32:40 <rosmaita> ok
14:33:30 <rosmaita> i'd like to either rebase or recheck 443636 to get fresh results to look at
14:33:34 <rosmaita> which would be better?
14:33:54 <jokke_> I'm digging into that failure and working on the further changes to address some of the concerns and hardening the functionality
14:34:06 <rosmaita> ok, ping me when it's updated, then
14:34:43 <rosmaita> #topic open discussion
14:34:49 <jokke_> the errors on the tests looks legit, just can't figure out how they popped up right now
14:35:15 <rosmaita> one quick thing from me, i need to look at where we are on the "community goals" and will report back next week
14:35:26 <rosmaita> mtreinish picked up the wsgi goal
14:35:42 <rosmaita> alex_bash has left, don't think the py35 goal is completed yet
14:36:03 <jokke_> I have not looked, how is the work looking, was he able to get the dependencies merged?
14:36:05 <rosmaita> #action rosmaita - look at where we are on community goals before next meeting
14:36:29 <jokke_> the py35 is not complete and I don't think we have anyone working on it
14:36:31 <rosmaita> jokke_: i talked to mtreinish at the summit, he thought he had a way forward on that
14:36:40 <jokke_> rosmaita: gr8!
14:37:15 <rosmaita> yes, no one currently working on py35
14:37:24 <rosmaita> i'm not sure what's left, need to look
14:37:39 <rosmaita> hopefully not too much
14:37:54 <rosmaita> that's all from me ... anyone else with open discussion topics?
14:37:57 <abhishekk> is  python-glanceclient gate is broken?
14:38:13 <jokke_> I think we merged the last patch of Alex after he changed the commit message to not claiming that the goal is achieved (as it disabled tons of tests on py35 to get the gating pass)
14:38:44 <rosmaita> i guess that patch gives us a list of the tests that need to be fixed
14:39:08 <rosmaita> i'll put together an etherpad to make it easy for interested parties to pick things up
14:39:26 <jokke_> it should at least give us indication ... I think we need to search for the tests that are skipped on py35 and see if the list is complete or not
14:39:36 <rosmaita> could be a good thing for new contributors. learn about glance by fixing tests
14:39:44 <rosmaita> (need to make that sound sexy, though)
14:40:20 <rosmaita> #action  rosmaita - put together etherpad of py35 tests that are currently skipped
14:40:48 <rosmaita> ok, i think i have enough to do for this coming week
14:40:57 <jokke_> "Work on Glance, become fat, grumpy and disorganized like jokke_" ... oh wait, no that didn't sound like sexy marketing talk, right ;P
14:41:26 <rosmaita> depends on how you feel about fat, grumpy, disorganized people ... some people are probably really into that!
14:41:44 <rosmaita> there's probably a special dating service
14:41:58 <rosmaita> we need to find it and advertise!
14:42:05 <jokke_> ;)
14:42:18 <rosmaita> become more sexy by working on glance!
14:42:46 <rosmaita> well, this channel is logged, so if someone by chance googles 'glance' and 'sexy', they will find this conversation
14:43:15 <rosmaita> i think we should just declare ourselves the sexiest project in openstack and see what happens
14:43:41 <rosmaita> in fact, that will be the subject of my email about uuid reuse
14:43:52 <rosmaita> [glance] the sexiest project in openstack
14:44:00 <jokke_> yes ... is there "definitely-sexy" tag or do we need to contact tc?
14:44:15 <rosmaita> jokke_: you def need to propose that to the TC!
14:44:32 <rosmaita> either that, or we just apply it to ourselves
14:44:45 <rosmaita> sounds like a mfedosin patch, actually
14:44:52 <rosmaita> like the one he did introducing typos
14:45:23 <mfedosin> I can revive it if you want ;)
14:45:34 <mfedosin> and add even more typos!
14:45:36 <jokke_> ok, should we take that 15min we have left and do something productive with it?
14:45:49 <jokke_> like end the meeting
14:45:51 <rosmaita> "Potential contributors are having difficulty determining what projects to work on.  We propose to fix that with the tc:definitely-sexy tag"
14:46:05 <rosmaita> ok, enough silliness
14:46:17 <jokke_> ;)
14:46:38 <rosmaita> ok, thanks for attending, everyone ... anyone who wants to help with image import refactor, ping jokke_ , he can tell you what needs attention
14:46:52 <rosmaita> any final business?
14:46:53 <jokke_> \o/
14:47:48 <rosmaita> ok, hearing none, i declare this meeting ended ... have a productive rest of the day, everyone!
14:47:55 <rosmaita> #endmeeting