14:01:27 <rosmaita> #startmeeting glance
14:01:28 <openstack> Meeting started Thu May 25 14:01:27 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:29 <rosmaita> #topic roll call
14:01:31 <openstack> The meeting name has been set to 'glance'
14:01:40 <abhishekk> o/
14:01:50 <jokke_> o/
14:01:53 <mfedosin> o/
14:02:06 <rosmaita> sorry for the late start, i was catching up on the dev list
14:03:25 <rosmaita> ok, guess we have a quorum, here we go ...
14:03:33 <rosmaita> #topic updates - happy towel day
14:03:39 <rosmaita> https://lemonly.com/wp-content/uploads/2012/05/Towel-day-Infographic2.jpg
14:03:47 <rosmaita> might as well have something to be happy about!
14:03:59 <rosmaita> #topic updates - glance personnel situation
14:04:27 <rosmaita> guess you've seen the ML ... stevelle, dharinic, and hemanthm have all stepped down from glance-core
14:04:41 <mfedosin> https://s-media-cache-ak0.pinimg.com/736x/f4/99/cf/f499cffdba28e5ae3854a012d8314d4e.jpg
14:04:54 <jokke_> yeah :(
14:05:06 <rosmaita> mfedosin: :)
14:05:18 <rosmaita> they all leave big holes in the project
14:05:40 <rosmaita> especially hemanthm , who was coresec and the release CPL for pike
14:05:45 <abhishekk> right :(
14:05:59 <rosmaita> and P-2 is coming up in 2 weeks, i believe
14:06:07 <jokke_> soon
14:06:54 <jokke_> I quess I assume the release liaison role as I've done it before
14:07:07 <rosmaita> jokke_: that would be very helpful
14:07:12 <mfedosin> I've created a topic about my return to core team...
14:07:25 <rosmaita> mfedosin: i saw, item 6
14:07:34 <rosmaita> let's move it up and discuss now
14:07:37 <mfedosin> we can discuss it now or postpone it to 6
14:07:39 <rosmaita> what's your current situation?
14:08:23 <mfedosin> I'm working on Glare :)
14:08:39 <rosmaita> that's nice :)
14:08:48 <mfedosin> and I think will continue for several months
14:09:14 <mfedosin> but I talked to my manager and he approved my desire to take part in the Glance project.
14:09:24 <rosmaita> that's good
14:09:33 <mfedosin> especially because glare and glance have much in common
14:09:34 <jokke_> :)
14:10:01 <mfedosin> I've implemented a lot of tests for glare that can be applied for glance, for example
14:10:09 <mfedosin> So I can spend some time reviewing the code and writing small patches.
14:10:59 <mfedosin> so yes, I want to return and help the project
14:11:01 <rosmaita> more tests would be good
14:11:05 <mfedosin> as much as I can
14:11:06 <abhishekk> mfedosin: good to hear that
14:11:12 <rosmaita> and your help would be appreciated
14:11:25 <mfedosin> I constantly receive messages in the IRC and by mail with a request to review something.
14:11:26 <rosmaita> i don't know whether this is an appropriate request, but here goes anyway
14:11:35 <mfedosin> in glance or related projects
14:11:54 <rosmaita> can we agree not to discuss anything about glance-glare project integration until the Queens PTG?
14:11:57 <mfedosin> But unfortunately without the core status my actions are hardly useful.
14:12:10 <mfedosin> okay :)
14:12:19 <mfedosin> rosmaita: ^
14:12:28 <rosmaita> cool, we just don't need the extra distraction
14:12:36 <rosmaita> but we definitely need the help
14:13:01 <mfedosin> as I said - I'll try to do as much as I can
14:13:15 <rosmaita> my feeling is that you are a high-quality engineer, and you certainly know the glance code base well
14:13:15 <mfedosin> What do you think?
14:13:58 <mfedosin> And I know how bad the code is :)
14:14:08 <rosmaita> not "bad", just "special"
14:14:11 <rosmaita> :)
14:14:25 <rosmaita> here's my honest opinion
14:14:37 <rosmaita> ordinarily, i'd wait a bit and let you do more reviews, etc.
14:14:43 <rosmaita> but these are not ordinary times
14:15:03 <rosmaita> so unless someone here has an objection
14:15:21 <rosmaita> i will propose your reinstatement to the ML, and we can see what hte rest of the community thinks
14:15:22 <mfedosin> should I write an email somewhere?
14:15:31 <rosmaita> i'll do it
14:15:42 <mfedosin> ah, okay, thank you!
14:15:56 <rosmaita> i definitely appreciate you stepping up like this, mike
14:16:17 <mfedosin> my pleasure
14:16:26 <rosmaita> and there is a still-open security bug that can use your help :)
14:16:51 <rosmaita> speaking of which ... the fix for that has become complicated enough that it needs a spec
14:17:02 <jokke_> :(
14:17:04 <mfedosin> you have no idea how many people wrote me about that
14:17:10 <rosmaita> i will get that posted soon on the bug
14:17:13 <jokke_> that's the one we discussed in the summit?
14:17:16 <rosmaita> (hopefully this afternoon)
14:17:23 <rosmaita> jokke_: yes, same one
14:17:35 <mfedosin> The Bug
14:17:38 <rosmaita> mfedosin: i believe you are already subscribed to the bug, you will get an email when i update it
14:17:43 <rosmaita> yes, that one!
14:18:18 <rosmaita> i was really hoping hemanthm could review that spec, i will still ask him, don't knwo what his time situation is, though
14:18:42 <rosmaita> ok, next topic
14:18:52 <rosmaita> #topic community goals report
14:19:16 <rosmaita> i didn't have time to make the python 3.5 etherpad this week
14:19:37 <rosmaita> but mtreinish has helpfully posted his wsgi goal patches
14:19:48 <rosmaita> let's make those a priority for review this week
14:19:59 <rosmaita> #link https://review.openstack.org/#/q/status:open+project:openstack/glance+branch:master+topic:goal-deploy-api-in-wsgi
14:20:08 <mtreinish> the glance side is pretty straightforward
14:20:11 <rosmaita> #link https://review.openstack.org/#/c/459451/
14:20:28 <mtreinish> the devstack is a bit more invovlved because I needed to do things a bit differently to work with chunked transfer encoding
14:20:36 <mtreinish> but it's still not that bad
14:22:00 <rosmaita> mtreinish: yes, in some clouds "several gigabytes" is close to a terabyte
14:22:14 <rosmaita> so i appreciate your extra work on 459451
14:23:42 <rosmaita> ok, there are already some +2s, so let's make an effort to get matt's stuff reviewed this week
14:24:04 <rosmaita> #topic image import update
14:24:20 <rosmaita> jokke_: anything to report/request?
14:24:49 <jokke_> yes
14:25:16 <jokke_> quick one ... flavio looked through the taskflow change and approved :)
14:25:28 <rosmaita> cool
14:26:07 <jokke_> obviously something broke but I have high hopes that once https://review.openstack.org/#/c/467145 merges I recheck those
14:27:33 <jokke_> meanwhile I've been looking for next patches to complement the intial including client side
14:27:49 <jokke_> and those help text changes etc.
14:28:39 <jokke_> I just try to get the two approved patches landed as my local repo is totally mess atm. and clean base would be super nice ;)
14:29:29 <jokke_> also something is horribly broken on that https://review.openstack.org/#/c/443636 I haven't figured out yet
14:30:05 <jokke_> it passed gate multiple times before but that just might be again some rebasing issues I'm hoping to clarify once the two patches lands
14:31:26 <rosmaita> ok, thanks ... what do you want me to say in the weekly priorities email?
14:31:45 <jokke_> so unblocking 391442 and 443632 are my top priorities above anything else atm.
14:32:07 <jokke_> feel free ... if it has some effect, even better ;)
14:32:48 <rosmaita> well, it's probably only us people here who will read it
14:32:51 <rosmaita> :(
14:33:26 <rosmaita> ok, thanks erno
14:33:49 <rosmaita> i forgot to give myself some actions
14:34:08 <jokke_> but that's it from me ... epect me to ping people around to for reviews once the next ones are in the pipeline/unblocked
14:34:08 <rosmaita> #action rosmaita email nominating mfedosin to glance-core
14:34:32 <rosmaita> #action rosmaita list mtreinish wsgi patches in priorities email
14:35:00 <rosmaita> #action rosmaita list erno's 391442 and 443632 in priorities email
14:35:15 <rosmaita> next topic
14:35:28 <rosmaita> #topic glance-specs action
14:35:41 <rosmaita> #link https://review.openstack.org/#/q/status:open+project:openstack/glance-specs+branch:master
14:36:25 <rosmaita> there are 2 +2s on https://review.openstack.org/#/c/451560/ ... jokke_ can you +A?
14:37:11 <rosmaita> it will go into the to-be-created "untargeted" specs directory
14:37:30 <rosmaita> same with https://review.openstack.org/#/c/206120/
14:37:47 <rosmaita> (though that only has 1 +2 atm)
14:38:13 <rosmaita> and same with https://review.openstack.org/#/c/448680/
14:38:35 <rosmaita> i'd just like to get those available in case someone new shows up and is interested in something to work on
14:38:45 <rosmaita> (actually, the first one is close to implemented)
14:39:13 <rosmaita> and, finally, i put up the pike priorities: https://review.openstack.org/#/c/468035/
14:39:18 <jokke_> wil look the later two ... first one +A'd
14:39:27 <rosmaita> ty
14:39:39 <jokke_> I know it was yours but I assumed we still had the agreement PTL +As specs
14:39:57 <rosmaita> oh, i forgot about that
14:39:58 <jokke_> but happy to do so if we have lifted that at this point
14:40:22 <rosmaita> yeah, i feel weird about +Aing my own stuff
14:40:32 <jokke_> I hear ya
14:40:58 <rosmaita> one more spec-related item from me
14:41:33 <rosmaita> i took the action item last week to investigate a fix for 0075, the ossn blocking people from purging the glance db
14:41:50 <rosmaita> i remembered that jay pipes has/had a blog called join-fu about databases
14:41:59 <rosmaita> so i asked him what he thought
14:42:30 <rosmaita> his response was that keeping track of the retired image IDs isn't really a database problem per se ...
14:42:35 <rosmaita> it's just a big problem
14:42:54 <rosmaita> so my hope that there was some kind of groovy database solution already known was in vain
14:43:13 <rosmaita> his opinion, which i think is the same as mine and hemanthm's at some point
14:43:37 <rosmaita> is that we need a policy to restrict image_id specification at image-creation time
14:43:47 <rosmaita> and let operators decide what to do about it
14:43:51 <jokke_> I'm still inclined to block that
14:43:56 <rosmaita> why?
14:44:00 <rosmaita> it's optional
14:44:06 <efried> #link http://www.joinfu.com/  <== that?
14:44:41 <rosmaita> efried: yes, looks like "had a blog" is the correct way to describe it!
14:44:58 <jokke_> I would never believed to use this, but that will introduce interoperability issue for something that we have discussed can be fixed without
14:45:18 <rosmaita> i don't see an interoperability issue at all
14:45:41 <rosmaita> i mean, it's like property protections
14:45:50 <jokke_> specially after the summit discussion where we had exactly 1 vite for "never use it, don't need" and "absolutely necessary"
14:45:53 <rosmaita> in some clouds, you can't create particular metadata
14:46:10 <rosmaita> i know, so "never use it" can protect with policy
14:46:20 <rosmaita> "absolutely need it" can leave it available
14:47:27 <rosmaita> i know that rackspace ran into performance issues with too much soft-deleted stuff in the images table
14:47:48 <rosmaita> they haven't exposed the ability to end users, so they were able to purge
14:47:51 <jokke_> that still introduces yet another place where those two coulds would behave differently on their public APIs
14:48:03 <rosmaita> not really
14:48:11 <rosmaita> you can just assume "can't do it" for all clouds
14:48:20 <rosmaita> and if you can, it's a nice surprise
14:48:39 <jokke_> well that's the problem ... as since the beginning of the time you have been able to assume can do
14:48:43 <jokke_> on all clouds
14:49:05 <rosmaita> yeah, but this is a security problem
14:49:18 <rosmaita> well, we can fight this out on the spec
14:49:25 <rosmaita> anyway, i was going to do a spec-lite
14:49:26 <jokke_> yup ;)
14:49:36 <rosmaita> but i will do a short full-spec so we can list the alternatives
14:49:50 <rosmaita> and then send out a message to operators for review
14:50:20 <rosmaita> ok, thanks for the quick discussion
14:50:39 <rosmaita> #topic python-glanceclient
14:50:58 <rosmaita> the word on the street is that someone has been asking for a release of glanceclient in #openstack-glance ?
14:51:06 <rosmaita> anyone present?
14:51:28 <efried> o/
14:51:37 <efried> My interest in a new glanceclient release is to unblock https://review.openstack.org/#/c/412634/ (related to the service-tokens blueprint).
14:51:43 <efried> The fixes, which recently merged, are https://review.openstack.org/466385 and https://review.openstack.org/396816
14:51:45 <jokke_> I was gonna ask that after those couple of fixes that was landed to unbreak the gate
14:51:53 <efried> Yuh, ^^
14:52:19 <rosmaita> #link https://review.openstack.org/#/q/status:open+project:openstack/python-glanceclient+branch:master
14:52:24 <rosmaita> those are the open patches
14:52:29 <abhishekk> If possible can some one review my small patches so that they can be part of release?
14:52:54 <rosmaita> abhishekk: i looked at yours this morning, did you figure out the weird https cert breakage?
14:53:06 <rosmaita> same test failing in py27 and py35
14:53:17 <rosmaita> (at least as of an hour ago)
14:53:22 <abhishekk> Patch is submitted for that which has merged today only
14:53:33 <abhishekk> I have added recheck for the same
14:53:52 <abhishekk> I guess yessterday nikhil has apprived that patch
14:54:17 <abhishekk> s/approvex
14:54:30 <rosmaita> ok, it would be helpful if we make a list now of the patches that need to get into a release
14:54:46 <rosmaita> would next wed be good to do a release?
14:55:20 * efried consults pike release schedule...
14:55:37 <jokke_> I don't think we're release ready today, def not want to release on Fri with skeleton crew
14:55:45 <rosmaita> agreed
14:55:56 <rosmaita> that's why i'm thinking day before next glance meeting
14:56:06 <abhishekk> Agree
14:56:06 <jokke_> so early next week is fine by me if we're ready by that
14:56:08 <rosmaita> efried: https://releases.openstack.org/pike/schedule.html
14:56:11 <efried> Sounds good to me.
14:56:42 <efried> That should leave enough time to resurrect the service token stuff in nova
14:56:57 <rosmaita> jokke_: can you hit https://review.openstack.org/#/c/457974/ real quick? docs patch
14:57:19 <rosmaita> efried: what are the patches you need in?
14:57:33 <efried> https://review.openstack.org/466385 and https://review.openstack.org/396816  (both already merged)
14:57:44 <efried> They unblock the gate, too.
14:57:52 <rosmaita> which is a nice bonus!
14:57:56 <rosmaita> ok, cool
14:58:06 <rosmaita> abhishekk: which are the patches you want in?
14:58:14 <rosmaita> and is there anything else necessary?
14:58:25 <abhishekk> Just a min
14:58:55 <rosmaita> efried: sorry, i didn't realize your patches had already merged
14:58:56 <abhishekk> https://review.openstack.org/444104
14:59:07 <jokke_> time check
14:59:14 <abhishekk> And Downloading image with --progress fails
14:59:30 <abhishekk> https://review.openstack.org/445318
14:59:46 <rosmaita> ok, i will put those in priority list, we will try to get merged over next few days
14:59:59 <rosmaita> and aim for release on wed may 31
15:00:02 <abhishekk> Thank you rosmaita
15:00:06 <rosmaita> np
15:00:13 <rosmaita> ok, thanks everyone!
15:00:16 <abhishekk> Thanks to all
15:00:17 <rosmaita> happy towel day
15:00:17 <jokke_> Thanks all
15:00:21 <rosmaita> #endmeeting