14:00:01 <rosmaita> #startmeeting glance
14:00:02 <openstack> Meeting started Thu Jun  1 14:00:01 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:06 <openstack> The meeting name has been set to 'glance'
14:00:11 <rosmaita> #topic roll call
14:00:19 <mfedosin> o/
14:00:24 <abhishekk> o/
14:00:43 <rosmaita> \o to you both
14:00:52 <rosmaita> erno said he will be a few minutes late
14:01:30 <abhishekk> ok
14:01:33 <rosmaita> i'll wait another minute for any stragglers
14:02:39 <rosmaita> ok, let's get started!
14:02:40 <jokke_> o/
14:02:41 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:52 <rosmaita> great, everyone is here!
14:03:18 <rosmaita> #topic update - congratulate mfedosin for reinstatement as glance core
14:03:23 <mfedosin> I like the first topic
14:03:30 <jokke_> :)
14:03:37 <jokke_> Welcome back Mike!
14:03:38 <rosmaita> as expected, i heard only positive comments, so mike's been added to the glance-core list
14:03:52 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/117785.html
14:03:52 <mfedosin> thank you folks :)
14:04:01 <mfedosin> I have an excuse to open a bottle of champagne tonight
14:04:01 <rosmaita> thank you for stepping up, mike!
14:04:12 <rosmaita> glad to give you an excuse!
14:04:31 <rosmaita> #topic updates - pike priorities
14:04:34 <abhishekk> mfedosin: cheers :)
14:04:47 <rosmaita> this has been sitting around: https://review.openstack.org/#/c/468035/
14:05:19 <rosmaita> could use some quick love so our priorities are posted
14:05:39 <rosmaita> i was tempted to ninja-approve it, but i would really prefer that it actually be reviewed
14:05:42 <rosmaita> :)
14:05:50 <mfedosin> so, the deadline is on 24th of July?
14:06:22 <rosmaita> yep, that's the feature freeze
14:06:28 <rosmaita> openstack-wide, not just glance
14:07:08 <mfedosin> I had thoughts to implement multi-store support for glance_store...
14:07:28 <rosmaita> yeah, that may have to wait until Queens
14:07:28 <mfedosin> but it seems I have to wait until next cycle
14:07:36 <rosmaita> we really need to get image import done
14:07:54 <mfedosin> okay, I'll concentrate on review first
14:08:00 <rosmaita> cool
14:08:16 <rosmaita> #topic updates - meeting next week?
14:08:31 <jokke_> https://review.openstack.org/#/c/468885/ https://review.openstack.org/#/c/443636/ https://review.openstack.org/#/c/443633/ https://review.openstack.org/#/c/468835/ :P
14:08:36 <rosmaita> i will be travelling, not sure i will be available for 14:00 utc meeting
14:08:46 <jokke_> The first one is gonna hopefully hit the gate now
14:08:53 <jokke_> and unblocks the 3rd one :)
14:09:05 <rosmaita> question is: does someone want to hold it, or should we cancel?
14:09:16 <jokke_> I can host it
14:09:23 <jokke_> if you're not around
14:09:27 <rosmaita> jokke_: some weird stuff happening on the gate, new setuptools broke a bunch of stuff (anything using six)
14:09:41 <rosmaita> plus ansible missing on a bunch of hosts
14:09:49 <jokke_> rosmaita: there were at least 2 different things breaking stuff
14:09:52 <mfedosin> yeah, gates are broken since morning
14:10:04 <rosmaita> ok, jokke_ has volunteered to host next week's meeting
14:10:11 <jokke_> I've been following infra whole day and it looks like it's finally unblocked
14:10:12 <mfedosin> I'll join
14:10:29 <rosmaita> #action jokke_ will host 8 june glance meeting
14:10:52 <jokke_> so when the gates are moving and the release tooling fixed we probably should try to get that glanceclient out today
14:10:57 <rosmaita> #topic community goals report
14:11:29 <rosmaita> i didn't have time to look carefully at mtreinish 's patches for the wsgi goal
14:11:50 <rosmaita> i noticed abhishekk left some comments
14:12:00 <rosmaita> will carry those over for next week's priorities
14:12:19 <rosmaita> as far as the py35 goal, i put together the etherpad
14:12:22 <abhishekk> yes
14:12:30 <rosmaita> #link https://etherpad.openstack.org/p/glance-pike-python35-goal
14:12:59 <rosmaita> looks like the remaining work is around https tests
14:13:04 <rosmaita> but that's all i could find
14:13:40 <abhishekk> yes IMO thats onlly thing is pending
14:13:49 <rosmaita> ok, thanks for the confirmation
14:14:10 <mfedosin> I can take a look at the wsgi patch - I've already implemented one in the project-which-must-not-be-named
14:14:18 <rosmaita> i haven't looked into how complicated that will be to fix, or whether its dependent on other changes
14:14:27 <rosmaita> mfedosin: great! that would be helpful
14:15:19 <rosmaita> #topic image import update
14:15:47 <rosmaita> jokke_: gave us a preliminary view with the patches posetd above
14:16:08 <rosmaita> (i am having internet slowdown)
14:16:29 <jokke_> yeah, sorry being bit eager with linking those :P
14:16:41 <rosmaita> np, anything else you want to say?
14:17:05 <jokke_> when we get those in, we have MVP together
14:17:24 <rosmaita> i am glad you said that!
14:17:43 <jokke_> at that point I will rebase my local branches against master to avoid long chains again and start pushing updates to those and work the client side as well
14:17:50 <rosmaita> good motivation for getting those in
14:18:13 <jokke_> unless anyone else wants to take that client side on
14:18:14 <rosmaita> is the current status waiting for them to merge, or do you still need some reviews?
14:19:00 <jokke_> the 3 last ones needs to be reviewed ... (again) they had to be rebased, which did not happen clenly
14:19:05 <jokke_> cleanly
14:19:18 <rosmaita> ok, will include that in the priorities email today
14:19:26 <rosmaita> anything else?
14:20:02 <jokke_> not really ... looking forward to get these in
14:20:28 <jokke_> oh the last one on that list of mine
14:20:49 <jokke_> it contains the doc text changes requested on the original review we pushed for later
14:21:13 <jokke_> so that should be easy to review and is based on master so should merge quickly
14:21:18 <rosmaita> ok, that's nice
14:21:47 <rosmaita> question: P-2 milestone is next week ... how destabilizing are these changes?
14:21:59 <rosmaita> (i am assuming not at all, let's get them in P-2)
14:22:29 <rosmaita> otherwise, we could cut P-2 now
14:22:40 <rosmaita> i don't want to holdup theimage import stuff at all
14:22:47 <jokke_> I'd prefer to have them in P-2
14:23:00 <rosmaita> i agree, anyone else ?
14:23:41 <abhishekk> +1
14:24:13 <rosmaita> ok, let's try to get them into P-2
14:24:28 <rosmaita> #topic releases update
14:24:48 <rosmaita> jokke_: i take it we did not do a new release of glanceclient yet?
14:25:11 <jokke_> nope
14:25:19 <rosmaita> #link https://review.openstack.org/#/c/467592/
14:25:28 <jokke_> I'd say we ask for it after the meeting if the release tooling is working again
14:25:30 <rosmaita> could everyone look at that right now?
14:25:49 <rosmaita> would like to include it unless there's a good reason not to
14:26:50 <mfedosin> looks good
14:27:02 <mfedosin> I'll approve it when gates are fixed
14:27:09 <rosmaita> excellent!
14:27:37 <rosmaita> ok, jokke_ let's cut glanceclient after https://review.openstack.org/#/c/467592/ is merged
14:27:53 <abhishekk> thank you rosmaita and jokke_ for review
14:28:27 <rosmaita> cool, that's glanceclient
14:28:37 <rosmaita> as far as glance itself goes
14:28:54 <jokke_> hate to nitpick on that change
14:29:05 <rosmaita> is there a problem?
14:29:20 <jokke_> so did not block it as it is, but the empty line really should be there between the class on function declaration
14:29:37 <jokke_> wondering why hacking checks did not catch it
14:30:26 <rosmaita> i am wondering the same thing, i thought i've gotten that error before
14:30:47 <abhishekk> jokke_: i don't think glance has specific hacking check to find out blank line after class definition
14:31:44 <abhishekk> does pylint gives that error?
14:32:58 <jokke_> I added the line back there .... I'm fine for you rosmaita to ninja it in
14:33:27 <rosmaita> looks like online pep8 is ok with no blank line there
14:35:32 <rosmaita> ok, when it passes gate i will ninja it in with ref to this meeting
14:35:52 <rosmaita> (and my connection has gotten worse, not sure what's up)
14:36:43 <rosmaita> ok, so after the above merges, jokke_ do you have time to set up the glance client release today or tomorrow?
14:36:58 <jokke_> rosmaita: I put in comment for it as well
14:37:05 <rosmaita> cool
14:40:22 <rosmaita> jokke_: glanceclient release?
14:40:43 <jokke_> need to request it after that change merges if we want it in
14:41:22 <rosmaita> right, just wanted to confirm that you have time tomorrow to put up the release patch?
14:41:34 <jokke_> no, today ;)
14:41:46 <rosmaita> even better!
14:41:48 <jokke_> I'm not gonna request release for Friday ;)
14:42:18 <rosmaita> ok, it's up to the gates, then
14:42:24 <jokke_> so if that change does not merge, then it goes to next Tue
14:42:33 <rosmaita> how many more hours are in your Thursday?
14:42:44 <jokke_> 7 ish
14:42:51 <jokke_> sorry 8 ish
14:43:35 <jokke_> if it breaks world I want to know about it tomorrow morning, not Tue morning :P
14:43:47 <jokke_> we have bank holiday at Monday
14:43:59 <rosmaita> #action rosmaita watch https://review.openstack.org/#/c/467592/ and notify jokke_ when it merges
14:44:08 <rosmaita> ok, osunds good
14:44:16 <rosmaita> sounds good, even
14:44:26 <rosmaita> ok, another question for jokke_
14:44:34 <jokke_> rosmaita: if I don't respond to IRC just ping me in Telegram ;)
14:44:44 <rosmaita> when do you want stuff merged to make the P-2?
14:44:50 <rosmaita> jokke_: ok, noted
14:45:02 <jokke_> hmm-m when was the deadline again?
14:45:11 <rosmaita> supposed to be next week
14:45:30 <rosmaita> (confirming)
14:45:46 <jokke_> next week, means Wednesday so we need really the stuff merged at Tue
14:46:14 <jokke_> and I'd request the tag tue evening then
14:46:22 <rosmaita> actually, release page says 8 june window
14:46:42 <rosmaita> so maybe we could push one more day
14:46:43 <rosmaita> ?
14:46:59 <jokke_> yeah ... lets say Wed 1200 utc
14:47:02 <rosmaita> up to you, though
14:47:13 <rosmaita> ok, i will make that clear in priorities email
14:47:23 <rosmaita> so the outstanding stuff is:
14:47:29 <jokke_> then we have time to fix any issues and get it really tagged at Thu
14:47:33 <rosmaita> image import (links above)
14:47:38 <rosmaita> wsgi goal
14:47:59 <rosmaita> we haven't really discussed the latter, but i don't think it's destabilizing
14:48:11 <rosmaita> so i don't see any reason to hold off on it?
14:48:22 <rosmaita> any other opinions?
14:48:46 <jokke_> even better if it's in
14:48:59 <rosmaita> ok, sounds good
14:49:00 <jokke_> in weird case that someone actually happens to try out our milestones
14:49:06 <rosmaita> :)
14:49:15 <rosmaita> you never know!
14:50:41 <rosmaita> #topic open discussion
14:50:54 <rosmaita> well, i kind of cheated and pre-loaded the open discussion
14:51:22 <rosmaita> jokke_: don't know if you had a chance to look over the comments on https://review.openstack.org/#/c/468179/ ?
14:51:47 <rosmaita> actually, ignore that
14:51:54 <rosmaita> we have enough to do ATM
14:52:12 <rosmaita> i do want to talke about the other item, though
14:52:33 <jokke_> nope haven't got on that yet
14:52:35 <rosmaita> i owed abhishekk some docs about how admin works in glance
14:52:46 <rosmaita> and this came up on the general ML this week
14:52:59 <rosmaita> but as i look into it, it is very confusing
14:53:11 <rosmaita> #link https://etherpad.openstack.org/p/glance-authN-authZ-model
14:53:29 <rosmaita> anyway, if naynoe has spare time, feel free to add comments to the above etherpad
14:53:41 <rosmaita> i'll be working on it intermittently
14:53:55 <abhishekk> rosmaita: thank you, I will also have a look
14:53:56 <rosmaita> and by naynoe, i mean 'anyone'
14:54:03 <rosmaita> :)
14:54:21 <rosmaita> that may be my next irc nick
14:54:39 <rosmaita> ok, anyone else?
14:54:40 <jokke_> ahh that one
14:54:53 <jokke_> coming up again
14:55:13 <jokke_> and I think someone even thought it would be good idea to hardcode it as "admin" lately :P
14:55:42 <rosmaita> arrrgh
14:57:45 <jokke_> rosmaita: I promise I get to back to that OSSN proposal
14:58:05 <rosmaita> jokke_: after P-2
14:58:25 <jokke_> might take it as night read over the long weekend :P
14:58:35 <rosmaita> ok, thanks everyone, and one more hearty round of applause for mfedosin
14:58:55 <jokke_> thanks all!
14:58:57 <abhishekk> thank you all
14:59:01 <mfedosin> I'm glad to be back
14:59:01 <rosmaita> (can't remember the hand-clap emoticon)
14:59:07 <mfedosin> thanks all!
14:59:55 <rosmaita> #endmeeting