14:00:36 <rosmaita> #startmeeting glance
14:00:37 <openstack> Meeting started Thu Jun 15 14:00:36 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:41 <openstack> The meeting name has been set to 'glance'
14:00:46 <rosmaita> #topic roll call
14:01:18 <rosmaita> hello everyone (anyone?)
14:01:36 <abhishekk> o/
14:01:44 <rosmaita> \o
14:02:07 <jokke_> o/
14:02:14 <rosmaita> \o
14:02:27 <jokke_> rosmaita: welcome back
14:02:30 <mfedosin> \o/
14:02:32 <rosmaita> ty
14:02:34 <abhishekk> \o/
14:02:34 <rosmaita> hi mike
14:02:34 <jokke_> hopefully you had good break
14:03:04 <rosmaita> had some quality time with the family, did some interviewing
14:03:05 <rosmaita> no news though
14:03:31 <rosmaita> ok, here's the link to the agenda (not much on it today):
14:03:34 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:03:48 <rosmaita> #topic updates
14:03:58 <rosmaita> #topic updates - docs
14:04:14 <rosmaita> there's a proposal to move more docs into individual project repos
14:04:31 <rosmaita> as far as i can tell, it's just movement, no new writing requirements at this point
14:04:48 <rosmaita> #link https://review.openstack.org/#/c/472275/
14:05:08 <rosmaita> take a look if you're interested
14:05:09 <jokke_> rosmaita: well it will put the maintenance burden to the individual projects 'though
14:05:22 <jokke_> which kind of probably should have been there anyways
14:05:26 <rosmaita> yes, it will, but things were going in that direction anyway
14:05:31 <rosmaita> what you just said
14:05:48 <mfedosin> what's the main point of standalone repo for docs?
14:06:01 <mfedosin> this repos will somehow be treated differently?
14:06:01 <rosmaita> main point of the patch is working out a common structure for the doc part of the project repos
14:06:19 <rosmaita> mfedosin: sorry, i wasn't clear
14:06:37 <rosmaita> the user-facing docs will be moved over to the project repos
14:06:57 <rosmaita> some of this was maintained previously in a separate repo by the docs team
14:07:25 <rosmaita> main reason for the repo was to have easy +2, +A abilities for the docs team without giving them the same in a code repo
14:07:25 <mfedosin> ah, now I got it
14:07:37 <rosmaita> now, they'll only have +1
14:07:40 <mfedosin> There seems to be no other choice
14:07:45 <rosmaita> but, now there are also fewer of them
14:08:02 <mfedosin> okay, I'll read the proposal
14:08:08 <rosmaita> thanks
14:09:31 <rosmaita> main impact on us may be some renaming and moving stuff around a bit inside the docs/ part of the project repos
14:10:07 <rosmaita> also, iirc the patch mentions a cli-reference
14:10:28 <rosmaita> but i'm now thinking that should be handled in the python-glanceclient repo, not the glance repo
14:10:36 <jokke_> yeah
14:10:52 <jokke_> doesn't make sense to put glanceclient docs into glance repo
14:11:01 <rosmaita> ok, anyone who gets a chance to read over the patch, please keep the above in mind
14:11:46 <rosmaita> #action rosmaita reread doc migration patch to see where the cli ref is supposed to go
14:11:51 <rosmaita> ok, that's all on that from me
14:12:10 <rosmaita> #topic updates - catching up
14:12:37 <rosmaita> i missed last week for vacation and am just getting caught up
14:12:56 <rosmaita> jokke_: i saw the glanceclient was released
14:13:10 <rosmaita> did we release P2 for glance?
14:13:18 <jokke_> yes and glance P-2 as well
14:13:23 <rosmaita> excellent, ty
14:13:29 <jokke_> ofc
14:14:40 <rosmaita> ok, that clears the table to get the wsgi stuff taken care of
14:15:03 <rosmaita> that will be the #1 priority for the next week
14:15:23 <rosmaita> a quick look is that the code basically looks ok
14:15:30 <rosmaita> i haven't had time to test it out yet though
14:15:58 <jokke_> what rosmaita just said
14:16:33 <rosmaita> anything else need to be on the priority list for next week?
14:16:43 <rosmaita> actually i can think of a few things
14:17:00 <jokke_> also thanks to mfedosin and flaper87 reviews the IIRC MVP has landed
14:17:02 <rosmaita> last i looked, my patch to get the priorities published for Pike hasn't been approved
14:17:20 <rosmaita> mfedosin: flaper87: good work!
14:17:30 <jokke_> rosmaita: I think I have +2 on that
14:17:43 <rosmaita> jokke_: yes, you are in the clear
14:17:47 <mfedosin> my please :)
14:18:10 <rosmaita> this could also use some love: https://review.openstack.org/469693
14:18:32 <rosmaita> get the 'untargeted' specs set up on the off chance someone shows up and wants to work on glance
14:18:55 <rosmaita> mfedosin: need you to look at https://review.openstack.org/468035
14:19:10 <rosmaita> (that's the one with jokke_ 's +2)
14:20:35 <jokke_> so I'm prioritizing to get client supporting the MVP and looking into for getting perhaps ceph support for the bikeshed aand maybe copy-from as well
14:20:36 <mfedosin> rosmaita: okay, added it in my review list
14:20:49 <rosmaita> ty
14:21:24 <rosmaita> jokke_: sounds good, probably copy-from would be higher priority than ceph support, but your employer may feel differently :)
14:21:46 <rosmaita> client support for the MVP would be great
14:22:54 <rosmaita> jokke_: probably nothing there yet to review?
14:22:56 <jokke_> rosmaita: well I kind of dislike the fact that only way to deploy HA and direct upload (as in use the new import) is to put the bikeshed on nfs
14:23:02 <jokke_> rosmaita: not yet
14:23:54 <rosmaita> jokke_: i agree with your dislike, but it's an MVP
14:24:04 <jokke_> rosmaita: indeed
14:24:09 <rosmaita> let's see how things shake out for you this week
14:24:34 <rosmaita> ok, so review priorities will be matt's wsgi common goal stuff
14:24:59 <rosmaita> jokke_ will be working on IIR stuff so we can start reviews next week
14:25:06 <jokke_> yeah, lets try to test that wsgi and get it in
14:25:34 <rosmaita> ok, good
14:25:42 <rosmaita> ok, last update
14:25:52 <rosmaita> #topic update - ML discussion
14:26:03 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/118173.html
14:26:22 <rosmaita> flavio started a discussion that he and mostly mfedosin have been contributing to
14:26:38 <rosmaita> if you haven't seen it, you should read through
14:27:09 <rosmaita> i'll just point out what i think about this, namely:
14:27:17 <mfedosin> A provocative letter requires a provocative response, doesn't it? :)
14:27:17 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/118271.html
14:27:42 <rosmaita> mfedosin: :)
14:28:21 * jokke_ blew up on that already. mfedosin no insults intended, sorry if you took it that way. And again sorry I should have calmed down before writing that mail
14:28:28 <rosmaita> anyway, short story is i think mike raises some good points, but we should think about them for queens PRG, not pike
14:28:49 <mfedosin> not Pike, for sure
14:28:57 <mfedosin> I hope that I expressed my idea clearly there
14:29:28 <rosmaita> ok, cool
14:29:51 <rosmaita> we've got enough to do with few enough people that i don't want it to be a distraction
14:30:12 <rosmaita> at the same time, if we're going to make a good decision about the future of glance, we need to have some discussion during pike
14:30:30 <rosmaita> so that we don't wind up putting it off again in queens
14:31:04 <mfedosin> rosmaita: I'll provide some details next Thursday
14:31:05 <jokke_> mfedosin: just to clarify the background a bit. We've been in quite deep shait for past 2-3months. As I understood Flavio was looking something to improve the situation (that has stressed me to very thin line) right now, not in 2 years ... so I took your proposal as in the context of that, not long term
14:31:16 <rosmaita> so, please continue to discuss, but please also don't let it get in the way of reviewing the glance priorities!
14:31:27 <rosmaita> mfedosin: jokke_
14:31:30 <rosmaita> oops
14:31:45 <rosmaita> was just going to say, i took it the way jokke_ did
14:31:58 <rosmaita> i am glad to hear it you did not mean it as a short term thing
14:33:24 <rosmaita> ok, that's all for updates
14:33:27 <mfedosin> I did not mean to offend anyone... And again, sorry if I wasn't clear in the first message
14:33:42 <rosmaita> mfedosin: no offense taken
14:34:10 <rosmaita> and sorry if i misunderstood
14:34:31 <rosmaita> just want to be clear that we need to focus on the pike deliverables during pike
14:34:48 <rosmaita> #topic open discussion
14:34:57 <mfedosin> it's absolutely clear that pike is pike
14:35:11 <mfedosin> and we discussed it many times
14:35:42 <mfedosin> and I'm happy to help all activities we planned for pike before moving forward
14:36:15 <rosmaita> excellent, thank you
14:36:15 <mfedosin> actually I have several exciting news, but I'm going to postpone them till the next meetings
14:36:18 <jokke_> mfedosin: thanks ... you know that your expertise is greatly appreciated
14:36:48 <rosmaita> mfedosin: will look forward to your exciting news!
14:38:51 <jokke_> also for Open Discussion
14:38:57 <rosmaita> ok, anything else?
14:39:09 <rosmaita> looks like jokke_ has something
14:39:09 <jokke_> we're still screwed with glance_store gate being bonked by Tempest
14:39:23 <jokke_> that has been case for past 3 weeks I think
14:39:41 <rosmaita> at least
14:40:18 <jokke_> So I'd like to bring up an idea that we drop every Tempest test run from our test suite that tempest does not gate themselves
14:40:31 <jokke_> to avoid them breaking us and not doing anything about it
14:41:08 <jokke_> and by tempest gating I mean woting jobs
14:41:50 <jokke_> if tempest runs the job non-voting we don't run it (like in the case of this specific job that keeps breaking as Tempest cores don't care if it breaks and merges those breaking changes anyways)
14:42:49 <rosmaita> (sorry for the delay, i am looking at some patches to see wha's up)
14:45:14 <rosmaita> looks like this got through clean a few days ago: https://review.openstack.org/#/c/431677/
14:46:11 <jokke_> rosmaita: that was stable
14:46:30 <rosmaita> oops
14:46:56 <jokke_> honestly I do not know where tose jobs differs if they do
14:47:45 <rosmaita> what's failing the most? for a while it was a shelving test not being able to delete a cinder snapsot or something
14:48:01 <jokke_> but the tempest-dsvm-full-ceph has not passed in master once since tempest guys merged the breaking changes
14:48:39 <jokke_> rosmaita: I think it's the new shelving test I proposed revert and it seems that they merged another breaking test as well
14:49:13 <rosmaita> that is quite annoying
14:49:50 <jokke_> and it's not first time they do this
14:49:54 <rosmaita> ok, so the disable shelve is https://review.openstack.org/#/c/473897/
14:50:22 <jokke_> so they have jobs non-voting that us and cinder (used to) gate and they merge stuff even if those non-voting jobs breaks
14:51:13 <jokke_> so at this point my proposal is that we don't run any jobs from tempest that tempest don't gate on themselves
14:51:38 <jokke_> saves quite a bit of developer and infra cycles
14:51:44 <rosmaita> well, that does seem reasonable
14:52:09 <rosmaita> tell you what ... let's collaborate on an etherpad for an ML item
14:52:17 <jokke_> ++
14:52:20 <rosmaita> (that way i can add some "please"s)
14:52:22 <rosmaita> :)
14:52:25 <jokke_> :P
14:52:55 <rosmaita> anything else?
14:53:07 <jokke_> like "Could you_, please,_ go and feck yourself" :P
14:53:19 <rosmaita> #action rosmaita jokke collaborate on ML message to qa/tempest
14:53:45 <jokke_> and no I would not go that far
14:54:05 <rosmaita> i was just going to say, you *have* learned to say "please"!
14:54:23 <jokke_> ;)
14:54:48 <rosmaita> ok, sounds like that's all for today.  Let's quit early and maybe jokke_ and i can get this tempest thing done real quick
14:54:52 <jokke_> but that's all from me
14:55:01 <rosmaita> #endmeeting