14:00:32 <rosmaita> #startmeeting glance
14:00:33 <openstack> Meeting started Thu Jul 20 14:00:32 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:36 <openstack> The meeting name has been set to 'glance'
14:00:45 <rosmaita> #topic roll call
14:01:06 <rosmaita> hello everyone
14:01:07 <smcginnis> o/
14:01:48 <rosmaita> nice to see you sean ... hope we get a few more people!
14:02:00 <abhishekk> o/
14:02:08 <rosmaita> hello abhishek
14:02:14 <abhishekk> hi rosmaita
14:02:50 <abhishekk> is jokke_ on leave?
14:03:36 <rosmaita> i didn't think so
14:03:49 <rosmaita> i think he leaves the first week of august
14:04:06 <abhishekk> ok
14:04:21 <rosmaita> although, he may have taken today off
14:04:26 <rosmaita> i'm not sure
14:04:26 <abhishekk> I haven't seen him around today
14:04:35 <smcginnis> rosmaita: Good to see we at least have a few folks. :)
14:04:56 <rosmaita> ok, i guess we can get started, i can coordinate with jokke later
14:05:11 <rosmaita> because a lot of the stuff on the agenda is associated with releases
14:05:27 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:05:39 <rosmaita> #topic updates
14:05:50 <rosmaita> #topic updates - glance_store release
14:06:01 <smcginnis> \o/
14:06:08 <rosmaita> thanks everyone for working/reviewing the glance_store patches
14:06:20 <rosmaita> #link http://lists.openstack.org/pipermail/release-announce/2017-July/002191.html
14:06:24 <rosmaita> it's released!
14:06:32 <abhishekk> great
14:06:33 <rosmaita> so that's our first "official" Pike release
14:06:52 <rosmaita> everyone take a minute to bask in the glory of a job well done
14:07:19 <rosmaita> i just want to mention that i wound up cancelling the deprecated option removal
14:07:32 <rosmaita> it began to look like a potentially destabilizing change
14:07:44 <rosmaita> and may require some discussion
14:08:03 <rosmaita> anyway, you don't need to look now, but i wrote up what's going on in case i get hit by a bus before queens
14:08:17 <rosmaita> #link https://etherpad.openstack.org/p/glance_store-remove-deprecated-swift-opts
14:08:46 <rosmaita> #topic updates - +1s on updates to global requirements
14:08:52 <rosmaita> just a quick mention here
14:09:09 <rosmaita> the updates to global requirements have passed tests, etc.
14:09:21 <rosmaita> our policy is that they can be ninja-approved by any glance core
14:09:39 <rosmaita> so, if you've +1d one of these, it must mean you have a special interest
14:09:40 <abhishekk> got it
14:09:51 <rosmaita> so please leave a comment saying something
14:10:14 <rosmaita> it's especially useful when just before a release one or two of these changes are proposed
14:10:21 <jokke_> hi, sorry for being late
14:10:30 <rosmaita> jokke_: np, glad you're here
14:10:34 <rosmaita> didn't get to your part yet
14:10:43 <rosmaita> anyway, to summarize, my point is
14:11:00 <rosmaita> feel free to +1 (or especially -1) those changes
14:11:06 <rosmaita> but please leave a comment explaining why
14:11:09 <rosmaita> that's all
14:11:36 <rosmaita> #topic updates - PTG
14:11:55 <rosmaita> we will definitely have a meeting room, but the details won't be available for a week or so
14:12:15 <rosmaita> so i just want to remind everyone to think of what needs to be discussed and add things to our planning etherpad
14:12:29 <rosmaita> #link https://etherpad.openstack.org/p/glance-queens-ptg-planning
14:12:33 <jokke_> that's fine ... most important is that we're accommodated and everyone knows at least some of us will be there :D
14:12:43 <rosmaita> :)
14:12:43 <jokke_> hopefully I'm one of those some
14:13:02 <abhishekk> :)
14:13:22 <rosmaita> we can talk about this later, but i think if our people cant' get travel support, we should do a virtual glance PTG
14:13:36 <rosmaita> some of the virtual midcycles were very productive
14:13:42 <smcginnis> rosmaita: +1
14:13:51 <rosmaita> but we'll talk about that next time
14:14:18 <rosmaita> #updates - Queens PTLs self-nomination period coming up
14:14:43 <rosmaita> you may have seen the emails about making sure you're registered with the foundation properly
14:14:58 <rosmaita> anyway, the self-nomination period is the week after next
14:15:26 <rosmaita> and i just noticed that i messed up the topic thingy
14:15:26 <rosmaita> #topic - updates - Queens PTLs self-nomination period coming up
14:15:31 <rosmaita> and that doesn't seem to have worked either
14:15:43 <rosmaita> there we go
14:16:11 <rosmaita> anyway, if you are thinking of running for glance PTL, feel free to ping me and i can give you an idea of what you'd be in for
14:16:20 <rosmaita> also, flaper87 is a good person to talk to
14:16:36 <rosmaita> and you can search for his blog post about running for PTL, some good info
14:16:58 <rosmaita> #topic updates - personal news
14:17:17 <rosmaita> so, between us and everyone reading the logs, i have some personal news
14:17:30 <rosmaita> i've accepted a job with verizon starting july 31
14:17:38 <smcginnis> rosmaita: Congrats!
14:17:42 <rosmaita> so i am employed again, and will be working on openstack
14:17:45 <abhishekk> congrats !!!
14:17:52 <rosmaita> thank you!
14:18:18 <rosmaita> this cycle has been a tough one because of the budget cutbacks killing off a lot of our cores
14:18:29 <rosmaita> and putting me out of commission for a while
14:19:01 <jokke_> <3
14:19:02 <rosmaita> anyway, i am planning to stand for PTL again
14:19:07 <rosmaita> though this would be the last time
14:19:09 <jokke_> happy days
14:19:23 <rosmaita> part of my goal would be to get others ready to do it
14:19:32 <rosmaita> and, it may be the case that someone's already ready
14:20:01 <rosmaita> anyway, if you're thinking of running, you'll have to post your self-nomination the week of july 31
14:20:07 <rosmaita> so it's good to start thinking now
14:20:21 <rosmaita> ok, final update:
14:20:31 <rosmaita> #updates - next week is R-5
14:20:48 <rosmaita> #topic updates - next week is R-5
14:20:52 <rosmaita> there we go
14:21:06 <rosmaita> ok, just going to list the stuff happening next week, and then we'll discuss them
14:21:19 <rosmaita> 1 glance P-3 milestone release
14:21:27 <rosmaita> 2 glance feature freeze
14:21:35 <rosmaita> 3 python-glanceclient Pike release
14:21:45 <rosmaita> 4 Pike community goals completion
14:21:59 <rosmaita> yeah, a lot of stuff
14:22:16 <rosmaita> #topic glance P-3 milestone release and feature freeze
14:22:44 <rosmaita> is anyone currently working on anything that could be considered a feature?
14:23:13 <rosmaita> #action rosmaita set up glance-specs repo for Queens proposals
14:23:55 <rosmaita> i didn't think so ... ok, do not start working on anything that's not a bugfix from now on
14:24:04 <abhishekk> no, but I like to understand the status of live-upgrades- may be later
14:24:04 <jokke_> I'm still looking if I manage to hack "copy-from" to IIR
14:24:06 <abhishekk> ok
14:24:27 <rosmaita> jokke_: that would be a good thing to get in
14:24:34 <jokke_> if it's easy enough to pull together I might try to get it done by early next week
14:24:52 <rosmaita> abhishekk: please put that on the PTG etherpad
14:25:01 <abhishekk> ok
14:25:11 <rosmaita> it would be good to discuss because most of the people who've worked on it have moved on
14:25:19 <rosmaita> would be a good idea to share the knowledge
14:25:30 <rosmaita> jokke_: see what you can do
14:25:30 <jokke_> I've been trying to get the client together for now but almost forgetting the lib release deadline kind of put me off track a bit
14:25:40 <rosmaita> i think copy-from would be a FFE candidate
14:26:09 <rosmaita> it would be good to get in, as i believe it's the final brick in the wall to remove the v1 api
14:26:16 <rosmaita> (kind of a bad mixed metaphor there)
14:26:19 <jokke_> well the thing is I'm out after the 1st of Aug ... so if it's not in by that I'm not touching it before the release ;)
14:26:43 <rosmaita> fair enought
14:26:46 <rosmaita> *enough
14:27:03 <rosmaita> let's all wish jokke_ well on a productive rest of the week and next week!
14:27:31 <abhishekk> yeah
14:27:59 <rosmaita> so the only things we'd have to get in to P-3 are features in progress
14:28:22 <rosmaita> since we don't have any of those (other than jokke_) i think we're ok with P-3 for glance
14:28:32 <jokke_> sounds good
14:28:37 <rosmaita> does that sound about right?
14:28:44 <jokke_> was the -rc1 week after P3?
14:28:55 <jokke_> or was it same week?
14:29:05 <rosmaita> no RC-1 is week of august 7
14:29:20 <smcginnis> Two weeks later
14:29:22 <smcginnis> https://releases.openstack.org/pike/schedule.html
14:29:49 <rosmaita> i'll take over the release duties while jokke_ is gone
14:30:24 <rosmaita> ok, next item
14:30:34 <rosmaita> #topic python-glanceclient Pike release
14:30:44 <smcginnis> #link https://review.openstack.org/#/q/project:openstack/python-glanceclient+status:open Open reviews
14:30:48 <rosmaita> this has to happen next week
14:30:49 <rosmaita> smcginnis: ty
14:30:53 <smcginnis> ;)
14:31:12 <jokke_> oh it was that far ... cool ... yeah that means we have plenty of bugfixing time after P3
14:32:06 <rosmaita> smcginnis: that's a fairly long list
14:32:20 <rosmaita> guess we should do another priority etherpad
14:32:37 <rosmaita> actually, before we do that, let's talk about the next item and then return to this
14:32:45 <rosmaita> #topic Pike community goals
14:32:47 <smcginnis> rosmaita: Looks like quite a few have issues. -1's and things.
14:33:13 <jokke_> so bit back to client release
14:33:45 <rosmaita> #topic python-glanceclient pike release
14:33:48 <jokke_> NOW is the time to adress the gate and review -1s ... looking there is not that much open atm. that would be clean to go
14:34:29 <jokke_> again if possible we're tagging at Wed so lets get the stuff we really need sorted asap
14:34:39 <smcginnis> +1
14:34:46 <jokke_> I make sure that my iir patch is up by Mon morn
14:35:00 <rosmaita> ok, let's do it now
14:35:16 <smcginnis> It would be good to identify important things to get in that may have been abandoned by their original submitter so someone else can pick it up and address review comments.
14:36:09 <abhishekk> +1
14:36:24 <rosmaita> https://etherpad.openstack.org/p/glance-client-priority-reviews-pike
14:36:31 <jokke_> so the client final release is bit like the non-client final release ... no more breaking changes/new features after next week. Bugfixes are ok to do as usual when ever we get them sorted.
14:36:46 <rosmaita> ok, let's go through sean's list from the top
14:37:12 <jokke_> But obviously I'd be super happy if we didn't need to block our fresh release from requirements just because there is something horribly broken
14:37:53 <jokke_> Lets keep releasing quality stables as usual :)
14:38:13 <rosmaita> i like that thought :D
14:39:57 <jokke_> ok ... moving forward again rosmaita ? ;)
14:40:03 <rosmaita> ok, https://review.openstack.org/480882 looks fine, i just have a -1 because i'd like an update made on the bug
14:40:22 <rosmaita> but the code change looks fine for the client
14:40:28 <rosmaita> and it has a +2
14:40:35 <rosmaita> so actually, this one is all on me
14:41:04 <rosmaita> next, https://review.openstack.org/475247
14:41:38 <rosmaita> looks ok, abhishek has requested a docs update be included
14:41:42 <jokke_> rosmaita: that was a good comment there. I totally agree that we should not merge PS closing bug unless it's really addressing the whole bug
14:42:24 <rosmaita> yeah, i'm fine with the patch, just want to know if we can close the whole bug or not
14:42:56 <rosmaita> and abhishekk good catch about updating the docs on 475247
14:43:07 <abhishekk> :)
14:43:15 <rosmaita> next, https://review.openstack.org/461725
14:44:30 <rosmaita> hopefully the commiter will address abhishek's points
14:44:59 <abhishekk> i will try to ping committer, she works during my timezone
14:45:17 <smcginnis> I think I've seen Pranali still active, so that's good.
14:45:39 <rosmaita> ok, cool, would be a nice-to-have
14:45:50 <jokke_> oh yeah ... and she is ramping up more and more glance stuff
14:46:07 <rosmaita> oh good, then let's be very encouraging!
14:46:16 <rosmaita> being on the priority list shows that we care
14:46:19 <jokke_> she seems to be quite motivated ... so happy to see changes coming from her.
14:46:57 <rosmaita> ok, looks like the consensus is https://review.openstack.org/358489 is not needed
14:47:13 <rosmaita> i will abandon it to clear it out of the way
14:48:24 <rosmaita> the doc links i'll look over, should be no big deal
14:48:33 <rosmaita> i can ninja in that one if it's ok
14:49:14 <rosmaita> how about https://review.openstack.org/484362
14:49:23 <jokke_> so regarding 475351 ... do we want to make that change now when it's reasonable oneliner already and if we do I'd argue we remove that 'HTTP' from there as well then
14:51:01 <jokke_> I'm just bit cautious how many users we break with that change who are scripting their client output validation
14:51:04 <smcginnis> jokke_: You mean it should just return self.details?
14:52:28 <jokke_> smcginnis: yeah ... taking in account that it already contains '404 Not Found: ' on top of the set message, I'm not convinced that HTTP gives really any value there is we don't keep the string as it is for backwards compatibility
14:52:48 <jokke_> s/is/if/
14:53:24 <rosmaita> i think the html content-type for the response was a good change, i think we should leave the message as it is
14:53:26 <smcginnis> True. Risk is probably low, but I guess I don't really have a strong opinion to keep or not keep it.
14:55:31 <abhishekk> just to remind we have 5 minutes left
14:55:39 <rosmaita> yeah, let's move on
14:55:43 <jokke_> ++
14:55:58 <rosmaita> i think if we change any of these, we need to make sure all returned responses are consistent
14:56:08 <rosmaita> let's not do that in Pike in the next few minutes
14:56:47 <abhishekk> and someone yesterday asked me a question about whether we are releasing glance with uwsgi? (because of that image-upload issue)
14:57:17 <jokke_> rosmaita: topic change?
14:57:26 <rosmaita> guess so
14:57:42 <rosmaita> anyone have time to stick around after the meeting to continue the client discussion?
14:57:52 <rosmaita> #topic community goals
14:58:20 <rosmaita> i think we keep uswgi in for P-3
14:58:27 <rosmaita> and assess what's going on
14:58:39 <abhishekk> ok
14:58:43 <rosmaita> or, we can decide about uwsgi before wed
14:59:01 <rosmaita> i'm supposed to reply next week about our status
14:59:11 <rosmaita> so, i can reply that we are still assessing the change
14:59:22 <jokke_> can we continue this on #os-glance? We're out of time
14:59:27 <smcginnis> Do we think issues can get resolved there before final freeze?
14:59:40 <rosmaita> smcginnis: don't know
14:59:52 <rosmaita> ok, let's head back to openstack-glance channel
14:59:55 <rosmaita> thanks everyone!
14:59:58 <smcginnis> Thanks!
14:59:59 <jokke_> Thanks!
15:00:02 <rosmaita> #endmeeting