14:00:11 <rosmaita> #startmeeting glance
14:00:12 <openstack> Meeting started Thu Jul 27 14:00:11 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:15 <openstack> The meeting name has been set to 'glance'
14:00:23 <rosmaita> #topic roll call
14:01:17 <rosmaita> hmmm
14:01:23 <rosmaita> could be a short meeting
14:01:39 <jokke_> o/
14:01:44 <rosmaita> but we do have quite a bit on the agenda
14:01:49 <rosmaita> \o
14:02:09 <abhishekk> o/
14:02:17 <rosmaita> \o
14:02:39 <jokke_> hey abhishekk
14:02:49 <abhishekk> hey jokke_
14:02:58 <rosmaita> i'm going to wait until :04 and then start
14:03:11 <jokke_> sure ... I pick up that coffee I put coming
14:03:17 <smcginnis> o/
14:03:22 <rosmaita> \o
14:05:49 <rosmaita> ok, let's get started
14:05:52 <rosmaita> hello everyone
14:06:03 <abhishekk> hi
14:06:05 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:06:13 <rosmaita> there's the agenda
14:06:22 <rosmaita> #topic updates
14:06:37 <rosmaita> #topic updates - glance P-3 release
14:07:07 <rosmaita> i think we're ok on this ... the release note about the wsgi containerization is in the gate
14:07:20 <rosmaita> soon as that's merged, jokke_ will put in the tag request
14:07:32 <rosmaita> #topic updates - community goals
14:07:48 <rosmaita> i'm supposed to report on the community goal progress this week
14:08:23 <rosmaita> mtreinish has already patched the appropriate upstream doc saying the wsgi goal is complete
14:08:36 <jokke_> \\o \o/ o// o/7
14:08:46 <rosmaita> i will be looking at where we stand on the python-35 goal today and tomorrow
14:08:53 <smcginnis> rosmaita: I forget, do we have running py3 tempest jobs
14:09:07 <abhishekk> i think 2 tests are skipped as of now
14:09:26 <rosmaita> right, glance skips 2 functional tests
14:09:52 <rosmaita> but i'm not sure we have py-35 gating on all of {glance, glance_store, python-glanceclient}
14:10:11 <rosmaita> i need to look more closely
14:10:17 <abhishekk> ok
14:10:32 <rosmaita> but, a lot of projects have not updated their goals yet
14:10:43 <rosmaita> so i'm not too worried about being a little late on this
14:11:10 <smcginnis> I have a feeling there will be a few that aren't able to complete the goal until Queens.
14:11:13 <rosmaita> but i may wait to send out the priorities list until tomorrow afternoon
14:11:20 <rosmaita> smcginnis: my impression, too
14:11:35 <smcginnis> It's unfortunate, but not the end of the world. At least the work is being done.
14:11:42 <rosmaita> that way, i can get some items on it about py35 if they look reasonable
14:11:48 <rosmaita> smcginnis: my thoughts exactly
14:11:56 <jokke_> specially the py3 is quite a big task for some projects
14:12:06 <rosmaita> ok, so that's all about the community goals for now
14:12:21 <rosmaita> #topic updates - glanceclient
14:12:36 <rosmaita> ok, as jokke_ put on the agenda, there a few patches outstanding:
14:12:49 <rosmaita> https://review.openstack.org/486630 <- image import support      https://review.openstack.org/487269 <- pike release note  (content depends on the above)      https://review.openstack.org/486824 <- one line doc change (must go in)
14:13:11 <rosmaita> thanks to everyone who reviewed the other patches that were on the etherpad
14:13:22 <mtreinish> smcginnis: I flipped the switch for all the integrated gate tempest jobs to make py35 voting right before the atl ptg
14:13:27 <mtreinish> so glance is covered by that
14:13:39 <smcginnis> mtreinish: Awesome, thanks.
14:13:42 <rosmaita> mtreinish: thanks for that info!
14:13:47 <mtreinish> the functional tests in tree still need coverage though
14:13:50 <jokke_> mtreinish: oh, cool! That sounds great
14:14:02 <mtreinish> as does anything outside the basic tempest-dsvm job
14:14:08 <rosmaita> mtreinish: also, thanks again for your work on the wsgi goal
14:14:10 <mtreinish> so like glance_store, etc
14:14:44 <rosmaita> mtreinish: yes, that's what i noticed as well
14:14:45 <mtreinish> rosmaita: sure, np. It was far more interesting than I originally expected
14:14:50 <mtreinish> heh, I had to brush off my c
14:14:59 <rosmaita> :)
14:14:59 <smcginnis> "interesting"
14:15:06 <jokke_> :D
14:15:07 <rosmaita> "interesting and exciting"
14:15:33 <rosmaita> #action rosmaita get good list of what exactly is left for all 3 projects for py35 goal
14:15:52 * jokke_ is sure mtreinish will think twice before volunteering taking on community goal for glance again :D
14:15:52 <rosmaita> ok, back to the client ... here are my thoughts, then let's discuss
14:16:06 <rosmaita> about the glanceclient changes in https://review.openstack.org/#/c/486630/
14:16:15 <rosmaita> due to the people-power constraints we've been working under, the test coverage isn't there
14:16:22 <rosmaita> the code basically looks good
14:16:29 <rosmaita> but as we add tests, we're going to find *something* (hopefully minor)
14:16:36 <rosmaita> so the situation is this:
14:16:43 <rosmaita> 1 - we release the pike glanceclient without image import support - this impacts anyone who wants to ship pike with client support for image import
14:16:53 <rosmaita> 2 - we release, add more tests, and backport any bug fixes
14:17:21 <rosmaita> it seems to me that there's an impact on users either way, just depends which one we like better
14:17:41 <abhishekk> 2 sounds good
14:17:51 <rosmaita> i am inclining to #2 because of the feature freeze
14:17:58 <smcginnis> My take is - it's easy to release new client's at any point, so option 2 might be better to at least have something out there.
14:18:03 <rosmaita> and we want people to use this functionality
14:18:19 <rosmaita> looks like i am preaching to the choir!
14:18:23 <smcginnis> :)
14:18:28 <jokke_> my very biased opinion is #2
14:18:37 <rosmaita> i thought i would have to try to sell this
14:18:53 <jokke_> and knowing that this will be tight I tried to make all the client changes as isolated from our normal workflow as possible
14:19:02 <rosmaita> yes, good point
14:19:07 <jokke_> os only thing I actually reused was the upload
14:19:10 <rosmaita> plus, image import is off by default in pike
14:19:41 <jokke_> so the changes even totally broken should not affect the client usage as it works today
14:19:58 <rosmaita> right, all current tests are passing
14:20:01 <smcginnis> jokke_: +1
14:20:09 <rosmaita> so it doesnt' look like this will cause any regressions
14:20:43 <rosmaita> ok, i updated the releasenote just before the meeting to explain the EXPERIMENTAL command that's being added
14:21:20 <rosmaita> i'd kind of like the help text for that command to be a bit more informative about the command being renamed or removed
14:21:33 <rosmaita> because i don't think end users read release notes
14:21:52 <rosmaita> and they may not realize what EXPERIMENTAL means
14:22:15 <abhishekk> +1
14:22:51 <rosmaita> in fact, to keep it short, maybe the help should just say "EXPERIMENTAL: this command may be renamed or removed."
14:23:04 <rosmaita> and not say what it does, interested people can look it up
14:23:18 <jokke_> rosmaita: IMHO they will learn if common sense is not a red flag enough ... but again I think I might be the one overestimating the users here
14:24:20 <rosmaita> yeah, i don't know
14:24:48 <smcginnis> rosmaita: Probably wouldn't hurt to throw "EXPERIMENTAL" in there.
14:24:52 <rosmaita> i guess we need to do a documentation update to make this clear?
14:24:57 <smcginnis> Should be able to get that updated and still released before the deadline.
14:24:58 <jokke_> smcginnis: it is there
14:25:09 <smcginnis> jokke_: Hah, oops. Guess I should look first. :)
14:25:14 <rosmaita> smcginnis: it is, just not the "may be renamed or replaced" part
14:25:51 <smcginnis> I tend to lean toward what jokke_ is saying then, that that should be a red flag enough. Either way though. We still have a little time.
14:26:18 <rosmaita> i see that kairat just added a comment, maybe we should log a warning when the command is used?
14:26:49 <jokke_> """EXPERIMENTAL: Create a new image via image import.""" that's the current
14:27:08 <jokke_> rosmaita: this is shell client, so no
14:27:17 <rosmaita> oh, right
14:27:23 <smcginnis> Yeah, not sure we want to dump warnings in the shell.
14:28:36 <rosmaita> ok, i just realized we don't have any doc changes on this patch
14:28:57 <jokke_> darn ... I knew I forgot something
14:28:59 <rosmaita> i will look real quick after the meeting and find an appropriate place to explain about the EXPERIMENTAL command
14:29:22 <rosmaita> that way, if someone says , what does "experimental" mean, there's a place to find out
14:29:27 <rosmaita> ok, problem solved
14:29:43 <rosmaita> let's leave the help text the way it is and add a little to doc
14:29:50 <smcginnis> +1
14:30:17 <jokke_> rosmaita: sounds good to me
14:30:29 <rosmaita> ok, i will +2 when the patch passes tests
14:30:46 <rosmaita> #action rosmaita - update glanceclient doc about image import
14:30:59 <rosmaita> ok, that will give us another patch to get in before release
14:31:45 <rosmaita> all right, all cores, please review these
14:32:00 <rosmaita> jokke_: you can review the doc change when i get it up, and we can ninja the doc change
14:32:12 <rosmaita> ok, i think that's everything?
14:32:20 <jokke_> rosmaita: yeah
14:32:34 <rosmaita> when i say, please review, i do mean right away!
14:32:36 <jokke_> oh ... thanks all for the efforts on the client
14:32:41 <rosmaita> we need to get the release cut today
14:33:05 <jokke_> we got lots of bugfixes and few good optimizations in even this has been quiet cycle
14:33:07 <rosmaita> abhishekk: do you feel ok +2ing the import client changes after tests pass?
14:33:35 <abhishekk> rosmaita: let me have a look once again before that
14:33:48 <rosmaita> sure
14:34:03 <rosmaita> i just want to make sure we have sufficient people actively looking
14:34:22 <rosmaita> ok that's all for updates
14:34:28 <rosmaita> #topic FFE requests
14:34:39 <rosmaita> this week is feature freeze
14:34:51 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-July/120205.html
14:35:06 <rosmaita> and with feature freeze, comes feature freeze exceptions
14:35:28 <rosmaita> jokke_ has requested a FFE for "copy-from" as part of image import refactoring
14:35:47 <rosmaita> i am inclined to say yes, as that is what we need to finally kill off v1
14:36:03 <rosmaita> to be clear, granting a FFE doesn't mean the change will definitely get in
14:36:07 <abhishekk> how many hours are remaining to cut the release
14:36:16 <rosmaita> will still require tests, etc
14:36:38 <rosmaita> but it means that we as a community are committed to reviewing, etc
14:36:38 <jokke_> So that should be fairly trivial to do. It's basically combination of the old image import task and the new flow we're doing. I have couple of small things to do to finetune it but I'm confident I will have the patch up for review tomorrow
14:36:59 <jokke_> abhishekk: so client release and P-3 needs to happen today
14:37:31 <rosmaita> i think P-3 is ready (FFE is a separate deal)
14:37:34 <abhishekk> means maximum 6 hours?
14:37:42 <abhishekk> from now?
14:38:01 <smcginnis> 2 weeks yet before RC, so should hopefully be OK for the FFE.
14:38:01 <abhishekk> sorry, I am in totally different timezone
14:38:31 <smcginnis> abhishekk: Yeah, probably ~6 hours to be fair to the release team for a new client release.
14:39:05 <abhishekk> thanks
14:39:44 <jokke_> rosmaita: P-3 needs to have that rel note merged and then tagged
14:40:24 <rosmaita> ok, we're just waiting on the relnote to merge
14:40:30 <jokke_> yup
14:41:53 <rosmaita> ok, i will send out to the ML saying that a FFE was granted for adding copy-from
14:42:02 <rosmaita> #action rosmaita FFE announcement
14:42:12 <rosmaita> i think we're supposed to keep the community informed
14:42:22 <rosmaita> and that was the only FFE request i'm aware of?
14:42:37 <rosmaita> so i think we are done with this topic
14:42:50 <rosmaita> #topic open discussion
14:42:51 <jokke_> that's all I know of
14:43:00 <rosmaita> hah, some actual open discussion time today!
14:43:10 <rosmaita> someone put PTG on the agenda
14:43:17 <jokke_> so I just wanted to check how PTG looks for people
14:43:33 <jokke_> I'm confirmed now, booked my tickes and hotel yesterday
14:43:50 <rosmaita> i believe i will be able to attend, but have not booked tickets or anything yet
14:43:53 <jokke_> so I will definitely be there :D
14:44:05 <abhishekk> I have registered today
14:44:13 <rosmaita> oh, cool
14:44:18 <jokke_> cool
14:44:19 <abhishekk> plane and hotel booking is pending
14:44:38 <smcginnis> I'm all set, but I think I mentioned on the etherpad I will probably have conflicts the entire time.
14:44:44 <jokke_> so lets start seriously planning our sessions for PTG then now when we have at least some level participation :D
14:44:48 <smcginnis> But would love to have a beer with folks if we can fit it in.
14:44:51 <mtreinish> I'll be there
14:45:35 <rosmaita> i will buy a round or two of beers
14:45:39 <rosmaita> we can all use it
14:45:47 <jokke_> :)
14:45:52 <smcginnis> rosmaita: Well, then I'll definitely be there. :P
14:45:58 <rosmaita> plus, i start working again on monday
14:46:03 <smcginnis> Woot!
14:46:14 <abhishekk> :)
14:46:31 <jokke_> so how about we start collecting any known events for evenings and then we can pick up the least colliding one for Glance night out :D
14:46:32 <rosmaita> we should have some good team diversity, i will be working for verizon
14:46:33 <abhishekk> so 2 rounds separate for that
14:47:00 <rosmaita> hopefully we can get our team:diverse-affiliaton tag back in pike
14:47:16 <rosmaita> ok, put me down for 4 rounds
14:47:19 <smcginnis> rosmaita: Are we far off from having that now?
14:47:28 <rosmaita> not necessarily all on the same night
14:47:41 <rosmaita> smcginnis: i have not really checked, i think we should be good, though
14:47:56 <jokke_> I think the current state is that we should have it again
14:47:57 <rosmaita> the rackspace and intel commits/reviews/etc were really early in the cycle
14:48:06 <jokke_> when it gets next time asserted
14:48:30 <rosmaita> here's a quick poll: who works for who?
14:48:34 <rosmaita> rosmaita - verizon
14:48:38 <jokke_> I proposed patches to remove the tags as I wasn't sure if the assert happens before or after release and based on the official docs we do not have it
14:48:40 <smcginnis> smcginnis - Huawei
14:48:50 <abhishekk> abhishekk - NTT Data
14:48:56 <jokke_> jokke_ - Red Hat
14:49:05 <jokke_> Pranali - Red hat
14:49:11 <jokke_> flaper87 - Red Hat
14:49:14 <smcginnis> Seems diverse to me. I can run the script later and check.
14:49:37 <jokke_> croelandt - Red Hat
14:49:38 <jokke_> :)
14:49:43 <abhishekk> :D
14:49:47 <rosmaita> lot of RH there!
14:50:11 <abhishekk> pranali was earlier working with me in NTT :)
14:50:22 <rosmaita> ok, well, as jokke_ said, please start thinking of topics for the PTG
14:50:36 <rosmaita> #link https://etherpad.openstack.org/p/glance-queens-ptg-planning
14:50:47 <rosmaita> anything else?
14:51:00 <rosmaita> (i have some glanceclient docs to go write)
14:51:05 <jokke_> I think we're pretty good
14:51:21 <jokke_> oh
14:51:25 <jokke_> one more thing
14:51:45 <jokke_> I'll propose the requirements change for store and client once the client gets tagged
14:52:07 <jokke_> i forgot the store last week
14:52:09 <rosmaita> thanks for being on top of that, it slipped my mind
14:52:30 <smcginnis> Don't forget stable branching in the deliverable/pike yaml.
14:53:05 <jokke_> smcginnis: yeap, thanks
14:54:30 <abhishekk> good to go?
14:54:43 <jokke_> yeah we should be good to wrap up
14:54:58 <abhishekk> all the best :)
14:55:04 <rosmaita> ok great, thanks everyone
14:55:09 <abhishekk> thank you
14:55:10 <jokke_> Thanks all!
14:55:11 <smcginnis> Thanks!
14:55:13 <rosmaita> btw, https://review.openstack.org/#/c/486630/8 just passed tests
14:55:23 <abhishekk> yes
14:55:56 <rosmaita> ok, we'll have an exciting rest of the day getting the glanceclient out the door
14:56:07 <rosmaita> #endmeeting