14:00:00 <rosmaita> #startmeeting glance
14:00:00 <openstack> Meeting started Thu Aug  3 14:00:00 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:04 <openstack> The meeting name has been set to 'glance'
14:00:14 <rosmaita> #topic roll call
14:00:18 <rosmaita> hello everyone
14:00:25 <rosmaita> looks quiet in the glance channel
14:00:29 <abhishekk> hi
14:00:38 <abhishekk> o/
14:00:45 <rosmaita> \o
14:01:28 <mfedosin> o/
14:01:32 <abhishekk> i guess jokke_ is on vacation
14:01:34 <rosmaita> hi mike
14:01:45 <rosmaita> yes, i think jokke_won't be here
14:01:45 <mfedosin> hello :)
14:02:32 <rosmaita> i guess let's wait a few more minutes, it's a light agenda today
14:02:33 <mfedosin> I think I have several things to discuss about ptg
14:02:43 <rosmaita> ok, great, we'll have time
14:03:38 <rosmaita> well, i don't want to waste anyone's time, the meeting logs will be available for anyone who shows up late
14:03:46 <rosmaita> #topic updates
14:03:58 <rosmaita> #topic update - releases
14:04:14 <rosmaita> we got the glanceclient 2.8.0 out the door
14:04:23 <rosmaita> after a long day
14:04:29 <rosmaita> and got P-3 tagged
14:04:41 <rosmaita> so, congratulations everyone
14:04:43 <abhishekk> \o/
14:04:49 <abhishekk> great
14:04:57 <rosmaita> #topic update - PTG travel support
14:05:14 <rosmaita> just a reminder that the travel support deadline for applications is August 6
14:05:21 <rosmaita> which is coming up fast
14:05:37 <rosmaita> there's info at the bottom of the ptg etherpad
14:05:48 <rosmaita> #link https://etherpad.openstack.org/p/glance-queens-ptg-planning
14:06:09 <rosmaita> i don't know how the applications are assessed, but we are a core project so make sure you mention glance
14:06:28 <rosmaita> #topic update - voter eligibility
14:06:42 <rosmaita> ptl and tc elections are coming up
14:06:56 <rosmaita> there was some kind of change in verifying who can vote
14:07:11 <abhishekk> is that so?
14:07:12 <mfedosin> who can now?
14:07:42 <rosmaita> same people, but your foundation membership email has to be lined up with your gerrit email
14:07:44 <rosmaita> something like that
14:07:46 <rosmaita> anyway
14:08:01 <rosmaita> fungi sent out an email with a helpful list so you can check easily
14:08:12 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-August/120544.html
14:08:33 <rosmaita> if you show up in the "members" list, you are OK; otherwise you'll have to read the email to see what you need to do
14:09:04 <rosmaita> anyway, check as soon as you can, ptl elections are next week (i think)
14:09:09 <rosmaita> and tc shortly after that
14:09:33 <rosmaita> #update - RC-1 and hard string freeze
14:09:36 <abhishekk> thanks for the update
14:09:41 <rosmaita> np
14:09:44 <rosmaita> oops
14:09:57 <rosmaita> #topic update - RC-1 and hard string freeze
14:10:12 <rosmaita> ok, next week is RC-1 time
14:10:27 <rosmaita> what this means is: we will cut the stable/pike branch for glance
14:10:35 <rosmaita> that will open master for new development
14:10:51 <rosmaita> but it also means that any bugfixes done in master will have to be backported into stable/pike
14:11:05 <rosmaita> and, such bugfixes should be "release-critical"
14:11:10 <rosmaita> here's a summary from ttx:
14:11:20 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2017-August/120574.html
14:11:47 <rosmaita> so, this week, we really need to get anything that should be in pike, into master before the branch is cut
14:12:08 <rosmaita> which brings us to the next topic, namely to talk about what's necessary
14:12:20 <rosmaita> #topic RC-1
14:12:37 <rosmaita> doc migration patches
14:12:45 <rosmaita> doug mentioned these on the ML
14:12:52 <rosmaita> i think Glance is actually OK for this
14:13:07 <rosmaita> doug used us as an experiment for how the migration should work
14:13:17 <abhishekk> yes, everything is marked as completed
14:13:21 <rosmaita> cool
14:13:38 <rosmaita> here's the list of what's happening with the docs migration in case you are interested:
14:13:50 <rosmaita> #link https://etherpad.openstack.org/p/doc-migration-tracking
14:14:03 <rosmaita> it includes stuff that's going to happen in queens also
14:14:17 <rosmaita> anyway, nothing for us to worry about there
14:14:30 <rosmaita> #topic RC-1 - metadefs
14:14:44 <rosmaita> there are a few metadefs patches outstanding
14:15:05 <rosmaita> i'd like to get those merged so that we don't have to worry about metadefs for a while
14:15:15 <rosmaita> i'll put a list of patches on the weekly priorities email
14:15:29 <rosmaita> #topic RC-1 - image import testing
14:15:46 <rosmaita> abhishekk has been good about this, already caught a bug and fixed it
14:16:13 <abhishekk> I will have a look again
14:16:17 <rosmaita> glance is being shipped with image import "off", but it would be good to get some more testing
14:16:34 <rosmaita> #topic RC-1 - image import discovery call
14:16:46 <rosmaita> the current /info call is very bare-bones
14:16:56 <rosmaita> which is OK since we said this is an MVP
14:17:55 <rosmaita> i may try to get some more done on that ... it's going to require some new config options
14:18:08 <rosmaita> which are usually the subject of much discussion
14:18:18 <rosmaita> so i may hold off, i'm not sure
14:18:40 <rosmaita> i don't think the enhanced call is necessary for people who want to test out import
14:18:56 <rosmaita> so i don't think it's release-critical
14:19:04 <abhishekk> right
14:19:15 <rosmaita> anyway, i'm just thinking out loud here and will shut up
14:19:30 <rosmaita> #topic RC-1 - image import docs
14:19:36 <rosmaita> actually this is more important
14:19:44 <rosmaita> i'll work on this instead
14:20:04 <rosmaita> we just need enough doc so that an interested operator would know what to do to use image import
14:20:30 <rosmaita> so this is higher priority than enhanced discovery
14:20:37 <rosmaita> and finally
14:20:46 <rosmaita> #topic RC-1 - py35 community goal
14:21:05 <rosmaita> we're pretty close on this, but i don't think we have to have it in pike
14:21:24 <rosmaita> i'd like to get it done before the pike release, but i think it's perfectly OK if we just get it done in master
14:21:48 <rosmaita> it's not like we're the only project that hasn't completed it
14:21:54 <rosmaita> so we're not holding up openstack
14:22:01 <abhishekk> any specific reason, I guess we are skipping two tests because of ssl issue i guess
14:22:19 <rosmaita> yes, that's the main thing
14:22:43 <abhishekk> ok
14:22:51 <rosmaita> and we need to check the gating for glance_store and glanceclient, i don't think they have voting py35 jobs atm
14:23:14 <abhishekk> ok
14:23:27 <rosmaita> anyway, i will interpret "during pike" to mean "during the pike release, but not necessarily in pike"
14:24:17 <rosmaita> i think that's pretty much it
14:24:52 <rosmaita> ok, just so i don't forget
14:25:06 <rosmaita> #action rosmaita - metadefs patch list for priorities
14:25:20 <rosmaita> #action rosmaita - image import docs
14:25:42 <rosmaita> also, i did notice that the docs table of contents page is kind of a mess ATM
14:26:26 <rosmaita> if i have time i'll file some bugs
14:27:05 <rosmaita> i'm not going to prioritize those, though, because that kind of thing tends to eat up reviewer time
14:27:26 <rosmaita> ok, i guess that's it
14:27:40 <rosmaita> #topic open discussion
14:27:59 <rosmaita> mfedosin: you wanted to talk about the ptg?
14:28:10 <mfedosin> oh yeah
14:28:29 <mfedosin> I just want to give our update...
14:28:47 <mfedosin> so, we booked a room for wednesday and thursday
14:29:20 <mfedosin> from glare team there will be me, Idan and Kairat
14:29:35 <mfedosin> so, I decided, maybe we can share a room
14:29:41 <rosmaita> good, glad you'll be there
14:29:42 <mfedosin> or take two adjacent
14:30:07 <mfedosin> because I want to participate in glance sessions too
14:30:25 <mfedosin> what do you think?
14:30:25 <rosmaita> right
14:30:59 <mfedosin> I haven't created our agenda for ptg, but hope to finish it next week
14:31:11 <rosmaita> yeah, our agenda is not set yet either
14:31:28 <rosmaita> i think we should definitely coordinate our agendas
14:31:46 <rosmaita> but i'd kind of prefer separate rooms
14:31:46 <mfedosin> indeed! that's exactly I wanted to suggest
14:32:10 <mfedosin> np, maybe it's even better
14:32:10 <rosmaita> or maybe separate rooms on 1 day, shared room another day
14:32:34 <rosmaita> i think there are probably business items that each team will have to attend to
14:32:41 <abhishekk> separate but next to each other?
14:32:41 <mfedosin> I will come to you to drink coffee when our is over.
14:32:46 <rosmaita> where extra people may be a distraction
14:33:06 <rosmaita> i'll be completely honest, the "should we replace glance" discussion could take days
14:33:16 <rosmaita> so i'd like to get some queens planning done first!
14:33:25 <rosmaita> because i don't see the replacement happening in queens
14:33:36 <rosmaita> i think there'd need to be a bunch of groundwork done
14:33:39 * smcginnis is on the go today but lurking
14:33:46 <rosmaita> smcginnis: hi!
14:33:46 <mfedosin> you said "days", I think "months" more correct
14:33:50 <smcginnis> o/
14:33:51 <rosmaita> :)
14:34:00 <rosmaita> well, we only have days in denver!
14:34:12 <mfedosin> ah, in that case - yes
14:34:39 <rosmaita> did kendall send out the rooms yet, or is she still working on them?
14:35:35 <smcginnis> I haven't seen a set room assignment yet.
14:35:39 <rosmaita> but also, mfedosin , make sure you put your name as "interested" on any of the glance stuff you want to attend, so we know which ones to coordinate
14:35:41 <mfedosin> don't know, but we booked a small one
14:36:04 <rosmaita> yeah, i told kendall small room, but haven't heard a definite schedule yet
14:36:15 <mfedosin> I want to discuss glance_store
14:36:36 <mfedosin> kairat has a radical vision, that we shouldn't use it in glare
14:36:58 <mfedosin> but I believe that we can refactor it a little bit and it will be fine
14:37:01 <rosmaita> i dont' think we have a proposal for glance_store, so feel free to put a proposal on the etherpad
14:37:09 <mfedosin> yep
14:37:31 <rosmaita> it would be good if we could make it so that both projects can consume it
14:37:40 <mfedosin> and probably I should participate in security session
14:37:51 <rosmaita> definitely
14:38:08 <mfedosin> rosmaita: agree, I tried to convince kairat, but now it is hard to do :)
14:38:17 <rosmaita> i don't know if you have had time to look at the spec on the security bug?
14:38:24 <rosmaita> that thing has gotten completely out of hand
14:38:32 <rosmaita> that's why i didn't mention it for RC-1
14:38:38 <mfedosin> nope :( can you send it to me?
14:38:41 <rosmaita> but we absolutely must do something
14:38:47 <rosmaita> mfedosin: it's attached to the bug
14:38:57 <mfedosin> got you
14:39:03 <mfedosin> sorry, was busy
14:39:09 <rosmaita> i think you should have access to the bug, if that changed, let me know
14:39:10 <rosmaita> np
14:39:11 <mfedosin> I'll take a look
14:39:22 <rosmaita> yeah, i'm curious what you'll think
14:39:39 <mfedosin> I'll leave my comment there
14:39:43 <rosmaita> cool
14:40:38 <rosmaita> ok, i'll send kendall an update saying that we want to be able to easily coordinate with the glare team, but also want some "alone time"
14:40:38 <mfedosin> btw, I want to organize a public demo with latest glare features before the ptg
14:40:54 <mfedosin> probably on 24th of August
14:41:47 <mfedosin> I want to present asynchronous upload workflows, dynamic quotas, data convertion and validation and so on
14:41:54 <mfedosin> are you interested?
14:41:56 <rosmaita> will be interesting to see what you've been working on
14:42:18 <mfedosin> okay, I'll announce it next week in the mailing list
14:42:28 <rosmaita> cool
14:42:51 <rosmaita> anyone else have anything for open discussion?
14:42:57 <mfedosin> okay, task for me - contact with kendall and review the spec
14:43:19 <abhishekk> no
14:43:35 <rosmaita> cool
14:43:35 <mfedosin> nothing else from my side
14:43:45 <rosmaita> anyone aware of anything we're missing for RC-1 ?
14:44:19 <rosmaita> well, if you think of anything, let me know
14:44:22 <smcginnis> I haven't checked, but last night I posted a link in the channel for some patches the requirements team was waiting on.
14:44:22 <abhishekk> i guess you have addressed all points
14:44:44 <abhishekk> that was about glance_store, right?
14:44:51 <smcginnis> Yep
14:44:53 <rosmaita> smcginnis: i didn't see that
14:45:45 <smcginnis> Found it: https://review.openstack.org/#/q/status:open+project:openstack/glance_store+branch:stable/pike+topic:backports
14:47:07 <rosmaita> smcginnis: this might be a problem with jokke_ on vacation
14:47:30 <rosmaita> i intentionally did not give myself +2 on stable branches
14:47:48 <rosmaita> who do i need to talk to about that?
14:48:20 <smcginnis> rosmaita: If tonyb is still around, probably him. But he's in Australia, so not sure his hours.
14:48:41 <rosmaita> ok, i will email him
14:48:47 <smcginnis> Maybe ping in openstack-requirements or openstack-stable?
14:49:35 <rosmaita> i'll do all of those
14:49:40 <smcginnis> ;)
14:49:48 <rosmaita> anything else?
14:50:05 <smcginnis> Nothing from me.
14:50:20 <rosmaita> #action rosmaita - get stable branch powers
14:50:26 <rosmaita> ok, thanks everyone!
14:50:33 <rosmaita> 10 free minutes, use them wisely
14:50:37 <abhishekk> thank you
14:50:46 <rosmaita> #endmeeting