14:00:06 <rosmaita> #startmeeting glance
14:00:06 <openstack> Meeting started Thu Aug 31 14:00:06 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:10 <openstack> The meeting name has been set to 'glance'
14:00:20 <abhishekk> o/
14:00:28 <rosmaita> #topic roll call
14:00:36 <rosmaita> hi abhishekk
14:00:48 <abhishekk> hi rosmaita
14:01:00 <jokke_> o/
14:01:30 <rosmaita> hi erno
14:01:48 <rosmaita> let's wait another minute or two
14:01:49 <abhishekk> hi jokke_
14:02:11 <jokke_> hey
14:02:44 <rosmaita> well, heck, let's get started
14:02:52 <rosmaita> #topic updates
14:03:08 * smcginnis sneeks in late
14:03:09 <rosmaita> actually, i should make sure everyone has the agenda
14:03:13 <rosmaita> we saw you!
14:03:16 <smcginnis> :)
14:03:25 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:03:35 <rosmaita> ok, first update
14:03:44 <rosmaita> #topic update - Pike released!
14:03:55 <rosmaita> yes, it happened! congratulation everyone
14:03:57 <abhishekk> \o/
14:04:04 <rosmaita> #link https://releases.openstack.org/pike/index.html#pike-glance
14:04:07 <smcginnis> Congrats all!
14:04:26 <rosmaita> let's bask in the glory of a job well done for 30 sec
14:05:14 <rosmaita> ok, enough basking
14:05:22 <abhishekk> :D
14:05:27 <rosmaita> #topic update - business
14:05:51 <rosmaita> while i've got you here, there are a few patches just to get ready for queens
14:06:04 <rosmaita> https://review.openstack.org/#/c/499155/
14:06:12 <rosmaita> https://review.openstack.org/#/c/497678/
14:06:38 <rosmaita> also, jokke_ and maybe smcginnis , do we have to worry about that SemVer commit?
14:06:46 <rosmaita> (do you even know what i am talking about?)
14:06:58 <jokke_> rosmaita: just gonna ask which one is that?
14:07:10 * rosmaita looking
14:07:44 <rosmaita> here's what i mean: https://docs.openstack.org/glance/latest/contributor/release-cpl.html#final-releases
14:07:54 <jokke_> if you mean the version bump, that should have been done when the stable/pike branch was created and iirc it's coming automatic nowadays
14:08:00 <rosmaita> one of the patches i listed above opens the data migration
14:08:18 <rosmaita> right, the release version
14:08:21 <smcginnis> I actually asked the release team about that.
14:08:27 <smcginnis> It was something new.
14:08:35 <rosmaita> dumb question ... how can i check the release version in master?
14:09:31 <smcginnis> rosmaita: I believe it stays at whatever the last release is until the first milestone release happens.
14:10:00 <rosmaita> right, and EmilienM (i think) was saying it's a problem for packagers or something
14:10:14 <smcginnis> The referenced patch there ended up being abandoned since it ended up getting close to Pike-1. But it may be worth trying again.
14:10:41 <smcginnis> FWIW, all projects do have this issue until the first release of a new cycle, so it's not something unique to glance.
14:10:58 <rosmaita> smcginnis good to know
14:10:59 <smcginnis> But if this works well, maybe this could be something we recommend to all projects to get around that.
14:11:10 <rosmaita> it's on our checklist, though, so i figure we need to do something
14:11:16 <smcginnis> I think it only affects those doing CD off of master.
14:11:18 <jokke_> oh ... hmm-m
14:11:47 <jokke_> just looking that but we should have done that at the branch creation
14:12:10 <rosmaita> possibly
14:12:21 <jokke_> as not everything between that and now are part of 15.0.0 as anything that happened in master since are backports
14:12:28 <jokke_> if included in pike
14:12:42 <smcginnis> jokke_: It only affects master. Maybe ideal to do it right at branch creation, but could still do it for anything going forward I think.
14:13:14 <rosmaita> take a look at this: https://docs.openstack.org/releasenotes/glance/unreleased.html
14:13:31 <rosmaita> showing as 15.0.0.0rc1-22
14:13:52 <rosmaita> and that's the RC-2 release note
14:14:51 <jokke_> hmm-m ... ok let me dig into pbr and figure out why that's a thing
14:15:28 <rosmaita> #action jokke_ follow up on whether we need to do something like https://review.openstack.org/#/c/453416/ in master soon
14:15:34 <jokke_> #action jokke_ to look into pbr and figure out why SemVer: api-break is needed and when it actually should be done
14:15:34 <rosmaita> ok, thanks
14:15:37 <jokke_> ahh
14:15:39 <jokke_> #undo
14:16:03 <rosmaita> ok one last business item
14:16:28 <rosmaita> these are for jokke_ , really, as they are focused on interoperable image import
14:16:34 <rosmaita> https://review.openstack.org/#/c/493436/
14:16:42 <rosmaita> https://review.openstack.org/#/c/498138/
14:16:53 <rosmaita> one of them is an update to the image status fields dev docs
14:17:04 <rosmaita> the other is the admin guide about configuring image import
14:17:12 <jokke_> oh cool
14:17:14 <jokke_> thanks
14:17:19 <rosmaita> LGTM, but i want to make sure you looked first
14:17:21 <jokke_> will look into them
14:17:28 <rosmaita> cool
14:17:40 <rosmaita> ok, moving on
14:17:51 <rosmaita> #topic tasks not working in Pike devstack
14:18:03 <rosmaita> this took me quite a while to track down
14:18:09 <rosmaita> there are two things happening
14:18:23 <rosmaita> #link https://bugs.launchpad.net/glance/+bug/1712463
14:18:25 <openstack> Launchpad bug 1712463 in Glance "failure when running under wsgi configuration" [High,In progress] - Assigned to Brian Rosmaita (brian-rosmaita)
14:19:37 <rosmaita> ok, the first problem is that oslo_concurrency.processutils, which we use in the "old" import task to run qemu-img to get info, doesn't work when glance is running under uwsgi
14:19:57 <rosmaita> that seems to be a bug in processutils
14:20:26 <rosmaita> but doesn't look like oslo_concurrency peeps have taken a look yet
14:21:16 <rosmaita> mtreinish suggested some workaround (i.e., don't use processutils)
14:21:34 <rosmaita> but, we should probably push them to fix the bug
14:22:07 <smcginnis> Do they have a PTG planning etherpad? Might be good to discuss it there?
14:22:07 <rosmaita> which reminds me, we are not consistent in our code when dealing with the output from processutils.trycmd()
14:22:18 <rosmaita> smcginnis good question, don't know
14:22:44 <rosmaita> #action rosmaita write up glance bug about dealing with processutils
14:22:58 <rosmaita> (no sense patching if we decide not to use processutils)
14:23:28 <smcginnis> Yep, they are meeting Mon-Tue: https://etherpad.openstack.org/p/oslo-ptg-queens
14:24:00 <rosmaita> ok, i will put a quick thing on the PTG and ping doug
14:24:04 <dhellmann> is the oslo team even aware of that processutils bug? I haven't heard about it, but I'm not fully in the loop with that team any more
14:24:15 <rosmaita> speaking of who!
14:24:24 * dhellmann arrives late, between meetings
14:24:27 <rosmaita> dhellmann don't know
14:24:39 <dhellmann> is the bug associated with an oslo deliverable?
14:24:43 <jokke_> I don't know how you guys feel, but running glance in wsgi container is not at the top of my priority list. We know that it's broken/flaky partially as we're fundamentally doing stuff that is outright just not supported by all the wsgi libs
14:24:48 <dhellmann> it is
14:24:49 <jokke_> dhellmann: \o
14:25:05 <mtreinish> rosmaita: my real suggestion was on how to fix processutils so it's not calling python via a subprocess which is just weird
14:25:20 <mtreinish> rosmaita: but it would also be quite simple to just bypass it and also keep the rate limiting
14:25:26 <rosmaita> mtreinish thanks for the clarification
14:25:40 <rosmaita> i think it's probably something better to fix in processutils
14:25:42 <EmilienM> rosmaita: woot?
14:25:48 <rosmaita> because other people will encounter it
14:25:51 <rosmaita> EmilienM hi!
14:25:58 <jokke_> EmilienM: \o
14:26:22 <dhellmann> regarding the version number bump, we don't want project teams each doing their own thing to solve that problem. let's make sure it's on the release team list for the ptg and see if we can come up with a common solution.
14:26:34 <rosmaita> EmilienM jokke_ will follow up with you, it's about kicking up the version in master before the first milestone
14:26:35 <rosmaita> or
14:26:38 <rosmaita> what dhellmann said
14:26:52 <rosmaita> ok, so that means jokke_ will hold off until after the ptg
14:26:58 <jokke_> dhellmann: thanks! That's kind of what I wanted to look/probe for
14:27:22 <smcginnis> If that works, we can just automate it.
14:27:24 <rosmaita> smcginnis can you put that on the release team ptg etherpad? i hear you are connected
14:27:32 <jokke_> as I thought the version bumping was not necessary anymore
14:27:58 <dhellmann> smcginnis : it's topic 15 on the backlog on the pike planning pad, so if you've copied that info over then it's already on the ptg list
14:28:13 <smcginnis> dhellmann: Oh, perfect. Yep.
14:28:20 <smcginnis> rosmaita: Done I guess. :)
14:28:55 <rosmaita> back to the uwsgi discussion
14:29:12 <rosmaita> the other problem is that we use an eventlet pool to run the actual tasks
14:29:38 <jokke_> yes
14:29:39 <rosmaita> i can't get tasks to run unless i put a waitall() after the spawn_n cal;l
14:30:13 <rosmaita> i know the pool exists, has 1024 threads
14:30:14 <dhellmann> is the wsgi app setting up eventlet in the expected way?
14:30:48 <rosmaita> well, we have some code that when you put a lock on the pool, it will create the pool if it doesn't exist already
14:31:06 <dhellmann> if running glance under a wsgi server isn't really recommended, maybe that's the response to the goal
14:31:07 <rosmaita> i don't know that we do any special setup
14:31:21 <rosmaita> dhellmann it is certainly beginning to look like that
14:31:31 <mtreinish> my guess is this was just working before because things were just running under the eventlet server
14:31:34 <jokke_> dhellmann: we should have that in our documentation for Pike already
14:31:47 <EmilienM> rosmaita: I'm missing context (I'm already in a meeting right now) but yeah if jokke_ can me ping later and tell me what's going on :D
14:31:51 <rosmaita> well, we do have warnings in the release notes and docs
14:32:03 <jokke_> EmilienM: sure
14:32:15 <rosmaita> EmilienM ty, nothing to worry about, release team will discuss at the ptg
14:32:25 <mtreinish> but and that new how to handle it, but if running outside of that we need to do all the setup like the eventlet server would
14:32:40 <rosmaita> we also have the upload issue, though
14:32:56 <rosmaita> #link https://bugs.launchpad.net/glance/+bug/1703856
14:32:57 <openstack> Launchpad bug 1703856 in Glance "502 Bad gateway error on image-create" [High,Confirmed] - Assigned to Matthew Treinish (treinish)
14:32:57 <mtreinish> although it makes me wonder what we gain by jamming this all under the same service
14:33:03 <mtreinish> rosmaita: I have fixes up for that
14:33:06 <jokke_> I think there was fix proposed for that for uwsgi
14:33:39 <mtreinish> see comment #19
14:33:46 <abhishekk> there are two patches
14:34:11 <abhishekk> one for glance and on in devstack, I will test this tomorrow
14:34:16 <rosmaita> ok, cool
14:34:19 <abhishekk> s/on/one
14:34:23 <rosmaita> thanks mtreinish for staying on top of this
14:34:29 <rosmaita> and thanks abhishekk for testing
14:34:32 <dhellmann> using wsgi probably makes more sense for services where the API and workers are separated, so I don't think it's a problem to just respond to the community goal with "don't do that" and move on
14:35:10 <rosmaita> dhellmann ok, that's good to know
14:35:17 <rosmaita> i guess we can discuss at the ptg
14:35:22 <dhellmann> although folks are likely to ask how to configure glance to be part of the same domain/path structure as the other apps, so having an answer to that would be good
14:35:28 <jokke_> specially as we're more and more relying on the tasks now which will need the eventlet anyways
14:35:51 <rosmaita> jokke_ so that makes me wonder about mtreinish 's question
14:35:53 <dhellmann> jokke_ : if those run in the background, they would be good candidates to move out of the main glance service
14:36:03 <rosmaita> what dhellmann said
14:36:31 <rosmaita> ok, looks like a good PTG topic
14:36:44 <jokke_> dhellmann: I don't see that being something that would a) being backportable for Pike (the goal) b) would happen in queens
14:38:47 <rosmaita> ok, well we will discuss in person at the PTG
14:39:41 <rosmaita> so conclusion here is that (a) put processutils on the oslo etherpad, and (b) don't do anything about the tasks not running in devstack issue until after we discuss at the ptg
14:39:43 <rosmaita> ok
14:40:00 <rosmaita> #topic priorities for R-25 (next week)
14:40:06 <rosmaita> ok, just a point of information
14:40:11 <rosmaita> monday is a USA holiday
14:40:45 <EmilienM> and Canada ;-)
14:40:57 <rosmaita> the py35 goal completion ... i still have not filled in that etherpad ... after today's meeting i will shut down my irc and email and just focus on that
14:41:19 <rosmaita> i'll give a status update in the priorities email
14:41:43 <rosmaita> ok, as far as wsgi goal followup, looks like we've got mtreinish 's two patches to review, so that's cool
14:41:52 <rosmaita> and the other thing is PTG planning
14:42:15 <rosmaita> looks like we have some new items that came up today
14:42:45 <rosmaita> please take a look at the topics there and indicate your interest
14:42:59 <rosmaita> though i think we'll have enough time to discuss them all
14:43:27 <jokke_> I've been filling it up ;)
14:43:37 <rosmaita> good, i haven't looked recently
14:43:40 <jokke_> as promised last week, by this meeting ;)
14:44:12 <rosmaita> cool, look like good additions
14:44:43 <rosmaita> ok, i will have a proposed schedule ready early wednesday, and we can finalize at next week's glance meeting
14:44:53 <rosmaita> unless people won't be available due to traveling?
14:45:13 <dhellmann> rosmaita : where's the ptg list?
14:45:24 <rosmaita> #link https://etherpad.openstack.org/p/glance-queens-ptg-planning
14:45:29 <dhellmann> thanks
14:46:10 <rosmaita> jokke_ , abhishekk will you be available for glance meeting next week
14:46:12 <rosmaita> ?
14:46:26 <abhishekk> i will be there
14:46:46 <jokke_> yeah, I should be here
14:46:55 <abhishekk> i am travelling on Friday
14:47:05 <rosmaita> excellent, we can finalize schedule at the meeting
14:47:14 <rosmaita> #topic open discussion
14:47:22 <rosmaita> anyone?
14:48:17 <jokke_> I think my only one for this was the ptg planning
14:48:41 <jokke_> or highlighting that we should get the topics ready for decision
14:48:55 <rosmaita> great
14:49:16 <rosmaita> we will have interesting topics to discuss for sure
14:49:51 <rosmaita> ok, well if no one else, thanks everyone for attending
14:50:02 <rosmaita> in addition to the ususal suspects, thanks dhellmann for dropping by
14:50:11 <dhellmann> o/
14:50:17 <abhishekk> thank you
14:50:28 <jokke_> Thanks! o/~
14:50:51 <rosmaita> ok, see you next week, and then for real the week after that!
14:50:56 <rosmaita> #endmeeting