14:00:30 <rosmaita> #startmeeting glance
14:00:31 <openstack> Meeting started Thu Dec 14 14:00:30 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:35 <openstack> The meeting name has been set to 'glance'
14:00:41 <rosmaita> #topic roll call
14:00:42 <abhishekk> o/
14:00:48 <McClymontS> o/
14:01:36 <bhagyashris> o/
14:01:40 <cleong> o/
14:02:38 <jokke_> o/
14:03:14 <rosmaita> ok, looks like we have a quorum
14:03:20 <rosmaita> good morning/afternoon/evening ,everyone
14:03:35 <rosmaita> as always, here's the agenda:
14:03:36 <jokke_> hey
14:03:41 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:03:41 <abhishekk> good morning rosmaita
14:03:53 <rosmaita> and it is a very light agenda today
14:04:07 <rosmaita> so plenty of time for open discussion
14:04:14 <rosmaita> #topic updates
14:04:35 <rosmaita> ok, so i was supposed to do a few things this week, namely:
14:04:47 <rosmaita> spec about policy changes
14:04:56 <rosmaita> no-op community goal proposal
14:05:18 <rosmaita> unfortunately, most of my time was consumed with the python-glanceclient gate situation
14:05:36 <rosmaita> so i need to check what the deadline is for community goal proposals
14:05:41 <rosmaita> (i hope it is not soon)
14:06:01 <rosmaita> and i've got the policy changes partially written up, but not pushed to gerrit yet
14:06:17 <rosmaita> so, the python-glanceclient gate situation
14:06:39 <rosmaita> it's been broken for a while as a casualty of the zuul3 migration
14:06:56 <rosmaita> some test jobs were auto-migrated in such a way that they no longer worked
14:07:05 <rosmaita> and that's what happened to us
14:07:37 <rosmaita> the nice thing about zuul3 is that we can define our gates in our own repo
14:08:20 <rosmaita> so there's a patch up moving the jobs to the python-glanceclient repo and rewriting them to use zuul3 and work
14:08:41 <rosmaita> that's mostly done, though it depends on a patch in the devstack repo that hasn't merged yet
14:08:45 <rosmaita> (last time i looked)
14:08:48 <rosmaita> unfortunately
14:09:00 <rosmaita> (how many times have i used that word?)
14:09:12 <jokke_> which is still waiting for the Monty's patch that is being bikeshed under devstack
14:09:27 <rosmaita> in between when the functional test jobs were passing previously and now, some stuff has broken
14:09:48 <abhishekk> like?
14:09:49 <rosmaita> i have a patch up (that i think merged yesterday) to fix one problem
14:10:00 <jokke_> i'm almost tempted to say that we grab that Monty's patch, to our own repo and consume it locally rather than wait much longer
14:10:24 <rosmaita> but now the funcitonal jobs don't run in devstack when the tls-proxy is running
14:10:44 <rosmaita> i.e., when you're using ssl, the tests break
14:11:11 <abhishekk> got it
14:11:14 <rosmaita> i filed a bug, i'll post the number in a minute
14:11:28 <rosmaita> it's a cert problem, but i haven't been able to isolate exactly where it's happening yet
14:11:44 <rosmaita> except really early, the client can't connect to keystone
14:13:22 <rosmaita> sorry, was looking in the glance bugs by mistake
14:13:24 <rosmaita> https://bugs.launchpad.net/python-glanceclient/+bug/1738033
14:13:30 <openstack> Launchpad bug 1738033 in Glance Client "functional tests broken in ssl environment" [Critical,Triaged] - Assigned to Brian Rosmaita (brian-rosmaita)
14:14:02 <rosmaita> it's assigned to me, but i'll be happy to hand it over if someone else wants it
14:14:22 <rosmaita> also, i will be happy to get advice from anyone familiar with this kind of problem
14:14:48 <rosmaita> jokke_ i think you have a good suggestion
14:14:54 <rosmaita> about monty's patch
14:15:06 <abhishekk> I am not familiar, but I will have a look tomorrow
14:15:19 <rosmaita> apparently the patch that we're depending on breaks some other project's job
14:15:35 <rosmaita> so if we move it to our repo, only we will be using it
14:15:56 <rosmaita> we can always revert to using the job def in the devstack repo once that's sorted out
14:16:00 <jokke_> I'm sure that someone will start crying that we're doing code duplication as soon as it merges, but looking the comment's I think santa comes first than we have tests running if we wait that
14:16:24 <rosmaita> exactly
14:16:38 <rosmaita> ok, i will do that right after the meeting
14:17:30 <rosmaita> so to summarize, the situation is that right now we are running with ZERO functional test gates for glanceclient
14:18:02 <rosmaita> the patches we have now will restore the gates, but only run hte functional tests without ssl
14:18:14 <rosmaita> which is better than nothing, but also far from ideal
14:18:37 <rosmaita> what i'd like to do is:
14:18:48 <rosmaita> (1) get the functional test gates running again
14:18:59 <rosmaita> (2) then we can merge the backlog of glanceclient changes
14:19:14 <rosmaita> (3) fix it so the functional gate works under ssl
14:19:29 <rosmaita> and not cut a release of the python-glanceclient until we have (3) done
14:19:57 <rosmaita> any comments?
14:20:16 <abhishekk> no, sounds good
14:20:31 <rosmaita> #action rosmaita edit current functional gate patch to include monty's new devstack-base job
14:20:38 <abhishekk> please let me know if I need to look during my day time
14:20:40 <jokke_> yeah, I'd be very uncomfortable releasing without ssl being tested
14:20:55 <rosmaita> once i have that up, it's all on us, which is the nice thing about zuul3
14:21:07 <jokke_> also I think finding possible solution to fix that ssl issue gets easier if we have gate that is able to run those tests
14:21:25 <rosmaita> abhishekk i'll shoot you an email
14:21:36 <abhishekk> rosmaita: sure
14:21:45 <rosmaita> i should have everything ready to go so that you can look at it in your morning
14:22:01 <rosmaita> also, i'll send you the little info i learned while looking at the ssl problem
14:22:16 <abhishekk> sounds good, that will be helpful
14:22:44 <rosmaita> but it's like 8 pm your time, so please enjoy your evening after the meeting
14:22:48 <rosmaita> :)
14:22:54 <rosmaita> ok, that's all from me
14:22:57 <abhishekk> :)
14:23:08 <rosmaita> gimme a sec to find the patch i'm talking about so everyone knows
14:24:17 <rosmaita> got it
14:24:22 <rosmaita> #link https://review.openstack.org/#/c/525045/
14:24:42 <rosmaita> ok, so i'll revise and rebase that patch, it should eliminate both dependencies
14:25:14 <rosmaita> one of the dependencies is monty's patch to the playbooks in the devstack repo
14:25:37 <rosmaita> (in case you're interested in looking at it)
14:25:48 <rosmaita> ok, that really is all from me
14:25:58 <rosmaita> actually, one more thing
14:26:29 <rosmaita> i will be travelling this weekend and only working limited hours monday-wednesday next week
14:26:45 <jokke_> k
14:26:53 <abhishekk> noted
14:26:57 <jokke_> One thing from me ref the client release
14:26:59 <rosmaita> thanks
14:27:01 <bhagyashris> ok
14:27:02 <rosmaita> ok
14:27:15 <rosmaita> jokke_ go ahead
14:27:24 <jokke_> please do make sure that if you have anything in flight for the client it get reviewed and ready to go
14:27:38 <abhishekk> ok
14:27:44 <jokke_> we want to merge the things we include and release asap after the gate is rectified
14:28:28 <jokke_> there's lots queued up waiting to be released that has been fixed this cycle
14:28:38 <rosmaita> so about that ... we had talked about releasing out of stable/pike ?
14:28:56 <rosmaita> i have not checked what's happening with the test jobs in stable/pike
14:29:06 <rosmaita> i am afraid it may not be good
14:29:20 <rosmaita> may have to backport this fix to stable/pike
14:29:22 <jokke_> me neither, but I assume we have same shit waiting there
14:29:37 <rosmaita> what jokke_ said
14:30:01 <jokke_> it's not like stable branches wouldn't use zuul 3
14:30:48 <rosmaita> right, and the plan is that once we define jobs in the repo, the jobs will go with the stable branch when they're cut, and that will allow us to change jobs in master without worrying about stable branches no longer passing
14:31:48 <rosmaita> ok, any other updates?
14:31:54 <jokke_> that is good point
14:32:12 <McClymontS> I can share an update
14:32:18 <jokke_> it's very dangerous as well ... so we need to have sharp eye on the test changes to make sure we don't cause any regressions
14:32:47 <rosmaita> jokke_ ++
14:32:54 <rosmaita> McClymontS go ahead
14:33:14 <McClymontS> The multihash spec is ready to be looked at for the most part
14:33:29 <rosmaita> you mean the implementation!
14:33:45 <McClymontS> unfortunately, I hit a snag late in the day yesterday and had to go so its not fully on gerrit yet but hoping to get the glance store element is expected to be on there soon
14:34:03 <rosmaita> that's great
14:34:06 <McClymontS> yep! the code is mostly there, we will need to discuss a few things in the open forum here but I think that will have to be next week now
14:34:20 <rosmaita> why don't you send an email to the ML when you have the patches up
14:34:37 <McClymontS> Specifically log levels, if any additional logging is wanted and how we exactly want to go about defaulting to sha if checksum only exists for many older images
14:34:39 <rosmaita> and then we can start looking
14:34:44 <McClymontS> will do, just wanted everyone to know its very close
14:35:19 <rosmaita> ok, put yourself on the agenda for next week and we can discuss
14:35:27 <rosmaita> glad to hear it's close! that's good work
14:35:27 <McClymontS> sounds good
14:35:41 <McClymontS> yes thanks, excited to get a feature in
14:36:01 <rosmaita> with all the glance related OSSNs out there, it's nice to have a new security feature
14:37:27 <rosmaita> ok, i guess that's all for updates
14:37:35 <rosmaita> #topic open discussion
14:37:44 <bhagyashris> Yesterday I have submitted patch [1] for Inject image metadata feature Implementation (https://blueprints.launchpad.net/glance/+spec/inject-automatic-metadata) [1]: https://review.openstack.org/#/c/527635/1 abhishekk reviewed the patch and given suggestion (Split out patch in 3 different patches) to avoid zuul tempest failing
14:37:53 <bhagyashris> Submitted 3 patches
14:38:14 <bhagyashris> [1]: https://review.openstack.org/#/c/527906/ (create glance-image-import.conf file all changes regarding new file will go in this patch, also you need to add sample file under etc directory as glance-image-import.conf and not as glance-image-import.conf.sample)
14:38:22 <bhagyashris> [2]: https://review.openstack.org/#/c/527907/ (devstack to copy glance-image-import.conf file to /etc/glance directory)
14:38:30 <bhagyashris> [3]: https://review.openstack.org/#/c/527635/2 (Code to inject metadata properties) But this patch requires to merge above two patches.
14:38:37 <abhishekk> that was my opinion though, jokke_, rosmaita please share your views as well
14:38:38 <bhagyashris> So I would like to see more opinions and reviews on above patches.
14:39:13 <bhagyashris> rosmaita: I will need your help to review [2] I mean in devstack we are making changes in lib/glance
14:39:55 <bhagyashris> saw the comments given by abhishekk on [1] and [2] mentioned above i will fix as early as possible. thanks abhishekk!!
14:40:20 <abhishekk> bhagyashris: no issues
14:41:23 <rosmaita> quick question about [2]
14:41:50 <rosmaita> actually, i will look at the patches first
14:42:18 <rosmaita> i have a patch up removing copying of conf files from devstack, instead use iniset to create the conf on the fly
14:42:39 <rosmaita> which is what we do for most of the conf files currently in devstack
14:43:04 <rosmaita> #link https://review.openstack.org/#/c/527263/
14:43:20 <rosmaita> anyway, maybe we can do that for this as well
14:43:37 <bhagyashris> ok
14:43:41 <rosmaita> ok, nice work bhagyashris, i look forward to looking over your patches!
14:44:07 <rosmaita> anything else?
14:44:19 <bhagyashris> so should i make changes in the devstack patch as per https://review.openstack.org/#/c/527263/ this?
14:44:38 <rosmaita> if that makes sense for what you're doing
14:44:54 <bhagyashris> ok
14:45:07 <rosmaita> take a look and see what you think
14:45:32 <bhagyashris> yes sure
14:45:46 <bhagyashris> thank you :)
14:46:08 <abhishekk> So for which milestone we are targeting policy related changes?, q-3 or r-*? I guess of rocky though
14:46:20 <rosmaita> abhishekk will have to be rocky
14:46:42 <abhishekk> rosmaita: got it
14:46:52 <jokke_> bhagyashris: I'll try to leave my comments in there today or tomorrow morn
14:47:13 <jokke_> bhagyashris: I have couple principal concerns about the implementation
14:47:42 <bhagyashris> jokke_: ok thank you :)
14:48:11 <rosmaita> anything else for open discussion?
14:48:37 <jokke_> I'd like to ask about peoples holiday plans
14:48:53 <jokke_> so we're just a week away from Xmas
14:49:04 <abhishekk> I will be having holiday on 25 and 1
14:49:33 <bhagyashris> same me too
14:49:38 <jokke_> I will personally be around at Xmas time, but likely be travelling from start of Jan
14:49:43 <smcginnis> I'm mostly out the 25th to 3rd, but will be in and out if anyone needs anything from me.
14:49:50 <rosmaita> i will be mostly away from dec 25 to jan 4
14:50:14 <rosmaita> like smcginnis i will be occasionally online doing stuff
14:50:49 <jokke_> ok ... so if something critical happens myself and abhishekk are the main points of contacts between Xmas and new year then
14:51:07 <rosmaita> yes, possibly nikhil as well
14:51:09 <jokke_> good to know that we have at least 2 cores more or less available :D
14:51:10 <abhishekk> yup
14:51:27 <McClymontS> I'm in and out from 22-5
14:51:55 <rosmaita> ok, if there's nothing else, we can end early today
14:52:09 <jokke_> Thanks all!
14:52:13 <abhishekk> Mostly we will not have meeting during xmas week then
14:52:15 <abhishekk> thank you
14:52:17 <rosmaita> thanks everyone!
14:52:32 <bhagyashris> thank you
14:52:36 <rosmaita> abhishekk good point
14:52:47 <rosmaita> should we meet on dec 28 ?
14:52:49 <jokke_> yeah, no meeting at 28th
14:52:58 <abhishekk> ack
14:53:02 <rosmaita> ok, we can cancel it now
14:53:07 <rosmaita> no meeting on dec 28
14:53:08 <jokke_> sounds good
14:53:18 <rosmaita> but, will look forward to seeing you all next week!
14:53:25 <rosmaita> #endmeeting