14:00:31 <rosmaita> #startmeeting glance
14:00:32 <openstack> Meeting started Thu Dec 21 14:00:31 2017 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:36 <openstack> The meeting name has been set to 'glance'
14:00:40 <rosmaita> #topic roll call
14:00:45 <jokke_> o/
14:00:46 <abhishekk> o/
14:01:20 <rosmaita> let's wait a few minutes
14:02:30 <rosmaita> i just did a recheck on the release notes for the stable/pike point release of glanceclient
14:02:43 <rosmaita> as i expected, it has no functional tests any more
14:02:54 <rosmaita> we can talk about that in a few minutes
14:03:14 <rosmaita> ok, i am impatient, guess we can get started
14:03:21 <rosmaita> hello abhishekk jokke_ bhagyashris
14:03:36 <rosmaita> #topic updates
14:03:49 <bhagyashris> rosmaita: hello
14:04:00 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:04:07 <rosmaita> (always forget that)
14:04:23 <rosmaita> ok, no meeting next week
14:04:40 <abhishekk> ack
14:04:58 <rosmaita> i'll be offline after today's meeting, but will be back tomorrow
14:05:39 <bhagyashris> ok
14:05:41 <abhishekk> ok
14:05:52 <rosmaita> what i'd like to do is review the priorities during open discussion today, so we all sort of have an idea of what to focus on
14:06:18 <rosmaita> ok, i think jokke_ has something about the glanceclient
14:06:28 <jokke_> yes
14:06:53 <jokke_> so the doc build problem prevented us to merge the ssl tests back
14:07:00 <jokke_> and held back everything else
14:07:05 <rosmaita> :(
14:07:18 <jokke_> which means that we're on Thu afternoon just before Xmas
14:07:59 <jokke_> now I want to hear opinions _if_ the gate behaves should we try still to get release out today or should we hold it off until new year
14:08:16 <rosmaita> too bad sean isn't here
14:08:30 <rosmaita> what are the implications of not releasing?
14:08:38 <jokke_> I kind of feel reluctant to release just before Xmas when we're really short on staff if the barge of doo hits the tornado
14:08:50 <rosmaita> i saw an email somewhere that the client should be released at Q-2 time
14:09:06 <rosmaita> which has passed, but i thought the gate problems might let us stretch it
14:09:31 <rosmaita> on the other hand, your point is well taken about releasing with no one around to fix emergencies
14:09:37 <jokke_> well all of our IIR fixes and everything we have done bugfix wise will not be available for consumers ... I doubt it's hugely big deal due to holidays and we haven't had lots of external pressure to do so
14:09:49 <rosmaita> and, it's not like people are clamoring for a new release
14:09:56 <rosmaita> (what jokke_ said)
14:10:08 <abhishekk> so better to go for new year?
14:10:13 <rosmaita> ok, let's release after jan 1
14:10:30 <rosmaita> that will allow us to get the functional tests into stable/pike
14:10:40 <rosmaita> removing them from project-config has removed them from all branches
14:10:42 <jokke_> Jan 2nd is Wed I think so lets aim to that
14:10:49 <rosmaita> sounds good
14:10:55 <abhishekk> +1
14:11:26 <rosmaita> we will need to backport https://review.openstack.org/#/c/528384/ and https://review.openstack.org/#/c/525045/ to stable pike
14:11:37 <rosmaita> guess i should squash them and put up a patch?
14:11:39 <jokke_> I rather have everyone in known state than break unfortunate few ... specially as we haven't really had tests running for a while
14:12:08 <rosmaita> jokke_ agreed
14:12:11 <jokke_> rosmaita: sounds like a plan if you have time before holidays
14:12:38 <jokke_> rosmaita: just say and I have a look on those next week
14:12:47 <rosmaita> i will have some time ... is it better to squash, or just backport them individually?
14:13:32 <rosmaita> one adds functional tests without ssl, the other restores the ssl and contains that script
14:13:48 <jokke_> I think we have more likelyhood for success if we squash them ;)
14:13:58 <rosmaita> off topic: i really wish i understood why no one else seems to be having this ssl problem
14:14:03 <rosmaita> ok, i will squash!
14:14:03 <jokke_> and they kind of belong into the same fix anyways
14:14:15 <rosmaita> makes sense
14:14:43 <rosmaita> any idea what was breaking the docs build?
14:15:52 <jokke_> nope, I'd guess something barfed either in infra side or sphinx ... I wasn't able to figure it out before the situation was normal again
14:15:55 <abhishekk> jokke_ has figured it was working now, I spend almost a day but wouldn't't understood
14:16:17 <jokke_> I spent pretty much whole this week banging my head against the wall with that
14:16:54 <rosmaita> i wonder if infra has any aspirin left over to share with us
14:17:09 <rosmaita> before i forget
14:17:19 <jokke_> basically the autoindex did not build so the link to the autoindex page pointed to non-existing location and because we fail on warning it blocked the gate
14:17:44 <rosmaita> #action rosmaita propose patch for stable/pike glanceclient to restore functional tests
14:18:11 <rosmaita> i couldn't get that to happen locally
14:18:25 <abhishekk> exactly
14:18:37 <rosmaita> wonder if out of disk space or something strange like that
14:18:44 <rosmaita> ok, as long as it seems to be working now
14:19:00 <jokke_> yeah, but I'm not sure if it was sphinx version change in infra nodes or something else causing it
14:19:15 <jokke_> yeah seems like it's fine now
14:19:25 <rosmaita> ok, i think that's all the updates
14:19:42 <rosmaita> #topic gate situation
14:19:47 <rosmaita> jokke_ that's you, too
14:20:09 <jokke_> Just wanted to highlight Fungi's email as at least it affected me heavily
14:20:31 <jokke_> so I use pretty much only watched-changes to track my gerrit
14:21:18 <jokke_> and as removing those Jenkins account votes cause an update to gerrit it basically flooded 2-3 pages of stale reviews on top of my list
14:21:36 <rosmaita> bummer
14:22:15 <abhishekk> that happened to me as well
14:22:24 <jokke_> might have happened to others as well ... _if_ your patch is hanging somewhere there and does not get attention just put a bump comment on it so it gets update event and populates back on the top of the list
14:22:32 <rosmaita> you must have thought for a minute that we suddenly had a bunch of new contributors!
14:23:11 <jokke_> nope, recognized lots of them and was wondering why the feck someone just bumped all of our stale stuff on top of the listing
14:23:32 <jokke_> super annoying and made workflow that bit of more timeconsuming and annoying again
14:23:52 <jokke_> it also provided great amount of spam
14:24:30 <rosmaita> ok, thanks for the heads up
14:25:07 <jokke_> that's it from me
14:25:13 <rosmaita> ok, that's all from the agenda
14:25:19 <rosmaita> #topic open discussion
14:25:51 <abhishekk> jokke_, could you have look at https://review.openstack.org/523366 when you get some free time?
14:26:11 <jokke_> sorry for hijacking the agenda so late, I just thought those two were important to discuss and there wasn't too much already
14:26:27 <jokke_> abhishekk: will do
14:26:30 <rosmaita> np
14:26:39 <abhishekk> also rosmaita, https://review.openstack.org/#/c/523028/ this one is for you
14:26:54 <abhishekk> jokke_, rosmaita: thank you
14:27:18 <jokke_> so quick heads up on the IIR front
14:27:33 <bhagyashris> jokke_ : Hi, Actually I have put the comment on https://review.openstack.org/#/c/528754/5 (Specifically patch Set No 5)
14:28:04 <jokke_> the hooks for having the plugins is up
14:28:34 <jokke_> bhagyashris: I saw it and I have absolutely no idea what that comment means ... did you perhaps forget to tell what change you made there?
14:28:37 <bhagyashris> jokke_, abhishekk: and thanks for reviewing https://review.openstack.org/#/c/527635/4 this. i am working on fixing the review comments
14:28:47 <rosmaita> abhishekk: i think the orange dot near "Parent(s)" means the patch needs to be rebased ... want to do it while we are here and then jokke_ and i can approve it: https://review.openstack.org/#/c/523028/
14:28:59 <rosmaita> because i think the rebase will wipe out the +2
14:29:26 <abhishekk> rosmaita: will have a look, and do it
14:29:29 <jokke_> if it's clean rebase it shouldn't but if it needs to be rebased manually it will ... iirc
14:30:01 <rosmaita> i'm not sure, zull3 doesn't seem to do auto rebase as much as zull2 did
14:30:12 <rosmaita> i seem to be rebasing all the time these days
14:30:19 <rosmaita> maybe it's just bad luck
14:30:20 <jokke_> I've noticed
14:30:24 <abhishekk> rosmaita: I am not seeing orange dot are you looking at PS 10?
14:30:45 <jokke_> so another thing about the IIR work
14:31:01 <rosmaita> abhishekk yes, in that box under the commit message
14:31:04 <bhagyashris> jokke_: I have put the comment where i have made changes instead of None there we will required group name 'image_import_opts'
14:31:36 <bhagyashris> #link: https://review.openstack.org/#/c/528754/5/glance/opts.py
14:31:43 <abhishekk> rosmaita: rebased
14:31:53 <rosmaita> cool, orange dot is gone
14:32:11 <rosmaita> and it kept jokke_ 's +2
14:32:34 <jokke_> Originally I was doing taskflow for each individual import method ... it's getting super messy ... so I'm refactoring that work currently and having just one taskflow with the logic to take the method and add needed tasks to the flow ... so basically instead of having static taskflow like we do now we build the flow as we need
14:32:48 <jokke_> should have patches up by new year for that finally
14:32:59 <abhishekk> great
14:33:12 <rosmaita> sounds good!
14:33:34 <rosmaita> ok, so priorities for the next 2 weeks
14:33:45 <jokke_> bhagyashris: oh ... now it makes so much more sense .... sorry, that's a good find there
14:33:56 * smcginnis peeks in
14:33:58 <rosmaita> - glanceclient gates unclogged
14:34:05 <rosmaita> - bhagyashris injection
14:34:10 <rosmaita> - scrubber
14:34:13 <jokke_> \\o \o/ o// o/7
14:34:35 <rosmaita> - comments on policy spec
14:34:41 <abhishekk> that sounds like bhagyasrhi's injection :d
14:34:46 <bhagyashris> jokke_: yeah
14:35:07 <rosmaita> well, we should all take a note to keep up on our innoculations
14:35:33 <rosmaita> i will be sure to be more clear in the email!
14:35:48 <bhagyashris> rosmaita: yes currently i am fixing the review comments given by abhishekk and jokke_. I would also like your insight on it
14:35:54 <bhagyashris> :)
14:36:02 <rosmaita> bhagyashris will read & comment tomorrow
14:36:27 <bhagyashris> rosmaita: i have made that task pluggable by making dependency on jokke_'s hook patch
14:36:34 <rosmaita> smcginnis you still there?
14:36:47 <bhagyashris> rosmaita: thank you :)
14:37:07 <smcginnis> rosmaita: o/
14:37:13 <jokke_> bhagyashris: abhishekk rosmaita new version uploaded with just the change bhagyashris flagged
14:37:14 <rosmaita> smcginnis quick question about python-glanceclient ... we are going to wait to release until jan 2
14:37:35 <rosmaita> smcginnis just wondering if that affects anything ... it willl be first queens release of glanceclient
14:37:46 <abhishekk> jokke_ will have a look
14:38:01 <smcginnis> rosmaita: That should be OK. You still have a few weeks then before the client lib freeze.
14:38:08 <rosmaita> ok, cool
14:38:13 <bhagyashris> jokke_: thank you jokke_ :)
14:38:22 <smcginnis> rosmaita: If there are any significant changes in there it might be worth doing an interim release.
14:38:32 <smcginnis> Just to get them out there and have some real-world time.
14:38:46 <smcginnis> rosmaita: But Jan 2 should be alright.
14:39:02 <jokke_> smcginnis: yeah, we've had loads of gate issues and don't want to take the risk to dump new release for Xmas markets when there is skeleton crew available
14:39:06 <jokke_> :)
14:39:18 <rosmaita> we'll see ... getting the functional test jobs to run has been more work than we expected
14:39:21 <smcginnis> jokke_: Ah, good point.
14:39:40 <smcginnis> rosmaita: Oh right, I meant to look into that too and got distracted.
14:39:49 <jokke_> smcginnis: thus proposing the delay even it's due for months already
14:39:56 <rosmaita> smcginnis i think we are ok now
14:40:11 <smcginnis> Yeah, this sounds like a good plan then given the timing. :)
14:40:16 <rosmaita> final problem was the doc build not working, but that seems to have fixed itself
14:40:30 <rosmaita> ok, anything else?
14:40:36 <abhishekk> Merry Xmas in advance \o/
14:40:48 <rosmaita> yes, happy holidays to everyone!
14:41:10 <bhagyashris> jokke_: just look at patch set 7 one more thing will need to fix in list_image_import_opts() method
14:41:11 <fungi> jokke_: apologies for the spam, but the presence of stale negative jenkins votes on changes was also causing problems for lots of people. there wasn't really a better way to fix that issue
14:41:42 <fungi> i made sure to only limit it to open changes with negative verified votes from the jenkins account
14:41:44 <jokke_> Indeed ... thanks for the support on a tough year everyone, enjoy the holidays and lets hope way better next year!
14:42:18 <jokke_> fungi: I totally understand the reasoning for it, it just didn't make it any less inconvenient ;)
14:42:22 <abhishekk> Amen
14:42:26 <fungi> understandable
14:42:31 <rosmaita> fungi we appreciate your work with infra ... happy holidays to you & the team
14:42:36 <fungi> thanks!
14:42:44 <jokke_> what rosmaita just said ^^
14:43:12 <rosmaita> ok, guess that's it ... let's wrap up early :)
14:43:22 <fungi> well, we rely on glance because we need to upload images for our servers constantly, so thanks and happy holidays to all of you too!
14:43:36 <rosmaita> thanks, everyone, and happy holidays!
14:43:54 <rosmaita> i'll be offline today but will be back tomorrow New York time
14:43:57 <jokke_> fungi: and the point was not to throw any blame on you per se ... just flag to others that we might miss/have missed some changes due to that
14:44:09 <fungi> yep, makes sense
14:44:11 <bhagyashris> jokke_: i guess you forgot second comment on same patch set https://review.openstack.org/#/c/528754/5/glance/opts.py
14:45:02 <rosmaita> #endmeeting