14:00:21 <rosmaita> #startmeeting glance
14:00:22 <openstack> Meeting started Thu Jan  4 14:00:21 2018 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:25 <openstack> The meeting name has been set to 'glance'
14:00:31 <rosmaita> #topic roll call
14:00:39 <rosmaita> happy new year, everyone!
14:00:40 <abhishekk> o/
14:00:46 <McClymontS> o/
14:00:52 <McClymontS> Happy new year all
14:00:59 <abhishekk> a very happy new year to all
14:01:34 <rosmaita> thanks, and jokke_ is also around here somewhere
14:01:35 <rosmaita> this should be a short meeting
14:01:40 <rosmaita> not much on the agenda
14:01:51 <rosmaita> plus, i am not actually back at work until tomorrow
14:02:03 <jokke_> o/
14:02:20 <rosmaita> #topic updates
14:02:25 <jokke_> Happy New Year to ye all!
14:03:00 <rosmaita> i don't really have any updates, so let's move onto the next item
14:03:07 <rosmaita> #topic glanceclient
14:03:18 <rosmaita> jokke_ tells me that 2.9.0 has been released
14:03:45 <abhishekk> great
14:03:48 <rosmaita> jokke_: was that from stable/pike ?
14:04:00 <jokke_> yep! The release patch got merged yesterday and that's on master
14:04:29 <rosmaita> ok, great ... i thought it might be held up
14:04:48 <rosmaita> i ran into some problems backporting the changes in master to get the functional test gates running
14:05:02 <rosmaita> #link https://etherpad.openstack.org/p/glanceclient-pike-backport-ft-gate-jobs
14:05:27 <jokke_> ok, I'll try to have a look before flying out Tomorrow
14:05:37 <rosmaita> i think its
14:05:47 <rosmaita> mostly devstack patches that are holding things up
14:06:00 <rosmaita> i will start bugging appropriate people when i am back tomorrow
14:06:02 <jokke_> ok
14:06:09 <jokke_> brilliant
14:06:41 <rosmaita> yeah, i am wondering whether we need to pre-emptively also backport those changes to stable/ocata just in case?
14:07:00 <rosmaita> (after stable/pike is settled, of course)
14:07:10 <jokke_> would be smart once we get to the bottom of it
14:07:32 <jokke_> don't want to have some critical bug being held off because your gates are stuck
14:07:49 <jokke_> s/your/uor/
14:07:51 <rosmaita> ok, hopefully the 2 devstack patches i have up will be sufficient, though zull isn't running my glanceclient patch, so i'm not 100% sure
14:07:53 <jokke_> out
14:07:55 <jokke_> our
14:08:09 <jokke_> lol ... seems that my brain is getting to the holiday mood already
14:08:15 <rosmaita> jokke_ you seem to still be in holiday mode!
14:08:49 <rosmaita> jokke_ you said you'll be travelling ... what is your work schedule for the next week?
14:09:00 <jokke_> I'm off till 25th
14:09:38 <rosmaita> wow
14:09:55 <rosmaita> ok, that's all from the agenda
14:10:03 <rosmaita> #topic open discussion
14:10:04 <abhishekk> happy holidays :D
14:10:09 <McClymontS> I have one item open
14:10:15 <jokke_> cheers ... looking forward to it
14:10:16 <abhishekk> me too
14:10:33 <McClymontS> abhishekk go ahead
14:10:43 <abhishekk> thanks :D
14:10:49 <McClymontS> np, mine is short
14:11:09 <abhishekk> so I have added in etherpad needs opinion about it
14:11:49 <abhishekk> short scenario is if you set processes under uwsgi.ini to greater that 40 then every client command returns 500 error
14:12:02 <abhishekk> otherthan glance command as well
14:12:14 <abhishekk> s/otherthan/other than
14:12:42 <abhishekk> link #http://paste.openstack.org/show/637738/
14:12:55 <abhishekk> I have explained this scenario in above paste
14:12:59 <rosmaita> abhishekk i guess you can do that (set workers = 40) in stable/ocata devstack?
14:13:17 <rosmaita> nice explanation in the paste, by the way, thank you
14:13:31 <abhishekk> rosmaita: I have not checked that
14:13:42 <rosmaita> that's ok
14:13:54 <rosmaita> quick question: what made you try this?
14:14:08 <abhishekk> Also the workers config option is unused in case glance is deployed under uwsgi
14:14:10 <McClymontS> agreed, good catch
14:14:46 <abhishekk> rosmaita: I just trying to check a scenario actual how many workers I can set
14:15:05 <abhishekk> s/i just/i was just
14:15:24 <rosmaita> abhishekk good thing to check
14:15:44 <rosmaita> i think there are some things being bypassed in config when running under uwsgi
14:15:48 <jokke_> abhishekk: well that's just one more point to weight that Glance should _not_ be ran under uwsgi
14:16:13 <McClymontS> is that a common opinion? I have actually thought that after working on it for a while
14:16:16 <rosmaita> i ran into a problem that malformed property protections config file doesn't prevent glance from starting
14:16:19 <abhishekk> rosmaita: agree or we need to document somewhere that if glance is used under uwsgi
14:16:53 <jokke_> tbh that list is growing so long that I'm at least not too interested to be worried about anything that breaks under uwsgi
14:16:55 <rosmaita> ok, tomorrow i will collect the bugs we know about for uwsgi so we can have them all documented in one place
14:17:43 <rosmaita> i have not gotten the devstack change working to run glance under systemd in devstack
14:17:53 <rosmaita> (mainly because i haven't really worked on it)
14:17:54 <abhishekk> rosmaita: great, kindly share the same as well
14:18:17 <rosmaita> yeah, i will file bugs for what i know about and circulate an item to the ML for more
14:19:01 <rosmaita> #action rosmaita glance-under-uwsgi bugs filed/tagged
14:19:08 <abhishekk> that's all from me, McClymonts: stage is yours
14:19:16 <rosmaita> #action rosmaita bug appropriate people about devstack backports
14:19:38 <rosmaita> #action rosmaita devstack patch for running glance under systemd without uwsgi
14:19:45 <McClymontS> awesome thank you abhishekk
14:19:59 <McClymontS> I have about 90-95% of the SHA code completed
14:20:10 <rosmaita> woot!
14:20:23 <McClymontS> One question I have is: is the gate working as expected?
14:20:34 <abhishekk> great
14:20:43 <McClymontS> both failed.. tests run locally.. but I did -1 the WF, does that cause an autofail?
14:21:16 <rosmaita> i don't think so ... do you have a link to the review?
14:21:31 <McClymontS> I will get it now
14:21:34 <rosmaita> the WF should just block merges (I believe)
14:21:51 <McClymontS> https://review.openstack.org/#/c/527737/
14:21:53 <McClymontS> glance
14:22:02 <McClymontS> https://review.openstack.org/#/c/528790/
14:22:07 <McClymontS> glance_store
14:22:26 <McClymontS> I will need some solid testing done and also I have asked rosmaita this but was curious if anyone has opinions on logging levels etc?
14:23:43 <rosmaita> the pep8 failure looks real
14:24:00 <McClymontS> Okay, maybe you and I can discuss tomorrow when you are back at work
14:24:02 <rosmaita> on 528790
14:24:09 <McClymontS> When I ran stuff locally it seemed good to go
14:24:10 <rosmaita> yeah, that will be fine
14:24:29 <rosmaita> that's always a bummer
14:24:39 <rosmaita> ok, we can talk tomorrow and sort it out
14:24:48 <abhishekk> I will also check the same
14:24:53 <McClymontS> okay cool. I will try to make sure that is all squared away. the only outstanding issue is getting the sha to return correctly on the api calls
14:25:11 <rosmaita> great!
14:25:14 <McClymontS> We will not be defaulting to sha quite yet. After reviewing the spec I think we should all discuss that further as well
14:25:45 <rosmaita> what would the default be?
14:26:04 <McClymontS> keep its current state for now(verifying checksum)
14:26:20 <rosmaita> oh, you mean for glance validating downloads?
14:26:42 <McClymontS> yeah, I felt like we needed to have the SHA code working 100% before we jumped into that realm
14:26:46 <McClymontS> plus the time crunch is on
14:27:04 <rosmaita> gotcha
14:27:13 <McClymontS> we can discuss more tmrw at work as well
14:27:21 <rosmaita> ok, we can talk after we've all see the code
14:27:22 <rosmaita> thanks!
14:27:30 <McClymontS> thats all from me guys
14:27:40 <McClymontS> thanks for the time.. send log docs if they exist at all as well
14:28:15 <rosmaita> you mean about appropriate levels? don't think we have anything specific to glance
14:28:40 <McClymontS> yeah, in that case I will add that to my code
14:28:48 <McClymontS> and let the review process do its thing
14:29:34 <rosmaita> sounds good ... looks like jokke got kicked from the channel, he has done the most work with glance logging
14:29:40 <rosmaita> ok, anything else?
14:29:59 <abhishekk> nothing from me
14:30:08 <McClymontS> Im good
14:30:11 <McClymontS> happy new year all
14:30:13 <rosmaita> cool, well happy 2018 everyone!
14:30:19 <bhagyashris> I would like to see more insights on patches https://review.openstack.org/#/c/528754/10 and https://review.openstack.org/#/c/527635/ zuul is giving the -1 on second patch becuse this patch is depends-on the devstack patch https://review.openstack.org/#/c/527907/ (requested devstack community to review the same)
14:31:07 <rosmaita> bhagyashris thanks - i will add your patch to my list of bugging devstack cores tomorrow
14:31:20 <bhagyashris> Happy new year!!! :)
14:31:34 <rosmaita> #action rosmaita review https://review.openstack.org/#/c/527907/
14:31:36 <bhagyashris> rosmaita: thank you :)
14:31:52 <rosmaita> guess that's it ... thanks everyone
14:32:08 <McClymontS> thank you all
14:32:11 <abhishekk> thank you all
14:32:19 <bhagyashris> thank you all
14:32:19 <rosmaita> #endmeeting