14:00:39 <rosmaita> #startmeeting glance
14:00:40 <openstack> Meeting started Thu Jan 18 14:00:39 2018 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:44 <openstack> The meeting name has been set to 'glance'
14:00:50 <rosmaita> #topic roll call
14:00:56 <abhishekk> o/
14:01:31 <rosmaita> hello everyone
14:01:49 <abhishekk> hi rosmaita
14:01:58 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:51 <rosmaita> #topic updates
14:03:24 <rosmaita> quick reminder of something i saw on the ML
14:03:43 <rosmaita> Vancouver summit call for presentations closes FEBRUARY 9, 2018 AT 6:59 UTC
14:03:51 <rosmaita> #link https://www.openstack.org/summit/vancouver-2018/call-for-presentations/
14:04:01 <rosmaita> just in case you'd like to submit something
14:04:19 <abhishekk> ack
14:04:25 <rosmaita> ok, next week is Q-3
14:04:31 <rosmaita> also, PTL self-nomination period
14:04:47 <rosmaita> we'll talk about Q-3 priorities later
14:04:56 <rosmaita> that's all the updates i've got
14:05:11 <rosmaita> #topic oslo.serialization problem
14:05:21 <rosmaita> this popped up on the ML
14:05:31 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2018-January/126202.html
14:05:55 <rosmaita> the requirements team wants to bump the version of oslo.serialization and it broke some glance tests
14:06:08 <rosmaita> there's a patch up to fix this:
14:06:32 <rosmaita> #link https://review.openstack.org/#/c/535166/
14:06:42 <rosmaita> it passes tests
14:07:04 <rosmaita> i tried running the glanceclient and glance_store tests with the new version of oslo.serialization
14:07:12 <rosmaita> glance_store passed
14:07:24 <rosmaita> i had trouble with glanceclient
14:07:38 <rosmaita> but it may be my environment or something
14:08:07 <rosmaita> if someone is set up to run glanceclient functional tests, it would be good to try this out
14:08:39 <rosmaita> i was getting this failure, but both with and without the updated oslo.serialization:
14:08:50 <abhishekk> i will do it tomorrow morning my time, let me know what exactly need to do
14:08:50 <rosmaita> glanceclient.tests.functional.test_readonly_glance.SimpleReadOnlyGlanceClientTest.test_list_v2
14:09:08 <rosmaita> 'ascii' codec can't encode characters in position 421-427: ordinal not in range(128)
14:09:29 <rosmaita> there may be a better way, but this is how i did it:
14:09:52 <rosmaita> grab a copy of the upper constraints file and save it locally
14:10:03 <rosmaita> you can use wget, the url is in tox.ini
14:10:26 <rosmaita> change the constraint on oslo.serialization to be the one in the constraints change patch
14:10:48 <rosmaita> which is https://review.openstack.org/#/c/531788/
14:11:22 <rosmaita> then export the UPPER_CONSTRAINTS_FILE environment variable
14:11:38 <rosmaita> with the value set to the absolute location of your fake u-c file
14:12:03 <rosmaita> then tox will use your fake file instead of downloading the real one
14:12:18 <rosmaita> the unit tests were ok
14:12:39 <rosmaita> the functional tests are the ones i have failing
14:12:58 <abhishekk> ok, sounds good will check the same, thank you for details
14:13:05 <rosmaita> thank you!
14:13:21 <rosmaita> if anyone else wants to try, since it's a functional test, you need to have devstack running
14:14:34 <rosmaita> ok, next topic
14:14:40 <rosmaita> #topic glance_store release
14:14:50 <rosmaita> needs to happen today
14:14:58 <rosmaita> still some outstanding patches, though
14:15:25 <rosmaita> #link https://etherpad.openstack.org/p/glance_store-queens-release
14:16:01 <rosmaita> i have a question on that etherpad
14:16:25 <rosmaita> cyril was looking into it, but i don't remember the resolution
14:16:52 <rosmaita> i think we decided to fix it by documentation?
14:17:07 <rosmaita> anyway, i guess it's really too late to do anything about it
14:17:09 <abhishekk> i also think so
14:17:22 <rosmaita> abhishekk do you remember the name of the config opt?
14:17:28 <rosmaita> i am blanking
14:17:50 <abhishekk> need to check in logs :(
14:18:06 <rosmaita> ok, i'll take an action item
14:18:36 <rosmaita> #action rosmaita put up spec lite to fix glance_store dynamic update setting by removing the option since no driver actually implements it
14:18:51 <rosmaita> we'll get rid of it for Rocky
14:19:18 <nikhil> o/
14:19:27 <rosmaita> so the remaining patches are the releasenote, which everyone please read and comment on:
14:19:35 <rosmaita> https://review.openstack.org/535172
14:20:28 <rosmaita> and i rewrote part of the functional test harness to use devstack's cloud.yaml for configuration instead of the special functional-test.conf
14:20:47 <rosmaita> i did that as part of the zuul3 migration for the gate tests
14:20:57 <rosmaita> we have experimental gate jobs that run the functional tests
14:21:40 <rosmaita> unfortunately, i did this all in one patch to update the tests and define the gate jobs
14:21:45 <rosmaita> and the gate jobs are not working
14:22:01 * smcginnis is late but finally made it
14:22:13 <rosmaita> but the new functional test stuff works locally
14:22:48 <smcginnis> I'll have to read the scrollback, but anything I can help with getting glance_store ready for today's deadline?
14:22:56 <rosmaita> i'd like to get those in, but we can always backport
14:23:04 <rosmaita> smcginnis good question!
14:23:59 <rosmaita> does anyone have a clean glance_store set up to run functional tests?
14:24:32 <rosmaita> actually, forget that
14:24:40 <rosmaita> so smcginnis here's the situation
14:24:56 <rosmaita> currently, we have experimental gate jobs to run functional tests for glance_store
14:25:05 <rosmaita> they got trashed during the migration
14:25:30 <rosmaita> i have them rewritten for zuul3, but i'm getting post_failure (even though wehn you look at the output, the tests all pass)
14:25:40 <abhishekk> croelandt, is also here now :)
14:25:50 <rosmaita> so the regular gates all pass
14:25:52 <smcginnis> rosmaita: Ah, so may need a zuul config change to get the tests to pass to wrap things up?
14:26:05 <rosmaita> well, it would be good if they pass
14:26:10 <rosmaita> but they are experimental
14:26:12 <smcginnis> Oh, you said experimental. Well, that's a little better I guess.
14:26:19 <rosmaita> yeah
14:27:13 <rosmaita> the functional test changes aren't mentioned in the release note
14:27:48 <rosmaita> so we don't absolutely have to get them in, i guess
14:28:07 <rosmaita> and they do pass morally
14:28:12 <rosmaita> :)
14:28:35 <smcginnis> :)
14:29:26 <rosmaita> so smcginnis how would it be if we cut the release without them, and then backport? guess we'd have to re-release? i think we want the updated gates in the branch in case other fixes need to be backported later
14:29:52 <smcginnis> rosmaita: Is the backport just the .zuul.conf changes for the functional jobs?
14:30:26 <rosmaita> well, plus some changes to the job structure to make it easy to run them in zuul
14:30:45 <rosmaita> let me find the patch so you can see what i mean
14:30:46 <smcginnis> rosmaita: But no "functional" changes. I think that's totally acceptable.
14:31:03 <rosmaita> https://review.openstack.org/526956
14:31:11 <smcginnis> If it's all zuul config and job definitions, that's easy to backport and shouldn't hurt anything.
14:31:14 <rosmaita> guess it depends on what you consider a functional change
14:32:29 <rosmaita> guess i could separate out the functional test changes from the gate job definitions
14:32:34 <smcginnis> I mean the running code of glance_store doesn't need to be altered. Or more importantly, the lib code isn't "broken" right now, so consumers of glance_store won't have a problem using it.
14:32:46 <smcginnis> Just looked at the patch. That looks fine to me.
14:32:49 <rosmaita> smcginnis correct
14:33:01 <rosmaita> ok, thanks
14:33:16 <rosmaita> so we'll merge the releasenote and then cut the release
14:33:31 <smcginnis> ++
14:33:33 <rosmaita> and backport 526956 as soon as it's fixed
14:33:36 <rosmaita> cool
14:34:41 <rosmaita> ok, so everyone: please review releasenote https://review.openstack.org/#/c/535172/ so we can merge it
14:34:56 <rosmaita> smcginnis i'll look for you as soon as i get the release patch together
14:35:24 <smcginnis> rosmaita: Great, just let me know if you have an issues getting the release patch done.
14:35:26 <rosmaita> ok, priorities for Q-3
14:35:32 <rosmaita> smcginnis will do!
14:35:43 <rosmaita> #topic priorities for Q-3
14:36:37 <rosmaita> ok, i talked with McClymontS earlier this week, we're going to hold off on the multihash until Rocky
14:36:43 <rosmaita> it touches too much stuff
14:36:53 <rosmaita> for example, needed some changes into glance_store
14:37:01 <McClymontS> yeah with the gate issues I think it would be wise to circle back to it
14:37:05 <rosmaita> but, i want to handle this like we did community images
14:37:08 <McClymontS> it does touch a lot of elements
14:37:29 <rosmaita> that is, try to merge very shortly after the stable/queens branch of glance is cut
14:37:41 <kairat> wow, multihash finally=)
14:37:59 <rosmaita> no sense leaving it hanging, let's get it in extremely early in queens
14:38:18 <abhishekk> you mean to say in rocky
14:38:24 <McClymontS> yes
14:38:25 <rosmaita> abhishekk ty!
14:38:42 <McClymontS> I'll also be taking a look at the lang neutralization stuff
14:38:49 <McClymontS> or normalization sorry
14:39:00 <rosmaita> i think it's actually neutralization
14:39:10 <rosmaita> make glance_store less images-centric
14:39:40 <rosmaita> ok, so as a result, what we have for Q-3 priorities are:
14:39:55 <rosmaita> (1) the image import injection stuff
14:40:04 <rosmaita> (2) anything associated with image import
14:40:37 <rosmaita> (3) the E-M-C glance-manage fix
14:40:52 <rosmaita> not sure there's a patch up for (3) yet, i need to look
14:41:03 <smcginnis> I think I remember seeing one.
14:41:25 <rosmaita> i've been talking with Shilpa about it, he had changes working locally
14:41:32 <rosmaita> smcginnis you are right, there's an old patch
14:41:51 <rosmaita> i think Shilpa was going to take it over
14:41:59 <rosmaita> i will check
14:42:12 <rosmaita> anyway, i will post review links in the email
14:42:25 <rosmaita> which i will not forget to send out this week
14:42:31 <rosmaita> because i will do it right after the meeting
14:43:40 <rosmaita> ok, that's all from me
14:43:48 <rosmaita> #topic open discussion
14:44:15 <abhishekk> Shilpa works during my timezone and I know she is working on that from week or two
14:44:32 <rosmaita> great!
14:45:09 <rosmaita> she's been very nice about staying late in the office her time to talk to me
14:45:26 <abhishekk> I know
14:46:01 <abhishekk> I will have a word with her to get update and will ask her if patch is ready the push it for review
14:46:15 <abhishekk> she works with bhagyashri
14:46:25 <rosmaita> i'm glad she picked this up ... luckily, i don't think we have any db migrations this cycle
14:46:34 <rosmaita> so once her fix is in, we will be ready for Rocky
14:46:42 <abhishekk> right
14:46:57 <rosmaita> which will be more exciting, multihash will be touching the database i believe
14:47:10 <McClymontS> it does touch the db, is there a link to her patch?
14:47:13 <McClymontS> sorry if I missed it
14:47:39 <abhishekk> I guess NTT guys will help if we want to get any work related to E-M-C
14:48:12 <rosmaita> ok, cool ... will have to ask them to help getting in-gate testing going
14:48:30 <abhishekk> cool
14:48:37 <rosmaita> that's what we really need, i think
14:48:59 <rosmaita> and once the zuul3 stuff has stabilized, shouldn't be remarkably difficult to get it going
14:49:05 <rosmaita> (though you never know)
14:49:17 <abhishekk> I guess we will have a chat during PTG
14:49:31 <rosmaita> yes, and that's a good reminder
14:49:53 <rosmaita> i saw on the ML that some other teams have started PTG etherpads
14:50:02 <abhishekk> yes
14:50:04 <rosmaita> i'll get something up, probably over the weekend
14:50:25 <rosmaita> or earlier
14:50:44 <rosmaita> i'll send an email the ML when it's up ... i won't delay the priorities email
14:51:07 <rosmaita> any other topics on people's minds?
14:51:44 <McClymontS> nah I am good
14:52:15 <abhishekk> notmyname, thank you
14:52:23 <abhishekk> sorry :)
14:52:34 <abhishekk> no from me
14:53:30 <rosmaita> ok, i will end early if everyone PROMISES TO GO READ THE RELEASENOTE PATCH FOR GLANCE_STORE RIGHT NOW
14:53:41 <rosmaita> #link https://review.openstack.org/#/c/535172/
14:53:44 <abhishekk> o/
14:54:53 <rosmaita> ok, thanks everyone ... don't forget to review the release note patch!
14:55:10 <rosmaita> can't cut a release without it
14:55:22 <rosmaita> well, i guess technically we could, but it would look stupid
14:55:39 <rosmaita> that's all!
14:55:44 <rosmaita> #endmeeting