14:01:02 <rosmaita> #startmeeting glance
14:01:03 <openstack> Meeting started Thu Feb  1 14:01:02 2018 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:06 <openstack> The meeting name has been set to 'glance'
14:01:11 <rosmaita> #topic roll call
14:01:15 <rosmaita> hello everyone!
14:01:18 <abhishekk> o/
14:01:20 <Brin> hello
14:01:39 <bhagyashris> o/
14:01:43 <McClymontS> o/
14:02:37 <rosmaita> well, guess we might as well get started
14:02:46 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:02:55 <rosmaita> #topic updates
14:03:13 <rosmaita> ok, after much anguish, Q-3 was released early this week
14:03:22 <rosmaita> i don't even remember what day, maybe tuesday
14:03:31 <rosmaita> anyway, i sent out something to the ML about that
14:04:01 <rosmaita> the key thing to keep in mind is that the gate to merge stuff has not gotten any faster
14:04:07 <smcginnis> o/
14:04:20 <McClymontS> still up near 24 hrs rosmaita?
14:04:49 <rosmaita> i think something got through yesterday in 18 hrs
14:04:54 <rosmaita> so maybe it is getting better
14:05:04 <McClymontS> hm still pretty unreasonable
14:05:23 <rosmaita> yes, i think there will be a lot of discussion at the ptg
14:06:00 <smcginnis> I know there was one of the cloud providers that gave us a higher quota, but if we actually used them all it was overloading the network.
14:06:08 <smcginnis> So they've dropped that down.
14:06:16 <rosmaita> yeah, there are a lot of moving parts
14:06:27 <smcginnis> Rather than having a higher number running at a time, but slower, we'll have a smaller, faster number.
14:06:32 <rosmaita> and improving one thing can degrade other stuff
14:06:32 <smcginnis> At least that's the hope I think.
14:07:00 <jokke_> o/
14:07:10 <rosmaita> yes, and i should stress that the infra team have been busting their butts
14:07:33 <rosmaita> there were several unfortunate occurrences that messed things up
14:07:49 <rosmaita> plus maybe the first time zuul3 was under extreme load conditions
14:08:19 <rosmaita> anyway, i have taken the liberty to reach out to the infra team for a "consulting" session at the PTG
14:08:30 <rosmaita> just want to go over our actual jobs with them
14:08:38 <rosmaita> make sure they're configured correctly
14:08:42 <McClymontS> good plan rosmaita, hopefully they can provide some guidance
14:08:50 <rosmaita> and maybe see if we can do something better
14:09:01 <rosmaita> i hope so, have not heard back yet
14:09:04 <rosmaita> also,
14:09:16 <rosmaita> i took the liberty of reaching out to the keystone team
14:09:24 <rosmaita> want a consulting session with them too
14:09:50 <abhishekk> good to have
14:09:51 <rosmaita> where we explain what our problems are (particularly with policies and image locations) and figure out what is available to help us
14:10:13 <rosmaita> want to make sure that whatever we want to use isn't planning to be obsoleted or anyghint
14:10:16 <rosmaita> *anything
14:10:38 <rosmaita> i did hear back from lance, they will schedule something with us early in the week, monday or tuesday
14:10:50 <rosmaita> with the option to maybe follow up later in the week if necessary
14:11:04 <rosmaita> i have gone off-topic
14:11:14 <rosmaita> anyway, don't forget the ptg planning etherpad:
14:11:27 <rosmaita> #link https://etherpad.openstack.org/p/glance-rocky-ptg-planning
14:11:41 <rosmaita> ok, so with Q-3 out the feature freeze is in effect
14:12:02 <rosmaita> and bugfixes at this point should only be release-critical
14:12:23 <rosmaita> though, i will interpret that a bit liberally
14:12:57 <rosmaita> there is a FFE request already, we will discuss later
14:13:08 <rosmaita> the image import stuff is also automatically FFE'd
14:13:25 <rosmaita> i don't think we will be able to remove v1 this cycle, however
14:13:32 <rosmaita> :(
14:14:12 <rosmaita> but, removing v1 and merging the multihash stuff should be undertaken as soon as possible after stable/queens is cut
14:14:18 <rosmaita> well, let's say
14:14:21 <rosmaita> multihash first
14:14:49 <rosmaita> and actually, the glance_store part of multihash can be done as soon as we have reviewer bandwidth
14:15:04 <abhishekk> sounds good
14:15:05 <rosmaita> but i am going off topic again
14:15:12 <McClymontS> probably need to review that a bit with someone as the code was finished a while ago
14:15:19 <McClymontS> make sure we won't create merge conflicts and the like
14:15:23 <rosmaita> McClymontS makes sense
14:15:41 <McClymontS> good news is I have .patch files for both repos so the changes are evident
14:16:31 <rosmaita> on that note, there are some patches that need reviews pronto
14:16:41 <rosmaita> https://etherpad.openstack.org/p/glance-quick-reviews
14:16:47 <rosmaita> #link https://etherpad.openstack.org/p/glance-quick-reviews
14:16:56 <rosmaita> i would ninja them in, but most of them are mine
14:17:15 <rosmaita> i bring it up now because one of the patches is functional tests in glance_store
14:17:31 <rosmaita> we've always had some, but they've always been experimental
14:17:49 <rosmaita> and they still are, but i had to rewrite them a bit to get them to work again
14:17:59 * jokke_ is bit multitasking with another meeting atm.
14:18:14 <rosmaita> anyway, abhishekk and jokke_ please check out that etherpad at your earliest convenience
14:18:27 <abhishekk> rosmaita, ohh I have added one patch in that
14:18:33 <McClymontS> I will review when I have time as well
14:18:42 <rosmaita> abhishekk good!
14:18:44 <rosmaita> McClymontS ty
14:19:00 <rosmaita> last update
14:19:17 <rosmaita> PTL self-nomination period ends on Wednesday
14:19:28 <rosmaita> so far, erno has put up a patch
14:19:42 <rosmaita> i guess everyone has seen my note on the ML?
14:20:06 <rosmaita> a few weeks ago i said that i had the support of my management to be PTL again, which was entierly true
14:20:10 <rosmaita> i did have support
14:20:11 <jokke_> will do
14:20:25 <rosmaita> but i decided it would be better to let someone else do it for a change
14:20:29 <rosmaita> before i burn out
14:20:41 <abhishekk> thank you rosmaita for your organized efforts
14:20:43 <rosmaita> like i said in the email, i'm going to continue to work on glance
14:20:55 <rosmaita> but concentrate on one or two things instead of 18
14:21:04 <smcginnis> Thanks for all your work rosmaita. Better to not get burned out.
14:21:06 <rosmaita> abhishekk yw
14:21:23 <rosmaita> smcginnis ty
14:21:37 <rosmaita> yes, we've got a good community and i want to continue working with y'all
14:22:01 <rosmaita> ok, that's all for the updates
14:22:15 <rosmaita> #topic Update the error response code in document
14:22:18 <rosmaita> Brin this is you
14:22:33 <Brin> I am here
14:22:47 <rosmaita> great, tell us something about this
14:22:51 <Brin> Update the error response code in document, consistent with cinder and nova document libraries.(e.g. 400 to badRequest(400))  (Brin Zhang
14:23:07 <Brin> I think here need to be consistent with cinder, nova api documentation
14:23:20 <Brin> because this way, the user can see a clear http error, rather than an error code, e.g.400,500,503
14:23:35 <Brin> do you think so?
14:23:50 <rosmaita> so you mean just in the documentation?
14:24:01 <Brin> yes
14:24:30 <rosmaita> so can you show an example? here's our docs: https://developer.openstack.org/api-ref/image/v2/index.html#images
14:25:10 <rosmaita> maybe this is better: https://developer.openstack.org/api-ref/image/v2/index.html#create-an-image
14:25:19 <smcginnis> Here is an example: https://review.openstack.org/#/c/527345/3/api-ref/source/v2/qos-specs-v2-qos-specs.inc
14:25:34 <Brin> You can fllow this link :https://developer.openstack.org/api-ref/image/v2/index.html#create-image-member
14:26:04 <smcginnis> My personal opinion for Cinder was the codes were mostly fine, but if someone wants to maintain the string representations, that may make it a little easier for some.
14:26:16 <Brin> I don't know what is the Error response codes: 400, 401, 403, 404, 409, 413
14:26:20 <smcginnis> So kind of a "meh, why not" in the end. :)
14:26:32 <rosmaita> i remember working on a table for these back when anne gentle was docs ptl
14:26:44 <rosmaita> i eventually abandoned it
14:27:34 <rosmaita> anyway, my only concern is, is there a table somewhere of the "official" strings?
14:28:03 <rosmaita> and why is "Request Entity Too Large(413)" not all one word like the others?
14:28:21 <rosmaita> in other words, i don't object to making the docs more clear, i just don't want a lot of churn
14:28:28 <rosmaita> i.e., fix it and then re-fix it
14:28:42 <rosmaita> on the other hand, doc churn is not like code churn
14:28:51 <rosmaita> so what the heck
14:28:52 <Brin> I think this is better for users who read api
14:29:12 <Brin> Instead of just seeing a single figure
14:30:22 <rosmaita> this is the table thing i was talking about: https://review.openstack.org/#/c/349551/
14:31:29 <jokke_> ok .. what did I miss
14:31:38 <smcginnis> Hah, line 66. :)
14:31:41 <Brin> rosmaita: yeah, I think it good.
14:31:59 <rosmaita> i forget why we never followed up with that
14:32:14 <rosmaita> other than it being a bit of work
14:32:38 <rosmaita> anyway, i personally have no objection if someone wants to update the docs as Brin suggests
14:33:24 <rosmaita> Brin are you interested in doing this, or is your aim to nudge projects to do this themselves?
14:34:17 <Brin> For future development, I think this is something to do
14:34:51 <Brin> I am willing to take the time to try this thing
14:35:11 <rosmaita> OK, sounds good
14:35:18 <jokke_> so just finished with backlog
14:35:19 <Brin> This should be done on the premise that everyone thinks it needs to be done
14:35:41 <rosmaita> OK
14:35:45 <Brin> ok
14:35:46 <jokke_> I'm not sure if that's worth of the time
14:36:02 <rosmaita> well, not our time
14:36:15 <rosmaita> but if someone new wants to take it on, what the heck
14:36:23 <jokke_> the API ref is for developers who are interacting directly with the API
14:36:26 <rosmaita> the numbers have well-defined text to go with them
14:36:26 <Brin> This is not a problem, given the time allowed :)
14:36:41 <rosmaita> so it's not like we'll have to review really carefully
14:36:42 <jokke_> I think the list of codes that doc has atm. is really quick to scan through what to expect
14:37:03 <jokke_> and when you're developing REST client, you gotta either have cheatsheet or you know these
14:37:07 <rosmaita> ok, tell you what
14:37:15 <rosmaita> this would be a good topic for a spec-lite
14:37:18 <Brin> Since you say that, it is not necessary
14:37:20 <jokke_> our clients does spell them out
14:37:27 <jokke_> for endusers
14:37:31 <Brin> Can proceed to the next topic
14:37:34 <jokke_> instead of throwing just a code
14:38:01 <rosmaita> ok, so opinion is mixed
14:38:09 <jokke_> so just wondering what the value is and if we spell them out, please make sure they do not become unreadable
14:38:11 <Brin> yeah
14:38:24 <jokke_> like one per line or something that is quick to look through
14:38:34 <rosmaita> that's the advantage of the rest_status_code table structure
14:38:52 <rosmaita> Brin why don't you look into that and follow up with us?
14:39:21 <jokke_> ++
14:39:28 <rosmaita> #topic FFE request for --check feature
14:39:35 <rosmaita> here's the info:
14:39:49 <rosmaita> #link http://specs.openstack.org/openstack/glance-specs/specs/untargeted/glance/lite-spec-db-sync-check.html
14:39:54 <rosmaita> #link https://review.openstack.org/#/c/455837/8/
14:40:07 <Brin> Perhaps I ignored this point, after the meeting I will conduct in-depth research
14:40:16 <Brin> thank you.
14:40:17 <rosmaita> thanks, Brin
14:40:38 <rosmaita> ok, key point here is (1) it's a spec lite, and (2) it's already been coded
14:40:49 <rosmaita> and it will be very useful for operators
14:40:55 <rosmaita> so i am inclined to grant an FFE
14:41:03 <bhagyashris__> yeah
14:41:07 <kairat> +1
14:41:08 <abhishekk> +1
14:41:12 <smcginnis> Looks low risk with some benefit.
14:41:15 <ShilpaSD> thnaks brin and rosmaita
14:41:31 <rosmaita> ok, cool, sounds like FFE should be granted
14:41:37 <rosmaita> that was easy!
14:41:46 <jokke_> I think that is crucial with our EMC approach that the operators have tools to verify on which stage they are ... defo +2 for that
14:41:48 <Brin> thanks.
14:41:56 <rosmaita> #topic policy-in-code community goal
14:42:04 <rosmaita> http://lists.openstack.org/pipermail/openstack-dev/2018-January/126827.html
14:42:09 <bhagyashris__> thank you :)
14:42:19 <rosmaita> ok, so lance sent out an email wondering what's up with our status
14:42:28 <rosmaita> i haven't responded yet
14:42:45 <rosmaita> because as far as i;m concerned, it's very low
14:42:50 <rosmaita> priority, that is
14:42:55 <rosmaita> two things:
14:43:10 <rosmaita> you need a policy file to effectively use property protections
14:43:17 <rosmaita> these changes don't touch that at all
14:43:29 <jokke_> and they really cant
14:43:50 <rosmaita> basically, i am going to reply that we're not doing it this cycle and i can take the heat for that as Queens PTL
14:44:12 <rosmaita> plus, we have the policy changes we want to make
14:44:29 <rosmaita> so i don't see the point in doing this right now
14:44:50 <abhishekk> agree
14:45:03 <rosmaita> #link https://review.openstack.org/#/c/528021/
14:45:14 <jokke_> yeah, we definitely should catch up with Lance in PTG and walk through where this is going to impact us
14:45:16 <rosmaita> ^^ that's what i mean by "policy changes"
14:45:33 <jokke_> and why this hasn't been done
14:45:38 <rosmaita> jokke_ i will make sure i say that in my response to the ML
14:45:54 <jokke_> I think it's easier to walk through in person than trying to put into an email
14:46:18 <rosmaita> yes, the email will just say (1) not doing it in queens, and (2) let's discuss in person in Dublin
14:46:23 <jokke_> Glance policies are unfortunately complex af atm
14:46:37 <jokke_> rosmaita: sounds good
14:46:38 <kairat> don't see how it affect property protections, maybe i missed something, it just change defaults from policy files to code
14:46:57 <rosmaita> kairat it makes them asymmetrical
14:47:10 <kairat> we also better get rid of policy layer
14:47:11 <jokke_> kairat: it will not achieve it's goals as property protections are relying on that file anyways
14:47:18 <kairat> if possible=)
14:47:31 <rosmaita> kairat exactly, i think the layer riddance should be done first
14:47:38 <jokke_> ++
14:48:06 <rosmaita> ok, that's everything on the agenda
14:48:07 <abhishekk> ++
14:48:10 <rosmaita> #topic open discussion
14:48:38 <smcginnis> Did we ever figure out the system package upgrade that was causing the services to fail to start with the functional tests?
14:48:53 <rosmaita> smcginnis yes, erno put up a patch, it has merged
14:49:00 <smcginnis> Awesome.
14:49:00 <rosmaita> it was an eventlet problem
14:49:04 <jokke_> ok if anyone missed it, I threw my name into the hat for PTL after lengthy discussions with various people including Brian
14:49:13 <smcginnis> We may need that backported. I saw some stable-maint checks failing.
14:49:15 <rosmaita> fixed in eventlet 0.22, but we are u-c at 0.20
14:49:16 <smcginnis> http://lists.openstack.org/pipermail/openstack-stable-maint/2018-February/007232.html
14:49:41 <smcginnis> Not sure if it's the same thing or not, but that will have to be sorted before any stable releases can be done most likely.
14:50:00 <smcginnis> jokke_: +1!
14:50:01 <jokke_> there is still time until tomorrow to nominate yourselves, otherwise you'll get me as default :P
14:50:19 <rosmaita> actually, the deadline is wednesday!
14:50:20 <abhishekk> jokke_, +2
14:50:33 <rosmaita> and jokke_ thank you for stepping up
14:50:38 <jokke_> rosmaita: oh, cool
14:51:01 <rosmaita> they monkeyed with the schedule this cycle, not sure why
14:51:27 <jokke_> so this is as much for me as for the community like I lined out in my nomination. I've been past couple of cycles all over the place and done half good job everywhere burning myself out as well
14:51:49 <rosmaita> smcginnis i guess they run those stable-maint jobs with the updated images?
14:51:55 <jokke_> so I need to focus more what I do and this is clear indication where I need to put my focus in
14:51:57 <smcginnis> rosmaita: I believe so.
14:52:09 <rosmaita> yeah, then they are all broken
14:53:28 <rosmaita> i'll put up a patch cherry-picking the change into stable/pike and stable/ocata
14:53:38 <smcginnis> ++
14:53:55 <jokke_> so one thing I can promise ye all. If you'll take me as PTL, I won't be writing the next big feature we want to implement in Glance during my term, but I'll do everything I can to enable you guys do it ;)
14:54:04 <rosmaita> #action rosmaita patch stable/pike and stable/ocata
14:54:10 <rosmaita> jokke_ ++
14:54:38 <abhishekk> :D
14:54:46 <jokke_> rosmaita: and thanks once more for your great work, support and mentoring
14:55:03 <rosmaita> glad to be of service :)
14:55:13 <rosmaita> ok, anything else?
14:55:25 <jokke_> copy from
14:55:37 <rosmaita> yes, so that has a FFE
14:55:41 <rosmaita> as part of image import
14:55:43 <jokke_> are you guys ok still pushing that in for the release?
14:55:56 <rosmaita> i definitely am
14:56:01 <jokke_> cool ... just wanted to bring it up in public if anyone has heavy objections
14:56:02 <abhishekk> +1
14:56:05 <jokke_> at this point
14:56:10 <rosmaita> because it will mean we can remove v1 at beginning of rocky
14:56:15 <jokke_> yes
14:56:20 <rosmaita> otherwise, we'll be in same position we are now
14:56:31 <jokke_> and were last cycle
14:56:39 <rosmaita> so I am gung-ho on image import copy-from
14:56:44 <rosmaita> and the cycle before that
14:56:48 <rosmaita> :)
14:57:37 <abhishekk> jokke_, kindly review https://review.openstack.org/523366 when you get time
14:58:37 <jokke_> abhishekk: will do
14:58:54 <abhishekk> jokke_, thanks
14:59:15 <rosmaita> ok, i guess that's all for this week ... thanks, everyone!
14:59:22 <jokke_> abhishekk: sorry, have slipped from me
14:59:24 <McClymontS> Thanks all
14:59:26 <jokke_> Thanks all!
14:59:37 <abhishekk> jokke_, no issues
14:59:41 <abhishekk> thank you all !!!
15:00:00 <rosmaita> #endmeeting