14:00:30 <jokke_> #startmeeting glance
14:00:31 <openstack> Meeting started Thu Mar  8 14:00:30 2018 UTC and is due to finish in 60 minutes.  The chair is jokke_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:34 <openstack> The meeting name has been set to 'glance'
14:00:34 <abhishekk> o/
14:00:36 <jokke_> #topic roll call
14:00:42 <jokke_> o/
14:00:44 <McClymontS> o/
14:00:44 <rosmaita> \o
14:01:40 <abhishekk> Looks like everyone settled after #SnowpenStack
14:01:41 <jokke_> this is gonna be short meeting
14:01:50 <jokke_> #topic Updates - Update from PTG
14:02:25 <jokke_> So just want to highlight few things quickly if someone is following up and missed our PTG stuff
14:02:41 <jokke_> #link https://etherpad.openstack.org/p/glance-rocky-ptg
14:03:06 <jokke_> that's our PTG etherpad that has links to the topic individual etherpads
14:03:15 <jokke_> highlights:
14:03:54 <jokke_> 1) we got agreed good split of cross project liaison assignments and the liaison page is updated
14:04:22 <jokke_> 2) We finally found agreement how we are going to attack OSSN-0075 so that will move forward this cycle
14:05:00 <jokke_> 3) Sean joined Glance core reviewers ... big hand for his help over past cycles
14:05:42 <abhishekk> \o/
14:05:48 <jokke_> #link https://etherpad.openstack.org/p/glance-rocky-priorities
14:07:02 <jokke_> That's our high level plan for the cycle ... lets try to get stuff landed before last week
14:07:14 <jokke_> anything I missed?
14:07:39 <abhishekk> nope
14:07:42 <rosmaita> think that's all
14:07:46 <jokke_> cool
14:07:56 <jokke_> #topic Updates - Release
14:07:59 <abhishekk> Bi-weekly meeting for bugs?
14:08:26 <jokke_> In case someone managed to miss we get Queens out last week \\o \o/ o// o/7
14:08:32 <rosmaita> i'll send out a doodle poll about a time for the bug meeting
14:08:33 <jokke_> we got even
14:08:45 <abhishekk> rosmaita, great
14:08:55 <jokke_> thanks for all hard work everyone!
14:09:01 <abhishekk> for queens \o/\o/\o/
14:09:07 <rosmaita> hooray!
14:09:35 <McClymontS> Woot
14:09:39 <jokke_> #topic Open discussion
14:09:45 <jokke_> That's all in agenda
14:10:09 <jokke_> yes I indeed missed the plan for bi-weekly bug meeting
14:10:36 <jokke_> #action rosmaita to send poll for the meeting time
14:10:41 <rosmaita> ok
14:10:55 <abhishekk> Had couple of patches up for reviews, kindly have look as per your convenient time
14:11:03 <jokke_> sure
14:11:28 <abhishekk> Also pranali will be up with glanceclient patch for web-download support by monday
14:11:36 <jokke_> so we were enjoying sunshine and some bare rocks yesterday. What was all that about gate being bonkers etc. was it us or just something in general?
14:11:41 <jokke_> gr8
14:11:58 <rosmaita> just a note about the OSSN-0075 proposal, I dropped out the business about a hard delete for images that have never had an image location set
14:12:06 <rosmaita> will be putting up another spec for that
14:12:25 <abhishekk> rosmaita, acked
14:12:30 <McClymontS> Awesome rosmaita, I'd like to help with that if possible
14:12:42 <jokke_> yes good point, that will need bit more refactoring ... we realized that we do soft delete everything
14:12:45 <rosmaita> McClymontS: i am counting on that!
14:13:00 <jokke_> McClymontS: yeah you got voluntold for that already :D
14:13:10 <McClymontS> It appears were all on the same page haha
14:13:13 <rosmaita> there's another OSSN, this one is 0076 that we can put the hard delete undewr
14:13:18 <rosmaita> *under
14:14:05 <jokke_> abhishekk: about my question above, what happened yesterday? TL;DR would be great
14:14:48 <abhishekk> jokke_, not sure but it was happening to couple of projects
14:15:29 <abhishekk> I have noticed for monasca, manila as well
14:15:36 <jokke_> ok
14:15:45 <jokke_> was it us breaking or something else?
14:16:02 <abhishekk> no it was something else
14:16:06 <jokke_> and is the situation ok now?
14:16:07 <jokke_> ok, cool
14:16:25 <rosmaita> glad it wasn't us doing the breaking!
14:16:30 <abhishekk> yes, its all green now
14:16:37 <jokke_> I was afraid that we broke world somewhere and pissed off for a day :P
14:16:44 <abhishekk> :D
14:17:04 <rosmaita> so it looks like everyone made it home from the PTG ok?
14:17:24 <rosmaita> abhishekk were your travels delayed?
14:17:30 <abhishekk> yes, but still fighting with jet lag
14:17:36 <abhishekk> rosmaita, yes by 5 hours
14:17:46 <rosmaita> that doesn't help with the jet lag
14:17:56 <rosmaita> at least you got to see some snow!
14:18:06 <jokke_> McClymontS: I dunno if you were reading the updates, but you might be happy not being there ... lots of people got snowed in Dub and had their flights delayed by days
14:18:11 <abhishekk> likely,
14:18:50 <rosmaita> McClymontS we never made it to Jameson distillery for the retrospective, it got snowed out
14:18:57 <rosmaita> :(
14:19:03 <abhishekk> :(
14:20:38 <jokke_> ok, well if anyone has anything else on their mind we can give 40min of your life back
14:20:45 <abhishekk> when do we have spec-freeze for rocky?
14:20:48 <rosmaita> wait!!!
14:20:56 <rosmaita> i have something about hidden images
14:21:00 <jokke_> ok
14:21:04 <rosmaita> the spec that's up, i mean
14:21:21 <rosmaita> at the PTG we discussed not making hidden images discoverable by end users
14:21:29 <jokke_> abhishekk: I think that's good question. Lets look the schedule and come up with date by next weeks meeting
14:21:34 <rosmaita> only the admin and the owner would be able to see them
14:21:42 <abhishekk> jokke_, sure
14:21:56 <rosmaita> belmiro responded on the spec that he thinks they need to be discoverable
14:22:14 <rosmaita> "We have use cases where the user can't/don't want to use the latest (recommended) image. This is user/service managers responsibility."
14:22:21 <jokke_> so why would we have hidden images if they were discuverable after all
14:22:30 <abhishekk> exactly
14:22:38 <rosmaita> well, the idea is that they are a recommendation
14:22:50 <McClymontS> Sorry for the delay, I am very sad to hear you guys missed the Jameson distillery
14:22:51 <jokke_> make them community images and they drop out of the default listing
14:22:54 <rosmaita> i mean, the suggested image shows up in the image list
14:23:07 <rosmaita> the others are still available
14:23:34 <rosmaita> anyway, belmiro says that the admin will have to maintain a list for people who need the old versions
14:23:56 <rosmaita> this may be a good topic for a quick operators poll
14:24:05 <abhishekk> guess so
14:24:16 <rosmaita> i can see this both ways
14:24:26 <jokke_> yeah, I think specially as he is not here, lets continue the discussion on the spec
14:24:39 <rosmaita> we could introduce a "show-hidden-images" policy ...
14:24:50 <jokke_> and if he has someone available for next weeks meeting time, they can put topic in for more real time discussion
14:25:01 * rosmaita waits for jokke_ to say "no way!"
14:25:11 <abhishekk> :D
14:25:30 <jokke_> nah ... I'm nice person and would never yell like that ... just -2 the spec :P
14:25:48 <rosmaita> very nice
14:26:00 <rosmaita> ok, sounds good, something for people to think about
14:26:16 <rosmaita> i think we should do the operators poll to get some data
14:26:18 <jokke_> yeah, I think that needs bit more discussion
14:28:14 <jokke_> Anything else?
14:28:26 <rosmaita> not from me
14:28:32 <abhishekk> thank you all, so only priorities for next week are some patches and specs review
14:29:13 <jokke_> yes, will send mail out, but effectively the spec reviews and the client patches would be first priority
14:29:44 <abhishekk> great, thank you again
14:29:56 <rosmaita> I just realized that when we remove v1, it will break the glanceclient tests
14:29:58 <rosmaita> a lot of them
14:30:21 <rosmaita> we may have to pin the glanceclient tests to run against stable/queens for a while
14:30:50 <jokke_> good point
14:30:51 <rosmaita> or something like that
14:31:05 <jokke_> ok, thanks everyone!
14:31:23 <rosmaita> i will look into this and report back at next meeting
14:31:28 <jokke_> rosmaita: ++
14:31:32 <abhishekk> ++
14:31:52 <jokke_> #action rosmaita look into how much of python-glanceclient tests will break due to v1 removal
14:32:03 <jokke_> #endmeeting