14:08:01 <rosmaita> #startmeeting glance
14:08:03 <openstack> Meeting started Thu Mar 15 14:08:01 2018 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:08:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:08:07 <openstack> The meeting name has been set to 'glance'
14:08:15 <rosmaita> #topic roll call
14:08:26 <abhishekk> o/
14:08:31 <w|zzy_> morning
14:08:38 <McClymontS> o/
14:09:18 <smcginnis> o/
14:09:23 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:09:41 <rosmaita> jokke_ has been delayed
14:10:15 <rosmaita> let's skip ahead and return to item #1 when he arrives
14:10:24 <rosmaita> #topic bug team meeting
14:10:26 <abhishekk> ok
14:10:47 <rosmaita> i sent out a poll about a good time for the meeting
14:10:54 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2018-March/128048.html
14:10:56 <jokke_> o/
14:11:07 <rosmaita> jokke_ hello!
14:11:26 <jokke_> _sorry_ ... I've clearly missed one day somewhere ... I was totally living Wed
14:11:26 <rosmaita> please respond by 23:59 UTC today ... looking like 10:00 UTC Monday will be selected
14:11:37 <abhishekk> jokke_, hi
14:11:38 <jokke_> thanks for stepping in!
14:11:42 <rosmaita> thought it was something like that
14:11:53 <rosmaita> i tried to get abhishekk to do it, but he's on mobile
14:11:55 <rosmaita> :)
14:12:17 <rosmaita> anyway, the bug meeting will be every 2 weeks for 45 minutes
14:12:34 <rosmaita> i'll send out an email early Friday morning UTC time about when the first meeting will be
14:12:42 <w|zzy> Much better time for people in Australia etc
14:12:47 <abhishekk> sounds good
14:13:02 <rosmaita> yes, we USA people are going to take one for the team on this
14:13:06 <rosmaita> :)
14:13:28 <rosmaita> ok, that's all for item #2, we can go back to #1
14:13:32 <abhishekk> ;)
14:14:14 <jokke_> Actually I have very little on updates wise. so this part will be quick
14:14:33 <jokke_> rosmaita: mind to change the topic or chair ;)
14:15:11 <rosmaita> how do you change the chair? anyone know?
14:15:20 <rosmaita> #chair jokke_
14:15:20 <jokke_> rosmaita: #chari jokke_
14:15:20 <openstack> Current chairs: jokke_ rosmaita
14:15:25 <jokke_> there we go
14:15:28 <rosmaita> can i un-chair myself?
14:15:38 <rosmaita> #nochair rosmaita
14:15:40 <jokke_> I don't think so and it doesn't matter
14:15:45 <rosmaita> :)
14:15:53 <jokke_> #topic updates
14:16:56 <jokke_> #link https://review.openstack.org/#/c/551935/
14:17:17 <jokke_> the glanceclient change we need to sort out and merge so we can release
14:17:38 <jokke_> looking pretty good, couple of minor things and that should be good to go. Keep your eyes on the review, please
14:17:57 <abhishekk> jokke_, we will push a new patch by tomorrow
14:18:05 <jokke_> and avoid merging anything else to the client until we get that tagged.
14:18:27 <jokke_> specially anything that might break the usability with queens api
14:18:39 <rosmaita> ok, i will watch that review also
14:19:17 <jokke_> Then specs ... We did change the specs repo acls if someone missed the memo on the priority email
14:20:17 <jokke_> sorry for not communicating the policy clearly abhishekk and smcginnis before hand. So now if there is something urgen breaking on that repo, just ping me
14:20:41 <jokke_> as we can't separate the +W rights to specs only, it's repo wide thing
14:20:50 <smcginnis> ack
14:20:56 <abhishekk> jokke_, ack
14:21:32 <jokke_> Then 3rd thing I'd like to point out as FYI:
14:23:05 <jokke_> The uWSGI conversation seems to be stull going and there might pop up some heated comments on that. I'm willing to take any responsibility of our agreement during the PTG that those uWSGI backports will not be accepted to our stable branches so you can direct anyone having issues with that to me
14:24:24 <jokke_> I'll try to keep you guys off from that as much as I can so we can focus on the more pressing things during the cycle
14:24:53 <rosmaita> ++
14:25:37 <abhishekk> ++
14:25:38 <jokke_> spotz: so I think that kind of stole your topic there. the link is broken but last time for our meeting go ahead
14:25:48 <jokke_> #topic devstack pike
14:26:59 <jokke_> spotz: you there?
14:27:02 <spotz> jokke_ no prob, I'm just defending the fact devstack pike needs to actually install. Not defending any method to reach the goal
14:27:48 <jokke_> spotz: I do agree ;)
14:28:30 <jokke_> ok, I pull couple of topics up from the open
14:28:48 <jokke_> #topic specs freeze
14:28:51 <rosmaita> spotz my concern about that backporting that patch is that the COA is for people who will be administrating an openstack cloud ... since we don't recommend uwsgi in production, it would be bad for them to think that uwsgi is the way to deploy glance
14:29:06 <jokke_> rosmaita: ++
14:29:11 <rosmaita> but agree that we need to get glance working in devstack
14:29:20 <jokke_> do we need more time on that?
14:29:53 <rosmaita> no, i just can't keep my mouth shut
14:29:54 <rosmaita> :)
14:29:58 <jokke_> oknp
14:30:24 <jokke_> so we did discuss this with Brian last week and would like to try something new here
14:30:57 <jokke_> is it absolutely horrible idea for rest of you if we spec freeze at R-2 which is week and half after the summit?
14:31:44 <jokke_> I think our early freezes might be one thing turning people away who gets interested during summit, comes to the onboarding and hears that they need to wait for 4 months before proposing their ideas
14:31:54 <rosmaita> only downside is that we will have to be expeditious reviewing specs right before R-2
14:32:08 <rosmaita> but if we plan ahead, that shouldn't be too bad
14:32:20 <abhishekk> seems good plan
14:32:36 <rosmaita> but i agree  with jokke_ that the super-early freeze may be a turn-off
14:32:38 <spotz> rosmaita: Sorry for late answer, the exam doesn't have them doing any configuration. It's all CLI and dashboard unless something is radically changing which I don't think it is
14:32:39 <smcginnis> That sounds good to me. I wouldn't imagine there would be too much coming in that late anyway, but nice to keep the door open for anything that comes up.
14:32:39 <jokke_> obviously we need to be realistic what can be approved for the cycle at that point, but it would keep the door open for some valuable feedback
14:33:16 <rosmaita> spotz ok, good to know
14:34:23 <jokke_> #topic S naming poll
14:34:29 <jokke_> #link https://civs.cs.cornell.edu/cgi-bin/vote.pl?id=E_40b95cb2be3fcdf1&akey=8cfdc1f5df5fe4d3
14:34:34 <jokke_> Remember to vote!
14:34:50 <jokke_> #topic Open Discussion
14:35:07 <rosmaita> resolution about stable branch EOL and "extended maintenance": https://review.openstack.org/548916
14:35:15 <rosmaita> that's just an awareness thing
14:35:22 <jokke_> rosmaita: you had couple of late stranglers there now we have plenty of time for them I think
14:35:27 <rosmaita> looks like it is going to pass (and may have passed already)
14:35:48 <smcginnis> Not yet, but it is looking close.
14:36:06 <rosmaita> smcginnis do you have a one-line summary of the plan?
14:36:11 <spotz> It's real close if it hadn't mhillman sent an email yesterday to get last comments in
14:36:28 <smcginnis> rosmaita: Maybe a two line summary. :)
14:36:34 <rosmaita> (or i can summarize and you can correct me)
14:36:43 <rosmaita> smcginnis go ahead!
14:37:04 <smcginnis> The idea is basically that by the time users actually got to a release and were finding issues and more interested in getting fixes in for them, we had already deleted the stable branch.
14:37:16 <smcginnis> We have a lot of operators still running Mitaka and Newton.
14:38:10 <smcginnis> We don't have resources to extend upstream support, but in the hopes of attracting folks that would be interested in backporting and testing those older stable branches now that they're more compelled to do so (by their supported customers, etc) we will leave the branches open longer.
14:38:30 <smcginnis> Related to that, there is another patch changing the stable policy to help enable this.
14:38:49 <smcginnis> #link https://review.openstack.org/#/c/552733/ Proposed change to stable policy
14:38:55 <rosmaita> i think that going to eliminate Phase III ?
14:39:18 <smcginnis> Yeah, and potentially phase I depending how things go.
14:39:40 <jokke_> IIRC based on the discussions in the Sydney this was some level of "there is enough downstream people interested about this to maintain the branches rather than consuming the upstream team time
14:39:44 <jokke_> "
14:39:52 <smcginnis> So it's not adding much to upstream team load, other than that there was objection to other teams taking over ownership of older stable branches. Some considered that then a fork."
14:40:10 <jokke_> ohh
14:40:13 <jokke_> I missed that
14:40:49 <smcginnis> The hope is there would be more downstream involvement, but the upstream teams would still retain some control over things so nothing gets merged that they are not OK with.
14:41:08 <smcginnis> And stable policy still would need to be followed that fixes go in upstream first, then get backported to older branches.
14:41:19 <smcginnis> So the older stable branches don't end up being "forks".
14:42:45 <rosmaita> ok, thanks smcginnis ... anyone interested in how the stable policy is evolving should look at https://review.openstack.org/#/c/552733/ and leave comments if appropriate
14:44:13 <smcginnis> I guess the one line summary is, the plan is to not prevent a place for interested parties to collaborate on supporting these older releases, while not putting undue load on the upstream teams that care about new development.
14:47:25 <rosmaita> so about my "second thoughts on OSSN-0075 spec" item ... i was writing up another spec to address OSSN-0076 and ran into some conceptual problems.  does anyone have time for a quick meeting tomorrow, 1/2 hour, so i can explain and get some ideas?
14:48:17 <rosmaita> these are already published ossn's, so i think we can talk in glance channel
14:48:32 <rosmaita> i just need some more time to get my thoughts in a coherent order
14:49:07 <jokke_> i'm ok with brainstorming session tomorrow
14:49:14 <jokke_> as long as it's not too late
14:49:27 <rosmaita> what would be a good time?
14:49:29 <jokke_> as tomorrow is apparently Friday :P
14:49:43 <abhishekk> If I am available at that time then will join as well
14:50:08 <jokke_> rosmaita: like before 17:00 utc would be great for me, I'd assume abhishekk would appreciate much earlier :D
14:50:32 <rosmaita> abhishekk what would work for you?
14:50:49 <abhishekk> 17:00 utc will work for me as weel
14:50:54 <abhishekk> s/weel/well
14:51:28 <rosmaita> i think jokke_ wanted to be done by 17:00 ... how about 16:30 utc?
14:51:35 <jokke_> ++
14:51:54 <abhishekk> sounds good
14:52:10 <rosmaita> ok, i will send an email to the ML in case anyone else wants to join
14:52:13 <rosmaita> thanks
14:52:51 <rosmaita> ok, i have a question about the next glanceclient release
14:53:06 <rosmaita> the current release is 2.9.1
14:53:11 <rosmaita> we have a stable/queens branch
14:53:47 <rosmaita> so i think we backport the web-download patch jokke_ mentioned earlier (after it's approved into master) into stable/queens, and release 2.9.2 from there?
14:53:53 <jokke_> hmm-m good point ... I think we had a bug that needs to be opened :P
14:53:58 <rosmaita> then the next release from master will be 2.10 ?
14:54:08 <rosmaita> or 2.10.0 ?
14:54:47 <jokke_> is 2.9.1 tagged in the stable branch?
14:55:12 <rosmaita> no i think it's in master
14:55:27 <jokke_> so stable would be the 2.8.0?
14:55:35 <jokke_> need to check that
14:55:47 <rosmaita> http://git.openstack.org/cgit/openstack/python-glanceclient/log/?h=stable%2Fqueens
14:56:41 <jokke_> so anyways, yes we will need to release 2.10.0 from master and 2.Y.Z+1 from stable what ever that Y.Z currently is in there
14:56:49 <rosmaita> it looks like 2.9.1 is in stable/queens ?
14:57:06 <jokke_> good so then it would be 2.9.2 in stable
14:57:21 <rosmaita> ok, sounds good
14:57:44 <jokke_> or need to speak with tonyb
14:57:47 <rosmaita> jokke_ are you going to file the bug? or want me to?
14:58:00 <jokke_> if we can relese 2.10.0 from stable and 2.11.0 from master
14:58:09 <jokke_> I can do it
14:58:20 <smcginnis> That would work.
14:59:00 <rosmaita> let's continue in glance channel after meeting, i am not clear on the numbering issues
14:59:00 <jokke_> #action jokke_ To open bug that python-glanceclient doesn't support web-download import method
14:59:08 <rosmaita> definite bug!
14:59:09 <jokke_> ok, that's all we have time for
14:59:13 <jokke_> thanks foks!
14:59:22 <jokke_> #endmeeting