14:00:03 <jokke_> #startmeeting glance
14:00:05 <openstack> Meeting started Thu Apr 19 14:00:03 2018 UTC and is due to finish in 60 minutes.  The chair is jokke_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:09 <openstack> The meeting name has been set to 'glance'
14:00:10 <abhishekk> o/
14:00:13 <jokke_> #topic roll call
14:00:15 <jokke_> o/
14:00:26 <jokke_> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:01:42 <jokke_> we have fairly short agenda today, but lets give minute or two for peopele to join
14:02:19 <abhishekk> ok
14:04:43 <jokke_> #topic updates & release updates
14:05:55 <jokke_> So first of all as you likely have noticed Brian is absent for personal reasons. Lets give him a bit of room and I'm sure he will be back when he can
14:06:33 <abhishekk> jokke_, ack
14:06:37 <jokke_> If you have something blocking you that is waiting on him, let me know and we'll work around it
14:08:21 <jokke_> Second we still have quite a few specs that are lacking reviews. I'll put the links to them for next weeks priority mail. Lets get the stuff we have agreed on reviewed that the plans looks as expected and get those merged.
14:08:41 <abhishekk> ok
14:09:57 <abhishekk> Are we planning to conduct bug-smash day tomorrow?
14:09:59 <jokke_> I think the scrubber stuff is looking pretty good, just haven't had time to test it yet. That would be nice to get out of the way and start really pushing for what we need to kill that v1 API
14:10:23 <jokke_> We really need to get that ready by milestone 2 so we don't get any surprises
14:10:29 <jokke_> abhishekk: yes
14:11:10 <jokke_> I'll try to be online as early as possible and we can convene in IRC and make sure we're up to date on our bug situation
14:11:24 <abhishekk> jokke_, are you going to prepare any etherpad where we can log the bugs?
14:11:38 <abhishekk> jokke_, that will be great, ping me once you are online
14:12:11 <jokke_> yeah, lets see at the morning (UTC) how we tackle this
14:12:28 <abhishekk> yep
14:12:52 <jokke_> Release side, I we got the Rocky-1 released today
14:13:04 <jokke_> so we're approaching R-2
14:13:28 <jokke_> that in mind, it's no time until feature freeze
14:13:47 <abhishekk> jokke_, great
14:14:09 <jokke_> So lets keep those reviews coming and hit down any nail heads we can to keep the FF time as smooth as possible
14:14:40 <abhishekk> yes
14:15:04 <jokke_> I'll check the stable branches and if we have releases pending from there will prepare those for next week
14:15:57 <jokke_> #action all Review pending specs and look into Images API v1 removal
14:16:06 <jokke_> that's all from me
14:16:16 <jokke_> #topic locations metadata
14:16:29 <jokke_> abhishekk: you had something unclear about that?
14:16:37 <abhishekk> jokke_, yes
14:17:16 <abhishekk> suppose from here https://github.com/openstack/glance_store/blob/master/glance_store/_drivers/rbd.py#L522 instead of returning empty dict if I want to return {'key': 'value'} then it fails
14:17:54 <abhishekk> due to this check https://github.com/openstack/glance_store/blob/master/glance_store/backend.py#L397
14:18:13 <abhishekk> six.texttype returns false for str in py27
14:18:19 <jokke_> yes
14:18:48 <abhishekk> which is wrong IMO, actually it should be six.stringtypes
14:19:11 <jokke_> it's pretty well documented for six.text_type and in the exception message in the check that for py27 that needs to be unicode encoded
14:19:40 <jokke_> which py27 strings are not by default
14:20:10 <jokke_> so {u'key': u'value'} should work just fine
14:20:21 <abhishekk> it does not work as well
14:20:42 <abhishekk> I have tried that
14:21:34 <jokke_> so what do you get as error on that point?
14:21:55 <abhishekk> same error message
14:22:06 <jokke_> that exception message should tell you the type of your val
14:22:28 <jokke_> and clearly that's not unicode if the check still fails
14:23:09 <abhishekk> jokke_, let me reconfirm this tomorrow
14:23:17 <jokke_> sure
14:23:47 <jokke_> I'm not sure how well Glance hides that
14:23:50 <abhishekk> I have reported another bug which we can discuss tomorrow for bug smash day
14:24:06 <jokke_> so you might need to do some tinkering to access the exception properly
14:24:18 <jokke_> ok
14:24:21 <abhishekk> jokke_, right
14:24:29 <jokke_> #topic Open Discussion
14:24:37 <jokke_> well we have 35min
14:25:13 <jokke_> anything else or do we free up the half an hour for more productive things?
14:25:20 <abhishekk> nothing from me
14:25:25 <McClymontS> I'm good, showed up late apologies
14:25:31 <jokke_> abhishekk: for you that later might mean getting home at reasonable time :D
14:25:39 <jokke_> McClymontS: \o
14:25:53 <abhishekk> jokke_, :D
14:26:23 <jokke_> McClymontS: so R-1 is released today ... some review help would be great specially on the specs that are still unmerged
14:26:37 <jokke_> was released even
14:26:43 <McClymontS> Absolutely, I'll head over and take a look
14:27:02 <jokke_> by the way .... before we end the meeting. Anyone heard from Dharini?
14:27:14 <abhishekk> no
14:27:52 <jokke_> ok, me neither ... lets hope she is just busy with other stuff
14:28:16 <jokke_> ok thanks all! We'll meet tomorrow for bug smash
14:28:24 <abhishekk> thank you
14:28:28 <McClymontS> Sounds good guys thanks
14:28:32 <jokke_> #endmeeting