14:03:14 <jokke_> #startmeeting glance
14:03:15 <openstack> Meeting started Thu May 17 14:03:14 2018 UTC and is due to finish in 60 minutes.  The chair is jokke_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:17 <abhishekk_> o/
14:03:18 <openstack> The meeting name has been set to 'glance'
14:03:20 <jokke_> #topic roll-call
14:03:22 <jokke_> o/
14:03:28 <rosmaita> o/
14:03:29 <smcginnis> o/
14:03:30 <McClymontS> o/
14:03:36 <jokke_> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:04:37 <rosmaita> sorry about all the stuff i added to the agenda, but i am working remotely and may lose connectivity
14:04:46 <jokke_> ok, lets get started, we have a lot on our plate
14:04:54 <jokke_> #topic updates
14:05:20 <jokke_> #info no meeting during the Summit week
14:05:41 <jokke_> So next week we will not have a glance meeting, I'll send mail out after this one
14:05:52 <abhishekk> ok
14:06:27 <jokke_> second thing, our specs are still lacking reviews/acs
14:06:42 <jokke_> #action all review pending glance-specs
14:07:08 <smcginnis> Are there any in particular that we should prioritize?
14:07:57 <rosmaita> probably abhishekk 's multistore?
14:08:13 <McClymontS> I have some feedback queued up for that still
14:08:14 <jokke_> we're approaching spec freeze, If it's your -2..+2 I just want to have ack specially from all the cores (appreciated from rest) to the specs we have open and are in the glance-rocky-priorities
14:08:22 <McClymontS> I reviewed it twice so far I believe
14:08:35 <abhishekk> will grateful to have reviews
14:08:47 <jokke_> #link https://etherpad.openstack.org/p/glance-rocky-priorities
14:09:27 <jokke_> and please if there is concerns on your spec, do revisit them asap so we get to an agreement and can merge them and work on the features
14:10:00 <rosmaita> OK
14:10:21 <abhishekk> ok
14:11:48 <jokke_> last update from me is, in case someone missed the memo, I'll be off the week after summit. I'll be in the West-Coast of US so anything urgent that needs my attention will be reacted on late hours
14:12:14 <abhishekk> ack
14:12:22 <jokke_> Telegram, WhatsApp etc. reaches and I'll try to have a peak on my work mail at least daily
14:12:34 <rosmaita> ack
14:12:54 <jokke_> cool I reorder the agenda bit as I wasn't sure if there was release updates
14:13:00 <jokke_> #topic release updates
14:13:10 <rosmaita> just a few reminders
14:13:22 <rosmaita> rocky-2 milestone is week of june 4
14:13:29 <rosmaita> that is also spec freeze date
14:13:45 <rosmaita> and, we have a bug scrub scheduled for friday june 8
14:14:25 <smcginnis> We probably won't be processing releases next week, but if anything comes up that is important let me know and we can get it out.
14:14:26 <rosmaita> jokke_ you will be back for week of june 4, right?
14:14:41 <jokke_> yes
14:14:55 <jokke_> I'll be coming home over the weekend
14:15:31 <rosmaita> oh yeah, last thing since no glance meeting next week
14:15:46 <rosmaita> next bug squad meeting is monday may 28
14:16:02 <rosmaita> that is all from me
14:16:15 <McClymontS> still at some super early time eastern rosmaita?
14:16:31 <jokke_> rosmaita: will you take chair on the Thu 31st of May meeting so we do not miss 2 of them?
14:16:31 <rosmaita> yeah, 10:00 utc i think?
14:16:36 <McClymontS> Thats not as bad
14:16:42 <rosmaita> jokke_ will do
14:16:49 <jokke_> ty
14:17:23 <jokke_> anything else on the updates?
14:17:25 <rosmaita> McClymontS that's UTC time
14:17:32 <McClymontS> right so 6 am east
14:17:41 <rosmaita> yeah
14:18:04 <McClymontS> Cool, I will try to make one
14:18:48 <jokke_> ok, moving on
14:18:58 <jokke_> #topic Tip tests
14:19:47 <jokke_> So, the glanceclient test issues (which rosmaita is going to talk next)revealead one lacking thing in our testing
14:20:12 <jokke_> we test only released dependencies, meaning these failures will come to us most of the time as surprise
14:20:24 <rosmaita> :)
14:20:36 <jokke_> Zuul allows us to test the tips of the repo if we so choose
14:20:57 <jokke_> and I would like us to do so for the openstack repos we depend on
14:21:36 <jokke_> but I do not want to block us as soon as something merges that breaks us, as it might be that such thing will not end up to the release at all
14:22:36 <jokke_> we have basically 3 options. Either we get periodical test job ran, which runs our tests against the tips, problem with this is, that no-one really follows those periodical tests
14:23:55 <jokke_> the second option is to have non-voting -tips test ran on every patch we upload, this obviously increses the load on infra, might make the tests even longer what they are now and the problem is the same. Pleople tends to ignore non-voting tests
14:24:14 <rosmaita> i think maybe periodical, and make it the release manager'
14:24:24 <rosmaita> s duty to check each week
14:24:38 <abhishekk> +1
14:24:40 <rosmaita> or, we make them run wendesday night so that they are always done before glance meeting
14:24:51 <jokke_> 3rd option would be to make the -tips test to experimental pipeline, which would need someone manually triggering the tests ... again not happening often enough
14:24:53 <rosmaita> then we could make it part of glance meeting to look
14:25:38 <rosmaita> does anyone know how to set up periodical jobs?
14:25:48 <rosmaita> i guess they have them set up on the stable branches
14:26:19 <jokke_> yeah, it's same as setting any other jobs into zuul, just need to set the pipeline to periodical
14:26:33 <rosmaita> oh, then that's not a big deal
14:26:50 <rosmaita> i will do an experimental patch later today
14:27:11 <jokke_> I think the periodical tests runs every night during the quiet hours
14:28:04 <jokke_> so are everyone ok with the idea of it being periodical test and release managers duty to keep eye on them weekly?
14:28:06 <abhishekk> may be day time at my end then
14:28:27 <abhishekk> ok for me
14:28:36 <rosmaita> sounds good, just something to report on at the weekly glance meeting
14:28:51 <jokke_> yeah
14:29:45 <jokke_> #agreed -tips tests to be setup as periodical and release liaison keeping eye out for them and reporting status on the teem meeting updates
14:30:21 <jokke_> rosmaita: you'll put the patch up? Can you also add it to the docs on the rel liaison duties?
14:30:32 <rosmaita> yes, will do both
14:30:55 <jokke_> #action rosmaita to setup the job and update rel liaison duties into the dev documentation
14:30:58 <jokke_> ty
14:31:02 <rosmaita> i'll put keystoneauth as library to test, we can add others as we think of them
14:31:59 <jokke_> rosmaita: just walk through the requirements.txt keystoneauth is obvious, swift client, cinder client and brick; and probably the oslo. stuff
14:32:29 <rosmaita> ok, that's a good list to start with
14:32:31 <jokke_> those should cover majority
14:32:37 <jokke_> gr8
14:32:48 <jokke_> #topic pthon-glanceclient gate status
14:32:51 <jokke_> rosmaita: floor is yours
14:33:09 <rosmaita> ok, so the glanceclient py35 gate is currently broken
14:33:23 <rosmaita> details on the agenda
14:33:31 <rosmaita> i will go directly to status
14:33:44 <rosmaita> we need keystoneauth 3.6.2 to be released
14:33:57 <rosmaita> then we need u-c to be changed to allow 3.6.2
14:34:16 <rosmaita> then i have a patch that we need to merge for glanceclient
14:34:24 <rosmaita> and then we should be back to normal
14:34:29 <rosmaita> (more or less)
14:34:51 <rosmaita> my patch is https://review.openstack.org/#/c/568698/
14:35:09 <jokke_> ok, any indication if keystone is gonna release that before the summit?
14:35:21 <jokke_> do we have workaround if not?
14:35:28 <rosmaita> release patch is up
14:35:34 <jokke_> ok, brilliant
14:35:48 <rosmaita> i don;'t know if the u-c change is proposed by bot, or if we have to do a manual one
14:35:51 <abhishekk> which just got approved
14:35:56 <rosmaita> cool
14:36:03 <abhishekk> I guess it is proposed by bot
14:36:40 <rosmaita> ok, then hopefully it will be proposed soon, i will keep a lookout and push it in release channel where most of the requirements people hang out
14:37:03 <rosmaita> so, i do want people to read the "fallout" section on the agenda
14:37:22 <rosmaita> as far as i can tell, my fix does not break any tests
14:37:41 <rosmaita> but ... whether it doesn't break *anything* depends on how good our test coverage is
14:38:13 <jokke_> we'll see
14:38:40 <rosmaita> yeah, i am a little worried about glance's use of keystoneauth1
14:38:43 <jokke_> so expectation is that the gate is unblocked today still
14:39:43 <rosmaita> possibly
14:40:01 <rosmaita> depends on the u-c patch and then my https://review.openstack.org/#/c/568698/ merging
14:40:22 <jokke_> yeah, lets keep eye on those while reviewing the specs ;)
14:40:24 <rosmaita> could use some eyes on that patch to make sure the fix makes sense
14:41:01 <rosmaita> i tried to explain clearly in commit msg and comments in the code
14:41:11 <jokke_> #link  https://review.openstack.org/#/c/568698/
14:41:42 <abhishekk> yeah comment you have written helps to understand the code
14:41:43 <jokke_> #action all eyes on the rosmaita's client patch 568698 to unblock gate
14:42:03 <rosmaita> and please read the "fallout" on the agenda
14:42:39 <rosmaita> that's all from me unless people have questions
14:43:37 <abhishekk> nothing for now
14:43:49 <McClymontS> Im good
14:43:56 <jokke_> #topic Open Discussion
14:44:04 <jokke_> anything else?
14:44:26 <abhishekk> Nothing from me
14:44:33 <McClymontS> I'll see some of you in Canada
14:44:46 <rosmaita> yes, let's plan to meet up at the glance update session
14:44:46 <abhishekk> all who are attending the summit, safe journey and enjoy the summit
14:44:51 <rosmaita> abhishekk thanks!
14:44:59 <McClymontS> Thank you abhishekk
14:45:00 <jokke_> yeah def for those of you coming to Vancouver, safe travels, can wait seeing ye all
14:45:07 <abhishekk> :D
14:45:24 <jokke_> I will look through the agenda out there and lets grab a team dinner again
14:45:25 <rosmaita> glance update is monday, and we can plan meetings to discuss specs, etc.
14:45:34 <rosmaita> jokke_ ++
14:45:50 <rosmaita> don't think there is a distillery tour in vancouver :(
14:45:55 <abhishekk> share photos ;)
14:46:05 <rosmaita> bummer that jameson's got snowed out in dublin
14:46:10 <jokke_> so if you have corp team nights out or something else blocking specific nights, please let me know asap
14:46:27 <McClymontS> jokke_ I am pretty booked most nights but will try to make time for sure
14:46:35 <McClymontS> Can skip something I am sure
14:47:39 <jokke_> McClymontS: it's pretty normal on summit week that every night has something going on. These thing quite often end up being dinner + roaming for drinks and socializing with the groups whose dinner was missed
14:47:47 <McClymontS> Just keep me posted on plans
14:48:02 <McClymontS> oh absolutely jokke_, but I'd like to meet up with out a doubt
14:48:06 <jokke_> so get used to the idea of rough week and long nights :P
14:48:13 <McClymontS> So let me know when and where, rosmaita has my number
14:48:24 <rosmaita> ++
14:48:34 <jokke_> that would be great, I'll put up dinner etherpad and send that to the mailing list as well today
14:49:05 <McClymontS> Awesome sounds great all
14:49:10 <jokke_> #action jokke_ to put up Glance Summit Dinner etherpad for planning
14:49:12 <McClymontS> I look forward to seeing you guys
14:49:16 <rosmaita> likewise!
14:49:19 <jokke_> likewise
14:49:27 <mugsie> rosmaita: there is a distilery in gastown fyi :P
14:49:32 <abhishekk> ok mates if nothing else, see you in week after summit
14:49:35 <jokke_> if nothing else, lets free up the 12min for something productive!
14:49:39 <abhishekk> thank you all :D
14:49:42 <McClymontS> Awesome
14:49:48 <rosmaita> ok! have a good day everyone
14:49:51 <jokke_> thanks all
14:49:58 <rosmaita> and a good evening to abhishekk
14:50:00 <jokke_> #endmeeting