14:02:06 <jokke_> #startmeeting glance
14:02:07 <openstack> Meeting started Thu Jul 12 14:02:06 2018 UTC and is due to finish in 60 minutes.  The chair is jokke_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:10 <jokke_> #topic roll call
14:02:11 <openstack> The meeting name has been set to 'glance'
14:02:14 <jokke_> o/
14:02:27 <abhishekk> o/
14:02:27 <rosmaita> o/
14:02:29 <jokke_> darn started on wrong meeting channel first :|
14:02:52 <abhishekk> o:
14:03:28 <abhishekk> it happens when you are working on functional testing :P
14:03:34 <jokke_> lets kick off and we'll see if Sean joins us
14:03:45 <jokke_> #topic updates
14:04:36 <jokke_> I'd like to remind that deadline for Berlin summit talk proposals is next week
14:05:13 <abhishekk> ack
14:05:17 <jokke_> if you were planning to submit a talk, please do so asap and if it's a glance talk, would be great if you let the rest know so we won't have overlapping presentations proposed
14:06:19 <abhishekk> jokke_, I might propose a talk on glance + ceph + multi-backend
14:06:46 <jokke_> next thing I wanted to highlight is the multi back-end work Abhishek is working on
14:07:13 <rosmaita> abhishekk: good idea
14:07:29 <abhishekk> rosmaita, :D
14:07:57 <jokke_> #action rosmaita smcginnis please review https://review.openstack.org/#/c/562467/ (the spec)
14:08:20 <rosmaita> ack
14:08:51 <abhishekk> also please review implementation  patches as and when you get some time
14:08:58 <jokke_> #action all please review https://review.openstack.org/#/q/topic:bp/multi-store+status:open+project:openstack/glance_store
14:09:26 <rosmaita> yes, i am sorry that i am getting behind on that
14:09:29 <jokke_> we would really really want to merge those today if possible and cut the store release
14:10:04 <abhishekk> also this one, https://review.openstack.org/#/c/581396/
14:10:08 <jokke_> I was yesterday finally poking deployment that had the feature in and it works
14:11:36 <abhishekk> I will be around next 3 to 4 hours if someone has any doubts
14:11:53 <jokke_> so the last one is good addition but should not be merged before the ones with bp/multi-store topic has been merged and is not panic as the final deadline is next week
14:12:03 <jokke_> we can deprecate stuff still next week etc.
14:12:15 <abhishekk> yes
14:12:21 <rosmaita> what about multihash support?
14:12:32 <jokke_> I just really want release of glance store out with the functionality to make sure it doesn't break world by something we missed on testing
14:14:37 <jokke_> rosmaita: I think it might be something that will be released early next week if it's ready ... that being the case I'd assume 0.26.0 being the glance_store version for Rocky
14:14:49 <rosmaita> ok, works for me
14:15:33 <jokke_> I just really really want those Abhishek's store changes in as they touch the store configuration in so many places
14:16:17 <jokke_> I rather spend tomorrow pulling hair why world broke than panic that next week when we released something broken at the final deadline
14:16:41 <abhishekk> works for me ass well
14:17:20 <jokke_> also honestly I rather have those two coming out separately so if the world breaks we know right away which one broke it :P
14:17:30 <abhishekk> :P
14:17:50 <rosmaita> :)
14:18:13 <jokke_> then next week we'll see what we got into glance_store in time and can make the call in which order we merge stuff into glance
14:18:30 <rosmaita> makes sense
14:18:33 <abhishekk> and what about glanceclient?
14:18:42 <jokke_> so please do not merge the multi back-end glance code yet, even if it looks good, just the glance_store parts
14:19:26 <rosmaita> glanceclient release is one week later, july 25
14:19:27 <jokke_> client lib deadline is I think 2 weeks from now, same time R-3 is so we have time to sort those out after the _store
14:19:39 <abhishekk> ok
14:20:10 <jokke_> but we must prioritize the store changes now if we want these both features landing in Rocky
14:20:18 <jokke_> above everything else
14:20:29 <rosmaita> right
14:20:31 <jokke_> that's all from me
14:20:47 <jokke_> #topic release updates
14:20:58 <rosmaita> ok, so key thing is glance_store
14:21:02 <rosmaita> which we just discussed
14:21:05 <rosmaita> so what erno said
14:21:26 <rosmaita> periodic jobs report
14:21:27 <rosmaita> ALL GREEN!
14:21:37 <rosmaita> that's all from me
14:21:41 <jokke_> \\o \o/ o// o/7
14:21:52 * jokke_ likes when everything is green
14:22:08 <jokke_> #topic Open-discussion
14:22:12 <abhishekk> then we have hide old images as well (but nothing of that related to store)
14:22:41 <rosmaita> good reminder
14:23:02 <abhishekk> I have modified the specs as we have discussed in last meeting
14:23:08 <jokke_> abhishekk: yes ... that's why we need to be careful in which order we merge stuff into the glance and glanceclient to make sure we have everything in working order and that multi-store in experimental
14:23:46 <jokke_> also v1 removal is having one more test failure I'm fighting with
14:23:53 <abhishekk> yes, so lets finalize the order, and write it down to one etherpad?
14:24:11 <abhishekk> jokke_, I will have a look at it tomorrow my time
14:24:16 <jokke_> for some reason our functional tests fails due to use_user_token option failure .... and I have no fecking idea why that breaks
14:24:57 <jokke_> so I keep banging my head against wall with that. Any help is appreciated but the store stuff needs to take priority on this right now
14:25:42 <abhishekk> jokke_, ^^^ I will have a look at it
14:26:07 <jokke_> anything else on your minds for today/this week?
14:26:25 <rosmaita> not me
14:26:38 <abhishekk> rosmaita, need release note for glance store
14:26:47 <abhishekk> not me
14:27:11 <abhishekk> looks like sean is on leave this week
14:27:12 <rosmaita> abhishekk i will put up a patch when i review the code ... thanks for the reminder
14:27:24 <abhishekk> rosmaita, tahnk you
14:27:34 <abhishekk> s/tahnk/thank
14:27:38 <jokke_> reno should be quick addition so yeah separate patch rather than embedding it to one of the existing ones is good idea
14:27:52 <abhishekk> ++
14:28:15 <jokke_> if nothing else, lets use the freed 30min to get the store rolling? ;)
14:28:28 <abhishekk> sounds good
14:28:56 <jokke_> ok, thanks all!
14:29:00 <jokke_> #endmeeting