14:00:23 <jokke_> #startmeeting glance
14:00:24 <openstack> Meeting started Thu Jul 26 14:00:23 2018 UTC and is due to finish in 60 minutes.  The chair is jokke_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:28 <openstack> The meeting name has been set to 'glance'
14:00:30 <jokke_> #topic roll-call
14:00:32 <jokke_> o/
14:00:50 <jokke_> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:59 <smcginnis> o/
14:01:07 <abhishekk> o/
14:01:24 <rosmaita> o/
14:02:18 <jokke_> cool cool ... hey all ... today is very release focused so lets get to it
14:02:25 <jokke_> #topic updates
14:02:39 <jokke_> the PTL self nomination window is open until 31st
14:03:02 <jokke_> if anyone else is still considering, there is time. I'm going to put mine up likely tomorrow
14:03:20 <jokke_> and that's all non-release updates we have going on atm.
14:03:27 <jokke_> #topic release updates
14:03:52 <rosmaita> ok, most stuff is on the agenda
14:04:04 <rosmaita> periodic test jobs look good
14:04:23 <rosmaita> they have started running for glance_store stable/rocky, so i put up a patch to remove them
14:04:37 <smcginnis> rosmaita: I just commented on that first one.
14:04:43 <rosmaita> also a patch to remove from glanceclient stable/rocky which was cut yesterday
14:05:24 <rosmaita> smcginnis ok, sounds like a good suggestion
14:05:30 <rosmaita> didn't know you could do that
14:05:47 <rosmaita> i will put up revised patches as soon as i figure out what it means
14:05:55 <rosmaita> and update the release CPL duties doc
14:06:12 <rosmaita> ok, glanceclient 2.12.0 was released yesterday
14:06:24 <rosmaita> wxy found a problem with his bugfix
14:06:47 <rosmaita> i think we need to include it, and if we do it today, it will be in the "official" rocky glanceclient
14:06:57 <rosmaita> links on the agenda
14:07:08 <rosmaita> jokke_ make sure you think the release note is ok
14:07:24 <jokke_> will do
14:07:45 <rosmaita> i take it you are OK with the release? i mean doing a second one
14:08:43 <rosmaita> patch merged in master, i just put up the cherry pick patch to stable/rocky, link on agenda
14:09:00 <jokke_> that's fine ... the issue is nasty enough to warrant that easily ... btw it was released today if I'm not totally wrong
14:09:04 <rosmaita> #link https://review.openstack.org/#/c/586232/
14:09:56 <rosmaita> i'll put up a new release patch once all the above lands
14:10:02 <rosmaita> ok, final thing
14:10:20 <rosmaita> smcginnis i am subject to correction, but is glance Rocky-3 due today?
14:10:36 <smcginnis> Correct.
14:10:43 <rosmaita> ugh
14:10:46 <jokke_> it's today and it marks FF
14:10:53 <smcginnis> Yep
14:10:59 <rosmaita> i'm going to need a FFE for multihash
14:11:16 <rosmaita> i am in the middle of reviewing abhishekk 's hidden images patch, looks good
14:11:29 <rosmaita> think that can get merged today and then cut Rocky-3 ?
14:11:50 <jokke_> ok, lets hop to the next topic and look what we have on hands
14:11:51 <abhishekk> do I need to file FFE for multi-store?
14:12:01 <jokke_> #topic release priorities
14:12:18 <rosmaita> yeah, jokke_ needs to lead this discussion
14:12:22 <jokke_> So we have 4 things pending to glance rocky-3
14:12:31 <jokke_> /rc1
14:13:01 <jokke_> we have multi back-end which needs to land last due to the requirement having experimental api version for it
14:13:37 <jokke_> we have hidden images and multihash as still pending features
14:13:52 <jokke_> and we have Images API v1 removal
14:14:06 <abhishekk> API v1 removal looks good to go
14:14:35 <jokke_> these are the things listed last week as well for todays deadline
14:15:00 <rosmaita> i have gotten way behind on reviews
14:15:02 <jokke_> I knew we're not gonna make with all of them and that we need to set FFEs for some
14:15:13 <smcginnis> Would have been nice to have the API v1 removal earlier in the cycle to make sure there aren't any unknowns, but I think we should get that done.
14:15:22 <jokke_> but I do not want to FFE all this and keep them hanging over next week as well
14:16:17 <jokke_> smcginnis: yeah, latest revision for that patch has been sitting there for 2 weeks now
14:16:38 <abhishekk> I guess we should get hidden images and v1 removal in today and file ffe for multihash and multi-backend?
14:17:09 <rosmaita> that seems reasonable
14:17:38 <jokke_> abhishekk: that's what I'm thinking ... multi back-end is easy as it's pretty much ready to go, might need some rebasing but technically it looks good to go
14:18:07 <jokke_> rosmaita: when can you have multihash patch up?
14:18:11 <abhishekk> yes
14:18:13 <jokke_> do you have time to do it?
14:18:26 <abhishekk> or I can take it?
14:18:31 <rosmaita> i do, but may have to finish it over the weekend
14:18:58 <rosmaita> current patch has some bad merge conflicts and i think a lot of test revisions
14:19:09 <jokke_> that's fine ... next week is just fine as long as we know it's next week and we're not pushing it further
14:19:10 <abhishekk> rosmaita, let me know if you need anything
14:19:19 <rosmaita> abhishekk thank you, i will
14:19:31 <jokke_> what abhishekk just said. If you need help let us know
14:19:51 <rosmaita> ty
14:20:09 <jokke_> the feature is in client so we did commit to it ... now lets get it done ;)
14:20:49 <jokke_> but we need to get stuff moving so we're not merging everything in the last minute. That's just way too risky and quickly gets us spinning rc10
14:21:08 <abhishekk> so anybody has FFE format :D, I haven't filed any FFE since Juno
14:21:40 <rosmaita> i haven't either, i just always only approved them :)
14:22:11 <abhishekk> I will +a v1 removal that is the only patch which will cause mine to go in conflicts
14:22:19 <jokke_> abhishekk: it's just mail to mailing list requesting it, stating the state of the work, reson for delay and estimated completion time
14:22:44 <smcginnis> Up to jokke_, but I think just posting something to openstack-dev asking for FFE for $FEATURE, then having his OK response should be good enough.
14:23:04 <smcginnis> Not too formal of a process.
14:23:12 <abhishekk> jokke_, smcginnis ack
14:23:26 <jokke_> so rosmaita if you shoot one for multihash and we can just publicly confirm what has agreed here and people know to expect those landing next week
14:23:26 <rosmaita> ok
14:24:12 <abhishekk> rosmaita, unless you want to have a look at v1 removal patch, I am going to approve it after meeting
14:24:28 <jokke_> I'm totally fine if we can keep our FFEs being those two and we have expectation that we have all features in by the next weeks meeting :)
14:25:09 <abhishekk> that will be pretty good for me, as I am going on vacation from 2nd August to 10th August
14:25:40 <abhishekk> (I will carry my laptop with me in case of any urgency)
14:25:43 <jokke_> I will take care of the API version patches and config syncs once we have stuff merging to do those
14:26:17 <abhishekk> jokke_, thank you, I guess documentation is also required for hidden images
14:26:40 <jokke_> abhishekk: yeah, take your well deserved time off and if we end up doing rebase and stuff like that, we'll get that sorted out. Don't worry work too much
14:27:04 <abhishekk> thank you
14:27:10 <rosmaita> i will help with rebases, it's my fault you have to wait to merge
14:27:15 <jokke_> So is this plan agreeable by everyone?
14:27:22 <abhishekk> yes
14:27:35 <rosmaita> yep
14:27:58 <smcginnis> ++
14:28:32 <jokke_> So anything minor popping up, lets file bugs and target them to RC1. From now on our only priority is to get these features in. Anything else can wait unless it's breaking gate and preventing us to merge stuff
14:28:55 <abhishekk> sounds good
14:29:07 <smcginnis> Yep, good plan.
14:29:11 <rosmaita> ok
14:29:14 <jokke_> we have still 2 weeks from now to RC1 so the week after next is good enough for any non-urgent bugfixes
14:29:34 <jokke_> _and_ monday is not bug scrub day
14:29:46 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-dev/2018-July/132523.html
14:29:51 <jokke_> that will be postponed by a week to keep the focus on the FFE items
14:29:51 <abhishekk> ack
14:30:34 <jokke_> #action jokke_ to ack FFEs on mailing list and push bug scrub monday by a week for feature work
14:32:20 <jokke_> #agreed multihash and multi back-end work will have FFE over Rocky-3 deadline until eob next Thu 2nd of Aug
14:32:27 <jokke_> #topic open discussion
14:32:48 <jokke_> This was easier than I thought! So anything else?
14:33:21 <rosmaita> there is some discussion on abhishekk
14:33:28 <rosmaita> 's spec for hidden images
14:33:41 <rosmaita> about the name 'os_hidden' ... just for awareness
14:33:50 <rosmaita> #link https://review.openstack.org/#/c/578755/
14:34:00 <rosmaita> i didn't think anyone would care
14:34:20 <jokke_> yes I saw that and we're not gonna change it and start fighting with the corner cases anymore
14:34:42 <smcginnis> Good response on there rosmaita
14:34:43 <rosmaita> yes, a bit late in the process
14:34:55 <rosmaita> but, it's interesting to see that people are keeping an eye on glance!
14:35:01 <rosmaita> smcginnis thanks
14:35:06 <jokke_> indeed thanks rosmaita for taking care of it and explaining the reasoning
14:35:26 <rosmaita> yeah, i lost that fight back in grizzly!
14:35:29 <jokke_> rosmaita: indeed ... there clearly is some interest sparking again which is good sign
14:35:46 <abhishekk> ++
14:36:27 <abhishekk> http://lists.openstack.org/pipermail/openstack-dev/2018-July/132524.html
14:37:33 <abhishekk> please approve modified specs before approving hidden images patch
14:37:36 <jokke_> ok, the formatting looks good on the image workflow spec now
14:37:53 <jokke_> I'll merge that so there is clarity what we're doing and how
14:38:42 <jokke_> if nothing else, lets use the extra 25min productive
14:38:44 <rosmaita> ok, so right now i will review v1 removal https://review.openstack.org/#/c/532503/ , it's got +2s so i will +W unless i find some problem, in which case jokke_ will kill me
14:38:59 <rosmaita> and then i wlll finish reviewing hidden images patch
14:39:11 <rosmaita> https://review.openstack.org/#/c/578755/
14:39:30 <rosmaita> that one currently has no +2s
14:39:45 <rosmaita> and abhishekk cannot review it
14:39:55 <jokke_> rosmaita: if you find real issue, that's great because the three of us missed it. I will kill you only if you start bikeshedding or nitpicking at this point :P
14:40:07 <rosmaita> noted
14:40:22 <jokke_> ;)
14:40:41 <abhishekk> great, I will be back online after 2 hours
14:41:02 <jokke_> ok, thanks all for your hard work and long hours pulling this together
14:41:10 <abhishekk> I can review multihash patch only :D
14:41:15 <rosmaita> ok, everyone ignore the periodic jobs patches
14:41:28 <rosmaita> i'll put up new ones after RC-1
14:41:39 <abhishekk> ack
14:42:34 <jokke_> anything else?
14:42:38 <jokke_> going first
14:42:42 <abhishekk> nope
14:42:56 <jokke_> going second
14:43:12 <jokke_> sold, thanks all
14:43:13 <abhishekk> thank you all
14:43:14 <jokke_> #endmeeting