14:00:03 <rosmaita> #startmeeting glance
14:00:04 <openstack> Meeting started Thu Sep 20 14:00:03 2018 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:07 <openstack> The meeting name has been set to 'glance'
14:00:10 <abhishekk> o/
14:00:12 <rosmaita> erno is going to be a bit late
14:00:21 <rosmaita> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:29 <rosmaita> #topic roll call
14:00:55 <abhishekk> we should skip the updates part for later
14:01:05 <rosmaita> good idea
14:01:30 <rosmaita> #topic periodic tips jobs
14:01:37 <rosmaita> they're all green!
14:01:52 <abhishekk> great
14:01:58 <smcginnis> Woot
14:02:13 <rosmaita> we still need to stop them from running in stable/rocky for glance and the client
14:02:32 <rosmaita> andreas had some concerns about the change, but i did answer this morning
14:02:46 <rosmaita> https://review.openstack.org/599837
14:02:46 <abhishekk> just saw the patches
14:02:54 <rosmaita> https://review.openstack.org/599844
14:03:23 <rosmaita> yeah, please take a look and let me know what you think ... i'd really like to merge these or give them up to someone else
14:03:46 <rosmaita> but enough about me
14:04:15 <rosmaita> #topic remove bandit tests from stable branches
14:05:05 <rosmaita> i guess the new thing there is backporting all the way to pike
14:06:20 <abhishekk> yes
14:06:38 <rosmaita> did anyone talk about this at the PTG?
14:07:09 <abhishekk> this topic was not on the list for PTG discussion
14:07:12 <smcginnis> I unfortunately had to miss all of the Glance sessions. :(
14:07:20 <rosmaita> i'm sort of leery about turning stuff off in still-active stable branches
14:07:41 <rosmaita> because i think imacdonn is going to make a bugfix backport to pike
14:07:46 <smcginnis> At least with bandit, that's not likely to uncover anything in stable branches. Especially the older ones.
14:08:05 <rosmaita> i'll admit i don't know much about bandit
14:08:10 <smcginnis> If there are issues, we should catch them before they are backported.
14:08:21 <smcginnis> Assuming someone actually looks at the output.
14:08:27 <rosmaita> :)
14:08:33 <abhishekk> :d
14:09:35 <rosmaita> let's put this down for jokke to take a look at
14:10:00 <rosmaita> #action jokke decide backport of https://review.openstack.org/#/c/598426/1
14:10:18 <rosmaita> ok, looks like next topic is really for jokke, too
14:10:25 <abhishekk> yes
14:10:30 <rosmaita> #action jokke look at item 4 in today's agenda
14:10:54 <smcginnis> We can just assign all actions to jokke since he's not here. :D
14:11:01 <rosmaita> ok, next item is about something discussed at the PTG
14:11:17 <rosmaita> #topic PTG report
14:11:32 <rosmaita> abhishekk: could you give a quick rundown of any highlights from the PTG?
14:11:32 <jokke_> o/
14:11:42 <rosmaita> ah, jokke_ is here
14:11:48 <rosmaita> abhishekk: you are saved by the bell
14:11:56 <abhishekk> ++
14:11:57 <rosmaita> #chair jokke_
14:11:57 <openstack> Current chairs: jokke_ rosmaita
14:12:07 <jokke_> literally just got home ... on from the conservatory ;)
14:12:11 <rosmaita> jokke_: we held off on the update for you
14:12:26 <jokke_> ok
14:12:28 <rosmaita> also, you have some actions assigned to you
14:12:41 <jokke_> so the highlights are pretty much:
14:13:07 <jokke_> we need to focus our limited resources to stabilize things again for Stein cycle
14:13:40 <jokke_> Meaning we will be making the multiple back-ends stable api by S-3
14:14:11 <jokke_> the other thing we will be working on is the cluster aware glance
14:14:42 <jokke_> mainly making pre-caching images possible and image import with glance-direct without shared filesystem
14:14:58 <jokke_> other than that we will be pretty much doing bugfixing etc.
14:15:15 <rosmaita> what do our resources look like for Stein?
14:15:34 <abhishekk> we have a milestone targets written down at the end of etherpad https://etherpad.openstack.org/p/stein-ptg-glance-planning
14:15:35 <smcginnis> Limited. :]
14:15:36 <jokke_> very thin
14:16:26 <rosmaita> ok, thanks ... i have not been following the ML at all
14:16:42 <jokke_> so there might be other feature work coming given that there is actual people doing it
14:16:46 <abhishekk> Luckily we have 2-3 new contributors willing to take care of some lite features
14:16:54 <rosmaita> nice!
14:17:12 <rosmaita> i just looked at that etherpad ... was it really just jokke_ and abhishekk at the PTG?
14:17:36 <rosmaita> (sean said earlier that he had other obligations and missed the glance sessions)
14:18:00 <abhishekk> on day one we were 3 people an day 4 we were total 4 peoples :D
14:18:08 <jokke_> yes, there was some interestand promises of people, but I'll be convinced when I see those people start to show up :D
14:18:21 <abhishekk> s/day one/day 3
14:18:30 <rosmaita> well, it's good that there were some new faces
14:18:35 <jokke_> yes
14:19:06 <abhishekk> yes
14:21:32 <abhishekk> (am I disconnected?)
14:21:41 <jokke_> no
14:21:42 <rosmaita> abhishekk: i see you
14:21:47 <abhishekk> ok
14:21:51 <jokke_> I just got browser up to get agenda open
14:22:04 <jokke_> so I guess that's it ... we can move on
14:22:24 <jokke_> #topic remove bandit tests from stable branches
14:22:51 <rosmaita> we discussed this, decided that you need to decide if it should go into stable/pike
14:23:10 <rosmaita> none of us have any objections
14:23:17 <jokke_> ok, will have a look, but should be fine dropping from there too
14:23:20 <rosmaita> but it's up to the ptl
14:23:50 <jokke_> #topic backports
14:24:11 <jokke_> there was 2 backports listed ... something special about these?
14:25:09 <jokke_> ohh this is the location replacement thingie
14:25:49 <rosmaita> jokke_: i think it's just the state transition change
14:25:53 <rosmaita> at least at this point
14:26:17 <rosmaita> i don't know why i am being such a weenie about these backports, it's another one i didn't want to approve myself
14:27:36 <jokke_> Yeah I'm not sure ... it definitely breaks our API backwards compatibility and I'm not still convinced it's a bug
14:27:50 <jokke_> but I don't know if it's worth of fighting
14:28:34 <rosmaita> i do think it's a bug ... is the API break that now you'll get the state transition?
14:29:30 <rosmaita> (just wondering if i am missing something)
14:29:32 <jokke_> well so far we haven't done state transition until you do add (which really is insert)
14:30:02 <jokke_> and I don't think it's documented anywhere either that the replace should trigger any state transitions
14:30:21 <jokke_> so in that perspective I think it's backwards breaking change
14:30:50 <rosmaita> well, the lack of documentation is certainly true
14:31:01 <rosmaita> i see your point
14:31:30 <jokke_> if it was documented as it should do it this would have been really straight forward bug to be fixed and backported
14:31:44 <jokke_> but that has never been the case
14:33:10 <rosmaita> i don't want to leave imacdonn hanging on this, maybe something to the ML?
14:33:25 <rosmaita> maybe operators list, just to see if it would break anything
14:33:42 <jokke_> my thought as well
14:33:46 <abhishekk> makes sense
14:34:02 <abhishekk> what smcginnis  opinion
14:34:49 <jokke_> although there is really no reason why anyone should ever use the replace against queued image that has no locations
14:34:55 <jokke_> but I do see the frustration
14:35:10 <smcginnis> Does someone have the review link?
14:35:24 <rosmaita> ++ to your comment about no reason why anyone would do this
14:36:02 <rosmaita> https://review.openstack.org/598204
14:36:08 <rosmaita> smcginnis: ^^
14:36:29 <smcginnis> Oh right, thanks.
14:36:47 <smcginnis> I took that as a bug fix, so even though it is a behavior change, it is a change to be "more correct".
14:36:58 <rosmaita> smcginnis: my feeling exactly
14:37:10 <rosmaita> though see what jokke_ said above about maybe it is not really a bug
14:38:21 <rosmaita> so, it has merged into master
14:38:31 <smcginnis> I can see it either way, so I will defer to the experts. :)
14:38:36 <rosmaita> i wonder if someone should write up a release note about it being a bugfix?
14:38:37 <smcginnis> But if it's merged to master...
14:38:45 <rosmaita> then that way we can backport more easily
14:38:49 <rosmaita> maybe without going to the ML
14:38:54 <smcginnis> That may help. Probably should have had that with there being a change in behavior.
14:38:56 <rosmaita> except to give a heads-up
14:39:16 <rosmaita> (that last comment was about going to the ML)
14:39:16 <jokke_> so I'm not gonna push revert for the master patch but I'm not eager to backport it either
14:39:37 <smcginnis> Maybe just leave it as is in stable and move forward?
14:39:43 <smcginnis> A release note would still be good in master.
14:39:51 <rosmaita> well, the one thing we know is that there is someone who needs to use this on the older branches
14:40:03 <rosmaita> question is whether we should make them carry their own patch
14:40:24 <jokke_> smcginnis: that's what I was thinking ... but lets ask people's opinion for it ... I know it will make Ian's life easier if we backport it
14:41:01 <rosmaita> ok, how about i work with ian on a release note, and then we send something to the ML?
14:41:29 <jokke_> yeah, lets not make the call hastily now.
14:41:48 <jokke_> #topic Validation data with location update, as discussed at PTG
14:41:54 <rosmaita> we need the release note anyway, and this way there will be something definite to refer to
14:42:00 <jokke_> so this is related to the above
14:42:33 <jokke_> there is currently no way to set any of the checksums when the locations patch call is used
14:43:20 <jokke_> and we discussed options to allow that pre/during the ptg
14:43:29 <rosmaita> did that change get merged into the API? i looked at a patch week before ptg, but then stuff came up and i never followed up
14:43:56 <jokke_> IMHO I think we should allow setting the checksums on the same call when the location is set and the image goes active
14:44:26 <jokke_> there is spec lite
14:44:29 <jokke_> #link  https://review.openstack.org/597648
14:44:45 <rosmaita> and allow it on no other calls, you mean?
14:44:47 <jokke_> api implementation
14:44:51 <jokke_> #link  https://review.openstack.org/597368
14:45:05 <jokke_> and client implementation
14:45:08 <jokke_> #link  https://review.openstack.org/602794
14:45:18 <jokke_> rosmaita: correct
14:45:45 <rosmaita> looks like i did not leave comments, wanted to look more closely, but i liked the general approach in the patch
14:45:58 <jokke_> I don't think we should break the API that has been stable for the other use cases but I'm willing to make this happen as there is no other way to get the info in
14:46:16 <rosmaita> well, it's only a teensy-tiny break
14:46:21 <jokke_> and last thing I want is the api node pulling the data down just to calculate checksum for it
14:46:34 <rosmaita> right
14:46:52 <rosmaita> and we don't want some clever person to start hiding checksum data in the location metadata
14:47:09 <rosmaita> so i am glad that this patch will reject any such attempt, iirc
14:47:25 <jokke_> it's not teensy break for any other usecases as we would need to start rejecting the data and killing images again upon upload/import if we allowed it in all cases
14:47:43 <rosmaita> i mean, they can still do it, but they can't call it 'checksum', 'os_hash_algo' or 'os_hash_value'
14:48:20 <jokke_> yeah, if you it into some other property it won't break anything if it's wrong
14:48:30 <rosmaita> so you are still dead-set against adding checksum to v2 API image-create?
14:49:17 <jokke_> yeah, that would need to break way too much ... the fight was lost when the API was designed and it works as designed
14:49:35 <abhishekk> (sorry I was busy in another meeting)
14:49:58 <rosmaita> ok, i will not argue
14:50:18 <jokke_> specially now when we have the conversion in image import which means that you really can't trust that the user know correct checksum for the data that ends to the backend
14:51:14 <rosmaita> that's a good point
14:51:23 <jokke_> and I don't want glance just overwriting the user given checksum either 'cause that would invalidate the whole point making it possible
14:51:51 <jokke_> so I'm ok allowing it in locations patch and limiting it to that
14:52:18 <rosmaita> well, i do think using the location is an elegant way to smuggle it in for this particular use case
14:52:29 <jokke_> then it's really admin's responsibility to not break their cloud ;)
14:52:31 <rosmaita> location metadata i mean
14:52:52 <jokke_> yeah, so lets continue the discussion on reviews
14:52:57 <rosmaita> ok
14:52:59 <abhishekk> so the current lite-spec is as per the discussion during the PTG
14:53:09 <jokke_> #topic Open Discussion
14:53:19 <abhishekk> I have one
14:54:02 <abhishekk> we need to add multiple backend support (support to read multiple backend config changes during scrubber and cache service start)
14:54:18 <abhishekk> so should I mark it as a bug and propose patches against it?
14:54:48 <jokke_> abhishekk: if there is issues with those two, then yes lets open a bug and work it through that way
14:54:53 <rosmaita> that makes sense to me
14:55:02 <abhishekk> jokke_, rosmaita ack
14:55:19 <jokke_> it's clearly something we have overlooked and is part of stabilizing the feature
14:56:02 <abhishekk> that's it, over to rosmaita
14:56:17 <rosmaita> i have some news ... i haven't put up a stackalytics patch yet because i don't know my new email
14:56:30 <rosmaita> but this is my last week at verizon
14:56:40 <rosmaita> and actually, i am on vacation until friday
14:56:53 <smcginnis> rosmaita: Good news, right?
14:56:55 <rosmaita> i'm headed to Red Hat
14:56:59 <smcginnis> Woot!
14:57:04 <rosmaita> thanks!
14:57:07 <jokke_> \\o \o/ o// o/7
14:57:09 <abhishekk> congratulations \o/
14:57:18 <rosmaita> thank you!
14:57:22 <jokke_> well that is good and not so good news
14:57:27 <smcginnis> The gravitational pull is getting strong over there. :)
14:57:44 <rosmaita> i have orientation early next week, so will mostly be offline until wednesday afternoon new york time
14:57:52 <abhishekk> :d
14:57:59 <rosmaita> yeah, the not so good part is that i'm being asked to work mostly on cinder
14:58:12 <rosmaita> but i have been assured that i can participate in glance
14:58:12 <smcginnis> Woot woot! :D
14:58:21 <rosmaita> but it will most likely be mostly reviews
14:58:28 <abhishekk> great
14:58:30 <rosmaita> won't have time for glance coding
14:58:32 <smcginnis> I'll help you with Cinder, you can help me with Glance. ;)
14:58:39 <abhishekk> I will catch you for coding help :P
14:58:40 <jokke_> <3
14:58:40 <rosmaita> smcginnis: deal!
14:59:19 <abhishekk> we need to worry about diversity tag?
14:59:31 <rosmaita> i think diversity tags were eliminated
14:59:35 <abhishekk> last minute
14:59:36 <jokke_> so yeah, even less diversity and bit of shift of focus but I hope this is overall positive change (at least Cinder team will win hell of a lot)
14:59:37 <abhishekk> great
14:59:37 <rosmaita> so no worries!
15:00:10 <abhishekk> ++, we can utilize rosmaita both ways :D
15:00:20 <rosmaita> :D
15:00:34 <jokke_> ok, that's it for today. Thanks all, hopefully I'll be awake tomorrow to tackle those few things hanging
15:00:43 <jokke_> #endmeeting