14:01:50 <jokke_> #startmeeting glance
14:01:50 <openstack> Meeting started Thu Dec 13 14:01:50 2018 UTC and is due to finish in 60 minutes.  The chair is jokke_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:53 <openstack> The meeting name has been set to 'glance'
14:01:55 <jokke_> #topic roll-call
14:02:00 <jokke_> o/
14:02:06 <rosmaita> o/
14:02:08 <LiangFang> o/
14:02:09 <abhishekk> o/
14:02:51 <jokke_> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:03:09 <jokke_> ok, looks like we have quorum
14:03:46 <jokke_> #topic release/periodic job updates
14:03:55 <abhishekk> o/
14:04:08 <jokke_> I have nothing special for today so lets hop directly to good stuff :D
14:04:45 <abhishekk> This Monday we have released python-glanceclient version 2.15.0 for Stein m2, 2.13.1 for stable/rocky and 2.10.1 for stable/queens
14:04:56 <abhishekk> We are in R-18 week, Stein 2 milestone will be on 11th January which will be exactly 1 month away from now
14:05:00 <rosmaita> nice work!
14:05:18 <abhishekk> Thank you for you and jokke_ for supporting
14:05:30 <rosmaita> that reminds me, jokke_ you were going to set up a meeting to discuss devstack with gmann ?
14:05:58 <abhishekk> For periodic jobs unfortunately functional-py35 jobs is failing and it is failing on master branch as well
14:06:26 <LiangFang> is it because some new code checked-in?
14:06:31 <abhishekk> I have found that this problem is only with Ubuntu
14:06:42 <abhishekk> LiangFang, no that is not the issue
14:06:59 <abhishekk> #link http://logs.openstack.org/89/617889/4/check/openstack-tox-functional-py35/4c79eb0/testr_results.html.gz
14:07:06 <rosmaita> must be something to do with the python package versions they are using
14:07:14 <rosmaita> which is a nightmare to figure out
14:07:34 <abhishekk> I have tried to move above failing  8 tests in black-list file and then other tests are failing than those
14:08:12 <abhishekk> I have verified versions of oslo.log. olso.service, python-subunit with passing and failiing logs but both are same
14:08:51 <rosmaita> i think we may need help from qe-type people who understand the subunit parsing stuff
14:08:59 <rosmaita> maybe cboylan or mtreinish
14:09:02 <jokke_> abhishekk: so this fails same way in master normal jobs and in the periodic tips jobs?
14:09:27 <abhishekk> One thing I observed is that in the passing log results it shows executed tests around 741 and in failing log results it shows 650 tests
14:09:29 <abhishekk> jokke_, yes
14:09:34 <rosmaita> and there is always dhellmann, he usually has good ideas
14:10:09 <jokke_> ok, yeah, it really sounds like some dependency broke
14:10:21 <abhishekk> rosmaita, ack, I guess we should send mail on ML?
14:10:23 <LiangFang> can we reproduce in local environment? it is not in tox.ini, right?
14:10:51 <rosmaita> LiangFang: you probably need to use ubuntu that is completely updated if you want to try
14:10:58 <rosmaita> yes, it is not a tox.ini issue
14:10:59 <abhishekk> LiangFang, you can reproduce this in local as well, not related to tox.ini
14:11:16 <abhishekk> what rosmaita just said
14:11:27 <LiangFang> my environment is ubuntu16.04
14:11:39 <abhishekk> Our patches are stuck because of this
14:11:56 <abhishekk> LiangFang, just run tox -r -e functional-py35
14:12:06 <LiangFang> ok
14:12:08 <abhishekk> It is failing for py37 as well
14:12:10 <LiangFang> I will try
14:12:46 <abhishekk> that's it from me
14:13:02 <abhishekk> I came across this bug, #link https://bugs.launchpad.net/cinder/+bug/1728640
14:13:03 <openstack> Launchpad bug 1728640 in Cinder "py35 unit test subunit.parser failures" [Critical,Fix released] - Assigned to Sean McGinnis (sean-mcginnis)
14:13:03 <rosmaita> LiangFang: make sure you do 'apt-get dist-upgrade -u'
14:13:19 <LiangFang> ok
14:13:22 <abhishekk> But it is not helping
14:13:57 <jokke_> k
14:14:01 <abhishekk> that's it from me
14:14:04 <jokke_> thanks abhishekk for digging into this
14:14:15 <abhishekk> I will put some time tomorrow as well
14:14:44 <jokke_> let try to get this figured out, if we need help, lets try to get it. ML thread with all possible info in it would likely be helpful
14:15:01 <abhishekk> ack
14:15:09 <jokke_> moving on
14:15:22 <jokke_> #topic adding 'description' property to images
14:15:55 <rosmaita> sorry to go backwards, but smcginnis mentions might be an stestr bug
14:16:18 <rosmaita> should probably mention that on the ML
14:16:26 <jokke_> gr8, thanks rosmaita
14:16:40 <abhishekk> who will send the mail?
14:16:52 <rosmaita> i nominate jokke_
14:16:55 <rosmaita> :)
14:17:00 <abhishekk> :)
14:17:07 <LiangFang> :)
14:17:12 <jokke_> I guess brinzhang is not here
14:17:15 <rosmaita> or smcginnis, since he is not here
14:17:29 <rosmaita> i was talking to brinzh this morning
14:17:34 <rosmaita> so i can cover this
14:17:53 <abhishekk> great
14:17:56 <rosmaita> basically, the issue is that lots of openstack resources have a 'description' metadata field
14:17:59 <jokke_> abhishekk: I'd appreciate if you did it as you have the best picture what's going on in there ... if you don't want to I can syn up with after the meeting and get it sent out
14:18:09 <rosmaita> but images don't have an official 'description'
14:18:23 <rosmaita> so this proposal is to add it as one of the "common image properties"
14:18:39 <rosmaita> which get mentioned in the schema, but are just stored in the image_properties table
14:18:47 <rosmaita> so no database migration needed
14:18:55 <abhishekk> jokke_, I will, but 2-3 hours after the meeting
14:19:11 <rosmaita> it's just an interoperability issue to "standardize" the field name
14:19:19 <jokke_> rosmaita: don't we have something like that in metadefs?
14:19:22 <rosmaita> because peopel have been able to add a 'description' forever
14:19:28 <rosmaita> jokke_: nope
14:19:40 <jokke_> ohh ...:P
14:19:43 <rosmaita> i think all we have for images is brianna's stuff for signatures
14:20:01 <rosmaita> there's some other stuff, but it's in with the nova and cinder metadefs, i think
14:20:23 <rosmaita> anyway, i put a link to an email on the agenda where this came up last week
14:20:38 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2018-December/000684.html
14:21:02 <rosmaita> so it looks like something worth addressing
14:21:10 <jokke_> #link  https://review.openstack.org/#/c/623405/
14:21:12 <rosmaita> and it's a really simple change
14:22:09 <abhishekk> sounds good to me
14:22:44 <rosmaita> anyway, that's all i got
14:23:25 <jokke_> just a quick note for the record
14:24:27 <abhishekk> (am I disconnected??)
14:24:38 <LiangFang> I can see your msg
14:24:41 <jokke_> as we do not populate that field by glance-api automatically at any case, I think this is something we can just reserve as string in the schema instead of using os_descrption fo avoid collisions
14:24:51 <abhishekk> LiangFang, thanks
14:25:00 <rosmaita> jokke_: good point
14:25:16 <rosmaita> yes, also we don't want the os_ prefix because no one else is using it
14:25:35 <jokke_> as we have had the principle that any new fields we introduce are os_ prefixed
14:25:39 <rosmaita> i think it's safe to assume that a description is what has been put into the 'description' metadata
14:25:54 <jokke_> so just wanted to put it in the record that there is reason why we are not doing it on this
14:26:04 <rosmaita> jokke_: yes, i think you should mention it on the patch
14:26:05 <jokke_> and I'd like to have that noted in the spec lite as well
14:26:47 <rosmaita> that should be a quick update
14:27:00 <jokke_> other than that, I'm fine with this ... should be simple thing to do and seems like it would make at least some people's lives easier
14:27:04 <rosmaita> also, might want to review the proposed text for the field in the schema
14:27:16 <jokke_> yeah ... will review that
14:27:24 <rosmaita> #link https://review.openstack.org/#/c/620433/
14:27:28 <rosmaita> i don
14:27:40 <rosmaita> t quite like it, but didn't have any suggestions when i looked this morning
14:28:02 <jokke_> ok, moving on
14:28:13 <jokke_> #topic devstack python3 behavior
14:28:26 <rosmaita> i don't really have anything to say other than awareness
14:28:43 <rosmaita> i put up the test patches, we are seeing the py35 failure that abhishekk is working on
14:28:54 <rosmaita> looks like client and store are OK
14:29:03 <abhishekk> yes
14:29:15 <rosmaita> actually, i should backtrack on that
14:29:26 <rosmaita> i am assuming it's the same failure i haven't actually looked
14:30:06 <rosmaita> so to be clear, other than putting up the test patches, i am not actually working on this
14:30:09 <rosmaita> :)
14:30:31 <rosmaita> and that's all from me
14:30:45 <jokke_> rosmaita: so just to be clear, what has changed?
14:31:01 <rosmaita> tbh, i don't know, doug discusses it in the email
14:31:09 <jokke_> or is this just to highlight the testing issues we already discussed earlier?
14:31:12 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2018-December/000642.html
14:31:14 <jokke_> ahh
14:31:16 <jokke_> ty
14:31:50 <rosmaita> i was worried about those tls termination problems
14:32:08 <rosmaita> but i just realized that devstack does tls termination in apache by default
14:32:11 <jokke_> that should not affect us as we do not have plugin for devstack
14:32:57 <jokke_> that Dougs mail indicates that those projects that has devstack plugins needs to indicate that they will run under py3
14:34:16 <jokke_> and honestly I do not know if glance is in devstack as plugin but just maintained and hosted by them in their repo, and maybe this is missing from there
14:34:58 <jokke_> but that is something the devstack team has control of
14:35:21 <jokke_> and definitely should not affect our functional jobs
14:35:45 <jokke_> so should not be related to the issues we see in the functional py3 job
14:36:56 <rosmaita> yeah, so probably nothing to worry about
14:37:28 <jokke_> but definitely good to be aware if we suddenly see some weird behavior in our devstack based jobs
14:37:37 <jokke_> or using devstack in general
14:38:15 <jokke_> #topic Open Discussion
14:38:41 <jokke_> LiangFang: thanks for flagging the gate issues, I think that was covered earlier or do you have something more to add?
14:39:05 <LiangFang> it has been covered, thanks
14:39:20 <jokke_> I would like to do a quick poll here as XMas is closing really fast
14:39:52 <jokke_> How are you folks going to be available between now and the 10th of January?
14:39:53 <LiangFang> will we have the meeting next week?
14:40:10 <rosmaita> i will be available next week
14:40:19 <rosmaita> not much after that, though
14:40:20 <abhishekk> I will be there all the time :D
14:40:30 <jokke_> yes, next week I'll be definitely hosting meeting
14:40:41 <LiangFang> ok:)
14:41:32 <jokke_> abhishekk: cool, I'll be flying to Funland before New Year
14:41:44 <LiangFang> abhishekk: the os running py35 function is ubuntu16.04 or 18.04?
14:41:48 <jokke_> Everyone ok if we do not have meeting at 27th?
14:41:50 <abhishekk> jokke_, great
14:42:00 <abhishekk> LiangFang, 16.04
14:42:05 <LiangFang> ok
14:42:18 <abhishekk> NP for me
14:42:19 <rosmaita> jokke_: no meeting on 27 is fine by me
14:42:24 <LiangFang> Np for me
14:42:47 <abhishekk> But we should meet after that as S2 will be around the corner
14:43:00 <jokke_> how about the first Thu of January? Do we want to have meeting week before the M2
14:43:03 <jokke_> ?
14:43:13 <rosmaita> probably yes on January 3
14:43:24 <abhishekk> yes
14:43:30 <jokke_> sounds good to me
14:44:26 <jokke_> #agreed 20th of Dec and 3rd of January meetings will run normally, 27th of Dec no meeting due to holiday season
14:44:47 <jokke_> anything else?
14:44:49 <abhishekk> #action,abhishekk to send mail about subunit.parser failure after 3 hours
14:44:59 <abhishekk> #action abhishekk to send mail about subunit.parser failure after 3 hours
14:45:05 <LiangFang> no more from me
14:45:24 <jokke_> abhishekk: gr8, ping me if you need anything ... I will be around
14:45:38 <abhishekk> No use of reviewing patches due to gate issue, but if you have time please review :D
14:45:50 <abhishekk> jokke_, sure
14:46:04 <jokke_> reviewing is always useful, just pointless to +W anything before we got that solved
14:46:15 <abhishekk> yep
14:46:28 <jokke_> abhishekk: rosmaita: you guys have anything else?
14:46:34 <abhishekk> no
14:46:38 <rosmaita> just one thing
14:46:42 <jokke_> shoot
14:46:51 <rosmaita> the devstack patch to run glance not under uwsgi by default
14:47:18 <rosmaita> can you set up a meeting with us and appropriate qe person?
14:47:24 <jokke_> yes ... I saw your note at the beginning ... have mail draft for the meeting request up now so I don't forget it this time
14:47:30 <rosmaita> ok, cool
14:47:36 <jokke_> expect to see mail in next like 15min
14:47:40 <abhishekk> cool
14:47:42 <rosmaita> i'd like to get that settled before S-2
14:47:47 <jokke_> indeed
14:48:06 <rosmaita> meeting will be helpful, that way they can just point me to what needs to change without me wasting a lot of time poking around
14:48:10 <rosmaita> thanks
14:48:16 <abhishekk> rosmaita, I guess someone has reviewed your patch and added valid comment their
14:48:28 <rosmaita> i haven't looked!
14:48:32 <rosmaita> guess i should
14:48:39 <jokke_> ;)
14:49:03 <abhishekk> ok, thank you all
14:49:09 <jokke_> cool ... we have 11min to give away so lets be productive and tap this down. Thanks everyone!
14:49:29 <jokke_> #endmeeting