14:01:27 <jokke_> #startmeeting glance
14:01:28 <openstack> Meeting started Thu Dec 20 14:01:27 2018 UTC and is due to finish in 60 minutes.  The chair is jokke_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:31 <openstack> The meeting name has been set to 'glance'
14:01:34 <jokke_> #topic roll-call
14:01:37 <jokke_> hello o/
14:01:37 <abhishekk> o/
14:01:40 <LiangFang> o/
14:01:44 <GregWaines> o/
14:01:45 <rosmaita> o/
14:02:54 <jokke_> sorry, we had company EMEA call that ran til exactly the top of the hour, gimme a minute here
14:03:37 <jokke_> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:03:40 <jokke_> there we go
14:04:21 <jokke_> #topic updates
14:05:13 <jokke_> So as agreed we will not have a meeting next week the 27th due to the EMEA and US holiday season
14:05:44 <rosmaita> \o/
14:05:46 <LiangFang> ack
14:05:55 <abhishekk> yey
14:06:07 <jokke_> As we have the M-2 coming up at 10th I will be in for the meeting at 3rd of Jan
14:06:22 <abhishekk> me as well
14:07:55 <jokke_> although, please note I will be travelling between new year and mid Jan, so the start of January I will definitely not be available for most of US timezones
14:08:10 <abhishekk> ack
14:08:43 <rosmaita> me neither, but for different reasons :)
14:09:05 <abhishekk> ack :)
14:09:26 <jokke_> then to the technical side
14:10:27 <jokke_> The gating failures we saw were traced back to oslo.policy change that was merged and released pretty much on same day so we did not get advanced warning from our tips tests
14:11:37 <abhishekk> I guess it started to fail on the same day when oslo.policy new version was released
14:11:58 <rosmaita> did we ever add back the glance functional tests to the requirements gate?
14:12:13 <jokke_> this change started to make deepcopies of the target object for it's internal processing and due to our onion model and the fact that our policies are not on the API layer it hit one of our nested proxy objects that definitely were not copyable
14:12:42 <jokke_> causin infite loop in the gate
14:12:53 <jokke_> #link https://review.openstack.org/#/c/625086/
14:13:30 <jokke_> #link https://review.openstack.org/#/c/625114/
14:13:52 <jokke_> we definitel should work through the later before logging off for the holidays
14:14:17 <jokke_> although I will be around still parts of next week
14:14:47 <rosmaita> i will be around for this too
14:14:56 <rosmaita> kind of important to get it fixed correctly
14:15:05 <rosmaita> (item 6 on the agenda)
14:15:35 <jokke_> this was fun to debug as it started to put so much output in gate that it also failed the logging there and the amount of details we got from the gate job was next to none
14:16:15 <jokke_> huge hand to cdent and mriedemann for helping us out with this!
14:16:25 <rosmaita> ++
14:16:26 <abhishekk> +1
14:16:46 <abhishekk> LiangFang, has also tried from his end
14:18:17 <jokke_> absolutely and my point was not to undermine any of the glance teams effort but those two guys are not actively working on glance, yet they took the time and stepped in when the understanding of gating etc. was needed
14:19:08 <jokke_> which was extremely helpful to filter out what was just jitter or side effects happening in the gate vs. what was actually breaking
14:19:59 <jokke_> ok ... lets move on so we do not run out of the time
14:20:11 <jokke_> #topic release updates
14:20:18 <jokke_> abhishekk: stage is yours
14:20:31 <abhishekk> yes
14:20:45 <abhishekk> Stein Milestoen 2 is 3 weeks away
14:21:05 <abhishekk> Please put/review the patches as much as possible
14:21:23 <abhishekk> Periodic tips jobs are all green (Finally)
14:21:34 <abhishekk> Thanks to erno and nova guys again
14:21:57 <rosmaita> did the review priority stuff merge into gerrit?
14:22:00 <abhishekk> That's it from the topic
14:22:20 <abhishekk> not yet I guess
14:22:22 <jokke_> rosmaita: not yet, zuul doesn't agree with me on something there
14:22:44 <rosmaita> jokke_: grab sean to help, he got it merged for cinder
14:23:27 <rosmaita> just shoot him an email and ask him to take over the patch
14:23:36 <jokke_> nice ... I will, it's on my todo list for today, I'd like to get it in so we can utilize it already during the holidays when we're running skeleton crew
14:23:44 <rosmaita> exactly
14:24:25 <rosmaita> he also set up a dashboard with a tiny url, ask him to do that too
14:25:17 <jokke_> Now I'd like to highlight here also that we do not release milestone releases anymore
14:25:37 <jokke_> but with M-2 the lib freeze is approaching very quickly
14:25:44 <abhishekk> yes
14:25:59 <jokke_> so if there is anything major that needs to be done in glance-store, lets get that ongoing
14:26:09 <abhishekk> ack
14:26:27 <jokke_> same with our client patches even I think they freeze bit later
14:26:30 <rosmaita> is there anything other than finalizing the multiple back end support?
14:26:38 <rosmaita> for glance_store, i mean
14:26:50 <abhishekk> nothing as of now
14:27:14 * smcginnis sneaks in the back
14:27:20 <LiangFang> I have one patch of glance_store
14:27:38 <LiangFang> abhishekk: and rosmaita already reviewed it
14:27:41 <rosmaita> smcginnis: read the scrollback, i volunteered you for some stuff
14:27:43 <jokke_> I don't think so. Majority of the back-end handling changes we will likely need to do is glance end and how store is interfaced rather than actual store changes
14:27:50 <smcginnis> rosmaita: Hah, will do.
14:27:54 <jokke_> smcginnis: welcome welcome
14:28:20 <jokke_> ok, can we move on?
14:28:24 <abhishekk> yes
14:28:45 <rosmaita> one minute
14:29:03 <rosmaita> there are some deprecated config opts in glance_store due for removal
14:29:38 <rosmaita> #link https://etherpad.openstack.org/p/glance-stein-deprecations
14:29:43 <jokke_> ok, if they can be safely done, we should get those done
14:30:13 <jokke_> asap so we can get those gating for a while before hitting the deadline
14:30:35 <rosmaita> take a quick look at the etherpad
14:30:57 <rosmaita> 'stores' and 'default_store' say subj to removal in stein
14:31:00 <rosmaita> is that true?
14:31:09 <abhishekk> we are not removing stores and default_store option yet, so that needs to be changed
14:31:46 <jokke_> the swift ones should at least be ok to go
14:31:56 <rosmaita> yeah
14:31:58 <jokke_> rosmaita: I don't think we can
14:32:00 <abhishekk> Earlier (when spec was approved it is decided to remove it in S but later we decided to keep it for another cycle or two)
14:32:16 <rosmaita> ok, i will put up a patch to amend the deprecation text for those two
14:32:33 <rosmaita> #action rosmaita glance_store patch updating dep notice for 'stores' and 'default_store'
14:32:36 <abhishekk> thanks
14:32:41 <jokke_> yeah I think it was bit hastily decided to be ready to get rid of the old style in Stein and just move to the multistore model
14:33:00 <rosmaita> ok
14:33:38 <rosmaita> any volunteers for the swift options?
14:33:44 <jokke_> basically the multi-store is still experimental so we cannot expect production clouds to migrate to that for their upgrades be clean to Stein if we remove those
14:34:15 <abhishekk> right
14:34:37 <jokke_> reminding the N -> N+1 should be working with same config file principle we have
14:35:30 <abhishekk> Lets move ahead
14:35:52 <jokke_> I can't promise I will be able to take those swift ones before the break so if someone else have time to tackle them, fleet free
14:35:55 <jokke_> feel
14:36:00 <jokke_> ok moving on
14:36:13 <jokke_> #topic updating show_multiple_locations deprecation notice
14:36:22 <rosmaita> that's me
14:36:23 <jokke_> rosmaita: this is yours I think
14:37:00 <rosmaita> it's come up in the glance channel that some operators have taken the deprecation notice seriously and tried to make it False and use policies
14:37:07 <rosmaita> which of course we know cannot work
14:37:13 <rosmaita> and they are quite annoyed
14:37:21 <jokke_> as you would
14:37:26 <rosmaita> anyway, i figure we should update the deprecation notice to be accurate
14:37:39 <rosmaita> so please look at the patch and let me know what you think
14:38:05 <rosmaita> #link https://review.openstack.org/625702
14:38:07 <abhishekk> looks straight forward to me
14:38:22 <rosmaita> i just wanted to make sure what i say there is accurate
14:38:37 <jokke_> yes, unfortunately that deprecation notice was done based on the promise of us having people to work on the policy refactoring which never happened and the change slipped from us
14:38:46 <rosmaita> agreed
14:38:52 <jokke_> so lets make that change _and_ backport it to stable
14:39:01 <rosmaita> it's my fault for letting the notice not be changed for so long
14:39:14 <rosmaita> i kept thinking we were about to start work on it
14:39:26 <jokke_> rosmaita: well I have been equally ignorant about that
14:39:39 <rosmaita> how far back to we want to backport it?
14:39:56 <rosmaita> should be pretty clean, just deprecation note change and release note
14:40:10 <jokke_> thus, lets push it to stable as well so we get those notices corrected for people who are running stable and trying to work on them
14:40:32 <jokke_> rosmaita: Rocky and Queens I'd quess
14:40:56 <rosmaita> we still have ocata and pike in stable/
14:41:00 <jokke_> and once that is done, me or you can write to the mailing list about it
14:41:15 <jokke_> rosmaita: yes, but those two are not our responsibility
14:41:40 <rosmaita> cool
14:42:21 <jokke_> ok lets move on, thanks for bringing this up
14:42:36 <rosmaita> np
14:42:39 <jokke_> #topic lower constrains under py36
14:42:48 <rosmaita> me again
14:43:10 <rosmaita> there is something very weird about the lower constraints job
14:43:22 <rosmaita> cdent left a note on the test patch i put up
14:43:34 <jokke_> first of all, pardon my ignorance, I didn't realize we even had 3.6 jobs I thought the community is focusing on 3.5 and 3.7
14:43:53 <rosmaita> i looked at what he mentioned, and it does indeed seem like the job as currently configured is behaving properly
14:44:20 <rosmaita> jokke_: i must admit, i lost track of what is happening with py3 efforts
14:44:26 <smcginnis> 3.6 is the current targeted runtime for stein.
14:44:47 <smcginnis> The policy has been to go with whatever is the default on the LTS releases of our supported platforms at the start of the cycle.
14:44:56 <rosmaita> what smcginnis said, so all the infra stuff is switching to run in py36
14:44:59 <smcginnis> That means 3.5 is no longer the target and 3.6 is.
14:45:10 <smcginnis> We need to be ready for 3.7 as that's likely what we will end up with for Train.
14:45:15 <abhishekk> ohh
14:45:32 <smcginnis> We've just been lucky that we've had a period there where there wasn't much change so we got used to just sticking with the same version.
14:46:00 <rosmaita> anyway, i have lost focus on what the lower-constraints are supposed to do, so i would like someone to take over the WIP patch i put up with the changes cdent suggested
14:46:19 <rosmaita> there's a comment on the patch with a link to 2 pastes showing the different pip freeze outputs you get
14:46:31 <rosmaita> #link https://review.openstack.org/626008
14:47:11 <jokke_> so the lower constraints IIUC is the minimum versions of dependencies we test and promise to be working
14:47:11 <rosmaita> i don't know that this is a high priority
14:47:23 <smcginnis> jokke_: Correct.
14:47:29 <abhishekk> rosmaita, I will take this (but around 26)
14:47:49 <jokke_> so in that light this is fairly important
14:47:50 <rosmaita> abhishekk: ty
14:47:54 <jokke_> thanks abhishekk
14:48:03 <smcginnis> Looks like it's passing with that patch, so that's good.
14:48:08 <abhishekk> no issues
14:48:41 <rosmaita> yeah, i think we may need to adjust the l-c.txt based on this, but there doesn't seem to be any major problem (yet)
14:48:58 <jokke_> so what I'm bit confused about is why do we have version numbers in our requirements with upper and lower constraints but in general that's the case ;)
14:50:02 <jokke_> also note that project based blacklisting does not work in the requirements
14:50:30 <jokke_> so us changing our requirements files has no effect on gate, all those changes must be done in the requirements repo
14:50:43 <abhishekk> exactly
14:51:02 <jokke_> this came to my knowledge when we were troubleshooting the gating issues discussed earlier
14:51:38 <jokke_> I tried to blacklist the oslo.policy to see if it indeed was the cause of our issues and gate still installed the blacklisted version and used that
14:51:59 <jokke_> so again I'm not sure why we do have those files in our repo in the first place
14:52:57 <LiangFang> should we change tox.ini to use blacklist?
14:52:57 <abhishekk> we have limited time and GregWaines has something to say in open discussion
14:53:05 <rosmaita> i'm done
14:53:13 <abhishekk> :D
14:53:51 <jokke_> #topic catch rdb NoSpace exception
14:54:00 <jokke_> LiangFang: you had this one
14:54:05 <LiangFang> it's mine, thanks
14:54:42 <LiangFang> i want to confirm with rosmaita, should I change image name to image id in this patch or in a followup patch?
14:55:06 <abhishekk> LiangFang, its good to be fixed in same patch I guess
14:55:15 <LiangFang> OK
14:55:37 <rosmaita> i wasn't sure if there was a good reason for rbd to use name instead of id?
14:55:40 <jokke_> we should always log id
14:56:05 <rosmaita> that was my thought, but i wasn't sure, since it's name everywhere else in that file
14:56:15 <jokke_> so if we have previously been logging name somewhere that is bug
14:56:36 <rosmaita> yeah, so maybe a separate patch would be better
14:56:38 <jokke_> as image doesn't need to have name at all so that would just lead the string being omitted
14:57:03 <LiangFang> ok
14:57:10 <jokke_> rosmaita: for fixing the existing, yes. Anything that is introduced now should be fixed before merging
14:57:43 <abhishekk> Last 3 minutes, next topic is already discussed
14:57:44 <rosmaita> ok, cool. so LiangFang use id on this patch in that code you touch, file a new bug, and then change the rest
14:57:45 <jokke_> we should not introduce buggy behavior even for consistency
14:57:54 <jokke_> ++
14:57:56 <LiangFang> ok
14:58:00 <rosmaita> ty
14:58:01 <jokke_> moving on
14:58:16 <rosmaita> yeah, skip 6, though look at my comment on the patch, please
14:58:25 <jokke_> #topic Open discussion
14:58:29 <GregWaines> I wanted to check in on status of REVIEW https://review.openstack.org/#/c/619638/
14:58:29 <GregWaines> ( Image Caching Enhancements for Edge Cloud )
14:58:36 <GregWaines> I have made updates based on first round of comments from Erno and Abhishek .
14:58:36 <GregWaines> Major change was to simplify proposal by removing the capability of Edge Cloud to be able to create local images … this was causing issues and was not absolutely required.
14:58:40 <jokke_> the proxy topic was pretty well covered at the beginning of the meeting
14:58:45 <GregWaines> Just wanted to check in on when next round of reviews could be done ?
14:59:20 <abhishekk> GregWaines, I will review it in next couple of days
14:59:30 <abhishekk> do you have PoC for this?
14:59:37 <GregWaines> excellent ... thanks very much.
14:59:46 <rosmaita> GregWaines: i will also commit to review asap
14:59:51 <GregWaines> We do have a PoC for this ... although it is based on PIKE
15:00:03 <jokke_> GregWaines: thanks for addressing those concerns. As you might have noticed if you were following the meeting, we've had bit of exitement lately. I will try to do a review on that before going for my travels
15:00:06 <abhishekk> great
15:00:09 <LiangFang> GregWaines: is there any code implemention done?
15:00:26 <smcginnis> Times up.
15:00:33 <jokke_> indeed
15:00:35 <abhishekk> thank you all
15:00:36 <jokke_> Thanks all!
15:00:38 <abhishekk> happy holidays
15:00:40 <smcginnis> Thanks!
15:00:41 <rosmaita> GregWaines: and also, you are doing the right thing by showing up and asking for reviews!
15:00:41 <jokke_> #endmeeting