13:59:12 <jokke_> #startmeeting glance
13:59:12 <openstack> Meeting started Thu Feb  7 13:59:12 2019 UTC and is due to finish in 60 minutes.  The chair is jokke_. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:15 <openstack> The meeting name has been set to 'glance'
13:59:23 <jokke_> #topic roll-call
13:59:26 <jokke_> o/
13:59:31 <abhishekk> o/
14:00:08 <jokke_> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:30 <jokke_> short agenda today and I think it's just you and me around unless Sean shows up
14:00:32 <abhishekk> looks like we are the only people who are around this time
14:00:37 <jokke_> so lets get on with it
14:00:37 <abhishekk> :D
14:00:50 <jokke_> #topic release & periodic updates
14:01:17 <abhishekk> periodic jobs are timing out intermittently, cause looks like parser error only
14:01:45 <jokke_> ok so this is the same thing still hauting us
14:01:55 <abhishekk> I have added one patch to reduce the logs, result is parser error is gone but still they are timing out
14:02:05 <jokke_> kk
14:02:14 <abhishekk> #link https://review.openstack.org/#/c/634628/
14:02:47 <abhishekk> I want you to have a look at below patch which is reducing significant amount of logs
14:02:55 <abhishekk> #link https://review.openstack.org/#/c/625125/
14:03:07 <jokke_> ok, will check them
14:03:11 <abhishekk> above patch submitted by matt and I have taken over that
14:03:35 <jokke_> gr8, thanks for ye both
14:03:54 <abhishekk> release update, we are approaching M3 and needs reviews on some of the open patches/ bug fixes
14:04:06 <abhishekk> glance-cores kindly have a look on those patches
14:04:28 <abhishekk> that's it from me for this topic
14:04:43 <jokke_> lets make sure they are review priority voted and get on them
14:04:57 <abhishekk> Ok, I will check the same
14:05:22 <jokke_> ok, lets open up for anything else
14:05:30 <jokke_> #topic open idscussion
14:05:39 <jokke_> #topic open discussion
14:06:34 <jokke_> I think I forgot to send the mail about the multiple backends
14:06:37 <jokke_> will do it today
14:06:51 <jokke_> double checking first that I actually didn't send it :P
14:06:57 <abhishekk> Nothing from me as of now for open discussion, just I will make sure all important patches have review priority set
14:07:13 <abhishekk> I guess you have replied
14:08:02 <jokke_> #action everyone Please review the patches that has +votes on review priority. If you think something else should be on that list, ping cores on #openstack-glance to discuss
14:09:18 <abhishekk> it was pretty short :D
14:09:26 <lpetrut> Hi
14:09:34 <jokke_> lpetrut: hello
14:09:46 <jokke_> just in time before we wrapped up :D
14:09:53 <abhishekk> :d
14:09:56 <lpetrut> heh
14:09:56 <lpetrut> about the Windows support effort, I got all the tests to run on Windows
14:10:05 <jokke_> Nice!
14:10:11 <lpetrut> everything is up for review, including a spec
14:10:28 <abhishekk> lpetrut, great
14:10:35 <jokke_> that's great, and they are not WIP: flagged anymore?
14:10:49 <lpetrut> nope, good to go IMO
14:11:36 <abhishekk> lpetrut, good to know
14:11:57 <lpetrut> there's just the last patch of the chain that is currently failing, I'll have to send an update on the requirements repo: https://review.openstack.org/#/c/634007/
14:11:58 <jokke_> lpetrut: thank you. I'll have a look on the scope and the spec. If it looks like something non-disruptive I'll put it for the next weeks agenda that we have exception for it and put them to the priority review Q
14:12:35 <lpetrut> that's great, thanks! I'm aware that this will not be high prio, but the impact should be minimal and it would be nice to have it in Stein
14:12:40 <jokke_> Obviously at this late stage we need to discuss the impact of any of those changes
14:12:40 <abhishekk> (do you have any setup/configuration instructions so that we/I can test it)
14:13:24 <jokke_> abhishekk has very good point. Doc change would be amazing to have instructions how to setup for Win
14:13:43 <abhishekk> +1
14:13:56 <jokke_> As I think none of us have even tried it
14:13:57 <lpetrut> all you need is a working python environment and you can install glance with pip. we usually provide MSIs for openstack services
14:14:07 <jokke_> cool
14:14:13 <lpetrut> config wise it's similar to what we have on Linux
14:14:43 <abhishekk> does it set keystone as well?
14:15:03 <lpetrut> nope, keystone doesn't have to be on Windows
14:15:17 <abhishekk> ok got it
14:16:11 <lpetrut> for Nova/Cinder, the MSIs had to do a bit more heavy lifting (creating switches, setting up Hyper-V live migration, iSCSI target service, etc), but in this case it's pretty straight forward.
14:16:14 <abhishekk> but as jokke_ said, we need a doc patch as well (if we agreed to get it in S)
14:16:40 <jokke_> lpetrut: abhishekk: so if I understand this correctly you can just kick up devstack, kill glance there, run it on Windows and do any manual testing on that. And unit/functional testing is just matter of running tox on windows?
14:16:54 <lpetrut> exactly
14:17:23 <abhishekk> jokke_, makes sense
14:17:27 <lpetrut> tbh, most changes were targeting the functional tests
14:17:32 <jokke_> lpetrut: if you don't mind, small section in our developer docs would be great to point that out
14:17:50 <lpetrut> sure, I'll prepare a patch for that as well
14:17:55 <abhishekk> great
14:18:04 <abhishekk> that will be very helpful
14:18:13 <jokke_> it would just reinforce the fact that we're looking to keep this alive, not just getting it done once
14:18:30 <abhishekk> ++
14:18:39 <lpetrut> yep, and also bring some awareness
14:18:55 <jokke_> lpetrut: you guys still up for setting up that 3rd party CI for Win testing once the changes are merged?
14:19:00 <jokke_> lpetrut: exactly
14:19:27 <lpetrut> we already have CIs for other projects (Nova, Cinder, Neutron and a few others). those can pick it up.
14:19:48 <lpetrut> I'll talk with our CI team to have one dedicated to glance patches
14:20:03 <abhishekk> cool
14:20:10 <jokke_> amazing, that way we don't break it right on the following cycle due to doing something in the testing that will not work again
14:21:02 <jokke_> would feel bad to see you doing all this work to get it done and then us breaking it right away because we did not know better :)
14:21:28 <lpetrut> yep. one one hand, 3rd party CIs don't get that much attention, but at least we'll know when things start failing and quickly send a fix if some breaking change gets in
14:22:08 <lpetrut> tbh, it's impossible to keep an eye on all 3rd party CIs (on Cinder, there are >50 drivers)
14:22:26 <jokke_> if it stays stable and you guys are willing to help to keep it clean when we have issues on win side, I'm willing to consider letting that being voting
14:22:57 <lpetrut> that's awesome. well, we'd need to get it rock solid first :)
14:23:32 <jokke_> I really dislike running tests non-voting no-one are ever looking at. The one Exception being our PY3 ssl tests as they are there just to remind us and sending clear indication that we know them not working
14:24:24 <lpetrut> makes sense
14:24:27 <jokke_> ok, anything else?
14:24:32 <abhishekk> nope
14:24:52 <lpetrut> nothing on my side, I'll wait for feedback on the patches and spec
14:24:59 <jokke_> great
14:25:00 <lpetrut> thangs again guys
14:25:10 <abhishekk> WC
14:25:32 <jokke_> in that case, have a great day, night, what ever it is at your timezone and lets free up the 35min for something productive :)
14:25:35 <jokke_> Thanks all
14:25:42 <abhishekk> thank you all
14:25:48 <jokke_> #endmeeting