13:59:40 <jokke_> #startmeeting glance
13:59:41 <openstack> Meeting started Thu Apr 11 13:59:40 2019 UTC and is due to finish in 60 minutes.  The chair is jokke_. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:44 <openstack> The meeting name has been set to 'glance'
13:59:45 <jokke_> #topic roll-call
13:59:48 <smcginnis> o/
13:59:49 <jokke_> o/
14:00:32 <smcginnis> Everyone else is off celebrating the release of stein. :)
14:00:40 <jokke_> so it looks like :D
14:00:48 <jokke_> lets give them couple of more min
14:01:13 <jokke_> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:01:25 <abhishekk> o/
14:01:39 <jokke_> hi abhishekk
14:02:02 <jokke_> giving one more minute to see if rosmaita is around before we start. Should be quick today
14:02:12 <rosmaita> o/
14:02:17 <jokke_> o/
14:02:28 <jokke_> #topic release updates
14:02:38 <jokke_> lets hit directly to the most important thing!
14:02:57 <jokke_> Thanks everyone!!!!!! We have Stein released
14:03:06 <abhishekk> \./
14:03:26 <rosmaita> \o/
14:03:57 <smcginnis> Congrats all on another release!
14:04:19 <jokke_> I specially want to point out that we released based on RC1 and the release itself was very painless. I'd say probably the easiest Glance release I've witnessed so far. So huge thanks to all
14:05:19 <jokke_> smcginnis: the release process itself is getting so well streamlined that it's breeze compared to what it used to be. And we did well getting everything together by the deadlines
14:05:41 <smcginnis> Great to hear you thought it was better. We are hoping to get some feedback on those changes.
14:05:51 <smcginnis> The goal was to try to make it easier on the the teams.
14:05:58 <smcginnis> Less administrative things to track.
14:06:28 <jokke_> indeed ... almost too easy :P
14:06:41 <smcginnis> Heh, that's the part I'm afraid of. :D
14:06:49 <jokke_> "Oh hups, we did release, didn't even notice" :D
14:08:10 <jokke_> and big thanks to abhishekk and rosmaita for tagteaming the release liaison and keeping the strings under the control
14:08:19 <smcginnis> ++
14:08:23 <abhishekk> thank you :D
14:08:24 <rosmaita> mostly abhishekk at this point!
14:08:49 <abhishekk> with your help \./
14:09:13 <jokke_> So definitely first round is on me when we get all of us together in Denver
14:09:28 <rosmaita> thanks, but i am purposefully being less and less helpful!  but ask if you need anything
14:09:51 <abhishekk> definitely
14:09:56 <abhishekk> jokke_, ++
14:10:17 <rosmaita> jokke_: just processed what you said, will def take you up on that!
14:10:25 <jokke_> abhishekk: we had some timeouts in the periodicals, but the intrepeter errors have now disappeared?
14:10:41 <abhishekk> right
14:11:04 <abhishekk> there were 3 timeouts in last 2 days
14:11:27 <abhishekk> and timeouts doesn't show subunit parser error
14:11:35 <jokke_> ohh
14:11:45 <jokke_> so these are something new?
14:12:35 <abhishekk> I am analyzing it
14:12:38 <jokke_> Any idea what is timing out?
14:12:42 <jokke_> ok ... thanks
14:12:49 <abhishekk> not sure yet
14:13:04 <smcginnis> Gate has seemed a little unstable lately. I've seen DNS and other network issues affecting other jobs.
14:13:05 <jokke_> yeah lets try to figure out what is causing it. It sounds quite a lot
14:13:08 <smcginnis> Possibly related.
14:13:11 <abhishekk> I will update once find out the reason
14:13:22 <jokke_> smcginnis: ok, thanks for the heads up.
14:13:56 <jokke_> abhishekk: keep that in mind and lets keep monitoring it. Now is good time to breathe a bit and look these things before Summit/PTG
14:14:09 <abhishekk> ack
14:14:39 <jokke_> Lets make sure we have our housekeeping done before we fully commit for the Train work items :)
14:15:08 <jokke_> I would really like if we didn't have month+ of gate issues this cycle :P
14:15:20 <rosmaita> on the housekeeping note, here's something that could use some attention: https://review.openstack.org/#/c/645799/
14:16:15 <jokke_> yes, on my review list to tackle "after the release is in a can"
14:16:27 <jokke_> thanks for reminding
14:16:47 <rosmaita> :)
14:17:34 <jokke_> we have few of those looming like 592653
14:18:55 <jokke_> ok, anything else around release topic?
14:19:59 <jokke_> #topic Open Discussion
14:20:09 <jokke_> Anything else in general?
14:20:22 <abhishekk> let me have a look at my patch list
14:20:26 <jokke_> kk
14:20:42 <jokke_> Just reminder, PTG planning!
14:21:00 <abhishekk> https://review.openstack.org/#/c/650187/
14:21:18 <abhishekk> kindly approve this backport related to stein cache manage documentation
14:21:57 <smcginnis> Oh, just making sure folks saw the pike announcement about extended maintenance.
14:22:01 <jokke_> we had RH Train planning meeting today and couple of other things came up we likely need to coordinate with cinder folks. So it might be worth of trying to schedule common slot. I'll try to have a chat with Jay and will update the etherpad
14:22:05 <smcginnis> We are overdue to be in that phase.
14:22:22 <smcginnis> So if we have any commits to stable/pike, we should do a final release while we can before it officially switches over.
14:22:27 <jokke_> smcginnis: yeah, does that need some actual attention from us?
14:22:34 <jokke_> okk
14:22:44 <smcginnis> Someone just needs to check if there is anything to be released.
14:22:59 <smcginnis> Someone == abhishekk ? :)
14:23:08 <rosmaita> yes, looks like there is some stuff piled up
14:23:20 <jokke_> will make sure that we have everything tracked at least we would like to get in there this week
14:23:21 <abhishekk> smcginnis, ack
14:23:47 <smcginnis> And then also a decision for the team as to whether we want extended maintenance. Teams can choose to just eol that branch if there is not interest in getting bug fixes backported that far.
14:24:16 <jokke_> I'm not sure we have that much that actually qualifies to be backported that far, but I'll take some time tomorrow for it
14:24:18 <rosmaita> there aren't any unmerged patches for glance stable/pike
14:24:49 <abhishekk> not at the moment
14:25:06 <rosmaita> so unless jokke_ finds something in queens that needs a backport, should be ready to go
14:25:09 <abhishekk> (means no patch to stable/pike)
14:25:14 <abhishekk> right
14:25:25 <rosmaita> we should probably discuss EOL vs Extended Maintenance at the PTG
14:25:31 <rosmaita> (over beverages)
14:25:32 <jokke_> nope, but will need to have quick look what we have backported down to queens and see if there was something that should have gone into Pike as well, I doubt so 'though
14:26:16 <jokke_> smcginnis: I tohught the extended maintenance was agreed to not to be project teams problem. So if it has became such, we will then just eol it
14:26:58 <rosmaita> jokke_: it is up the the project team whether to keep the branch open for fixes (but not releases)
14:27:04 <jokke_> when the extended maintenance was agreed to be a thing, there was clear agreement that it will be maintained outside of the project teams scope
14:27:13 <rosmaita> otherwise users need to fork and patch themselves
14:28:12 <smcginnis> jokke_: Defaults to the project team, but I believe there is some provision in there that "other groups" could choose to do that extended maintenance if the normal team was not interested in doing so.
14:28:43 <jokke_> smcginnis: kk ... well that makes this easy
14:29:21 <smcginnis> It does say it will go to eol after 6 months if no one is maintaining it, but I don't think we've really figured out how to identify if it's unmaintained, or just no patches have been needed yet.
14:29:38 <jokke_> #action anyone interested to keep Glance Pike open, step up by next week's meeting or the branch will be checked for potential release and eol'd
14:30:03 <rosmaita> jokke_: you should probably send an announcement to the ML
14:30:25 <jokke_> rosmaita: I guess that could be sensible thing to do :P
14:30:34 * smcginnis secretly hopes to reduce the number of stable branches
14:30:45 <jokke_> smcginnis++
14:31:36 <jokke_> ok, anything else?
14:31:59 <abhishekk> nothing from me
14:32:07 <smcginnis> Nothing from me either.
14:32:24 <rosmaita> me neither
14:32:28 <jokke_> gr8
14:33:05 <jokke_> In that case, thanks all, lets raise a glass some point end of this week for the successful release and give yourselves pad to the back. we did it again!
14:33:14 <smcginnis> abhishekk, jokke_: Are you both going to make it to Denver?
14:33:21 <jokke_> smcginnis: yup
14:33:23 <abhishekk> yes
14:33:25 <smcginnis> Great!
14:33:40 <jokke_> I'll be there whole week, I think abhishekk and rosmaita for the PTG
14:33:55 <abhishekk> rosmaita, will be also for whole week i guess
14:34:02 <rosmaita> i'll be there whole week too, doing a presentation at noon on Monday
14:34:11 <jokke_> Nice!
14:34:11 <rosmaita> (getting in 1am monday!)
14:34:15 <jokke_> ouch
14:34:19 <abhishekk> cool, grab t-shirts for me :P
14:34:58 <jokke_> we can continue on #os-g
14:35:00 <jokke_> #endmeeting