14:00:15 <jokke_> #startmeeting glance
14:00:20 <jokke_> #topic roll-call
14:00:21 <openstack> Meeting started Thu Apr 18 14:00:15 2019 UTC and is due to finish in 60 minutes.  The chair is jokke_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:25 <openstack> The meeting name has been set to 'glance'
14:00:27 <jokke_> o/
14:00:28 <smcginnis> o/
14:00:49 <jokke_> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:51 <rosmaita> o/
14:01:52 <jokke_> I was just on phone with abhishekk so I'd assume he is lurking somewhere around
14:02:04 <abhishekk> o/
14:02:09 <jokke_> there we go :D
14:02:16 <jokke_> #topic release updates
14:02:46 <abhishekk> periodic jobs 3 failures since Mon, 2 failures due to dependency issues and only 1 timeout so far this week
14:03:10 <abhishekk> the reason for timeout is unknown and no sign of subunit.parser error in the logs
14:03:50 <smcginnis> I've seen tempest timeouts on other patches. Maybe related.
14:04:10 <jokke_> So it seems that something has finally affected our tests enough that we're not hitting that subunit.parser issue anymore \\o \o/ o// o/7
14:04:21 <smcginnis> \o/
14:04:57 <jokke_> Which brings us conveniently to our next topic
14:05:08 <jokke_> #topic Handling deprecations
14:05:15 <abhishekk> We need to move specs from approved to implemented directory for Stein and need to move specs to Train which were not implemented in Stein
14:05:34 <jokke_> abhishekk: yes thanks for reminding that
14:05:36 <jokke_> #undo
14:05:37 <openstack> Removing item from minutes: #topic Handling deprecations
14:05:46 <abhishekk> that's it from me :D
14:05:51 <jokke_> #action jokke_ to take care of spec housekeeping
14:06:02 <jokke_> #topic Handling deprecations
14:06:22 <rosmaita> jokke_: you should be able to find my commit from the last time we moved specs & use that as a guide
14:06:37 <rosmaita> you move the specs physically and then setup the redirect
14:06:43 <jokke_> rosmaita: yeah I remember that. Thanks I'll look for it
14:07:06 <rosmaita> but you need to be careful with the redirect, i broke the openstack.org website with a mistake
14:07:14 <smcginnis> :)
14:07:16 <jokke_> :P
14:08:21 <jokke_> ok, so to the deprecations. Over past cycles we have been bit too laxed about it. And it definitely did contribute to the subunit.parser issue and makes reading the logs just nightmare.
14:09:06 <jokke_> I need to keep better track of getting around the deprecations we have pending (not only what we have deprecated in Glance but keeping track of deprecations in our dependencies)
14:10:07 <jokke_> If anyone has spare time to look how to get rid of some of the deprecation messages popping up, great, if not please remind me every now and then that they need to be taken care of.
14:10:18 <abhishekk> I can create one etherpad for this
14:10:25 <smcginnis> I did take a few days and propose patches against oslo libs and some others to get rid of the common deprecation messages we were getting.
14:10:48 <jokke_> smcginnis: indeed, thanks <3
14:10:48 <rosmaita> yeah, we should make sure smcginnis's patches are merged
14:11:00 <smcginnis> Really just need some of those to get released, then go through the logs of a tox run and see where else they are popping up.
14:11:21 <smcginnis> Some of the common oslo ones should reduce the noise quite a bit.
14:11:26 <abhishekk> I have little bit free time next week so I will work on this
14:11:39 <jokke_> yup, it's something I should have been keeping better track of and I do intend to do so this cycle
14:11:50 <smcginnis> abhishekk: Great!
14:11:54 <jokke_> smcginnis: great stuff
14:12:16 <smcginnis> jokke_: It's been an OpenStack-wide issue, so don't feel too bad about not keeping track in glance.
14:13:15 <jokke_> thanks
14:13:25 <rosmaita> yes, and your predecessor as ptl pretty much ignored this entirely :)
14:13:36 <jokke_> :P
14:14:02 <jokke_> yeah something we have to improve so I wanted to bring it up as we had very thin agenda for today
14:14:14 <jokke_> at least we have recognized the issue on record :D
14:14:45 <smcginnis> ++
14:15:10 <abhishekk> +1
14:15:15 <jokke_> moving on unless someone has something to add to this
14:15:40 <abhishekk> nothing at the moment
14:16:13 <jokke_> #topic Summit/PTG planning
14:16:56 <jokke_> First of all, please send me a mail if there is something you want me to highlight in the project update
14:17:23 <rosmaita> you may want to review some rocky stuff
14:17:39 <rosmaita> i just replied to something on the ML where someone said too bad glance only supports md5
14:17:55 <jokke_> IIRC I asked for 20min slot so I'm gonna keep it tight but if there is anything you guys think might be worth of mentioning I'm more than happy to take suggestions in
14:18:50 <jokke_> the PTG side is building up pretty well
14:19:04 <jokke_> #link https://etherpad.openstack.org/p/Glance-Train-PTG-planning
14:19:46 <jokke_> keep them coming in. I will try to have some kind of skeleton ready for next weeks meeting
14:19:54 <abhishekk> ack
14:20:07 <jokke_> So likely will be looking into it At Wed Thu timeframe
14:20:32 <jokke_> The summit is just week and half away :D
14:21:36 <jokke_> #action jokke_ Make PTG plan by next Thu meeting
14:22:05 <abhishekk> We definitely need some discussion with jars in hand :D
14:22:21 <jokke_> one thing in that schedule I'd like to highlight after I probably made few new friends yesterday by replying to the community goal review is the client situation I added in
14:22:30 <abhishekk> jokke_, need time for cross project discussion mainly with cinder and nova
14:23:21 <jokke_> abhishekk: ack it's on my list
14:23:32 <abhishekk> thanks
14:23:47 <jokke_> smcginnis: rosmaita: How is Cinder planning looking?
14:24:22 <rosmaita> i think jay said he's finalizing things today and/or tomorrow?
14:24:24 <jokke_> Are you guys going to have busy PTG in that front and do you have any schedule built up yet?
14:24:31 <jokke_> rosmaita: ok, cool
14:24:44 <jokke_> I'll definitely try to sync up with him today then
14:24:52 <smcginnis> We do have the three days, but not sure how busy Saturday will be.
14:25:16 <jokke_> sure
14:25:22 <rosmaita> i am really sorry that i will be there all day saturday, flying out on the redeye
14:25:35 <jokke_> how is your travel plans btw? When are you flying out?
14:25:55 <smcginnis> I get there Saturday afternoon, leaving Saturday night. Long week.
14:25:56 <rosmaita> very late saturday, so i will be available all day!
14:26:02 <abhishekk> I will be flying out on Sunday evening
14:26:09 <jokke_> nice
14:26:10 <rosmaita> i arrive 1am monday morning
14:26:14 <smcginnis> Ouch
14:26:27 <rosmaita> yeah, only decent flight i could find
14:26:30 <abhishekk> I will arrive 4 PM on Wednesday
14:26:38 <smcginnis> "decent" :)
14:26:52 <smcginnis> abhishekk: Just in time for the real fun to start. ;)
14:26:55 <jokke_> So I will be there Sun late afternoon, my flight is scheduled to land 17:30
14:27:00 <abhishekk> :D
14:27:09 <jokke_> and I hafe full Saturday availability scheduled as well
14:27:47 <rosmaita> we can remove the registry!
14:27:54 * jokke_ is actually flying out of Denver at Tue
14:28:03 <jokke_> rosmaita: indeed
14:28:33 <jokke_> #topic open discussion
14:28:40 <jokke_> Anything else?
14:29:01 <jokke_> Oh and before I forget, we have here this thing called Easter this weekend
14:29:21 <abhishekk> not at the moment
14:29:27 <jokke_> So I will not be around tomorrow nor Monday. Telegram reaches
14:29:34 <abhishekk> happy holidays
14:29:59 <jokke_> Tomorrow I likely be away from home most of the day (have some friends coming over for the weekend) Monday bit better if needed
14:30:18 <abhishekk> tomorrow we have holiday as well
14:30:20 <rosmaita> i won't be available tomorrow, but will be on monday
14:30:42 <abhishekk> so my weekend starts right after the meeting \o/
14:30:48 <jokke_> ok, lets hope the world does not blow up tomorrow as it seems we have no-one around :P
14:30:55 <abhishekk> :D
14:31:06 <jokke_> abhishekk: \\o \o/ o// o/7
14:31:50 <abhishekk> ;)
14:32:18 <jokke_> So meeting normally next week, the following week our weekly meeting is f2f in Denver and the week after I might not be able to chair it but we'll see. I keep you guys updated
14:32:28 <rosmaita> ok
14:32:42 <jokke_> I shoot mail out to the list
14:32:57 <abhishekk> ack
14:33:02 <jokke_> #action jokke_ to inform mailing list about weekly meetings over next 3 weeks
14:33:21 <jokke_> if nothing else, lets end this and free up the extra 25min we have!
14:33:35 <jokke_> going once
14:33:55 <smcginnis> Nothing from me. Thanks!
14:33:56 <jokke_> going twice
14:34:02 <abhishekk> nothing from me
14:34:02 <rosmaita> nothing more from me!
14:34:04 <abhishekk> thank you
14:34:06 <jokke_> Sold! Thanks all!
14:34:10 <rosmaita> bye
14:34:15 <jokke_> #endmeeting