14:00:09 <abhishekk> #startmeeting glance
14:00:10 <openstack> Meeting started Thu Jul 11 14:00:09 2019 UTC and is due to finish in 60 minutes.  The chair is abhishekk. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'glance'
14:00:20 <abhishekk> #topic roll call
14:00:28 <abhishekk> ./
14:00:36 <davee_> o/
14:01:11 <abhishekk> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:01:18 <abhishekk> hi davee_
14:01:40 <abhishekk> lets wait for 2-3 minutes for other peoples to join
14:01:50 <davee_> Good evening there Abhishekk
14:01:59 <alistarle> Hello
14:02:04 <abhishekk> thanks
14:02:10 <abhishekk> hi alistarle
14:02:31 <abhishekk> So Update is glance PTL is on vacation for next two weeks
14:02:49 <davee_> I need a vacation
14:03:06 <abhishekk> If you have any doubts or need any help feel free to ping any core reviewers
14:03:13 <abhishekk> davee_, :D
14:03:32 <abhishekk> rosmaita, hi
14:03:32 <rosmaita> o/
14:03:38 <rosmaita> sorry i'm late
14:03:55 <abhishekk> no problem
14:04:03 <abhishekk> we have very small agenda today
14:04:16 <abhishekk> Erno is on vacation for next two weeks
14:04:38 <abhishekk> #topic release/periodic jobs update
14:04:50 <abhishekk> So T2 milestone is two weeks away
14:05:02 <abhishekk> We have lot more to do during this two weeks
14:05:19 <abhishekk> First thing we need to roll out glance  store 1.0
14:05:32 <abhishekk> and then we have glance patches lined up for reviews
14:05:45 <abhishekk> #link https://etherpad.openstack.org/p/Glance-Train-MileStone-1-Release-Plan
14:06:11 <abhishekk> Kindly focus on this etherpad, it has all the patches stacked up
14:06:22 <rosmaita> ok
14:06:41 <rosmaita> do me a favor -- put some text at the top saying that this is for M2
14:06:55 <rosmaita> (otherwise the title of the etherpad makes it seem out of date)
14:07:05 <abhishekk> As jokke_ will be out we are the one who need to take care of this stuff
14:07:10 <abhishekk> rosmaita, ack
14:07:17 <rosmaita> right
14:08:23 <rosmaita> what's the deal with that abandoned patch?
14:08:23 <abhishekk> For periodic jobs we just have one timeout in last two weeks
14:08:36 <rosmaita> https://review.opendev.org/#/c/663740/1
14:09:35 <abhishekk> that's it from this topic
14:10:01 <abhishekk> rosmaita, you want to say something about above patch you just posted?
14:10:18 <rosmaita> yes, mthode abandoned it
14:10:33 <abhishekk> yeah because we have 0.29.1 released
14:10:34 <rosmaita> but you have it as something we want to merge?
14:11:28 <abhishekk> not recollecting it :(
14:11:42 <rosmaita> line 10 in your etherpad
14:12:49 <rosmaita> looks like 0.29.1 is already in u-c: https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L624
14:13:48 <abhishekk> sorry corrected it
14:13:55 <abhishekk> rosmaita, yes
14:15:27 <rosmaita> ok
14:15:52 <abhishekk> #topic Open discussion
14:15:57 <rosmaita> i hate to be stupid about this, but for T-2, do we need to do the glance-store v1.0 release first, and then the other stuff?
14:17:23 <davee_> Never hurts to ask a clarifying question
14:17:40 <rosmaita> davee_: ty!
14:17:41 <abhishekk> rosmaita, if we need to release 1.0 of store for T2 then we need line 16,17, and 21 to be merged from the etherpad for T2
14:18:09 <alistarle> Is there any way that glance authorize upload to multiple backend ? One teammate develop that patch in order to do it, with the spec associated https://review.opendev.org/#/c/667132/
14:18:30 <alistarle> For sure we will continue reviewing patch on etherpad before asking review for that ;)
14:18:42 <rosmaita> so lines 16,17,21 *before* release store 1.0 ?
14:18:52 <abhishekk> Else we can go ahead and merge patches #18, #19 and #20 from the etherpad
14:19:18 <abhishekk> Line #16 before release and 17 and 21 after release
14:19:48 <rosmaita> abhishekk: can you reorder the etherpad to make this clear?
14:19:59 <rosmaita> i have not been paying as much attention as i should
14:20:06 <abhishekk> rosmaita, yes
14:20:17 <abhishekk> once meeting is over I will reorder the etherpad
14:20:43 <rosmaita> thanks ... it would be good to say what we can merge in glance with current 0.29.1, and then the glance_store 1.0, and then what after 1.0 is released
14:20:54 <abhishekk> ack
14:21:13 <abhishekk> will do and notify by mail
14:21:21 <rosmaita> abhishekk: thanks!
14:21:37 <rosmaita> also, i probably won't get to this until tomorrow, so no rush
14:21:39 <abhishekk> do we have anything to discuss?
14:21:40 <davee_> Might be helpful also to add a -T2 to indicate that item is part of T2 changes
14:22:12 <abhishekk> alistarle, sorry I have overlooked your question
14:22:19 <abhishekk> could you please elaborate the same?
14:22:32 <abhishekk> davee_, ack
14:22:54 <alistarle> Yes, we implement the multi-backend in a multi-datacenter approach, and we really lacked to push image to multiple backend trough glance
14:23:18 <alistarle> as today the multi-backend implementation only allow to push your image one time, in one the enabled_stores
14:23:52 <abhishekk> right
14:24:15 <alistarle> we tought it is good to leverage on the interaporable import system already present in glance, in order to upload image in multiple store
14:24:34 <abhishekk> So I would suggest you to have a spec/lite-spec to discuss approach about the same
14:24:55 <alistarle> https://review.opendev.org/#/c/669201/ Here we go ;)
14:25:02 <abhishekk> It will be good first we agree on the use case and approach before directly reviewing it on the patch
14:25:24 <alistarle> Sure
14:25:34 <abhishekk> cool
14:25:49 <alistarle> We just have dev the code for internal purpose, but let's look at the spec before
14:26:04 <abhishekk> Let me and other reviewers spend some time in understanding the same and we can discuss this over next weeks meeting
14:27:01 <alistarle> Ty ! btw we'll continue to review on your T-2 patches waiting for that
14:27:18 <rosmaita> it would be good to have jokke_'s input on this, but he won't be back for next week's meeting
14:27:20 <abhishekk> alistarle, thank you
14:27:25 <rosmaita> can we wait until week after?
14:27:43 <abhishekk> alistarle, ^^
14:28:01 <alistarle> no problem
14:28:08 <abhishekk> great
14:28:33 <rosmaita> thanks
14:29:12 <abhishekk> alistarle, we might need the full specification (glance-specs) for this as it will be api impact and would be a major change
14:29:56 <abhishekk> Do anyone have anything to discuss?
14:30:28 <abhishekk> I will modify the etherpad and send it to openstack-discuss ML so that everyone will get the notification
14:31:09 <rosmaita> alistarle: i think your proposal may impac the location-strategies module, have you looked at that at all?
14:31:57 <rosmaita> if not, i can put some info on the gerrit review
14:33:09 <alistarle> I know this options but I don't know if it affect this patch, but if you have input you can put it in gerrit for sure
14:34:15 <rosmaita> ok, sounds good
14:34:29 <abhishekk> #action abhishekk  modify the etherpad and send it to openstack-discuss ML
14:34:50 <abhishekk> does something went wrong here :D
14:35:01 <abhishekk> First time used action tag :P
14:36:06 <abhishekk> If we don't have anything to discuss further, we can wrap this up early
14:36:53 <davee_> nothing further from me
14:37:05 <abhishekk> rosmaita, alistarle ^^
14:37:11 <rosmaita> we'll have to look at the logs after the meeting and see if the action worked
14:37:20 <rosmaita> i can't remember if you get feedback or not
14:37:30 <abhishekk> rosmaita, ack
14:37:32 <rosmaita> it think it's like the 'link' command, no feedback
14:37:41 <rosmaita> nothing more from me
14:37:49 <abhishekk> cool
14:38:04 <abhishekk> thank you guys for your time, see you all next week
14:38:38 <abhishekk> #endmeeting