14:02:23 <jokke_> #startmeeting glance
14:02:24 <openstack> Meeting started Thu Aug 15 14:02:23 2019 UTC and is due to finish in 60 minutes.  The chair is jokke_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:27 <openstack> The meeting name has been set to 'glance'
14:02:37 <jokke_> #topic roll-call
14:02:43 <jokke_> o/
14:05:40 <rosmaita> o/
14:05:50 <jokke_> hey Brian
14:06:16 <jokke_> looks like we're on quite thin crew today
14:06:25 <rosmaita> :)
14:06:49 <jokke_> lets just power through couple of things and call it early
14:07:03 <jokke_> #topic Open Discussion
14:07:37 <jokke_> like said I've been going through bunch of reviews, trying to test what I can and sanity checking the rest
14:07:40 <rosmaita> i have lost track of the release situation (the early RC)
14:09:08 <jokke_> like the you mean the etherpad?
14:09:42 <rosmaita> yeah, that plus what our plans are
14:10:02 <rosmaita> abhishek had mentioned you wanted to get an early RC out before M3
14:10:06 <rosmaita> or something like that
14:10:36 <jokke_> Well IMO the main priority is to get the multistore in place and tag it (with the backend --> store changes) so people can test it easily
14:11:19 <jokke_> it's my biggest worry atm. that we did overlook something with the _store 1.0.0 we're not catching
14:11:25 <rosmaita> that makes sense
14:11:31 <rosmaita> yes, i agree about your worry
14:12:30 <jokke_> anything and everything else should fall in place pretty smooth due to quite limited usecases or just good baseline testing we have in place for the parts they are touching
14:13:45 <jokke_> which brings me to my personal headache
14:13:47 <rosmaita> did you get a chance to look at https://review.opendev.org/#/c/674697/ ? the point of that one was that i started to write up the release notes about how/when to config the filesystem stores for staging/tasks, and instead figured it would make sense to get that info into the sample config
14:14:05 <rosmaita> then the release note can just say consult the sample config
14:14:31 <jokke_> #link https://review.opendev.org/#/c/669655
14:15:23 <jokke_> ^^ is the rabbit cluster awareness. If you have time at some point I would really appreciate some help. You seem to be much better identifying reasons for flakyness in tests
14:15:30 <rosmaita> i have not looked at that yet, glad to see dsmith paying attention
14:15:47 <rosmaita> ok, i'll set aside some time for that
14:16:06 <rosmaita> btw, i will miss next week's meeting due to cinder midcycle
14:16:22 <jokke_> would really appreciate if you can, if you can't I understand and keep banging my head against the wall :D
14:16:28 <jokke_> okok
14:17:14 <rosmaita> i'll make some time this afternoon, maybe have some feedback when you get in tomorrow
14:17:51 <jokke_> ah, yes ... I've partially reviewed that your example config patch. Which means that my attention got pulled into something else :(
14:19:22 <rosmaita> when you look at it, i think it's good for now ... in the future, when we support other backends, we may just want to put in the group with its comment explaining what it's for, and tell people to get the config for the particular backend from somewhere else
14:19:33 <jokke_> So the config is double edged sword. the files are mile long already and stuff just gets lost in there. I think we definitely need to put some info there, but it by no means should replace us actually properly documenting those changes and having good reno for it
14:20:12 <rosmaita> yeah, i agree ... but i think we definitely need at least the group in there
14:20:31 <jokke_> most likely
14:20:58 <rosmaita> i had a bug recently downstream where the cinder sample config was missing some stuff, the customer did not realize you needed to add more stuff
14:21:04 <jokke_> let me run config gen and have a look what comes out and how it looks like. I'll think about it properly
14:21:12 <rosmaita> good
14:21:18 <rosmaita> yeah, we have some options
14:21:26 <rosmaita> 1) just add the groups
14:21:41 <rosmaita> 2) just add the groups + filesystem_store_data_dir and no other config
14:21:51 <rosmaita> 3) groups + all filesystem config
14:21:55 <rosmaita> that patch is #3
14:22:14 <jokke_> kk
14:22:17 <rosmaita> i was just going to do #2, but then that cinder bug i mentined came up
14:22:33 <rosmaita> yeah, so gen the config and see what you think ... it is indeed massive
14:22:51 <jokke_> I spend some time on it ... might just poke the configgen configs to kind of do me simplified config file without all the 5k lines of crap :D
14:23:48 <rosmaita> grep -v FTW
14:24:57 <jokke_> those things were all I got ... I keep reviewing stuff and try to get the multistore patches either in or -1'd ... thanks for lots of thorough reviews! it's been pleasure to do reviews and seeing the dialog on those patches catching small but impactful things
14:25:17 <rosmaita> cool
14:25:31 <rosmaita> it would be helpful for you to ping me directly if i need to re-review anything
14:25:41 <jokke_> will do, np
14:25:45 <rosmaita> great
14:26:06 <jokke_> I know how easy it is to miss those things from the flood of spam that gerrit generates
14:26:48 <rosmaita> yeah, i have kind of stopped paying attention to gerrit emails
14:27:28 <jokke_> I'd love to be able to stop all mails from gerrit by default and having subscribe button on the reviews where I could tell gerrit "Inform me about any changes on this PS"
14:27:38 <jokke_> s/PS/review
14:27:42 <rosmaita> ++
14:28:08 <jokke_> did you have anything else for todays meeting?
14:29:34 <jokke_> oh one more note, on mailing list, looks like the default devstack deployment bit someone to arse again :(
14:29:55 <rosmaita> bummer
14:30:13 <rosmaita> btw, rant into a prob in irc about the glance-import.conf not being read
14:30:19 <rosmaita> *ran
14:30:23 <jokke_> I'll try to find time and energy to try to hit it again
14:30:46 <rosmaita> the workaround is just add the groups and options directly to glance-api.conf
14:30:47 <jokke_> oh, like ever or with some special case?
14:31:01 <rosmaita> no, for our recommended configuration
14:31:28 <rosmaita> the code to look at import.conf is only in matt's uwsgi loading script
14:31:33 <rosmaita> not our "normal" wsgi app
14:31:42 <jokke_> ohhh crap
14:31:50 <rosmaita> yeah, that's been there for a while
14:32:01 <jokke_> thanks, I'll take fixing that as my topmost priority
14:32:02 <rosmaita> there was that fix to devstack that abhishek recommended
14:32:06 <jokke_> I guess so
14:32:07 <rosmaita> to use --config-dir
14:32:12 <jokke_> yeah
14:32:22 <rosmaita> but i ran into problems with that
14:32:23 <jokke_> I think that's what I have been doing and not hitting it
14:32:35 <rosmaita> it was also reading the registry conf and starting glance on the wrong port
14:32:46 <jokke_> ok, thanks for highlighting it. I'll get on that for sure
14:32:59 <rosmaita> i think config-dir reads all the files it can find and builds the conf object out of that
14:33:11 <jokke_> #action jokke_ to fix the config read of glance-import.conf
14:33:20 <jokke_> yup
14:33:22 <rosmaita> give me a min and i'll find you the LP bug
14:33:46 <jokke_> I'm sure I can find it if there is bug open already
14:34:47 <rosmaita> https://bugs.launchpad.net/glance/+bug/1775782
14:34:48 <openstack> Launchpad bug 1775782 in Glance "glance-image-import.conf not parsed when running under wsgi" [Critical,Triaged]
14:34:56 <jokke_> ty
14:35:18 <jokke_> anything else?
14:35:40 <rosmaita> this was the discussion in irc about that: http://eavesdrop.openstack.org/irclogs/%23openstack-glance/%23openstack-glance.2019-08-08.log.html#t2019-08-08T21:58:35
14:35:52 <jokke_> k
14:36:07 <jokke_> #link https://bugs.launchpad.net/glance/+bug/1775782
14:36:07 <openstack> Launchpad bug 1775782 in Glance "glance-image-import.conf not parsed when running under wsgi" [Critical,Triaged]
14:36:18 <jokke_> #link http://eavesdrop.openstack.org/irclogs/%23openstack-glance/%23openstack-glance.2019-08-08.log.html#t2019-08-08T21:58:35
14:41:14 <rosmaita> i guess that's everything for today?
14:41:42 <jokke_> yup
14:41:45 <jokke_> thanks!
14:41:48 <jokke_> #endmeeting