14:05:15 <rosmaita> #startmeeting glance
14:05:16 <openstack> Meeting started Thu Sep 12 14:05:15 2019 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:20 <openstack> The meeting name has been set to 'glance'
14:05:24 <rosmaita> #topic roll call
14:05:28 <abhishekk> o/
14:05:48 <rosmaita> good morninig abhishekk, may be just you and me
14:06:11 <abhishekk> good morning rosmaita, most likely :D
14:06:27 <rosmaita> let's skip to release updates
14:06:32 <rosmaita> this week is feature freeze
14:06:40 <abhishekk> ack
14:06:52 <rosmaita> you have patches listed on the agenda
14:06:54 <rosmaita> oops
14:06:58 <rosmaita> i forgot to change topic
14:07:03 <abhishekk> yeah
14:07:03 <rosmaita> #topic release update
14:07:16 <abhishekk> so D day has come
14:07:23 <rosmaita> ok, abhishekk has put together a list of pritority patches
14:07:34 <rosmaita> #link https://etherpad.openstack.org/p/glance-train-priority-patches
14:07:59 <abhishekk> yes, so priority is to get features in before M3 release
14:08:12 <abhishekk> we will target bug fixes in RC1
14:08:20 <rosmaita> ok
14:08:27 <rosmaita> are we going to do an M3?
14:08:39 <rosmaita> or just acknowledge the deadline?
14:09:01 <abhishekk> So first three patches are important in the etherpad
14:09:12 <abhishekk> rosmaita, that was the plan till yesterday
14:09:26 <abhishekk> I don't know what jokke_ has planned
14:09:44 <rosmaita> ok
14:09:53 <abhishekk> along with 1st 3 and 7th patch is important
14:10:03 <rosmaita> looks like i can renew my +2 on https://review.opendev.org/#/c/611253/19
14:10:10 <abhishekk> So how do we acknowledge the deadline
14:10:23 <abhishekk> rosmaita, yes, it's just a rebase, no code change
14:10:34 <rosmaita> i think we just say, we are now under feature freeze
14:10:44 <abhishekk> also it will be good if we find smcginnis
14:10:56 <abhishekk> Is this done by sending ML?
14:11:15 <smcginnis> o/
14:11:18 <rosmaita> no, i think it's just done right now in this meeting, the FF is openstack-wide
14:11:24 <rosmaita> hi sean
14:11:32 <rosmaita> abhishekk has a question
14:11:38 <rosmaita> if we don't do m3 release
14:11:48 <rosmaita> how do we acknowledge feature freeze?
14:12:02 <rosmaita> i was saying , we just say, "Glance is under FF" in this meeting
14:12:42 <smcginnis> Yeah, I think it's just really amongst the team that we know it's now FF and don't approve the addition of new features unless there's been an explicit agreement to allow an exception.
14:13:03 <abhishekk> smcginnis, cool
14:13:19 <rosmaita> great
14:13:26 <abhishekk> rosmaita, let's acknowledge the same :D
14:13:44 <rosmaita> another question -- i would like to deprecate an option, do in need a FFE?
14:13:47 <smcginnis> If it's something we can still get in today, I think we can allow that. But after the end of today then I think we need to enforce limiting things to just bugfixes and critical things for train.
14:13:55 <smcginnis> rosmaita: I wouldn't think so.
14:14:24 <abhishekk> smcginnis, if you get some time please have a look at first 4 patches from https://etherpad.openstack.org/p/glance-train-priority-patches
14:14:31 <rosmaita> ok, good, i'll get a patch up before RC1
14:14:45 <abhishekk> some of them already has at least 1 +2
14:14:55 <smcginnis> abhishekk: Sure, I'll try to spend a little time later today to go through those.
14:15:11 <abhishekk> smcginnis, cool, appreciate your efforts
14:15:47 <abhishekk> so, let's acknowledge that we are in FF phase now
14:16:12 <rosmaita> #action everyone Glance is now in feature freeze for Train
14:16:18 <abhishekk> ack
14:16:41 <jokke_> o/
14:16:47 <rosmaita> ok, i guess that's all for releases
14:16:49 <rosmaita> hi jokke_
14:17:00 <rosmaita> abhishekk: did you do a glanceclient release?
14:17:11 <rosmaita> for train, i mean
14:17:18 <abhishekk> rosmaita, one patch still needs to merge for glancevclient
14:17:23 <jokke_> hey sorry ... got distracted digging out something and didn't realize tis was back to back with my previous one
14:17:24 <rosmaita> ok
14:17:32 <abhishekk> #link https://review.opendev.org/658961
14:17:55 <abhishekk> This is about backend -> store change
14:18:17 <jokke_> I very much thing that we should tag M3 with the key removal and caching patches
14:18:29 <jokke_> big things that potentially affect a lots of people
14:18:39 <abhishekk> Is it possible for someone to put a release patch for client as I will be mostly out
14:18:55 <smcginnis> jokke_ has a -1 on that client patch yet. Is it realistic that we can get that in today?
14:18:55 <rosmaita> ok, so the idea is release m3 glance, and that will contain the api changes that are needed for https://review.opendev.org/#/c/658961/
14:19:14 <rosmaita> abhishekk: i can do it, i have the releases repo checked out
14:19:32 <abhishekk> rosmaita, many thanks :D
14:19:37 <jokke_> I have no problem throwing in release patch as well
14:19:41 <rosmaita> np
14:19:47 <jokke_> as long as we're in a shape to release
14:20:04 <abhishekk> jokke_, in that case, we need to regenerate config patch, reno patch and then release patch
14:20:19 <smcginnis> Do we think anyone would actually pick up and use an m3 glance release, or would we want that just to have a clear checkpoint of where that backend/store change happened?
14:20:59 <jokke_> smcginnis: basically I'd like to tag it so it gets packaged for anyone who wants to test it outside of devstack
14:21:32 <jokke_> I'm not expecting anyone to run anything extensive on it, just encourage testing
14:22:12 <rosmaita> ok, well we are up against the deadline for glanceclient today
14:22:19 <abhishekk> I am Ok with it, but in reno do we need to mention that multi-store is still experimental?
14:22:20 <smcginnis> That's fair enough. We (or at least I) have been discouraging milestone releases unless we know someone wants to actually package and test it, but that seems fair in this case.
14:22:22 <rosmaita> so we need to work out exactly what we are doing here
14:22:36 <abhishekk> also do we need to bump API version?
14:23:03 <jokke_> I can do that with the config refresh
14:23:30 <abhishekk> rosmaita, client patch is ready to go, erno has just -1 it as it should not get merge before the glance patch
14:23:43 <rosmaita> ok
14:24:06 <rosmaita> erno, why don't you put together the M3 release and ping me as needed to review patches
14:24:06 <abhishekk> so for client patch also we need a reno patch ( it will be easy as this is the only change in client patch)
14:24:28 <abhishekk> I can review it from mobile as well
14:24:46 <abhishekk> Just ping me on telegram
14:24:48 <rosmaita> abhishekk: what's needed in the glanceclient reno?
14:25:06 <abhishekk> this backend to store change we need to mention right?
14:26:07 <rosmaita> oh, crap, i was supposed to write that
14:26:27 <rosmaita> guess i still can
14:26:57 <abhishekk> great
14:26:59 <jokke_> rosmaita: will do
14:27:00 <rosmaita> so will this be glanceclient 2.17.0 ?
14:27:09 <abhishekk> yes
14:27:37 <rosmaita> ok, so erno, you work on the glance M3 stuff, i will write a releasenote for the client release
14:28:10 <jokke_> rosmaita: also mention that from now on multi-store commands are considered stable and we're not fecking around with them anymore
14:28:22 <abhishekk> Do we need API version bump?
14:28:31 <rosmaita> jokke_: ack
14:29:30 <smcginnis> Bonus points if you include the word "fecking" in the release notes. :)
14:29:43 <rosmaita> smcginnis: challenge accepted
14:29:45 <abhishekk> :D
14:31:25 <rosmaita> so for API, CURRENT is 2.7 and 2.8 is EXPERIMENTAL ... do we just make 2.8 CURRENT?
14:31:25 <abhishekk> jokke_, are you going to send ML for FFE of cluster awareness?
14:31:55 <abhishekk> I guess, multi-store is still experimental
14:32:22 <jokke_> abhishekk: I think that boat has sailed
14:32:39 <abhishekk> as we have couple of important patches still needs to get in which can now be done in RC1 phase
14:32:48 <abhishekk> jokke_, really sorry for it
14:33:48 <abhishekk> So we need to approve https://review.opendev.org/658961 patch ASAP so that we can proceed with client release
14:33:54 <jokke_> so about the API version, I assume we want to have both current cache and multistore current at T release
14:34:19 <abhishekk> jokke_, could you please do the needful
14:34:36 <jokke_> how about we do 2.9 EXPERIMENTAL on M3, and promote it directly current if we feel comfortable doing that at RC1
14:34:48 <abhishekk> +1
14:35:22 <jokke_> and for M3 we just leave 2.8 EXPERIMENTAL as well, or is there some stupid test again blocking us to do so?
14:35:53 <rosmaita> i forget how i wrote those tests
14:36:01 <rosmaita> so maybe
14:36:03 <abhishekk> I don't think so, that test is only for migration
14:36:31 <jokke_> If you did it, I'd assume you weren't crazy enough of blocking us having multiple Experimentals :D
14:36:40 <abhishekk> :D
14:36:49 <jokke_> doesn't sound like you
14:36:53 <rosmaita> i remember that issue came up, and i do not remember how we resolved it
14:37:08 <rosmaita> i will blame nikhil :D
14:37:11 <jokke_> ok, well I'll see it once I run the tests
14:37:29 <abhishekk> cool
14:37:42 <abhishekk> so looks like we have all sorted out at the moment
14:38:02 <rosmaita> i think the test handles multiples
14:38:25 <rosmaita> it checks to make sure the version negotiation code is in sync with the version response
14:38:37 <rosmaita> that was a bug that came up at some point
14:38:51 <jokke_> rosmaita: mind to review 680786 (Cyril's reno patch for key deletion), I'll do the same after the meeting
14:38:57 <rosmaita> Bug 1609571
14:38:59 <openstack> bug 1609571 in Glance newton "version negotiation api middleware is NOT up to date to include v2.3 as CURRENT version" [Critical,Fix released] https://launchpad.net/bugs/1609571 - Assigned to Nikhil Komawar (nikhil-komawar)
14:39:30 <rosmaita> jokke_: ack
14:39:51 <abhishekk> I will try to rush home asap, so I can offer some helping hand
14:40:25 <jokke_> rosmaita: oh sorry, that was your PS
14:40:48 <rosmaita> jokke_: yeah, i put up a revision last night
14:40:53 <jokke_> abhishekk or smcginnis: will need you to glance through that reno
14:41:01 <abhishekk> jokke_, on it
14:41:03 <rosmaita> https://review.opendev.org/#/c/680786/4
14:41:30 <rosmaita> would be good for smcginnis to look, it is cinder-related
14:41:45 <jokke_> tyty
14:44:07 <abhishekk> looks good to me
14:45:00 <abhishekk> Last 15 minutes
14:45:10 <abhishekk> I guess we are well set on course of action
14:45:17 <smcginnis> jokke_, rosmaita: ack
14:45:57 <jokke_> yeah ... lots of small things and hours of gating ahead, but we should be good
14:48:00 <abhishekk> great
14:48:34 <rosmaita> ok
14:50:04 <jokke_> so quick recap just that we're on same page
14:50:44 <rosmaita> good, please do!
14:51:08 <jokke_> I'll throw up config/API version patch, rosmaita does renos for client side, I'll double check if we have any renos missing for M3 and after those are merged drop release patches for both
14:51:51 <jokke_> API will be 2.7 CURRENT, 2.8 EXPERIMENTAL, 2.9 EXPERIMENTAL for M3 as long as our testing allows
14:52:21 <jokke_> oh, and we need to merge the abhishekk's client backend-> store patch
14:52:38 <jokke_> did I miss anything from the above?
14:53:49 <abhishekk> We need reno for cache-prefetcher, Add 'compressed' option to container_format, Change location metadata key 'backend' to 'store', Image deletion returns 500 if 'file' store is not enabled
14:55:45 <abhishekk> Also we need to re-enable multiple stores functional tests which we skipped while releasing glance-store 1.0 (I guess we can do it while RC1 phase when we get other multiple store changes in?
14:56:13 <jokke_> yeah, lets flip those on by RC1
14:56:28 <abhishekk> ack, I have added it in todo list of mine
14:56:50 <jokke_> it's fine to keep skipping those while we're still claiming the feature experimental
14:57:03 <jokke_> which I want to change by the final T release ;)
14:57:06 <abhishekk> cool
14:57:14 <abhishekk> last 4 minutes
14:58:25 <rosmaita> abhishekk: pretty sure 'compressed' container_format has a reno, not sure if it merged, though
14:58:33 <rosmaita> it was separate from the code change patch
14:58:37 <jokke_> like said I go through those
14:59:00 <jokke_> iirc renos should be quick to gate as we hav quite minimal testing on those
14:59:04 <abhishekk> rosmaita, that will be great
14:59:21 <rosmaita> cool
14:59:42 <abhishekk> rosmaita, it is there :D
14:59:45 <rosmaita> ok, jokke_ and i will communicate in glance channel as we get stuff done
14:59:47 <abhishekk> you have put it
14:59:54 <jokke_> ++
15:00:01 <abhishekk> thank you all
15:00:08 <smcginnis> Thanks
15:00:11 <jokke_> Thanks everyone!
15:00:22 <rosmaita> #endmeeting