14:00:08 <abhishekk> #startmeeting glance
14:00:08 <opendevmeet> Meeting started Thu Jun 17 14:00:08 2021 UTC and is due to finish in 60 minutes.  The chair is abhishekk. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:08 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:08 <opendevmeet> The meeting name has been set to 'glance'
14:00:10 <abhishekk> #topic roll call
14:00:16 <abhishekk> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:17 <abhishekk> o/
14:00:21 <jokke_> o/
14:00:27 <dansmith> o/
14:00:37 <abhishekk> lets wait couple of minutes for others
14:01:21 <Steap_> o/
14:02:06 <abhishekk> may be rosmaita is busy in other meeting
14:02:29 <pdeore> o/
14:02:33 <abhishekk> he is here
14:02:38 <abhishekk> lets start
14:02:46 <rosmaita> o/
14:02:55 <abhishekk> #topic release/periodic jobs update
14:02:59 <rosmaita> sorry for being late, and sorry in advance for not paying attention
14:02:59 <abhishekk> 4 weeks for M2
14:03:10 <abhishekk> no worries
14:03:25 <abhishekk> Means we have 3 weeks for quotas and cache work
14:03:37 <abhishekk> Periodic jobs, 1 failure related to image failed to reach active state in 15 seconds
14:04:05 <abhishekk> might be due to some non related issues, I will go through logs
14:04:15 <abhishekk> moving to next topic
14:04:18 <abhishekk> #topic M2 Target progress check
14:04:26 <abhishekk> Unified quota spec
14:04:38 <abhishekk> Patches are up and we need reviews from volunteer reviewers
14:04:50 <abhishekk> Its in good shape now
14:05:06 <abhishekk> So kindly review, rosmaita, Steap_ ^^
14:05:20 <abhishekk> Cache API
14:05:29 <abhishekk> Spec is approved, client spec is under review
14:05:41 <abhishekk> We have 3 weeks to complete the work
14:05:50 <dansmith> I haven't seen any more movement on the server side cache code, did I miss it?
14:06:13 <jokke_> dansmith: nope, haven't got to it yet
14:06:24 <abhishekk> jokke_, please let me know if you need additional resource
14:06:24 <dansmith> okay, just didn't want to be ignoring it if so
14:06:51 <abhishekk> I know you are busy with glance/swift stuff
14:07:16 <abhishekk> I can volunteer myself for client side work
14:07:21 <jokke_> cheers, next week should be fine to look into that too. Have some other things on my plate I need to get done by tomorrow afternoon
14:07:44 <abhishekk> cool, lets sync next week then
14:07:47 <abhishekk> moving ahead
14:08:14 <abhishekk> pdeore, is also with us now, so we can share the work
14:08:29 <abhishekk> moving ahead,
14:08:33 <abhishekk> #topic Policy refactoring
14:09:09 <abhishekk> With help of dansmith and his PoC, I have written a spec for policy refactoring work
14:09:18 <abhishekk> #link https://review.opendev.org/c/openstack/glance-specs/+/796753
14:09:26 <abhishekk> #link  https://review.opendev.org/q/topic:%22policy-poc%22+(status:open%20OR%20status:merged)
14:09:55 <abhishekk> This is going to be big task and we need all possible help to achieve this goal
14:10:04 <dansmith> s/big/massive/
14:10:33 <abhishekk> So kindly have a look at the spec and PoC
14:10:47 <abhishekk> We need to start putting active efforts into this ASAP
14:11:04 <abhishekk> any questions around this?
14:11:54 <abhishekk> I take that as no, I guess next week we will have more discussion around this
14:11:59 <abhishekk> moving ahead
14:12:08 <abhishekk> #topic Launchpad and Gerrit team restructuring
14:12:48 <abhishekk> Last week when rosmaita was not around, I noticed that we were unable to set/add new release or milestones in launchpad
14:13:15 <abhishekk> He was the only active launchpad admin for glance till then
14:13:29 <abhishekk> With help of fungi I have added myself and jokke_ to it
14:13:55 <abhishekk> There are lots of people who are not active and yet are LP administrator for glance
14:13:56 <rosmaita> sorry, i didn't realize how important i was
14:14:01 <abhishekk> :D
14:14:22 <abhishekk> Same thing goes for our gerrit core reviewers team
14:14:43 <abhishekk> I would like to remove/cleanup both the teams
14:14:43 <rosmaita> i thought any core member can administer the core team?
14:14:46 <Steap_> rosmaita: we were quite surprised as well
14:15:19 <abhishekk> core team can administer in gerrit but LP administrator is different
14:15:20 <jokke_> rosmaita: yeah, gerrit teams are bit different. We just have people like Nikhil still in glance core
14:15:31 <rosmaita> ah, ok
14:16:12 <abhishekk> If all are onboard then I will cleanup our both the teams after the meeting
14:16:40 <jokke_> ++
14:17:08 <fungi> team members can be set as administrators by other administrators
14:17:13 <fungi> i recommend having several
14:17:29 <abhishekk> yes, I want to remove only those which are not active
14:17:43 <fungi> and at least making sure to update it to include the ptl as an administrator when there's a change in leadership
14:18:15 <abhishekk> Yep, I made a note of this, and will also include it in our documentation somewhere
14:18:56 <abhishekk> thanks fungi for your help
14:18:58 <abhishekk> moving ahead
14:19:12 <abhishekk> #topic Bi-weekly Bug discussion (3rd Meet)
14:19:25 <abhishekk> Last week we skipped it as there were less members
14:19:41 <abhishekk> Lets go through them one by one
14:19:51 <abhishekk> #link https://bugs.launchpad.net/glance/+bug/1889664
14:20:23 <abhishekk> this was filed by jokke_
14:21:15 <Steap_> DO we know when thre is going to be another eventlet release?
14:21:18 <abhishekk> jokke_, could you please update the recent status of eventlet release on the bug?
14:21:30 <jokke_> I think we got rid of caps already, probably need to check the minimums before closing that off
14:21:53 <jokke_> abhishekk: Yeah, I'll add that to my next weeks todo list
14:22:12 <abhishekk> ack, thank you
14:22:53 <abhishekk> #link https://bugs.launchpad.net/glance/+bug/1843772
14:23:11 <abhishekk> glance-manage utility tool doesn't recognize config dirs
14:24:03 <abhishekk> Do we need to fix this issue?
14:24:41 <abhishekk> glance-manage has now nothing to do with any other config file than glance-api.conf
14:25:41 <Steap_> if glance-manage is not supposed to read any other file, then this bug feels invalid
14:25:45 <Steap_> doesn't it?
14:26:21 <abhishekk> but, glance-manage help text shows --config-dir option
14:27:04 <Steap_> do we have --config-dir for any other utility?
14:27:37 <abhishekk> Steap_, we removed registry so glance-manage now only need to read api.conf
14:27:52 <abhishekk> AFAIK, no
14:28:16 <jokke_> I think it still initially defaults to glance-manage.conf, and then gapi.conf
14:28:23 <Steap_> maybe we just want to remove --config-dir
14:29:14 <abhishekk> #action abhishekk to submit a patch to remove --config-dir option and defaults utility to read api.conf
14:29:47 <abhishekk> Next one is trivial, so skipping it, I will submit a patch for that
14:29:52 <abhishekk> Non existing property protection file raises 500 Internal server error Edit
14:30:02 <jokke_> but I'm not sure what is not working as the bug mentions conf.d dirs which IIRC we have never had anything to do with
14:30:52 <Steap_> apparently we read both glance-api.conf and glance-manage.conf
14:30:59 <Steap_> if I'm reading the source correctly
14:31:43 <jokke_> Steap_: yup, that's what I just said we do go through them both if they exists in the --config-dir specified
14:32:07 <abhishekk> I think generally the utility looks for config files in 3 locations
14:32:40 <abhishekk> 1. default one, 2. --config-dir path to config files and 3. If neither then from conf.d directory
14:34:22 <abhishekk> Next one is doc issue
14:34:25 <abhishekk> #link https://bugs.launchpad.net/glance/+bug/1930932
14:34:56 <abhishekk> this is also related to config file
14:35:26 <abhishekk> I think this is deployment specific issue
14:36:44 <jokke_> yeah, that bug should be closed as invalid
14:37:26 <abhishekk> cool
14:37:46 <abhishekk> and last one is related to our policy refactoring stuff, I have added it as reference to my spec
14:37:53 <abhishekk> https://bugs.launchpad.net/glance/+bug/1915582
14:38:11 <dansmith> ++
14:38:15 <abhishekk> So, what should be the status of this bug, as we are going to consider it as a feature
14:38:50 <dansmith> confirmed? it's definitely correct :)
14:39:42 <abhishekk> Ok, we need to keep it in mind to refer this bug in our patches in that case
14:39:59 <dansmith> I dunno,
14:40:13 <dansmith> we don't have to be that strict, IMHO, and we could also refer to it in the final doc patch or something
14:40:14 <jokke_> opinion maybe?
14:40:26 <dansmith> opinion means we're not going to fix it (according to the description)
14:41:00 <jokke_> IMHO one should not have change perms without read but
14:41:50 <dansmith> I dunno, you can have -w- perms on a dir in unix, but not r--
14:42:00 <dansmith> but either way, this is just an example of get/modify
14:42:14 <abhishekk> OK, we can continue discussion on the spec :D
14:42:22 <dansmith> the real confusion comes when you end up with things like get-image-location and get-image conflicting or something like that
14:42:36 <dansmith> abhishekk: maybe mark the spec as related-bug to this and then be done with it?
14:42:50 <abhishekk> hmm, sounds good
14:42:59 <abhishekk> will do it in next revision
14:43:03 <dansmith> cool
14:43:17 <abhishekk> moving to Open discussion
14:43:26 <abhishekk> #topic Open discussion
14:43:39 * abhishekk miss old bots :D
14:43:56 <dansmith> Steap_: would love to see you take another trip through the quota patches if you can, just to get your +1 on things
14:44:02 <abhishekk> rosmaita, Steap_ reminder to review quota patches
14:44:05 <Steap_> dansmith: I will :)
14:44:11 <dansmith> it'll help rosmaita when he gets there too, knowing more eyes have looked
14:44:15 <rosmaita> ack
14:44:15 <dansmith> Steap_: thanks :)
14:44:34 * rosmaita can use all the help he can get
14:44:46 <abhishekk> Nothing from me
14:45:19 <jokke_> I'm good too
14:45:35 <Steap_> I'm good
14:45:56 <rosmaita> nothing from me
14:45:57 <abhishekk> So just to inform all of you
14:46:28 <abhishekk> pdeore, is going to help us in maintaining glance-tempest-plugin
14:46:46 <rosmaita> \o/
14:47:03 <abhishekk> she is also going to increase her presence in glance in terms of reviews and contribution
14:47:31 <Steap_> \o/
14:47:38 <abhishekk> That's it
14:48:03 <abhishekk> I guess we can wrap it then
14:48:06 <abhishekk> thank you all
14:48:25 <abhishekk> have a good weekend, and don't forget to review spec and patches :D
14:48:56 <abhishekk> #endmeeting