14:00:10 <pdeore> #startmeeting glance
14:00:10 <opendevmeet> Meeting started Thu Jul 14 14:00:10 2022 UTC and is due to finish in 60 minutes.  The chair is pdeore. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:10 <opendevmeet> The meeting name has been set to 'glance'
14:00:11 <pdeore> #topic roll call
14:00:11 <pdeore> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:18 <pdeore> o/
14:00:18 <dansmith> o/
14:00:34 <mrjoshi> o/
14:01:28 <pdeore> lets wait few minutes for everyone to join
14:02:56 <akekane_> o/
14:03:16 <pdeore> shall we start?
14:03:47 <akekane_> I think lets start
14:03:58 <pdeore> ok
14:04:05 <pdeore> #topic release/periodic jobs
14:04:09 <akekane_> rosmaita, jokke_ will join us in middle
14:04:22 <pdeore> It's M2 Release Week and we have released glance-store 4.0.1 & python-glanclient 4.0.1 yesterday
14:04:36 <pdeore> glance m2 release patch is up for review
14:04:42 <pdeore> #link https://review.opendev.org/c/openstack/releases/+/849782
14:04:58 <pdeore> But there is one patch in pipeline, it might get merged in some time, so we need to update the hash
14:05:04 <akekane_> we need to wait for couple of patches to be merged
14:05:19 <akekane_> 1 is cyrils patch and other is release notes patc
14:05:27 <akekane_> * patch
14:05:36 <pdeore> ohh yeah the releasenote one is also there :)
14:05:52 <akekane_> yes
14:06:07 <pdeore> I will update the hash once those are done..
14:06:24 <akekane_> cool
14:06:34 <jokke_> is there -w vote already on that patch so release team does not go ahead and just do it?
14:07:01 <pdeore> ohh yes, I will do it
14:07:12 <akekane_> they don't do it unless there is confirmation from project member
14:07:33 <akekane_> but -w is better option to avoid any casualties
14:08:19 <pdeore> Done
14:08:24 <akekane_> immediate cache patch is also up and all tests including tempest are passing
14:08:41 <jokke_> akekane_: if ptl or release liaison proposes the patch the bot will automatically give it the PTL approval vote
14:08:55 <akekane_> yep,
14:09:12 <akekane_> patch is proposed by pdeore
14:09:27 <akekane_> but -w is better option to avoid any risk :D
14:10:29 <pdeore> ack, moving ahead
14:10:34 <pdeore> Periodic Jobs, all green except the 'translation update' jobs failing with RETRY_LIMIT
14:10:44 <akekane_> cool
14:11:22 <akekane_> anything else to add here?
14:11:29 <pdeore> It's retrying for the virtual environment which is not getting created because ensurepip is not available
14:11:43 <akekane_> ok
14:12:02 <akekane_> its not glance related error, so lets not worry about it atm
14:12:17 <pdeore> ack
14:12:40 <pdeore> so, that's it from me :)
14:12:42 <pdeore> #topic Glance-replicator
14:12:53 <pdeore> This one is added by Cyril
14:12:55 <akekane_> Cyril has added this topic
14:13:09 <akekane_> we came across these patches last week during review party
14:13:32 <akekane_> AFAIK our glance-replicator is broken since Icehouse
14:13:43 <akekane_> and I also didn't see anyone is using this
14:13:51 <akekane_> so the question here is
14:14:03 <akekane_> should we deprecate replicator or should we fix it?
14:14:17 <dansmith> what does it do?
14:14:22 <akekane_> I am in favor of removing it
14:14:42 <dansmith> er, what *did* it do?
14:14:53 <akekane_> IMO, it replicates the image in another region
14:15:28 <akekane_> glance-replicator is a utility can be used to populate a new glance server using the images stored in an existing glance server. The images in the replicated glance server preserve the uuids, metadata, and image data from the original.
14:15:31 <jokke_> We 100% decided years ago to deprecate and remove it. Honestly I did not realized we did not do it yet
14:15:38 <dansmith> ack, well broken since icehouse seems like an obvious case to remove it
14:15:48 <rosmaita> dansmith: ++
14:16:04 <rosmaita> i thought it had been removed too
14:16:16 <akekane_> Ack, in that case I will abandon those patches
14:16:24 <akekane_> and submit a patch to remove the replicator
14:16:51 <akekane_> Should I first mark it as deprecated or directly remove it in this cycle
14:17:07 <jokke_> rosmaita: IIRK it was decided when Nikhil was still PTL
14:17:17 <jokke_> Anyways like ages ago
14:17:37 <akekane_> yep, during I or J cycle
14:17:38 <dansmith> seems like "broken since last decade" is probably enough deprecation warning, IMHO
14:17:39 <jokke_> or might have been at your early tenure, but I'm sure that decision was made
14:17:47 <rosmaita> dansmith: ++
14:17:48 <dansmith> deprecation is for things that work that are going to be removed :)
14:17:51 <jokke_> dansmith: yep :P
14:17:55 <akekane_> :D
14:18:00 <akekane_> noted
14:18:49 <akekane_> #action abhishekk to abandon replicator patches and submit new patch to remove it
14:19:03 <akekane_> we can move ahead now
14:19:10 <pdeore> ack
14:19:15 <pdeore> #topic Open Discussions
14:20:01 <jokke_> Just quick FYI
14:20:11 <akekane_> pslestan1, certainly need help in unit tests coverage for glance-download plugin patch
14:20:27 <jokke_> I'll be taking couple of weeks PTO over next 3 weeks. So won't be much around
14:20:28 <dansmith> akekane_: they need help?
14:21:07 <akekane_> dansmith, yeah, they raised this flag 4 weeks ago that they are not much familiar in unit and functional testing
14:21:19 <akekane_> jokke_, cool, enjoy your timeoff
14:21:30 <dansmith> akekane_: oh okay.. should be similar to the web-download tests
14:22:06 <akekane_> right,
14:22:36 <akekane_> but they mentioned it earlier that we can contribute if possible
14:22:44 <dansmith> I could get something started if it'd help
14:22:58 <akekane_> sounds good if you have time
14:23:08 <dansmith> I don't, but.. someone needs to :)
14:23:22 <dansmith> I was poking around with it a bit yesterday, when I realized I could get it to read /etc/passwd :)
14:23:48 <akekane_> cool :d
14:24:07 <akekane_> also does anyone has environment with tripleo and rbac deployed?
14:24:14 * dansmith lols
14:24:21 <akekane_> haha
14:24:38 <pdeore> I'm trying but not yet completed
14:24:45 <akekane_> ok
14:25:23 <akekane_> that is all from me for the day
14:26:05 <pdeore> anyone has anything else to discuss? or we can wrap up early ?
14:26:21 <jokke_> dansmith: I'm pretty sure unittesting the web download that could be possible, but should not be possible to have it do that on functionals/tempest
14:26:44 <dansmith> jokke_: we can test it in tempest easily, so we need that too,
14:26:47 <jokke_> otherwise the filters are broken badly, but IIRC there was even test case for it
14:27:02 <dansmith> but there are unit tests for web-download, so at least parity with those is important I think
14:27:53 <akekane_> ++
14:28:06 <akekane_> I think unit tests will be easy to add for glance-download
14:28:15 <dansmith> yeah
14:29:07 <dansmith> so we're done?
14:29:16 <akekane_> another 1 is review instant caching of image patch as I got request from tempest guys to get that merged
14:29:23 <akekane_> so that they can get tempest patch in
14:29:39 <akekane_> done now
14:30:07 <akekane_> we can wrap up and go back to work :D
14:30:15 <pdeore> ack, Thanks everyone for joining !!
14:30:21 <dansmith> oh right, you changed the wsgi thing and I never got back to it, sorry
14:30:25 <akekane_> thank you all!
14:30:30 <akekane_> dansmith, no problem
14:30:55 <jokke_> thanks all
14:31:10 <pdeore> #endmeeting