14:00:10 <pranali> #startmeeting glance
14:00:10 <opendevmeet> Meeting started Thu Dec  1 14:00:10 2022 UTC and is due to finish in 60 minutes.  The chair is pranali. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:10 <opendevmeet> The meeting name has been set to 'glance'
14:00:10 <pranali> #topic roll call
14:00:10 <pranali> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:15 <pranali> o/
14:00:33 <mrjoshi> o/
14:00:41 <rosmaita> o/
14:00:52 <croelandt> o/
14:01:02 <abhishekk> o/
14:01:34 <pranali> There is power failure at my place, and laptop battery is about to die, so it would be nice if someone chair the meeting when you see me offline
14:01:54 <pranali> we have short agenda today, so hopefully we will finish it early
14:02:10 <abhishekk> I can walk through the proceedings
14:02:21 <pranali> abhishekk, Thanks :)
14:02:29 <abhishekk> np
14:02:50 <pranali> i think most of the members are here, so let's start
14:02:59 <pranali> #topic release/periodic job updates
14:03:13 <pranali> Milestone 2 is 1 month away from now, which is also a spec freeze for us
14:03:33 <pranali> Once M2 is over we will not accept any spec
14:04:00 <pranali> we will revisit the specs in next topic
14:04:04 <abhishekk> * owners can submit them but we will not approve it for current cycle
14:04:24 <pranali> yes :)
14:04:48 <pranali> Periodic job all green except TIME_OUT for fips jobs, everything else is green
14:04:57 <pranali> moving to next
14:04:59 <pranali> #topic Specs
14:05:10 <croelandt> I added this
14:05:10 <pranali> #link https://review.opendev.org/c/openstack/glance-specs/+/854112  Add option region_name to s3 store
14:05:26 <croelandt> yeah this one we merged,thanks!
14:05:33 <pranali> croelandt, yeah
14:05:41 <pranali> next is
14:05:43 <pranali> #link https://review.opendev.org/c/openstack/glance-specs/+/863209  - Repropose new location APIs spec
14:05:52 <croelandt> Erno, Rajat and I were discussing security issues with this one
14:06:06 <abhishekk> I think there are multiple +2s now
14:06:07 <croelandt> it would be nice if we could close this topic and move forward with the spec
14:06:32 <croelandt> oh it was merged :)
14:06:36 <croelandt> never mind then :)
14:06:51 <abhishekk> no I guess you have added old reference here
14:07:12 <pranali> yeah it's from last cycle
14:07:12 <abhishekk> #link https://review.opendev.org/c/openstack/glance-specs/+/863209
14:07:18 <abhishekk> this is the latest version
14:07:38 <croelandt> oh yeah I messed up
14:07:39 <abhishekk> I asked rajat to let me know if he has any doubts about the comments on the spec
14:07:52 <abhishekk> So we will sync on it
14:07:59 <pranali> yeah so there are some comments on this patch, I'll ping rajat to update it accordingly and if he has any doubt about the same
14:08:11 <pranali> abhishekk, thanks
14:08:31 <abhishekk> np
14:08:45 <pranali> next is
14:08:46 <pranali> #link https://review.opendev.org/c/openstack/glance-specs/+/787179 - Speedup upload images for Swift backend
14:09:06 <pranali> the owner has updated the new patch set, and need our attention on this, so kindly please have a look
14:09:17 <abhishekk> I have added my note there
14:09:33 <abhishekk> the new revision is not what we discussed during the PTG
14:10:44 <pranali> yes, seems the owner has updated the ps after that, and expecting some reviews i think
14:11:12 <abhishekk> just cross check the spec and what we discussed in PTG
14:11:19 <abhishekk> if it is there then I will review it
14:11:37 <pranali> ack
14:11:54 <pranali> moving to next
14:11:59 <abhishekk> also it is in merged conflict now
14:12:46 <pranali> yes, it's bcz one spec is merged today, I will ping the owner and will ask to update the same
14:13:08 <abhishekk> ack
14:13:15 <pranali> #topic Do we care about ARM64
14:13:45 <croelandt> yeah there are a few patches that add support for ARM64 in Zuul
14:13:50 <croelandt> my question is: "do we care?"
14:14:02 <croelandt> I'm not against it, but do we run Glance on ARM64 machines?
14:14:33 <abhishekk> I don't think so, per as per rosmaita's comment it looks like other projects are running those
14:14:57 <croelandt> I could rebase the latest patch and see whether that works
14:15:01 <croelandt> but I'm curious why we do this :D
14:15:11 <abhishekk> me too
14:15:25 <croelandt> rosmaita: around? :)
14:15:40 <rosmaita> sorry, in another meeting
14:15:51 <croelandt> ok
14:15:53 <abhishekk> lets abandon it with a comment to "Give importance of why we should have this in glance"
14:16:04 <rosmaita> because everyone else has it?
14:16:09 <croelandt> rosmaita: yeah but why? :)
14:16:17 <croelandt> that feels like a good  reason to add it
14:16:18 <croelandt> but still
14:16:47 <rosmaita> because people want to run it on arm64
14:17:04 <rosmaita> are the jobs failing or something?
14:17:45 <abhishekk> 1st patch it was -1 since 2019
14:17:54 <croelandt> rosmaita: we just have multiple idle patches
14:18:37 <croelandt> https://review.opendev.org/c/openstack/glance/+/854938 we should probably just merge this one
14:18:37 * pranali 's laptop is about to shoutdown, passing the chair to abhishekk
14:18:38 <rosmaita> oh ... well, there's a job template, cinder has been running them for a long time
14:18:53 <pranali> #chair abhishekk
14:18:53 <opendevmeet> Current chairs: abhishekk pranali
14:19:25 <abhishekk> so we should update the patch accordingly and abandon other patches
14:19:46 <croelandt> do we need to update?
14:19:51 <croelandt> what's wrong with the  current patch?
14:19:55 <rosmaita> i can take an action item to find out what the deal is with arm64
14:20:11 <abhishekk> sounds good
14:20:42 <croelandt> rosmaita: ping me and I'll happily +2+1
14:20:45 <rosmaita> #action rosmaita find out what the deal is with openstack arm64 support
14:20:52 <rosmaita> croelandt: ok
14:21:28 <abhishekk> lets move to open discussion
14:21:36 <abhishekk> #topic Open discussion
14:21:40 <croelandt> We also had this spec https://review.opendev.org/c/openstack/glance-specs/+/863110 :)
14:22:59 <abhishekk> will have a look this or early next week
14:23:33 <croelandt> thanks
14:23:47 <abhishekk> from my side, just reminder to rosmaita to have a look at service role and db migration constant patch
14:23:59 <abhishekk> keystone spec is not approved yet :(
14:24:31 <rosmaita> who's the keystone ptl?
14:25:52 <abhishekk> its leaderless project
14:26:04 <rosmaita> ok, that seems to be working well
14:27:54 <abhishekk> I think that is all from me
14:28:03 <croelandt> I'm good as well
14:28:15 <abhishekk> lets conclude for today then
14:28:20 <abhishekk> thank you all!
14:28:39 <abhishekk> #endmeeting