14:00:12 <pranali> #startmeeting glance
14:00:12 <opendevmeet> Meeting started Thu Feb  8 14:00:12 2024 UTC and is due to finish in 60 minutes.  The chair is pranali. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:12 <opendevmeet> The meeting name has been set to 'glance'
14:00:12 <pranali> #topic roll call
14:00:12 <pranali> #link https://etherpad.openstack.org/p/glance-team-meeting-agenda
14:00:22 <pranali> o/
14:01:00 <rosmaita> o/
14:01:11 <croelandt> o/
14:01:12 * abhishekk in different meeting but here if i required
14:01:25 <pranali> ok, let's start then
14:01:32 <pranali> #topic release/periodic jobs updates
14:01:39 <pranali> M3 is just 3 weeks from now
14:01:57 <pranali> and glance_store release will be a week before that, so can we have review party next week if everyone is available
14:02:37 * croelandt is available
14:02:39 <pranali> so that we can get time to address the review comments before final release
14:03:18 <pranali> cool, let's have it next week then
14:03:50 <pranali> Periodic jobs are all green except intermittent TIME_OUTs on fips jobs
14:04:00 <pranali> moving to next
14:04:03 <pranali> #topic other release-related stuff
14:04:13 <pranali> Transition Yoga to Unmaintained
14:04:13 <pranali> #link https://review.opendev.org/c/openstack/releases/+/906584
14:04:30 <pranali> open reviews: #link https://review.opendev.org/q/(project:openstack/glance+or+project:openstack/glance_store+or+project:openstack/python-glanceclient)+AND+status:open+AND+branch:stable/yoga
14:05:02 <rosmaita> so, the deadline for final release from yoga was actually November 2023
14:05:07 <pranali> I think we should have these 2 patches in before the branch moves to unmaiantain
14:05:22 <rosmaita> but, the release team is allowing people to do them late
14:05:24 <rosmaita> (i think)
14:06:07 <pranali> ohh ok
14:06:30 <rosmaita> ok, then we need to merge them, propose a final yoga release (which is really going to piss off the release team, because a library release affects requirements (upper-constraints)
14:06:47 <pranali> i think the backports are allowed in unmaintained branches as well, right?
14:06:58 <croelandt> or we could drop those backports :)
14:07:00 <rosmaita> and then update the yoga->Unmaintained patch with the correct hashes
14:07:05 <croelandt> Do we have distros depending on Yoga?
14:07:21 <rosmaita> croelandt: yes, the other option is just to abandon those
14:07:53 <rosmaita> pranali, yes, there is a global unmaintained core team that can merge stuff into unmaintained/yoga
14:08:09 <rosmaita> so we can split the difference:
14:08:31 <rosmaita> abandon now, then re-propose to unmaintained/yoga after it's created
14:09:09 <rosmaita> croelandt: that patch seems more of a nice to have than a necessity, security-wise ... is that right?
14:09:46 <croelandt> Well it's not optimal to show access keys even in DEBUG logs
14:09:57 <croelandt> I think some people would consider it a critical issue
14:09:59 <croelandt> we decided not to
14:10:26 <croelandt> That's why I wonder whether distros are based on yoga
14:12:01 <rosmaita> well, we need to decide if it's worth burning a bunch of good will with the release team to do a late yoga release
14:12:26 <rosmaita> I don't know, but i do know that some distro is based on victoria
14:12:40 <rosmaita> and there are unmaintainers for that branch
14:12:50 <rosmaita> so, they will want to have this fix in victoria
14:13:01 <rosmaita> and hence, they will backport it
14:13:23 <rosmaita> so i think if we re-propose for unmaintained/yoga, that will be sufficient for distros
14:13:43 <croelandt> if that means less stress for the release team, I'm all for it
14:13:48 <rosmaita> amen!
14:13:49 <pranali> then i think abandoning now and then re-propose to unmaintained/yoga after it's created would be better
14:14:22 <rosmaita> ok, cool, then pranali you just need to check that the hashes are correct on that patch and then +1 it
14:14:42 <pranali> yes I will do that right after the meeting
14:14:47 <rosmaita> cool
14:15:08 <pranali> and for ussuri to EOL as well, #link https://review.opendev.org/c/openstack/releases/+/903311
14:15:08 <rosmaita> that will break the glance release notes job, btw
14:15:24 <rosmaita> (when they delete stable/yoga)
14:15:34 <rosmaita> there will be bot-generated patches for all deliverables
14:15:51 <rosmaita> but, we decided to go with different patches in cinder
14:15:57 <pranali> ohh ok
14:16:17 <rosmaita> https://review.opendev.org/c/openstack/cinder/+/907836
14:16:42 <rosmaita> the base path on that review is the bot-proposed one
14:16:53 <rosmaita> *patch
14:17:08 <rosmaita> no, that's incorrect to
14:17:12 <rosmaita> *too
14:17:18 <rosmaita> PS1 is what the bot proposed
14:17:27 <rosmaita> PS3 is what we decided to go with
14:17:46 <rosmaita> either one will work, just a matter of what the project prefers
14:18:28 <rosmaita> but my reason for mentioning is that someone needs to be ready to merge the change after stable/yoga is deleted to unbreak the release job
14:18:50 <pranali> ok
14:19:10 <rosmaita> anyone want me to explain the difference between the patches?
14:19:11 <pranali> so what glance should prefer ?
14:19:20 <pranali> same as cinder ? :)
14:19:29 <rosmaita> that would be my preference!
14:19:32 <rosmaita> so the issue is
14:19:48 <rosmaita> the bot generated patch will look for releasenotes in unmaintained/yoga
14:20:08 <rosmaita> so our release notes will include changes merged by people not on the glance team
14:20:44 <rosmaita> the cinder-style patch looks for release notes before yoga-eom tag, which are the release notes for stuff we (glance team) merged
14:21:27 <rosmaita> i think ironic wants to go with the bot patch, but they are also creating an ironic-unmaintained-core
14:21:42 <rosmaita> so they are going to active in the unmaintained branches
14:21:52 <rosmaita> (i am assuming that we don't want to be)
14:22:07 <rosmaita> so that's the difference and the implications
14:23:10 <pranali> Thanks for sharing this :)
14:23:24 <rosmaita> np
14:23:49 <pranali> let's move ahead
14:23:55 <rosmaita> btw, i wanted to mention 2 dashboards i added to the "spotlight links" on the agenda
14:24:12 <rosmaita> one for release patches, one for bot-generated patches
14:24:31 <rosmaita> hopefully they will make it easier for us to do these things faster
14:25:48 <pranali> yeah, that would be really helpful, Thanks again !
14:25:51 <rosmaita> ok, sorry for hijacking
14:26:14 <pranali> np :)
14:26:16 <rosmaita> we were supposed to be talking about ussuri EOL
14:26:31 <rosmaita> looks like there are no open reviews, so that's good
14:26:44 <rosmaita> just need to verify the hashes on the patch and give it a +1
14:26:53 <rosmaita> https://review.opendev.org/c/openstack/releases/+/903311
14:26:58 <pranali> yeah as i mentioned that above, I will check that too
14:27:08 <rosmaita> great!
14:27:35 <rosmaita> that's all from me
14:27:43 <pranali> cool, let's move ahead
14:27:46 <pranali> #topic  Important Reviews
14:27:57 <pranali> Centralized cache DB - #link https://review.opendev.org/q/topic:%22centralized-cache-db%22
14:27:57 <pranali> New Location APIS -  #link https://review.opendev.org/q/topic:%22New-Location-Apis%22
14:28:35 <pranali> So, these are the possible targets for this cycle, just waiting for reviews, so kindly please have a look on priority
14:29:30 <pranali> we can target these for review party as well, but it would be better if we can do it before that :)
14:29:41 <pranali> Support for Image Encryption - #link https://review.opendev.org/c/openstack/glance/+/902648
14:30:00 <pranali> There are few comments from abhishekk on this since quite a long time which are not addressed, I will try to reach out to the owner for the same so we will get clear idea whether we can have this in this cycle or not
14:30:29 <pranali> that's it from me
14:31:21 <pranali> moving to open discussions
14:31:23 <pranali> #topic Open Discussion
14:31:52 <pranali> anyone has anything else to highlight ?
14:32:07 <rosmaita> just about the scrubber
14:32:23 <rosmaita> no response to my email proposing to remove it
14:32:29 <rosmaita> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/33F37CL4NUE3QI6GYBWG5BL5UNBK4L5U/
14:32:49 <rosmaita> tbh, i don't know how to interpret that
14:33:04 <croelandt> yeah
14:33:19 <croelandt> "does nobody use that, or are people just not reading that mailing list"
14:33:20 <rosmaita> although, the scrubber is really only helpful for swift
14:33:31 <rosmaita> and i think more people are using ceph?
14:34:20 <rosmaita> or maybe we improved the swift glance_store ?
14:34:53 <rosmaita> it used to be that the call to swift to delete an image did not return until all the segments making up the image had been deleted on the swift side
14:35:00 <rosmaita> and that could take a really long time
14:35:06 <pranali> I think we should mention the timeline of few weeks, if we no response till then we will assume that it's a go forward signal
14:35:09 <rosmaita> but maybe that's not an issue any more?
14:37:05 <pranali> i'm not sure about this
14:37:36 <rosmaita> me neither
14:39:08 <abhishekk> Lets wait for two more weeks, anyway we are going to remove it next cycle
14:39:44 <abhishekk> I think we need to deprecate delayed_delete config option?
14:41:49 <pranali> I think restore
14:44:32 <pranali> abhishekk, ^
14:44:37 <abhishekk> both
14:44:45 <pranali> ohh ok
14:44:55 <abhishekk> delayed_delete is not useful if scrubber will be removed
14:45:39 <pranali> ack
14:46:31 <pranali> so let's wait for few more weeks as abhishekk mentioned,
14:46:44 <abhishekk> yep
14:47:59 <pranali> ok, anyone has anything else to discuss ?
14:49:02 <rosmaita> abhishekk: good point, we need to deprecate delayed_delete
14:49:12 <abhishekk> yes
14:49:23 <abhishekk> we can deprecate it this cycle I guess
14:49:53 <rosmaita> ok, maybe the thing to do is i will follow up that email with a reply to myself with a link to the patch deprecating delayed_delete
14:49:59 <rosmaita> then people will know we mean business
14:50:42 <pranali> :D
14:50:45 <abhishekk> ++
14:50:50 <pranali> +1
14:51:21 <rosmaita> #action rosmaita - post delayed_delete deprecation patch and send email to ML
14:52:08 <pranali> great !
14:52:21 <pranali> let's conclude for the day then
14:52:40 <pranali> Thanks everyone for joining !!
14:52:46 <rosmaita> bye
14:52:54 <pranali> bye
14:52:56 <pranali> #endmeeting